收集 Varonis 記錄
本文說明如何使用 Bindplane 代理程式,將 Varonis 記錄擷取至 Google Security Operations。
Varonis 是資料安全性與數據分析平台,可針對檔案存取事件、權限變更、驗證活動和 DatAlert 安全性警示,產生 CEF 和 LEEF 格式的系統記錄訊息。剖析器會從 CEF、LEEF 和鍵/值格式的記錄中擷取欄位,並對應至統合資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Varonis 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Varonis 的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/varonis: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: VARONIS raw_log_field: body service: pipelines: logs/varonis_to_chronicle: receivers: - udplog exporters: - chronicle/varonis
設定參數
請替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:請將此值設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/varonis: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: VARONIS raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 Varonis 中設定系統記錄匯出功能
- 登入 Varonis 網頁版 UI。
- 依序前往「工具」>「DatAlert」> 選取「DatAlert」。
- 選取「設定」。
- 請提供下列設定詳細資料:
- Syslog Message IP Address:輸入 Bindplane 代理程式 IP 位址。
- 「Port」(通訊埠):輸入 Bindplane 代理程式通訊埠編號 (例如
514,用於 UDP)。 - 設施名稱:選取設施。
- 按一下「套用」。
在 Varonis 中設定系統記錄格式
- 依序前往 「Tools」 > 「DatAlert」 > 「Alert Templates」。
- 按一下「Edit Alert Template」(編輯快訊範本),然後選取「External system default template」(外部系統預設範本)。
- 在「套用至警告方法」中,從清單中選取「Syslog 訊息」。
- 在選單中依序選取「規則」>「快訊方法」。
- 選取「Syslog message」(系統記錄訊息)。
- 按一下 [確定]。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
act |
security_result.summary |
CEF 訊息中 act 欄位的值。 |
cn1 |
security_result.rule_id |
CEF 訊息中 cn1 欄位的值。 |
cs1 |
network.email.to |
CEF 訊息中 cs1 欄位的值,特別是電子郵件收件者。 |
cs2 |
security_result.rule_name |
CEF 訊息中 cs2 欄位的值。 |
device_version |
metadata.product_version |
CEF 訊息中 device_version 欄位的值。 |
dhost |
principal.hostname |
CEF 訊息中 dhost 欄位的值,代表主機名稱。如果 file_server 存在且不是「DirectoryServices」,則會覆寫這個值。 |
duser |
target.user.userid |
CEF 訊息中 duser 欄位的值。經過 gsub 轉換,移除反斜線並分割為 target.user.userid 和 target.administrative_domain。 |
dvchost |
target.hostname |
CEF 訊息中 dvchost 欄位的值。 |
filePath |
target.file.full_path |
CEF 訊息中 filePath 欄位的值。 |
rt |
metadata.event_timestamp |
CEF 訊息中 rt 欄位的值,剖析為時間戳記。 |
severity |
security_result.severity |
CEF 訊息或 LEEF 訊息中 severity 欄位的值。轉換為大寫。根據數值或關鍵字,對應至 UDM 嚴重性值 (LOW、INFORMATIONAL、MEDIUM、HIGH、CRITICAL)。 |
Acting Object |
target.user.user_display_name |
鍵/值資料中 Acting Object 欄位的值。以「\」分割,擷取顯示名稱。 |
Acting Object SAM Account Name |
target.user.userid |
鍵/值資料中 Acting Object SAM Account Name 欄位的值。 |
Device hostname |
target.hostname |
鍵/值資料中 Device hostname 欄位的值。 |
Device IP address |
target.ip |
鍵/值資料中 Device IP address 欄位的值。 |
Event Time |
metadata.event_timestamp |
鍵/值資料中 Event Time 欄位的值,剖析為時間戳記。 |
Event Type |
target.application、metadata.event_type |
鍵/值資料中 Event Type 欄位的值。用於衍生 metadata.event_type (FILE_OPEN、USER_CHANGE_PERMISSIONS、USER_CHANGE_PASSWORD、USER_UNCATEGORIZED)。 |
File Server/Domain |
principal.hostname |
鍵/值資料中 File Server/Domain 欄位的值。如果不是「DirectoryServices」,則會覆寫從 dhost 衍生的 principal.hostname。 |
Path |
target.file.full_path |
鍵/值資料中 Path 欄位的值。 |
Rule Description |
metadata.description |
鍵/值資料中 Rule Description 欄位的值。 |
Rule ID |
security_result.rule_id |
鍵/值資料中 Rule ID 欄位的值。 |
Rule Name |
security_result.rule_name |
鍵/值資料中 Rule Name 欄位的值。 |
intermediary_host |
intermediary.hostname |
由 grok 擷取的值,代表中繼主機名稱。 |
log_type |
metadata.log_type |
硬式編碼為 VARONIS。 |
metadata.event_type |
metadata.event_type |
根據 evt_typ、act 和 filepath 的值衍生。如果 event_type 為 GENERIC_EVENT 且 principal_hostname 存在,則預設為 STATUS_UPDATE。 |
metadata.product_name |
metadata.product_name |
硬式編碼為 VARONIS,但可由 LEEF 訊息中的 product_name 欄位覆寫。 |
metadata.vendor_name |
metadata.vendor_name |
硬式編碼為 VARONIS,但可由 LEEF 訊息中的 vendor 欄位覆寫。 |
prin_host |
principal.hostname |
由 grok 擷取的值,代表主機名稱主體。 |
product_name |
metadata.product_name |
LEEF 訊息中的值。 |
security_result.action |
security_result.action |
衍生自 result 或 Event Status 欄位。如果結果為 Success,請設為「ALLOW」,否則請設為 BLOCK。 |
timestamp |
timestamp、metadata.event_timestamp |
事件時間戳記是根據可用性,從各種欄位 (datetime1、event_time、start_datetime、datetime2) 衍生而來。如果沒有其他時間戳記欄位,系統會使用原始記錄中的 create_time 做為備用欄位,並對應至 timestamp 和 metadata.event_timestamp。 |
vendor |
metadata.vendor_name |
LEEF 訊息的值。 |
fname |
event.idm.read_only_udm.target.file.names |
從變更記錄對應 |
msg |
event.idm.read_only_udm.security_result.description |
從變更記錄對應 |
cs7 |
event.idm.read_only_udm.security_result.url_back_to_product |
從變更記錄對應 |
usrName |
principal.user.userid |
從變更記錄對應 |
Event_Type |
metadata.product_event_type |
從變更記錄對應 |
domain |
prinicipal.administrative_domain |
從變更記錄對應 |
proto", "cat", "Event_Additional_Data", "Event_Status", "Email_Attachment_Name", "Email_Date", "Account_of_Changed_Permissions", "Permissions_Changes", "Permissions_before_Change", and "Permissions_after_Change |
additional.fields |
從變更記錄對應 |
Affected_Object_Path |
taregt.file.full_path |
從變更記錄對應 |
Affected_Object |
security_result.detection_fields |
從變更記錄對應 |
src |
principal.ip |
從變更記錄對應 |
Alert_ID |
security_result.rule_id |
從變更記錄對應 |
Email_Recipients |
network.email.to |
從變更記錄對應 |
Email_Item", "Mailbox_Access_by_Owner", "Threshold_Value", "Threshold_First_Timestamp", "Event_by_MailboxOwner", and "Email_Sender |
additional.fields |
從變更記錄對應 |
Email_Sender |
network.email.from |
從變更記錄對應 |
accountName |
target.user.userid |
從變更記錄對應 |
Device_Name |
taregt.hostname |
從變更記錄對應 |
Event_Type_ID |
metadata.product_log_id |
從變更記錄對應 |
Event_File_Server_Domain |
target.administrative_domain |
從變更記錄對應 |
Alert_Page_URL |
taregt.url |
從變更記錄對應 |
devTime |
metadata.event_timestamp |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。