Collect SAP SM20 logs
This document explains how to ingest SAP SM20 logs to Google Security Operations using the Bindplane agent.
SAP SM20 is the SAP Security Audit Log that captures user authentication, authorization changes, and transaction activities within SAP systems. The Bindplane agent collects exported SAP SM20 log files directly from the local file system.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance
- Windows Server 2016 or later, or Linux host with
systemd - Network connectivity between the Bindplane agent and the SAP application server
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
- Privileged access to the SAP system with administrator permissions (SAP_ALL or equivalent authorization)
Get Google SecOps credentials for the Bindplane agent
To authenticate the Bindplane agent to Google SecOps, choose one of the following methods:
- New deployments: Use the Chronicle API (Option 1).
- Legacy deployments: Continue using the ingestion authentication file (Option 2) until the Ingestion API is discontinued on July 20, 2027.
Option 1: Create a service account for the Chronicle API (recommended)
- Sign in to the Google Cloud console and select the Google Cloud project that is linked to your Google SecOps instance.
- Go to IAM & Admin > Service Accounts.
- Click Create service account.
- Provide the following configuration details:
- Service account name: Enter a name for the account (for example,
bindplane-ingest). - Service account description: Enter a description (for example,
Bindplane agent log ingestion).
- Service account name: Enter a name for the account (for example,
- Click Create and continue.
- In the Grant this service account access to project section, click Select a role and select Chronicle Editor.
- Click Continue, and then click Done.
- Click the service account you created, and then go to the Keys tab.
- Click Add key > Create new key.
- Select JSON and click Create. The key file is downloaded to your computer.
- Save the key file as
ingestion-auth.jsonin the Bindplane collector directory (/opt/observiq-otel-collector/ingestion-auth.jsonon Linux orC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.jsonon Windows), or updatecreds_file_pathinconfig.yamlto match the path where you save it. - Go to IAM & Admin > Settings and copy the Project number. You'll need it for the exporter configuration.
Option 2: Download the ingestion authentication file (legacy)
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
- Download the ingestion authentication file.
- Save the file securely on the system where the Bindplane agent will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietWait for the installation to complete.
Verify the installation by running:
sc query observiq-otel-collectorThe service should show as RUNNING.
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shWait for the installation to complete.
Verify the installation by running:
sudo systemctl status observiq-otel-collectorThe service should show as active (running).
Additional installation resources
For additional installation options and troubleshooting, see the Bindplane agent installation guide.
Configure the Bindplane agent to ingest logs and send to Google SecOps
Locate the configuration file
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
Edit the configuration file
Replace the entire contents of
config.yamlwith the following configuration:receivers: filelog: include: - /usr/sap/<SID>/DVEBMGS00/log/audit_* start_at: beginning exporters: chronicle/sap_sm20: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: SAP_SM20 raw_log_field: body ingestion_labels: env: production service: pipelines: logs/sap_sm20_to_chronicle: receivers: - filelog exporters: - chronicle/sap_sm20
Configuration parameters
Replace the following placeholders:
Receiver configuration:
filelog: The receiver type for collecting log files from diskinclude: List of file paths to monitor. Default SAP Security Audit Log locations:- Linux:
/usr/sap/<SID>/DVEBMGS00/log/audit_* - Windows:
C:\usr\sap\<SID>\DVEBMGS00\log\audit_* - Replace
<SID>with your SAP System ID (for example,PRD,QAS,DEV)
- Linux:
start_at: Set tobeginningto read existing logs orendto only read new entries
Exporter configuration:
sap_sm20: Descriptive name for the exportercreds_file_path: Full path to the service account JSON key file (Option 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>: Customer ID from the previous steplocation: Replace<LOCATION>with the region of your Google SecOps instance (for example,us,europe, orasia-southeast1). The exporter prefixeschronicle.googleapis.comwith this value. See Regional Endpoints for the complete list.project: Replace<PROJECT_NUMBER>with the project number from IAM & Admin > Settings.endpoint: Keep set tochronicle.googleapis.com.SAP_SM20: Log type exactly as it appears in Chronicleingestion_labels: Optional labels in YAML format (for example,env: production)
Pipeline configuration:
sap_sm20_to_chronicle: Descriptive name for the pipeline
Legacy ingestion API exporter
If you use the ingestion authentication file from Option 2, replace the
exportersblock with the following. Setcreds_file_pathto the path to the ingestion authentication file, and if your instance is outside the US, replacemalachiteingestion-pa.googleapis.comwith your regional endpoint (for example,europe-malachiteingestion-pa.googleapis.com).exporters: chronicle/sap_sm20: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SAP_SM20 raw_log_field: body ingestion_labels: env: production
Save the configuration file
- After editing, save the file:
- Linux: Press
Ctrl+O, thenEnter, thenCtrl+X - Windows: Click File > Save
- Linux: Press
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux, run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows, choose one of the following options:
Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collectorServices console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- Press
Configure SAP SM20 Security Audit Log
- Sign in to the SAP system using SAP GUI with an administrator account.
- Run transaction SM19 (Security Audit Configuration).
- Activate the Security Audit Log by selecting Security audit > Activate.
- Configure the audit filters:
- Click Create to add a new filter.
- Select the audit classes to capture:
- Dialog login: Logon and logoff events
- RFC/CPIC login: Remote function call authentication events
- Transaction start: Transaction execution events
- Report start: Report execution events
- Change user master record: User administration changes
- Set the Client (for example,
000,100, or*for all clients). - Set the User to
*to capture events for all users. - Select the Audit severity levels: Critical, Severe, and Important.
- Click Save to activate the filter.
- Verify the audit log file location by running transaction SM21 or checking the profile parameter
rsau/local/file. Default log file locations:- Linux:
/usr/sap/<SID>/DVEBMGS00/log/audit_<date> - Windows:
C:\usr\sap\<SID>\DVEBMGS00\log\audit_<date>
- Linux:
Ensure the Bindplane agent
includepath inconfig.yamlmatches the audit log file location with a wildcard pattern.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
| WP_TYP, ALGREPNA, ALGAREA, ALGFILENO, ALGFILEPOS, ALGINST, ALGSUBID, UTCDIFF, ALGTASKNO, ALGTASKTYPE, ALGTCODE, log_event.log_event.ALGAREA, log_event.fields.EVENT_SUBTYPE, log_event.log_event.ALGFILENO, log_event.log_event.ALGFILEPOS, log_event.log_event.ALGREPNA, log_event.log_event.ALGSUBID, log_event.log_event.ALGSYSTEM, log_event.log_event.UTCDIFF, log_event.log_event.UTCSIGN, log_event.log_event.ALGTASKNO, log_event.log_event.ALGTASKTYPE, log_event.log_event.ALGTCODE, log_event.log_event.WP_TYP | additional.fields | Merged with label objects for each non-empty field |
| extensions.auth.type | Set to "AUTHTYPE_UNSPECIFIED" if event_type is USER_LOGIN | |
| WP_SERVER, log_event.log_event.WP_SERVER | intermediary.hostname | Value from WP_SERVER if not empty, overwritten by log_event.log_event.WP_SERVER if not empty |
| ALGTEXT, log_event.log_event.ALGTEXT | metadata.description | Value from ALGTEXT if not empty, overwritten by log_event.log_event.ALGTEXT if not empty |
| metadata.event_type | Set to USER_LOGIN if ALGTEXT or log_event.log_event.ALGTEXT contains "logon successful" and has_principal and has_target, else PROCESS_LAUNCH if has_principal and has_target_process, else STATUS_UPDATE if has_principal, else GENERIC_EVENT; in 0035 branch, STATUS_UPDATE if has_principal, else GENERIC_EVENT | |
| log_event.fields.EVENT_TYPE | metadata.product_event_type | Value copied directly |
| session_id | network.session_id | Value copied directly |
| INSTANCE_NAME, ALGSYSTEM, log_event.host, log_event.log_event.INSTANCE_NAME, log_event.log_event.ALGSYSTEM | principal.asset.hostname | Value from INSTANCE_NAME if not empty, overwritten by ALGSYSTEM if not empty, then by log_event.host if not empty, then by log_event.log_event.INSTANCE_NAME if not empty, then by log_event.log_event.ALGSYSTEM if not empty |
| ip | principal.asset.ip | Value copied directly |
| INSTANCE_NAME, ALGSYSTEM, log_event.host, log_event.log_event.INSTANCE_NAME, log_event.log_event.ALGSYSTEM | principal.hostname | Value from INSTANCE_NAME if not empty, overwritten by ALGSYSTEM if not empty, then by log_event.host if not empty, then by log_event.log_event.INSTANCE_NAME if not empty, then by log_event.log_event.ALGSYSTEM if not empty |
| ip | principal.ip | Value copied directly |
| log_event.source, log_event.sourcetype | principal.labels | Merged with label objects for log_event.source and log_event.sourcetype if not empty |
| TXSUBCLSID, log_event.log_event.TXSUBCLSID | security_result.description | Value from TXSUBCLSID if not empty, overwritten by log_event.log_event.TXSUBCLSID if not empty |
| TXSEVERITY, log_event.log_event.TXSEVERITY | security_result.severity | Set to "CRITICAL" if TXSEVERITY matches (?i)Severe|critical, overwritten if log_event.log_event.TXSEVERITY matches (?i)Severe|critical |
| WP_STATUS, log_event.log_event.WP_STATUS | security_result.summary | Value from WP_STATUS if not empty, overwritten by log_event.log_event.WP_STATUS if not empty |
| application | target.application | Value copied directly |
| ALGLTERM, log_event.log_event.INSTANCE_NAME, log_event.log_event.ALGLTERM | target.asset.hostname | Set to ALGLTERM if ALGLTERM is not an IP, overwritten by log_event.log_event.INSTANCE_NAME if not empty, overwritten by log_event.log_event.ALGLTERM if log_event.log_event.ALGLTERM is not an IP |
| ALGLTERM, log_event.log_event.IPADDRESS, log_event.log_event.ALGLTERM | target.asset.ip | Set to IP extracted from ALGLTERM if ALGLTERM is IP, overwritten by IP from log_event.log_event.IPADDRESS if it's IP, overwritten by IP from log_event.log_event.ALGLTERM if it's IP |
| ALGLTERM, log_event.log_event.INSTANCE_NAME, log_event.log_event.ALGLTERM | target.hostname | Set to ALGLTERM if ALGLTERM is not an IP, overwritten by log_event.log_event.INSTANCE_NAME if not empty, overwritten by log_event.log_event.ALGLTERM if log_event.log_event.ALGLTERM is not an IP |
| ALGLTERM, log_event.log_event.IPADDRESS, log_event.log_event.ALGLTERM | target.ip | Set to IP extracted from ALGLTERM if ALGLTERM is IP, overwritten by IP from log_event.log_event.IPADDRESS if it's IP, overwritten by IP from log_event.log_event.ALGLTERM if it's IP |
| log_event.log_event.ALGCLIENT, log_event.log_event.ALGINST | target.labels | Merged with label objects for log_event.log_event.ALGCLIENT and log_event.log_event.ALGINST if not empty |
| WP_PID, log_event.log_event.WP_PID | target.process.pid | Value from WP_PID if not empty, overwritten by log_event.log_event.WP_PID if not empty |
| ALGCLIENT, ALGINST | target.resource.attribute.labels | Merged with label objects for ALGCLIENT and ALGINST if not empty |
| resource_id | target.resource.product_object_id | Value copied directly |
| ALGUSER, log_event.log_event.ALGUSER | target.user.userid | Value from ALGUSER if not empty, overwritten by log_event.log_event.ALGUSER if not empty |
| metadata.product_name | Set to "SAP_SM20" | |
| metadata.vendor_name | Set to "SAP_SM20" | |
session_id |
event.idm.read_only_udm.network.session_id |
Mapped from changelog |
application |
event.idm.read_only_udm.target.application |
Mapped from changelog |
resource_id |
event.idm.read_only_udm.target.resource.product_object_id |
Mapped from changelog |
hostname |
event.idm.read_only_udm.principal.hostname |
Mapped from changelog |
hostname |
event.idm.read_only_udm.principal.asset.hostname |
Mapped from changelog |
ip |
event.idm.read_only_udm.principal.ip |
Mapped from changelog |
ip |
event.idm.read_only_udm.principal.asset.ip |
Mapped from changelog |
date |
event.idm.read_only_udm.metadata.event_timestamp |
Mapped from changelog |
ALGCLIENT" and "ALGINST |
target.resource.attribute.labels |
Mapped from changelog |
WP_TYP", "ALGREPNA", "ALGAREA", "ALGFILENO", "ALGFILEPOS", "ALGSUBID", "UTCDIFF", "ALGTASKNO", "ALGTASKTYPE", "ALGTCODE |
additional.fields |
Mapped from changelog |
Change Log
View the Change Log for this parser
Need more help? Get answers from Community members and Google SecOps professionals.