Collect FileZilla FTP logs

Parser Version: 1.0

Supported in:

This document explains how to ingest FileZilla FTP logs to Google Security Operations using the Bindplane agent.

FileZilla is an open-source FTP server and client that generates log files containing connection details, file transfer operations, authentication events, and session activity. The parser extracts fields from log data using grok patterns and maps them to the Unified Data Model (UDM).

Before you begin

Make sure you have the following prerequisites:

  • A Google SecOps instance
  • Windows Server 2016 or later, or Linux host with systemd
  • The Bindplane agent must be installed on the same host as FileZilla (or have access to the FileZilla log file path)
  • If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
  • Administrative access to the FileZilla application

Get Google SecOps credentials for the Bindplane agent

To authenticate the Bindplane agent to Google SecOps, choose one of the following methods:

  • New deployments: Use the Chronicle API (Option 1).
  • Legacy deployments: Continue using the ingestion authentication file (Option 2) until the Ingestion API is discontinued on July 20, 2027.
  1. Sign in to the Google Cloud console and select the Google Cloud project that is linked to your Google SecOps instance.
  2. Go to IAM & Admin > Service Accounts.
  3. Click Create service account.
  4. Provide the following configuration details:
    • Service account name: Enter a name for the account (for example, bindplane-ingest).
    • Service account description: Enter a description (for example, Bindplane agent log ingestion).
  5. Click Create and continue.
  6. In the Grant this service account access to project section, click Select a role and select Chronicle Editor.
  7. Click Continue, and then click Done.
  8. Click the service account you created, and then go to the Keys tab.
  9. Click Add key > Create new key.
  10. Select JSON and click Create. The key file is downloaded to your computer.
  11. Save the key file as ingestion-auth.json in the Bindplane collector directory (/opt/observiq-otel-collector/ingestion-auth.json on Linux or C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json on Windows), or update creds_file_path in config.yaml to match the path where you save it.
  12. Go to IAM & Admin > Settings and copy the Project number. You'll need it for the exporter configuration.

Option 2: Download the ingestion authentication file (legacy)

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Collection Agents.
  3. Download the ingestion authentication file.
  4. Save the file securely on the system where the Bindplane agent will be installed.

Get Google SecOps customer ID

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Profile.
  3. Copy and save the Customer ID from the Organization Details section.

Install the Bindplane agent

Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.

Windows installation

  1. Open Command Prompt or PowerShell as an administrator.
  2. Run the following command:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. Wait for the installation to complete.

  4. Verify the installation by running:

    sc query observiq-otel-collector
    

    The service should show as RUNNING.

Linux installation

  1. Open a terminal with root or sudo privileges.
  2. Run the following command:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. Wait for the installation to complete.

  4. Verify the installation by running:

    sudo systemctl status observiq-otel-collector
    

    The service should show as active (running).

Additional installation resources

For additional installation options and troubleshooting, see the Bindplane agent installation guide.

Configure the Bindplane agent to ingest FileZilla logs and send to Google SecOps

Locate the configuration file

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

Edit the configuration file

  • Replace the entire contents of config.yaml with the following configuration:

    receivers:
      filelog:
        file_path: '<PATH_TO>/filezilla-logs.log'
        log_type: 'file'
    
    exporters:
      chronicle/filezilla_ftp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FILEZILLA_FTP
        raw_log_field: body
    
    service:
      pipelines:
        logs/filezilla_ftp_to_chronicle:
          receivers:
            - filelog
          exporters:
            - chronicle/filezilla_ftp
    

Configuration parameters

Replace the following placeholders:

  • Receiver configuration:

    • file_path: Full path to the FileZilla log file:
      • Linux: for example, /var/log/filezilla/filezilla-logs.log
      • Windows: for example, C:\Users\<username>\AppData\Local\FileZilla\filezilla-logs.log
      • The exact path depends on the filename and location configured in FileZilla (see Configure logging in FileZilla)
  • Exporter configuration:

    • creds_file_path: Full path to the service account JSON key file (Option 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Customer ID copied from the Google SecOps console
    • location: Replace <LOCATION> with the region of your Google SecOps instance (for example, us, europe, or asia-southeast1). The exporter prefixes chronicle.googleapis.com with this value. See Regional Endpoints for the complete list.
    • project: Replace <PROJECT_NUMBER> with the project number from IAM & Admin > Settings.
    • endpoint: Keep set to chronicle.googleapis.com.

Legacy ingestion API exporter

  • If you use the ingestion authentication file from Option 2, replace the exporters block with the following. Set creds_file_path to the path to the ingestion authentication file, and if your instance is outside the US, replace malachiteingestion-pa.googleapis.com with your regional endpoint (for example, europe-malachiteingestion-pa.googleapis.com).

    exporters:
      chronicle/filezilla_ftp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FILEZILLA_FTP
        raw_log_field: body
    

Save the configuration file

  • After editing, save the file:
    • Linux: Press Ctrl+O, then Enter, then Ctrl+X
    • Windows: Click File > Save

Restart the Bindplane agent to apply the changes

  • To restart the Bindplane agent in Linux, run the following command:

    sudo systemctl restart observiq-otel-collector
    
    1. Verify the service is running:

      sudo systemctl status observiq-otel-collector
      
    2. Check logs for errors:

      sudo journalctl -u observiq-otel-collector -f
      
  • To restart the Bindplane agent in Windows, choose one of the following options:

    • Command Prompt or PowerShell as administrator:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • Services console:

      1. Press Win+R, type services.msc, and press Enter.
      2. Locate observIQ OpenTelemetry Collector.
      3. Right-click and select Restart.
      4. Verify the service is running:

        sc query observiq-otel-collector
        
      5. Check logs for errors:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Configure logging in FileZilla

  1. Sign in to the server with FileZilla.
  2. Open the FileZilla software.
  3. Go to Edit > Settings.
  4. Select Logging from the menu.
  5. Provide the following configuration details:
    • Select the checkbox Show timestamps in messagebox.
    • Select the checkbox Log to file.
    • Filename: Enter a filename and select the storage path (for example, filezilla-logs).
    • Optional: Limit size of logfile: Select this checkbox to limit the amount of space a log file can use.
    • Optional: Limit: Enter a max file size for your log file in Megabytes.
  6. Click OK.
  7. Restart FileZilla.

UDM mapping table

Log field UDM mapping Logic
data read_only_udm.metadata.description The raw log data field content.
data read_only_udm.metadata.event_timestamp.seconds Extracted from the data field using a grok pattern and converted to epoch seconds.
data read_only_udm.network.http.response_code Extracted from the data field using a grok pattern.
data read_only_udm.principal.hostname Extracted from the data field using a grok pattern.
data read_only_udm.principal.port Extracted from the data field using a grok pattern.
data read_only_udm.principal.user.userid Extracted from the data field using a grok pattern, only if the value is not not logged in.
data read_only_udm.target.ip Extracted from the data field using a grok pattern.
data read_only_udm.target.process.pid Extracted from the data field using a grok pattern.
read_only_udm.metadata.event_type Set to NETWORK_FTP if target.ip exists, otherwise set to GENERIC_EVENT.
read_only_udm.metadata.log_type Set to FILEZILLA_FTP.
read_only_udm.metadata.product_name Set to FILEZILLA.
read_only_udm.metadata.vendor_name Set to FILEZILLA.

Change Log

View the Change Log for this parser

Need more help? Get answers from Community members and Google SecOps professionals.