Collect Sophos Endpoint logs
This document explains how to collect Sophos Endpoint (formerly Sophos AV/Intercept X) logs by using the Bindplane agent. The parser transforms JSON logs into a unified data model (UDM). It extracts fields from nested JSON structures, maps them to UDM fields, and performs event categorization based on the type field, enriching the data with specific details and actions for different Sophos AV event types.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance
- Windows 2016 or later, or a Linux host with
systemd - An additional Windows or Linux machine, capable of continuously running Python
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
- Privileged access to Sophos Central Admin console
Get Google SecOps Ingestion Authentication File
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
- Download the Ingestion Authentication File.
- Save the file securely on the system where Bindplane will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
- Copy and save the Customer ID from the Organization Details section.
Install the Bindplane Agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows Installation
- Open the Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux Installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
Additional Installation Resources
For additional installation options, consult this installation guide.
Configure the Bindplane Agent to ingest Syslog and send to Google SecOps
- Access the Configuration File:
- Locate the
config.yamlfile. Typically, it's in the/etc/bindplane-agent/directory on Linux or in the installation directory on Windows. - Open the file using a text editor (for example,
nano,vi, or Notepad).
- Locate the
Edit the
config.yamlfile as follows:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'SOPHOS_AV' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labelsReplace the port and IP address as required in your infrastructure.
Replace
<customer_id>with the actual Customer ID.Update
/path/to/ingestion-authentication-file.jsonto the file path where the authentication file was saved in Step 1.
Restart Bindplane Agent to apply the changes
To restart the Bindplane agent in Linux, run the following command:
sudo systemctl restart bindplane-agentTo restart the Bindplane agent in Windows, you can either use the Services console or enter the following command:
net stop BindPlaneAgent && net start BindPlaneAgent
Configure Sophos Central API access
- Sign in to Sophos Central Admin.
- Select Global Settings > API Token Management.
- Click Add Token to create a new token.
- Enter a token name and click Save. The API Token Summary for the provided token is displayed.
- In the API Token Summary section, click Copy to copy the API access URL and headers.
Install Python on the additional machine
- Open the web browser and go to the Python website.
- Click Download Python for your operating system (Windows or Mac).
Install Python.
- On Windows:
- Run the installer.
- Check the box that says Add Python to PATH.
- Click Install Now.
On Mac:
- Python may already be installed, if not you can install the latest version using the terminal.
- Open Terminal and type the following command:
python --version
- On Windows:
Download the Sophos integration script
- Go to the GitHub page for Sophos Central SIEM Integration GitHub Repository.
- Click the green Code button > Download ZIP.
- Extract the ZIP file.
Set up the script configuration
- Find and open the
config.inifile with a text editor. - Edit the configuration file:
- API Token: Enter the API Key copied earlier from Sophos Central.
- Syslog Server Details: Enter the details of your syslog server.
- Host: Enter the Bindplane IP address.
- Port: Enter the Bindplane port number.
- Protocol: Enter UDP (you can also use TCP or TLS depending on your setup).
- Save the file.
Run the script
Go to the script folder.
On Windows:
- Press the Windows key and type
cmd. - Click Command Prompt.
- Go to the script folder:
cd C:UsersYourNameDownloadsSophos-Central-SIEM-Integration- Press the Windows key and type
On macOS:
- Go to Applications > Utilities.
- Open Terminal.
- Go to the script folder:
cd /Users/YourName/Downloads/Sophos-Central-SIEM-Integration
Run the script:
Type the following command to start the script:
python siem.py
Automate the script to run continuously on Windows (using Task Scheduler):
- Open the Task Scheduler by typing Task Scheduler in the Start menu.
- Click Create Task.
- In the General tab:
- Name your task; for example,
Sophos AV Log Export.
- Name your task; for example,
- In the Triggers tab:
- Click New and set the task to run Daily or At startup (depending on your preference).
- In the Actions tab:
- Click New and select Start a program.
- Browse for the
python.exeexecutable (usually found atC:PythonXXpython.exe). - In the Add arguments field, type the path to the script; for example,
C:UsersYourNameDownloadsSophos-Central-SIEM-Integrationsiem.py.
- Click OK to save the task.
Automate the script to run continuously on Mac (using Cron Jobs):
- Open the Terminal.
- Type
crontab -eand pressEnter. Add a new line at the end of the file:
* * * * * /usr/bin/python /Users/YourName/Downloads/Sophos-Central-SIEM-Integration/siem.pySave and exit the editor.
UDM Mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
s_ip |
intermediary.ip |
Merged |
description |
metadata.description |
Directly mapped |
name |
metadata.description |
Directly mapped |
security_result.description |
metadata.description |
Renamed/mapped |
end |
metadata.event_timestamp |
Parsed as RFC3339 |
ts |
metadata.event_timestamp |
Parsed as RFC3339 |
action |
metadata.event_type |
Mapped: unknown → NETWORK_CONNECTION, allowed → SCAN_PROCESS, blocked → `SCAN_PROC... |
e_type |
metadata.event_type |
Mapped values (11 total, e.g. NonCompliant → SCAN_HOST, SavDisabled → `SETTING_MODIFIC... |
type |
metadata.event_type |
Mapped values (13 total, e.g. Event::Endpoint::NonCompliant → SCAN_HOST, `Event::Endpoin... |
e_type |
metadata.product_event_type |
Directly mapped |
type |
metadata.product_event_type |
Directly mapped |
action |
network.direction |
Mapped: warned → OUTBOUND, unknown → OUTBOUND |
e_type |
network.direction |
Mapped: WindowsFirewall::Blocked → OUTBOUND |
type |
network.direction |
Mapped: Event::Endpoint::WindowsFirewall::Blocked → OUTBOUND |
action |
network.ip_protocol |
Mapped: warned → TCP, unknown → TCP |
appSha256 |
principal.file.sha256 |
Directly mapped |
dhost |
principal.hostname |
Directly mapped |
host |
principal.hostname |
Directly mapped |
source_info.ip |
principal.ip |
Merged |
src_ip |
principal.ip |
Merged |
id |
principal.resource.id |
Directly mapped |
suser |
principal.user.user_display_name |
Directly mapped |
suser |
principal.user.userid |
Directly mapped |
user |
principal.user.userid |
Directly mapped |
user_id |
principal.user.userid |
Directly mapped |
endpoint_id_label |
security_result.about.labels |
Merged |
endpoint_type_label |
security_result.about.labels |
Merged |
action |
security_result.action |
Mapped values (5 total, e.g. allow → sec_action, unknown → sec_action, allowed → `... |
sec_action |
security_result.action |
Merged |
group |
security_result.category_details |
Merged |
sub_cat |
security_result.category_details |
Merged |
desc |
security_result.description |
Directly mapped |
e_type |
security_result.description |
Mapped: (UpdateRebootRequired/ServiceNotRunning/NonCompliant/OutOfDate) → `security_result... |
type |
security_result.description |
Mapped: Event::Endpoint::(UpdateRebootRequired/ServiceNotRunning/NonCompliant/OutOfDate) →... |
rule |
security_result.rule_name |
Directly mapped |
rules |
security_result.rule_name |
Directly mapped |
severity |
security_result.severity |
Mapped values (6 total, e.g. low → LOW, low → MEDIUM, low → HIGH) |
security_result.description |
security_result.summary |
Renamed/mapped |
application |
target.application |
Directly mapped |
endpoint_id |
target.asset_id |
Directly mapped |
f_path |
target.file.full_path |
Directly mapped |
f_size |
target.file.size |
Renamed/mapped |
dhost |
target.hostname |
Directly mapped |
host |
target.hostname |
Directly mapped |
application |
target.process.file.full_path |
Directly mapped |
customer_id |
target.resource.id |
Directly mapped |
e_type |
target.resource.name |
Mapped: SavDisabled → Real time protection, OutOfDate → Device Registration, `Regist... |
p_device |
target.resource.name |
Directly mapped |
scan_name |
target.resource.name |
Directly mapped |
type |
target.resource.name |
Mapped: Event::Endpoint::SavDisabled → Real time protection, `Event::Endpoint::OutOfDate... |
action |
target.resource.type |
Mapped: blocked → Device, restricted to read-only → Device |
e_type |
target.resource.type |
Mapped values (5 total, e.g. SavDisabled → SETTING, OutOfDate → SETTING, `Registered... |
type |
target.resource.type |
Mapped values (5 total, e.g. Event::Endpoint::SavDisabled → SETTING, `Event::Endpoint::O... |
url |
target.url |
Directly mapped |
duid |
target.user.userid |
Directly mapped |
suser |
target.user.userid |
Directly mapped |
user |
target.user.userid |
Directly mapped |
| N/A | metadata.event_type |
Constant: GENERIC_EVENT |
| N/A | metadata.product_name |
Constant: Sophos Anti-Virus |
| N/A | metadata.vendor_name |
Constant: Sophos |
| N/A | network.direction |
Constant: OUTBOUND |
| N/A | network.ip_protocol |
Constant: TCP |
| N/A | security_result.description |
Constant: security_result.summary |
| N/A | security_result.severity |
Constant: LOW |
| N/A | target.resource.name |
Constant: Real time protection |
| N/A | target.resource.type |
Constant: SETTING |
Need more help? Get answers from Community members and Google SecOps professionals.