Collect HPE Nimble Storage OS logs
This document explains how to ingest HPE Nimble Storage OS logs to Google Security Operations using Bindplane.
HPE Nimble Storage OS is a storage array operating system that generates system, hardware, and replication logs. The platform monitors storage operations and provides detailed event logging for capacity management, array health, and data protection activities. HPE Nimble Storage arrays support native syslog forwarding of system events to external collectors.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance
- Windows Server 2016 or later, or Linux host with
systemd - Network connectivity between the Bindplane agent and HPE Nimble Storage array
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
- Privileged access to the HPE Nimble Storage array with administrator permissions
Get Google SecOps ingestion authentication file
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
Download the Ingestion Authentication File. Save the file securely on the system where Bindplane will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietWait for the installation to complete.
Verify the installation by running:
sc query observiq-otel-collector
The service should show as RUNNING.
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shWait for the installation to complete.
Verify the installation by running:
sudo systemctl status observiq-otel-collector
The service should show as active (running).
Additional installation resources
For additional installation options and troubleshooting, see Bindplane agent installation guide.
Configure the Bindplane agent to ingest syslog and send to Google SecOps
Locate the configuration file
Linux:
sudo systemctl status observiq-otel-collectorWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
Edit the configuration file
Replace the entire contents of
config.yamlwith the following configuration:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/nimble_os: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NIMBLE_OS raw_log_field: body ingestion_labels: env: production service: pipelines: logs/nimble_to_chronicle: receivers: - udplog exporters: - chronicle/nimble_os
Configuration parameters
Replace the following placeholders:
Receiver configuration:
udplog: The receiver type based on protocol:udplogfor UDP syslogtcplogfor TCP syslog
0.0.0.0: IP address to listen on:0.0.0.0to listen on all interfaces (recommended)- Specific IP address to listen on one interface
514: Port number to listen on (for example,514,1514,6514)
Exporter configuration:
nimble_os: Descriptive name for the exportercreds_file_path: Full path to ingestion authentication file:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>: Customer ID from the previous stependpoint: Regional endpoint URL:- US:
malachiteingestion-pa.googleapis.com - Europe:
europe-malachiteingestion-pa.googleapis.com - Asia:
asia-southeast1-malachiteingestion-pa.googleapis.com - See Regional Endpoints for complete list
- US:
NIMBLE_OS: Log type exactly as it appears in Chronicleingestion_labels: Optional labels in YAML format (for example,env: production)
Pipeline configuration:
nimble_to_chronicle: Descriptive name for the pipeline
Save the configuration file
- After editing, save the file:
- Linux: Press
Ctrl+O, thenEnter, thenCtrl+X - Windows: Click File > Save
- Linux: Press
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux:
Run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows:
Choose one of the following options:
- Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collector- Services console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
- Press
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Configure HPE Nimble Storage OS syslog forwarding
HPE Nimble Storage arrays support forwarding system, hardware, and replication event logs to an external syslog server. You can configure syslog forwarding using the CLI or the management GUI.
Configure syslog using the CLI
Connect to the HPE Nimble Storage array via SSH with administrator credentials:
ssh admin@<nimble_array_ip>Enable syslog and specify the Bindplane agent as the syslog server:
group --edit --syslog_server <bindplane_agent_ip>(Optional) Specify a custom syslog port (default is
514):group --edit --syslog_port <port_number>Verify the syslog configuration:
group --info | grep -i syslogThe output should show
Syslogd enabled: Yes, along with the configured server address and port.
Configure syslog using the management GUI
- Sign in to the HPE Nimble Storage management interface.
- Go to Administration > Syslog.
- Click Enable Syslog Server.
- In the Server field, enter the IP address of the Bindplane agent host.
- In the Port field, enter the port matching the Bindplane agent receiver configuration (default
514). - Click Save.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
| extensions.auth.mechanism | Authentication mechanism | |
| extensions.auth.type | Authentication type | |
| data_message | metadata.description | Event description |
| type | metadata.event_type | Event type |
| type | metadata.product_event_type | Product event type |
| id | metadata.product_log_id | Product log ID |
| version | metadata.product_version | Product version |
| group | principal.group.group_display_name | Group display name |
| logsource | principal.hostname | Principal hostname |
| client_ip | principal.ip | Principal IP address |
| array | principal.resource.name | Resource name |
| principal.resource.resource_subtype | Resource subtype | |
| principal.resource.resource_type | Resource type | |
| status | security_result.action | Security action |
| error | security_result.description | Security result description |
| security_result.summary | Security result summary | |
| filename,target | target.file.full_path | File full path |
| object_id | target.resource.id | Resource ID |
| object,target,filename,partner,volname | target.resource.name | Resource name |
| target.resource.resource_subtype | Resource subtype | |
| target.resource.resource_type | Resource type | |
| target.user.user_display_name | User display name | |
| username | target.user.userid | User ID |
| metadata.product_name | Product name | |
| metadata.vendor_name | Vendor name |
Need more help? Get answers from Community members and Google SecOps professionals.