Collect Barracuda Email Security Gateway logs
This document explains how to ingest Barracuda Email Security Gateway logs to Google Security Operations using Bindplane.
Barracuda Email Security Gateway is an email security appliance that provides inbound filtering for spam, viruses, spoofing, and phishing attacks. It also provides outbound filtering for data loss prevention and email encryption. The gateway logs all email transactions, policy actions, and threat detections via syslog.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance.
- A Windows 2016 or later or Linux host with systemd.
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements.
- Privileged access to the Barracuda Email Security Gateway management console.
Get Google SecOps ingestion authentication file
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agent.
- Download the Ingestion Authentication File.
- Save the file securely on the system where Bindplane will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
- Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open the Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
Additional Installation Resources
For additional installation options, consult this installation guide.
Configure the Bindplane agent to ingest Syslog and send to Google SecOps
Access the Configuration File:
- Locate the
config.yamlfile. Typically, it's in the/observiq-otel-collector/directory on Linux or in the installation directory on Windows. - Open the file using a text editor (for example,
nano,vi, or Notepad).
- Locate the
Edit the
config.yamlfile as follows:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <your_customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'BARRACUDA_EMAIL' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- Replace the port and IP address as required in your infrastructure.
- Replace
<your_customer_id>with the actual Customer ID. - Update
/path/to/ingestion-authentication-file.jsonto the file path where the authentication file was saved in Step 1.
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux:
Run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows:
Choose one of the following options:
- Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collector- Services console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
- Press
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Configure syslog forwarding on Barracuda Email Security Gateway
- Sign in to the Barracuda Email Security Gateway web interface.
- Go to ADVANCED > Advanced Networking.
- In the Syslog section, configure the following fields:
- Syslog Server: Enter the IP address or hostname of the Bindplane agent host (for example,
192.168.1.100). - Syslog Port: Enter
514(or your configured Bindplane agent port). - Syslog Protocol: Select TCP.
- Syslog Server: Enter the IP address or hostname of the Bindplane agent host (for example,
Click Save Changes.
Verify syslog delivery
- After configuring syslog forwarding, send a test email through the gateway.
- To confirm that the gateway is sending syslog data, go to ADVANCED > Troubleshooting and view the Syslog section to monitor real-time mail syslog output.
On the Bindplane agent host, verify that logs are being received:
sudo journalctl -u observiq-otel-collector -f
For more information, see the Barracuda Email Security Gateway syslog documentation.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
dst_domain |
target.hostname |
Value of dst_domain field. |
dst_domain |
target.asset.hostname |
Value of dst_domain field. |
geoip |
target.location.country_or_region |
Value of geoip field. |
hdr_from |
network.email.from |
Value of hdr_from field if it is an email address. |
hdr_to |
network.email.to |
Value of hdr_to field if it is an email address, otherwise parsed from JSON array in hdr_to field. |
host |
principal.hostname |
Value of host field. |
host |
principal.asset.hostname |
Value of host field. |
message_id |
network.email.mail_id |
Value of message_id field. |
product_log_id |
metadata.product_log_id |
Value of product_log_id field. |
queue_id |
security_result.detection_fields |
Value of queue_id field. |
recipient_email |
network.email.to |
Value of recipient_email field if it is not empty or -. |
recipients.action |
security_result.action |
Mapped to ALLOW if value is "allowed", otherwise mapped to BLOCK. |
recipients.action |
security_result.action_details |
Value of recipients.action field. |
recipients.delivery_detail |
security_result.detection_fields |
Value of recipients.delivery_detail field. |
recipients.delivered |
security_result.detection_fields |
Value of recipients.delivered field. |
recipients.email |
network.email.to |
Value of recipients.email field if it is an email address. |
recipients.reason |
security_result.detection_fields |
Value of recipients.reason field. |
recipients.reason_extra |
security_result.detection_fields |
Value of recipients.reason_extra field. |
recipients.taxonomy |
security_result.detection_fields |
Value of recipients.taxonomy field. |
service |
security_result.summary |
Value of service field. |
size |
network.received_bytes |
Value of size field converted to an unsigned integer. |
src_ip |
principal.ip |
Value of src_ip field if it is not empty or 0.0.0.0. |
src_ip |
principal.asset.ip |
Value of src_ip field if it is not empty or 0.0.0.0. |
src_ip |
security_result.about.ip |
Value of src_ip field if it is not empty or 0.0.0.0. |
subject |
network.email.subject |
Value of subject field. |
target_ip |
target.ip |
Value of target_ip field. |
target_ip |
target.asset.ip |
Value of target_ip field. |
timestamp |
metadata.event_timestamp |
Parsed timestamp from the log entry. |
metadata.event_type |
Hardcoded to EMAIL_TRANSACTION. |
|
metadata.log_type |
Hardcoded to BARRACUDA_EMAIL. |
|
metadata.vendor_name |
Hardcoded to "Barracuda". | |
network.application_protocol |
Set to SMTP if process field contains "smtp". |
|
network.direction |
Set to INBOUND if process field contains "inbound", set to OUTBOUND if process field contains "outbound". |
|
security_result.action |
Set based on a combination of action, action_code, service, and delivered fields. |
|
security_result.category |
Set based on a combination of action, reason, and other fields. |
Need more help? Get answers from Community members and Google SecOps professionals.