Trend Micro Deep Security 로그 수집
이 문서에서는 Bindplane을 사용하여 Trend Micro Deep Security 로그를 Google Security Operations에 수집하는 방법을 설명합니다. Trend Micro Deep Security는 물리적, 가상, 클라우드 워크로드에 대한 멀웨어 방지, IPS, 방화벽, 무결성 모니터링, 로그 검사, 애플리케이션 제어를 제공하는 서버 보안 플랫폼입니다. Deep Security는 Trend Vision One 플랫폼으로 통합되고 있지만 Deep Security Manager는 모든 보호 모듈에 대해 syslog 이벤트를 계속 생성합니다.
자세한 내용은 Trend Micro Deep Security 로그 수집을 참고하세요.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- systemd가 있는 Windows 2016 이상 또는 Linux 호스트
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 관리자 또는 감사자 역할로 Trend Micro Deep Security Manager 웹 콘솔에 대한 권한 있는 액세스 권한
- Deep Security Manager 20.0 이상
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 신규 배포: Chronicle API (옵션 1)를 사용합니다.
- 기존 배포: 2027년 7월 20일에 수집 API가 지원 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다 (예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 생성한 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가> 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path을 저장된 경로와 일치하도록 업데이트합니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
- 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 설치
- 루트 또는 sudo 권한이 있는 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
추가 설치 리소스
- 추가 설치 옵션은 이 설치 가이드를 참고하세요.
Syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일에 액세스합니다.
config.yaml파일을 찾습니다. 일반적으로 Linux의/opt/observiq-otel-collector/config.yaml디렉터리 또는 Windows의 설치 디렉터리에 있습니다.- 텍스트 편집기 (예:
nano,vi, 메모장)를 사용하여 파일을 엽니다.
다음과 같이
config.yaml파일을 수정합니다.receivers: tcplog: listen_address: "0.0.0.0:1514" exporters: chronicle/trendmicro_ds: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<CUSTOMER_ID>' endpoint: chronicle.googleapis.com log_type: TRENDMICRO_DEEP_SECURITY raw_log_field: body ingestion_labels: service: pipelines: logs/trendmicro_ds_to_chronicle: receivers: - tcplog exporters: - chronicle/trendmicro_ds
- 인프라에서 필요에 따라 포트와 IP 주소를 바꿉니다.
<LOCATION>을 Google SecOps 인스턴스의 리전 (예:us,europe또는asia-southeast1)으로 바꿉니다. 내보내기 도구는 이 값으로chronicle.googleapis.com프리픽스를 지정합니다.<PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.<CUSTOMER_ID>를 실제 고객 ID로 바꿉니다./path/to/ingestion-authentication-file.json을 서비스 계정 키 파일 (옵션 1)이 저장된 경로로 업데이트합니다.
기존 수집 API 내보내기
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/trendmicro_ds: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: TRENDMICRO_DEEP_SECURITY raw_log_field: body ingestion_labels:
Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collectorWindows에서 Bindplane 에이전트를 다시 시작하려면 서비스 콘솔을 사용하거나 다음 명령어를 입력하면 됩니다.
net stop observiq-otel-collector && net start observiq-otel-collector
Trend Micro Deep Security에서 syslog 전달 구성
Deep Security Manager에서 syslog 설정 구성
- Trend Micro Deep Security Manager 웹 콘솔에 로그인합니다.
- Administration(관리) > System Settings(시스템 설정) > Event Forwarding(이벤트 전달)으로 이동합니다.
- SIEM 섹션에서 원격 컴퓨터로 이벤트 전달 (Syslog 사용)을 선택합니다.
syslog 구성 옆에 있는 수정을 클릭합니다.
다음 구성 세부정보를 제공합니다.
- 서버 이름: Bindplane 에이전트 호스트의 IP 주소를 입력합니다.
- 서버 포트:
1514(또는 구성된 포트)를 입력합니다. - 전송: TCP를 선택합니다.
- 이벤트 형식: Common Event Format (CEF)을 선택합니다.
확인을 클릭하여 시스템 로그 서버 구성을 저장합니다.
전달할 이벤트 유형 선택
이벤트 전달 탭에서 전달할 이벤트 유형을 구성합니다.
- 멀웨어 방지 이벤트: 멀웨어 방지 이벤트를 Syslog로 전달을 선택합니다.
- 웹 평판 이벤트: 웹 평판 이벤트를 Syslog로 전달을 선택합니다.
- thought 방화벽 이벤트: 방화벽 이벤트를 Syslog로 전달을 선택합니다.
- 침입 방지 이벤트: 침입 방지 이벤트를 Syslog로 전달을 선택합니다.
- 무결성 모니터링 이벤트: 무결성 모니터링 이벤트를 Syslog로 전달을 선택합니다.
- 로그 검사 이벤트: 로그 검사 이벤트를 Syslog로 전달을 선택합니다.
- 애플리케이션 제어 이벤트: 애플리케이션 제어 이벤트를 Syslog로 전달을 선택합니다.
- 시스템 이벤트: 시스템 이벤트를 Syslog로 전달을 선택합니다.
저장을 클릭합니다.
정책 수준 syslog 구성 (선택사항)
특정 정책에 대해 syslog 전달을 구성해야 하는 경우 다음 단계를 따르세요.
- 정책으로 이동합니다.
- 구성하려는 정책을 더블클릭합니다.
설정 > 이벤트 전달로 이동합니다.
각 보호 모듈에 대해 전역 syslog 설정을 재정의할 수 있습니다.
- 상속을 선택하여 전역 설정을 사용합니다.
- 예를 선택하여 특정 정책에 대해 syslog 전달을 사용 설정합니다.
- 특정 정책에 대해 syslog 전달을 사용 중지하려면 아니요를 선택합니다.
저장을 클릭합니다.
syslog 전달 확인
- Deep Security Manager에서 이벤트 및 보고서 > 이벤트로 이동합니다.
- 보안 관련 활동이 생성되고 있는지 확인합니다.
Bindplane 에이전트 로그를 확인하여 syslog 메시지가 TCP 리스너에서 수신되는지 확인합니다.
sudo journalctl -u observiq-otel-collector -f
자세한 내용은 Trend Micro Deep Security syslog 문서를 참조하세요.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
dvc |
about.ip |
병합됨 |
aggregation_type_label |
additional.fields |
병합됨 |
cn1Label |
additional.fields |
매핑됨: Host ID → cn1_label |
cn1_label |
additional.fields |
병합됨 |
fileInCompressedFile_label |
additional.fields |
병합됨 |
repeat_count_label |
additional.fields |
병합됨 |
cef_host |
intermediary.hostname |
직접 매핑됨 |
hostname |
intermediary.hostname |
직접 매핑됨 |
cef_host |
intermediary.ip |
병합됨 |
hostname |
intermediary.ip |
병합됨 |
desc |
metadata.description |
직접 매핑됨 |
timestamp |
metadata.event_timestamp |
ISO8601(으)로 파싱됨 |
has_principal |
metadata.event_type |
매핑됨: true → NETWORK_HTTP, true → STATUS_UPDATE |
TrendMicroDsTenant |
metadata.product_deployment_id |
직접 매핑됨 |
event_id |
metadata.product_event_type |
직접 매핑됨 |
log_type |
metadata.product_name |
직접 매핑됨 |
product_version |
metadata.product_version |
직접 매핑됨 |
organization |
metadata.vendor_name |
직접 매핑됨 |
proto |
network.ip_protocol |
매핑됨: ICMPv6 → ICMP |
in |
network.received_bytes |
이름 변경/매핑됨 |
out |
network.sent_bytes |
이름 변경/매핑됨 |
dvchost |
principal.asset.hostname |
직접 매핑됨 |
shost |
principal.asset.hostname |
직접 매핑됨 |
src |
principal.asset.ip |
병합됨 |
dvchost |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
직접 매핑됨 |
src |
principal.ip |
병합됨 |
smac |
principal.mac |
병합됨 |
srcMAC |
principal.mac |
병합됨 |
spt |
principal.port |
직접 매핑됨 |
srcPort |
principal.port |
직접 매핑됨 |
TrendMicroDsProcessPid |
principal.process.pid |
직접 매핑됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
suid |
principal.user.userid |
직접 매핑됨 |
usrName |
principal.user.userid |
직접 매핑됨 |
action |
security_result.action |
병합됨 |
act |
security_result.action_details |
직접 매핑됨 |
result |
security_result.action_details |
직접 매핑됨 |
cat |
security_result.category_details |
병합됨 |
msg |
security_result.description |
직접 매핑됨 |
TrendMicroDsPacketData_label |
security_result.detection_fields |
병합됨 |
behaviour_type_field |
security_result.detection_fields |
병합됨 |
cn3_label |
security_result.detection_fields |
병합됨 |
count_label |
security_result.detection_fields |
병합됨 |
cs1_label |
security_result.detection_fields |
병합됨 |
cs2_label |
security_result.detection_fields |
병합됨 |
cs3_label |
security_result.detection_fields |
병합됨 |
cs4_label |
security_result.detection_fields |
병합됨 |
cs5_label |
security_result.detection_fields |
병합됨 |
cs6_label |
security_result.detection_fields |
병합됨 |
cs7_label |
security_result.detection_fields |
병합됨 |
frame_type_field |
security_result.detection_fields |
병합됨 |
malware_target |
security_result.detection_fields |
병합됨 |
process_label |
security_result.detection_fields |
병합됨 |
target_type |
security_result.detection_fields |
병합됨 |
tenant_field |
security_result.detection_fields |
병합됨 |
tenant_id_field |
security_result.detection_fields |
병합됨 |
sev |
security_result.severity |
매핑됨: "0", "1", "2", "3", "LOW" → LOW, "4", "5", "6", "MEDIUM" → MEDIUM, `"7", "8"… |
sev |
security_result.severity_details |
직접 매핑됨 |
name |
security_result.summary |
직접 매핑됨 |
result |
security_result.summary |
직접 매핑됨 |
event_name |
security_result.threat_name |
직접 매핑됨 |
organization |
target.administrative_domain |
직접 매핑됨 |
cef_host |
target.asset.hostname |
직접 매핑됨 |
hostname |
target.asset.hostname |
직접 매핑됨 |
target |
target.asset.hostname |
직접 매핑됨 |
dst |
target.asset.ip |
병합됨 |
filePath |
target.file.full_path |
직접 매핑됨 |
cs3 |
target.file.md5 |
직접 매핑됨 |
TrendMicroDsFileSHA1 |
target.file.sha1 |
직접 매핑됨 |
cs2 |
target.file.sha1 |
직접 매핑됨 |
fileHash |
target.file.sha256 |
직접 매핑됨 |
cn2 |
target.file.size |
이름 변경/매핑됨 |
fsize |
target.file.size |
이름 변경/매핑됨 |
cef_host |
target.hostname |
직접 매핑됨 |
hostname |
target.hostname |
직접 매핑됨 |
target |
target.hostname |
직접 매핑됨 |
dst |
target.ip |
병합됨 |
dmac |
target.mac |
병합됨 |
dstMAC |
target.mac |
병합됨 |
dpt |
target.port |
직접 매핑됨 |
dstPort |
target.port |
직접 매핑됨 |
duser |
target.user.user_display_name |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: NETWORK_HTTP |
| 해당 사항 없음 | network.ip_protocol |
상수: ICMP |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
cs4" , "TrendMicroDsPacketData" and "cn3 |
security_result.detection_fields |
변경 로그에서 매핑됨 |
cn1 |
principal.asset_id |
변경 로그에서 매핑됨 |
security_result.action |
BLOCK |
변경 로그에서 매핑됨 |
cef_host" and "hostname |
intermediary.ip |
변경 로그에서 매핑됨 |
TrendMicroDsMalwareTarget","TrendMicroDsProcess", "TrendMicroDsMalwareTargetCount","TrendMicroDsMalwareTargetType" and "TrendMicroDsBehaviorType |
security_result.detection_fields |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.