Collect Symantec VIP Enterprise Gateway logs
This document explains how to ingest Symantec VIP Enterprise Gateway logs to Google Security Operations using the Bindplane agent.
Symantec VIP (Validation and ID Protection) Enterprise Gateway is a multi-factor authentication solution that generates syslog messages for authentication events, credential validation, LDAP synchronization, and health check activity. The parser extracts fields from JSON-formatted and syslog-formatted logs and maps them to the Unified Data Model (UDM).
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance
- Windows Server 2016 or later, or Linux host with
systemd - Network connectivity between the Bindplane agent and the Symantec VIP Gateway
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
- Administrative access to the Symantec VIP Gateway web UI
Get Google SecOps credentials for the Bindplane agent
To authenticate the Bindplane agent to Google SecOps, choose one of the following methods:
- New deployments: Use the Chronicle API (Option 1).
- Legacy deployments: Continue using the ingestion authentication file (Option 2) until the Ingestion API is discontinued on July 20, 2027.
Option 1: Create a service account for the Chronicle API (recommended)
- Sign in to the Google Cloud console and select the Google Cloud project that is linked to your Google SecOps instance.
- Go to IAM & Admin > Service Accounts.
- Click Create service account.
- Provide the following configuration details:
- Service account name: Enter a name for the account (for example,
bindplane-ingest). - Service account description: Enter a description (for example,
Bindplane agent log ingestion).
- Service account name: Enter a name for the account (for example,
- Click Create and continue.
- In the Grant this service account access to project section, click Select a role and select Chronicle Editor.
- Click Continue, and then click Done.
- Click the service account you created, and then go to the Keys tab.
- Click Add key > Create new key.
- Select JSON and click Create. The key file is downloaded to your computer.
- Save the key file as
ingestion-auth.jsonin the Bindplane collector directory (/opt/observiq-otel-collector/ingestion-auth.jsonon Linux orC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.jsonon Windows), or updatecreds_file_pathinconfig.yamlto match the path where you save it. - Go to IAM & Admin > Settings and copy the Project number. You'll need it for the exporter configuration.
Option 2: Download the ingestion authentication file (legacy)
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
- Download the ingestion authentication file.
- Save the file securely on the system where the Bindplane agent will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietWait for the installation to complete.
Verify the installation by running:
sc query observiq-otel-collectorThe service should show as RUNNING.
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shWait for the installation to complete.
Verify the installation by running:
sudo systemctl status observiq-otel-collectorThe service should show as active (running).
Additional installation resources
For additional installation options and troubleshooting, see the Bindplane agent installation guide.
Configure the Bindplane agent to ingest syslog and send to Google SecOps
Locate the configuration file
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
Edit the configuration file
Replace the entire contents of
config.yamlwith the following configuration:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/symantec_vip: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: SYMANTEC_VIP raw_log_field: body service: pipelines: logs/symantec_vip_to_chronicle: receivers: - udplog exporters: - chronicle/symantec_vip
Configuration parameters
Replace the following placeholders:
Receiver configuration:
listen_address: IP address and port to listen on:0.0.0.0to listen on all interfaces (recommended)- Port
514is the standard syslog port (requires root on Linux; use1514for non-root)
Exporter configuration:
creds_file_path: Full path to the service account JSON key file (Option 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Customer ID copied from the Google SecOps consolelocation: Replace<LOCATION>with the region of your Google SecOps instance (for example,us,europe, orasia-southeast1). The exporter prefixeschronicle.googleapis.comwith this value. See Regional Endpoints for the complete list.project: Replace<PROJECT_NUMBER>with the project number from IAM & Admin > Settings.endpoint: Keep set tochronicle.googleapis.com.
Legacy ingestion API exporter
If you use the ingestion authentication file from Option 2, replace the
exportersblock with the following. Setcreds_file_pathto the path to the ingestion authentication file, and if your instance is outside the US, replacemalachiteingestion-pa.googleapis.comwith your regional endpoint (for example,europe-malachiteingestion-pa.googleapis.com).exporters: chronicle/symantec_vip: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SYMANTEC_VIP raw_log_field: body
Save the configuration file
- After editing, save the file:
- Linux: Press
Ctrl+O, thenEnter, thenCtrl+X - Windows: Click File > Save
- Linux: Press
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux, run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows, choose one of the following options:
Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collectorServices console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- Press
Configure syslog in Symantec VIP Enterprise Gateway
- Sign in to the Symantec VIP Gateway web UI.
- Go to Logs > Syslog Configuration.
- If configuring Syslog for the first time, select Yes when prompted. If already configured, click Edit.
- Provide the following configuration details:
- Syslog Facility: Select LOG_LOCAL0.
- Syslog Host: Enter the Bindplane agent IP address.
- Syslog Port: Enter the Bindplane agent port number (for example,
514for UDP).
- Click Save.
- Go to Settings > Console Settings.
- Provide the following configuration details:
- Logging Level: Select Info.
- Enable Syslog: Select Yes.
- Click Submit.
- Go to Settings > Health Check Settings.
- Select Yes to enable the Health Check Service.
- Provide the following configuration details:
- Logging Level: Select Info.
- Enable Syslog: Select Yes.
- Click Submit.
- Go to User Store > LDAP Directory Synchronization.
- Edit the following configuration details:
- Log Level: Select Info.
- Enable Syslog: Select Yes.
- Click Submit.
UDM mapping table
| Log field | UDM mapping | Logic |
|---|---|---|
| application | read_only_udm.principal.application | Value taken from application field extracted by json filter. |
| command | read_only_udm.target.process.command_line | Value taken from command field extracted by grok pattern. |
| credentialType | This field is not directly mapped to the UDM. It is used to derive the value of read_only_udm.extensions.auth.mechanism. | |
| data | This field is not directly mapped to the UDM. It is parsed to extract other fields. | |
| data2 | This field is not directly mapped to the UDM. It is parsed to extract other fields. | |
| datetime | read_only_udm.metadata.event_timestamp.seconds read_only_udm.metadata.event_timestamp.nanos |
Seconds and nanoseconds since epoch extracted from the datetime field. |
| desc | read_only_udm.metadata.description | Value taken from desc field extracted by json filter. |
| description | read_only_udm.security_result.description | Value taken from description field extracted by json filter. |
| filename | read_only_udm.target.process.file.full_path | Value taken from filename field extracted by grok pattern. |
| hostname | read_only_udm.principal.hostname | Value taken from hostname field extracted by json filter. |
| host_name | read_only_udm.intermediary.hostname | Value taken from host_name field extracted by json filter. |
| log_level | This field is not directly mapped to the UDM. It is used to derive the value of read_only_udm.security_result.severity. | |
| log_type | read_only_udm.metadata.product_event_type | Value taken from log_type field extracted by json filter. |
| msg | This field is not directly mapped to the UDM. It is parsed to extract other fields. | |
| operation | read_only_udm.security_result.summary | Value taken from operation field extracted by grok pattern. |
| processid | read_only_udm.target.process.pid | Value taken from processid field extracted by grok pattern. |
| product | read_only_udm.metadata.product_name | Value taken from product field extracted by json filter. |
| reason | read_only_udm.metadata.description | Value taken from reason field extracted by grok pattern. |
| request_id | read_only_udm.target.resource.id | Value taken from request_id field extracted by grok pattern. |
| src_ip | read_only_udm.principal.ip | Value taken from src_ip field extracted by grok pattern. |
| status | read_only_udm.metadata.description | Value taken from status field extracted by grok pattern. |
| summary | read_only_udm.security_result.summary | Value taken from summary field extracted by json filter. |
| timestamp.nanos | read_only_udm.metadata.event_timestamp.nanos | Nanoseconds from the original log timestamp. |
| timestamp.seconds | read_only_udm.metadata.event_timestamp.seconds | Seconds from the original log timestamp. |
| time | This field is not directly mapped to the UDM. It is used to derive the values of read_only_udm.metadata.event_timestamp.seconds and read_only_udm.metadata.event_timestamp.nanos. | |
| user | read_only_udm.target.user.userid | Value taken from user field extracted by json filter or grok pattern. |
| vendor | read_only_udm.metadata.vendor_name | Value taken from vendor field extracted by json filter. |
| read_only_udm.extensions.auth.mechanism | Determined by the credentialType field. If credentialType is SMS_OTP or STANDARD_OTP, then OTP is used. If credentialType matches the regular expression PASSWORD, then USERNAME_PASSWORD is used. |
|
| read_only_udm.extensions.auth.type | If the reason field matches the regular expression LDAP, then SSO is used. Otherwise, AUTHTYPE_UNSPECIFIED is used. |
|
| read_only_udm.metadata.event_type | Determined by the presence of certain fields. If user or processid is not empty, then USER_LOGIN is used. If user is empty and src_ip is not empty or 0.0.0.0, then STATUS_UPDATE is used. Otherwise, GENERIC_EVENT is used. |
|
| read_only_udm.metadata.log_type | Hardcoded to SYMANTEC_VIP. |
|
| read_only_udm.security_result.action | Determined by the status field. If status is Authentication Success, GRANTED, Authentication Completed, After Services Authenticate call, or CHALLENGED, then ALLOW is used. If status is DENIED, Acces-Reject, Unknown Error, Service Unavailable, or FAILED, then BLOCK is used. If status is PUSH request sent for user or Trying to fetch attribute, then QUARANTINE is used. |
|
| read_only_udm.security_result.severity | Determined by the log_level field. If log_level is DEBUG, INFO, or AUDIT, then INFORMATIONAL is used. If log_level is ERROR, then ERROR is used. If log_level is WARNING, then MEDIUM is used. |
Change Log
View the Change Log for this parser
Need more help? Get answers from Community members and Google SecOps professionals.