Forescout eyeSight 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Forescout eyeSight (이전 명칭: CounterACT) 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Forescout eyeSight는 IT, IoT, OT, IoMT 기기 전반에서 에이전트리스 기기 가시성, 분류, 규정 준수 평가를 제공하는 네트워크 액세스 제어 (NAC) 플랫폼입니다. 연결된 모든 기기를 실시간으로 검색하고 프로파일링하므로 조직에서 엔드포인트 에이전트 없이 액세스 정책을 적용하고 공격 표면을 줄일 수 있습니다.
자세한 내용은 Forescout NAC 문서를 참고하세요.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
systemd이 설치된 Windows 2016 이상 또는 Linux 호스트- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Forescout 콘솔에 대한 액세스 권한 (관리자 계정)
- Forescout 어플라이언스와 Bindplane 에이전트 호스트 간의 네트워크 연결
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
- 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/forescout_nac: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: FORESCOUT_NAC raw_log_field: body ingestion_labels: env: production service: pipelines: logs/forescout_to_chronicle: receivers: - udplog exporters: - chronicle/forescout_nac
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0를 사용하여 모든 인터페이스에서 수신 대기합니다. 포트514는 syslog의 표준입니다 (Linux에서 루트 권한 필요, 루트가 아닌 경우1514사용).
내보내기 도구 구성:
creds_file_path: Google SecOps 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>: Google SecOps 고객 ID입니다.endpoint: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Forescout eyeSight syslog 전달 구성
- 관리자 계정으로 Forescout Console에 로그인합니다.
- 도구 > 옵션으로 이동합니다.
- 옵션 트리에서 모듈 > Syslog (버전에 따라 Syslog 플러그인)을 펼칩니다.
- 추가를 클릭하여 새 syslog 타겟을 만듭니다.
- 다음 구성 세부정보를 제공합니다.
- 이름: 설명이 포함된 이름을 입력합니다 (예:
SecOps-Bindplane). - 서버 주소: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예:
192.168.1.100). - 포트:
514(또는 Bindplane 에이전트에서 구성된 포트)를 입력합니다. - 프로토콜: UDP를 선택합니다.
- 형식: 파싱 요구사항에 따라 CEF (Common Event Format) 또는 Syslog (RFC 3164)를 선택합니다.
- 시설: LOCAL0 (또는 조직의 syslog 정책과 일치하는 시설)을 선택합니다.
- 심각도: 정보 또는 원하는 최소 심각도 수준을 선택합니다.
- 이름: 설명이 포함된 이름을 입력합니다 (예:
- 이벤트 유형 섹션에서 전달할 로그 카테고리를 선택합니다.
- 호스트 속성 변경: 기기 분류 및 속성 업데이트
- 정책 위반: 규정 준수 정책 위반 및 NAC 시행 조치입니다.
- 네트워크 액세스 이벤트: 엔드포인트 연결 및 연결 해제 이벤트입니다.
- 인증 이벤트: 802.1X 및 사용자 인증 이벤트입니다.
- 조치 결과: 해결 및 대응 조치의 결과입니다.
- 확인을 클릭하여 syslog 타겟 구성을 저장합니다.
- 적용을 클릭하여 변경사항을 활성화합니다.
Bindplane 에이전트 로그를 확인하여 syslog 메시지가 수신되고 있는지 확인합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
about |
about |
병합됨 |
deviceNtDomain |
about.administrative_domain |
이름이 변경됨/매핑됨 |
deviceExternalId |
about.asset.asset_id |
직접 매핑됨 |
device_product |
about.asset.asset_id |
직접 매핑됨 |
device_vendor |
about.asset.asset_id |
직접 매핑됨 |
fileHash |
about.file.full_path |
직접 매핑됨 |
filePath |
about.file.full_path |
이름이 변경됨/매핑됨 |
_hash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fileHash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fsize |
about.file.size |
이름이 변경됨/매핑됨 |
dvchost |
about.hostname |
이름이 변경됨/매핑됨 |
ips |
about.ip |
병합됨 |
dvcmac |
about.mac |
병합됨 |
mac_address |
about.mac |
병합됨 |
deviceTranslatedAddress |
about.nat_ip |
병합됨 |
Emne |
about.process.command_line |
직접 매핑됨 |
Path |
about.process.command_line |
직접 매핑됨 |
Subject |
about.process.command_line |
직접 매핑됨 |
deviceProcessName |
about.process.command_line |
이름이 변경됨/매핑됨 |
dvcpid |
about.process.pid |
이름이 변경됨/매핑됨 |
permissions |
about.resource.attribute.permissions |
병합됨 |
Assigned_hosts_label |
additional.fields |
병합됨 |
Available_memory_label |
additional.fields |
병합됨 |
Available_swap_label |
additional.fields |
병합됨 |
Connected_clients_label |
additional.fields |
병합됨 |
EM_connection_status_label |
additional.fields |
병합됨 |
Engine_status_label |
additional.fields |
병합됨 |
Installed_Plugins_label |
additional.fields |
병합됨 |
Used_memory_label |
additional.fields |
병합됨 |
Used_swap_label |
additional.fields |
병합됨 |
additional_cfp1 |
additional.fields |
병합됨 |
additional_cfp2 |
additional.fields |
병합됨 |
additional_cfp3 |
additional.fields |
병합됨 |
additional_cfp4 |
additional.fields |
병합됨 |
additional_cn1 |
additional.fields |
병합됨 |
additional_cn2 |
additional.fields |
병합됨 |
additional_cn3 |
additional.fields |
병합됨 |
additional_cs1 |
additional.fields |
병합됨 |
additional_cs2 |
additional.fields |
병합됨 |
additional_cs3 |
additional.fields |
병합됨 |
additional_cs4 |
additional.fields |
병합됨 |
additional_cs5 |
additional.fields |
병합됨 |
additional_cs6 |
additional.fields |
병합됨 |
additional_cs7 |
additional.fields |
병합됨 |
additional_devicePayloadId |
additional.fields |
병합됨 |
additional_eventId |
additional.fields |
병합됨 |
additional_flexString1 |
additional.fields |
병합됨 |
additional_fname |
additional.fields |
병합됨 |
application_status_label |
additional.fields |
병합됨 |
cpu_usage_label |
additional.fields |
병합됨 |
cs5_label |
additional.fields |
병합됨 |
type_label |
additional.fields |
병합됨 |
intermediary |
intermediary |
병합됨 |
iporhost |
intermediary.asset.hostname |
직접 매핑됨 |
middle_ip |
intermediary.asset.ip |
병합됨 |
iporhost |
intermediary.hostname |
직접 매핑됨 |
middle_ip |
intermediary.ip |
병합됨 |
pid |
intermediary.process.pid |
직접 매핑됨 |
desc |
metadata.description |
직접 매핑됨 |
event_type |
metadata.description |
직접 매핑됨 |
msg |
metadata.description |
이름이 변경됨/매핑됨 |
device_event_class_id |
metadata.product_event_type |
직접 매핑됨 |
engineName |
metadata.product_event_type |
직접 매핑됨 |
event_name |
metadata.product_event_type |
직접 매핑됨 |
eventtype |
metadata.product_event_type |
직접 매핑됨 |
externalId |
metadata.product_log_id |
직접 매핑됨 |
device_product |
metadata.product_name |
직접 매핑됨 |
product |
metadata.product_name |
직접 매핑됨 |
device_version |
metadata.product_version |
직접 매핑됨 |
device_vendor |
metadata.vendor_name |
이름이 변경됨/매핑됨 |
vendor_name |
metadata.vendor_name |
직접 매핑됨 |
app_protocol_output |
network.application_protocol |
직접 매핑됨 |
mail_from |
network.email.from |
직접 매핑됨 |
mail_subject |
network.email.subject |
병합됨 |
mail_to |
network.email.to |
병합됨 |
requestMethod |
network.http.method |
이름이 변경됨/매핑됨 |
requestClientApplication |
network.http.user_agent |
이름이 변경됨/매핑됨 |
ip_protocol_out |
network.ip_protocol |
직접 매핑됨 |
protocol |
network.ip_protocol |
직접 매핑됨 |
protocol1 |
network.ip_protocol |
직접 매핑됨 |
in |
network.received_bytes |
이름이 변경됨/매핑됨 |
out |
network.sent_bytes |
이름이 변경됨/매핑됨 |
session_id |
network.session_id |
직접 매핑됨 |
sntdom |
principal.administrative_domain |
이름이 변경됨/매핑됨 |
sourceServiceName |
principal.application |
이름이 변경됨/매핑됨 |
Host |
principal.asset.hostname |
직접 매핑됨 |
Hostname |
principal.asset.hostname |
직접 매핑됨 |
Source |
principal.asset.hostname |
직접 매핑됨 |
Source_1 |
principal.asset.hostname |
직접 매핑됨 |
host_ip |
principal.asset.ip |
병합됨 |
source_ip |
principal.asset.ip |
병합됨 |
src_ip |
principal.asset.ip |
병합됨 |
Group_name |
principal.group.group_display_name |
직접 매핑됨 |
Gruppenavn |
principal.group.group_display_name |
직접 매핑됨 |
Device_name |
principal.hostname |
직접 매핑됨 |
Enhetsnavn |
principal.hostname |
직접 매핑됨 |
Host |
principal.hostname |
직접 매핑됨 |
Hostname |
principal.hostname |
직접 매핑됨 |
Source |
principal.hostname |
직접 매핑됨 |
Source_1 |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
이름이 변경됨/매핑됨 |
host_ip |
principal.ip |
병합됨 |
principal_ip |
principal.ip |
병합됨 |
shost |
principal.ip |
병합됨 |
source_ip |
principal.ip |
병합됨 |
src_ip |
principal.ip |
병합됨 |
MAC |
principal.mac |
병합됨 |
mac |
principal.mac |
병합됨 |
mac_addr |
principal.mac |
병합됨 |
src_mac |
principal.mac |
병합됨 |
sourceTranslatedAddress |
principal.nat_ip |
병합됨 |
sourceTranslatedPort |
principal.nat_port |
이름이 변경됨/매핑됨 |
source_port |
principal.port |
이름이 변경됨/매핑됨 |
spt |
principal.port |
이름이 변경됨/매핑됨 |
src_port |
principal.port |
직접 매핑됨 |
command |
principal.process.command_line |
직접 매핑됨 |
sproc |
principal.process.command_line |
이름이 변경됨/매핑됨 |
spid |
principal.process.pid |
이름이 변경됨/매핑됨 |
resource |
principal.resource.name |
직접 매핑됨 |
principal_role |
principal.user.attribute.roles |
병합됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
User |
principal.user.userid |
직접 매핑됨 |
suid |
principal.user.userid |
이름이 변경됨/매핑됨 |
user_id |
principal.user.userid |
직접 매핑됨 |
user_name |
principal.user.userid |
직접 매핑됨 |
username |
principal.user.userid |
직접 매핑됨 |
sec_result |
security_result |
병합됨 |
security_result |
security_result |
병합됨 |
res_label |
security_result.about.resource.attribute.labels |
병합됨 |
_action |
security_result.action |
병합됨 |
sec_action |
security_result.action |
병합됨 |
security_result_action |
security_result.action |
병합됨 |
Action_Taken |
security_result.action_details |
직접 매핑됨 |
act |
security_result.action_details |
직접 매핑됨 |
cat |
security_result.category_details |
병합됨 |
Category |
security_result.description |
직접 매핑됨 |
Reason |
security_result.description |
직접 매핑됨 |
Scan_Type |
security_result.description |
직접 매핑됨 |
Type |
security_result.description |
직접 매핑됨 |
act |
security_result.description |
직접 매핑됨 |
description |
security_result.description |
직접 매핑됨 |
details |
security_result.description |
직접 매핑됨 |
et_lower |
security_result.description |
직접 매핑됨 |
event_type |
security_result.description |
직접 매핑됨 |
kv_data |
security_result.description |
직접 매핑됨 |
msg_data_2 |
security_result.description |
직접 매핑됨 |
policy_details |
security_result.description |
직접 매핑됨 |
rnmsg |
security_result.description |
직접 매핑됨 |
infection_channel_label |
security_result.detection_fields |
병합됨 |
operasjon_label |
security_result.detection_fields |
병합됨 |
operation_label |
security_result.detection_fields |
병합됨 |
permission_label |
security_result.detection_fields |
병합됨 |
protocol_label |
security_result.detection_fields |
병합됨 |
spyware_Grayware_Type_label |
security_result.detection_fields |
병합됨 |
threat_probability_label |
security_result.detection_fields |
병합됨 |
tillatelse_label |
security_result.detection_fields |
병합됨 |
Rule |
security_result.rule_id |
직접 매핑됨 |
alart_id |
security_result.rule_id |
직접 매핑됨 |
device_event_class_id |
security_result.rule_id |
직접 매핑됨 |
Match |
security_result.rule_name |
직접 매핑됨 |
mwProfile |
security_result.rule_name |
직접 매핑됨 |
severity |
security_result.severity_details |
직접 매핑됨 |
Result |
security_result.summary |
직접 매핑됨 |
appcategory |
security_result.summary |
직접 매핑됨 |
event_name |
security_result.summary |
직접 매핑됨 |
event_type |
security_result.summary |
직접 매핑됨 |
log_description |
security_result.summary |
직접 매핑됨 |
reason |
security_result.summary |
이름이 변경됨/매핑됨 |
Spyware |
security_result.threat_name |
직접 매핑됨 |
Unknown_Threat |
security_result.threat_name |
직접 매핑됨 |
Virus_Malware_Name |
security_result.threat_name |
직접 매핑됨 |
threat |
security_result.threat_name |
직접 매핑됨 |
oldFilePath |
src.file.full_path |
이름이 변경됨/매핑됨 |
oldFileSize |
src.file.size |
이름이 변경됨/매핑됨 |
old_permissions |
src.resource.attribute.permissions |
병합됨 |
dntdom |
target.administrative_domain |
이름이 변경됨/매핑됨 |
destinationServiceName |
target.application |
이름이 변경됨/매핑됨 |
Destination |
target.asset.hostname |
직접 매핑됨 |
Target |
target.asset.hostname |
직접 매핑됨 |
Target_1 |
target.asset.hostname |
직접 매핑됨 |
computer_name |
target.asset.hostname |
직접 매핑됨 |
Destination |
target.asset.ip |
병합됨 |
dest_ip |
target.asset.ip |
병합됨 |
destination_ip |
target.asset.ip |
병합됨 |
target_ip |
target.asset.ip |
병합됨 |
Destination |
target.hostname |
직접 매핑됨 |
Target |
target.hostname |
직접 매핑됨 |
Target_1 |
target.hostname |
직접 매핑됨 |
computer_name |
target.hostname |
직접 매핑됨 |
temp_dhost |
target.hostname |
직접 매핑됨 |
Destination |
target.ip |
병합됨 |
IPv6_Address |
target.ip |
병합됨 |
dest_ip |
target.ip |
병합됨 |
destination_ip |
target.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
target_ip |
target.ip |
병합됨 |
dest_mac |
target.mac |
병합됨 |
mac_address |
target.mac |
병합됨 |
destination_translated_address |
target.nat_ip |
병합됨 |
destinationTranslatedPort |
target.nat_port |
이름이 변경됨/매핑됨 |
dest_port |
target.port |
직접 매핑됨 |
dpt |
target.port |
이름이 변경됨/매핑됨 |
port |
target.port |
이름이 변경됨/매핑됨 |
dproc |
target.process.command_line |
이름이 변경됨/매핑됨 |
File_name |
target.process.file.full_path |
직접 매핑됨 |
Infected_Resource |
target.process.file.full_path |
직접 매핑됨 |
Object |
target.process.file.full_path |
직접 매핑됨 |
Objekt |
target.process.file.full_path |
직접 매핑됨 |
dpid |
target.process.pid |
이름이 변경됨/매핑됨 |
resource_Type_label |
target.resource.attribute.labels |
병합됨 |
request |
target.url |
직접 매핑됨 |
target_role |
target.user.attribute.roles |
병합됨 |
CustomerName |
target.user.user_display_name |
직접 매핑됨 |
temp_duser |
target.user.user_display_name |
직접 매핑됨 |
Bruker |
target.user.userid |
직접 매핑됨 |
User_value |
target.user.userid |
직접 매핑됨 |
temp_duid |
target.user.userid |
직접 매핑됨 |
username |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | about |
상수: about |
| 해당 사항 없음 | about.ip |
상수: ips |
| 해당 사항 없음 | about.mac |
상수: mac_address |
| 해당 사항 없음 | about.nat_ip |
상수: deviceTranslatedAddress |
| 해당 사항 없음 | about.resource.attribute.permissions |
상수: permissions |
| 해당 사항 없음 | additional.fields |
상수: additional_eventId |
| 해당 사항 없음 | extensions.auth.type |
상수: MACHINE |
| 해당 사항 없음 | intermediary |
상수: intermediary |
| 해당 사항 없음 | intermediary.asset.ip |
상수: middle_ip |
| 해당 사항 없음 | intermediary.ip |
상수: middle_ip |
| 해당 사항 없음 | metadata.event_type |
상수: USER_LOGIN |
| 해당 사항 없음 | metadata.product_name |
상수: FORESCOUT NAC |
| 해당 사항 없음 | metadata.vendor_name |
상수: FORESCOUT |
| 해당 사항 없음 | network.direction |
상수: INBOUND |
| 해당 사항 없음 | network.email.subject |
상수: mail_subject |
| 해당 사항 없음 | network.email.to |
상수: mail_to |
| 해당 사항 없음 | principal.asset.ip |
상수: source_ip |
| 해당 사항 없음 | principal.ip |
상수: principal_ip |
| 해당 사항 없음 | principal.mac |
상수: mac |
| 해당 사항 없음 | principal.nat_ip |
상수: sourceTranslatedAddress |
| 해당 사항 없음 | principal.user.attribute.roles |
상수: principal_role |
| 해당 사항 없음 | security_result |
상수: security_result |
| 해당 사항 없음 | security_result.about.resource.attribute.labels |
상수: res_label |
| 해당 사항 없음 | security_result.action |
상수: _action |
| 해당 사항 없음 | security_result.alert_state |
상수: ALERTING |
| 해당 사항 없음 | security_result.category_details |
상수: cat |
| 해당 사항 없음 | security_result.detection_fields |
상수: operation_label |
| 해당 사항 없음 | security_result.rule_name |
상수: Virtual Firewall blocking |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
| 해당 사항 없음 | src.resource.attribute.permissions |
상수: old_permissions |
| 해당 사항 없음 | target.asset.ip |
상수: target_ip |
| 해당 사항 없음 | target.ip |
상수: dst_ip |
| 해당 사항 없음 | target.mac |
상수: mac_address |
| 해당 사항 없음 | target.nat_ip |
상수: destination_translated_address |
| 해당 사항 없음 | target.resource.attribute.labels |
상수: resource_Type_label |
| 해당 사항 없음 | target.user.attribute.roles |
상수: target_role |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.