收集 Xcitium Endpoint Security 記錄
剖析器版本:2.0
本文說明如何使用 Bindplane 代理,將 Xcitium Endpoint Security (舊稱 Comodo) 記錄檔擷取至 Google Security Operations。
Xcitium Endpoint Security 是端點防護平台,結合防毒軟體、防火牆、入侵防護和封鎖技術,保護端點免受已知和未知威脅。這項解決方案採用預設拒絕方法,並搭配自動隔離功能,可隔離無法辨識的檔案和程序,防止這些檔案和程序在分析期間造成損害。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Xcitium 代管端點之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Xcitium Endpoint Manager 控制台 (原 Comodo ITSM/ITarian) 的特殊權限存取權
- Xcitium Endpoint Manager 的管理員角色,可修改設定檔和入口網站設定
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
選項 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」>「Service Accounts」。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「服務帳戶名稱」:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「Service account description」(服務帳戶說明):輸入說明 (例如
Bindplane agent log ingestion)。
- 「服務帳戶名稱」:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到您的電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「設定」>「資料管理」>「收集代理程式」。如果使用的是僅限 SIEM 的平台,請依序前往「Settings」>「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「設定」>「管理」>「設定檔」。如果使用的是僅限 SIEM 的平台,請依序前往「設定」>「設定檔」。
- 複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/comodo_av: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'your-customer-id' endpoint: chronicle.googleapis.com log_type: COMODO_AV raw_log_field: body ingestion_labels: service: pipelines: logs/comodo_to_chronicle: receivers: - udplog exporters: - chronicle/comodo_av
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠。使用0.0.0.0監聽所有介面。預設系統記錄檔通訊埠為514。
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1)。- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:Google SecOps 控制台中的客戶 ID。location:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/comodo_av: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'your-customer-id' endpoint: malachiteingestion-pa.googleapis.com log_type: COMODO_AV raw_log_field: body ingestion_labels:
儲存設定檔
編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X。 - Windows:依序點選「檔案」>「儲存」。
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔,找出錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分執行命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔,找出錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Xcitium Endpoint Security syslog 轉送
Xcitium Endpoint Manager 提供兩個層級的系統記錄轉送功能。請一併設定這兩項,確保記錄涵蓋範圍完整。
設定端點層級系統記錄轉送 (Xcitium Client - Security 記錄)
- 登入 Xcitium Endpoint Manager 控制台。
- 依序前往「Configuration Templates」>「Profiles」。
- 按一下要修改的 Windows 設定檔,或建立新的設定檔。
- 依序點選「Add Profile Section」>「Logging Settings」。
- 在「Xcitium Client - Security」部分,啟用「Write to Syslog Server」。
- 提供下列設定詳細資料:
- Host:輸入 Bindplane 代理程式主機的 IP 位址或主機名稱。
- 「Port」(通訊埠):輸入 Bindplane 代理程式中設定的通訊埠編號 (例如
514)。
- (選用) 啟用「Write to Log File (CEF Format)」,以通用事件格式保留記錄檔的本機副本。
- 在「Communication Client」部分,啟用「Write to Syslog Server」。
- 提供下列設定詳細資料:
- Host:輸入 Bindplane 代理程式主機的 IP 位址或主機名稱。
- 「Port」(通訊埠):輸入 Bindplane 代理程式中設定的通訊埠編號 (例如
514)。
- 選取要收集記錄的事件類型:
- 監控記錄檔
- 指令碼記錄
- OS 修補程式記錄
- 第三方應用程式更新記錄
- 應用程式安裝記錄
- 解除安裝記錄
- 事件偵測及應變 (EDR) 代理程式通訊記錄
- Xcitium Client - Security (XCS) 通訊記錄
- 遠端控制通訊記錄
- 作業記錄
- 按一下「儲存」。
設定入口網站層級的系統記錄轉送 (稽核記錄)
- 登入 Xcitium Endpoint Manager 控制台。
- 依序前往「設定」>「入口網站設定」>「記錄設定」。
- 按一下 [編輯]。
- 啟用「Write to syslog server」。
- 提供下列設定詳細資料:
- Host:輸入 Bindplane 代理程式主機的 IP 位址或主機名稱。
- 「Port」(通訊埠):輸入 Bindplane 代理程式中設定的通訊埠編號 (例如
514)。
按一下「儲存」。
詳情請參閱 Xcitium Endpoint Manager 記錄設定說明文件和設定稽核記錄。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
event_type |
metadata.event_type |
已重新命名/對應 |
data5 |
principal.application |
直接對應 |
data3 |
principal.asset.platform_software.platform_version |
直接對應 |
dvchost |
principal.hostname |
直接對應 |
dvc |
principal.ip |
已合併 |
data4 |
principal.user.product_object_id |
直接對應 |
filePath |
target.file.full_path |
直接對應 |
fname |
target.process.parent_process.file.full_path |
直接對應 |
suser |
target.user.userid |
直接對應 |
| 不適用 | metadata.product_name |
常數:COMODO_AV |
| 不適用 | metadata.vendor_name |
常數:COMODO |
| 不適用 | principal.ip |
常數:dvc |
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。