收集 Cloudian HyperStore 記錄
剖析器版本:2.0
本文說明如何使用 Bindplane 代理程式,將 Cloudian HyperStore 記錄檔擷取至 Google Security Operations。
剖析器會使用 grok 模式,從 Cloudian HyperStore syslog 訊息中擷取欄位,包括時間戳記、IP 位址、使用者名稱和說明。它會將擷取的欄位對應至統合式資料模型 (UDM),並根據識別出的活動設定適當的事件類型。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Cloudian HyperStore 系統之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Cloudian HyperStore 的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
選項 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」>「Service Accounts」。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「服務帳戶名稱」:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「Service account description」(服務帳戶說明):輸入說明 (例如
Bindplane agent log ingestion)。
- 「服務帳戶名稱」:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到您的電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「設定」>「資料管理」>「收集代理程式」。如果使用的是僅限 SIEM 的平台,請依序前往「Settings」>「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「設定」>「管理」>「設定檔」。如果使用的是僅限 SIEM 的平台,請依序前往「設定」>「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/cloudian_hyperstore: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: CLOUDIAN_HYPERSTORE raw_log_field: body service: pipelines: logs/cloudian_hyperstore_to_chronicle: receivers: - udplog exporters: - chronicle/cloudian_hyperstore
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0:監聽所有介面 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要 root 權限;非 root 權限請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/cloudian_hyperstore: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CLOUDIAN_HYPERSTORE raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X鍵 - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔,找出錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分執行命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔,找出錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Cloudian HyperStore syslog
- 使用 CLI 登入 HyperStore Config Controller 節點。
執行下列
hsctl指令:hsctl config set logging.syslog.remote.enabled=true hsctl config set logging.syslog.remote.host=<BINDPLANE_IP> hsctl config set logging.syslog.remote.protocol=<UDP_OR_TCP> hsctl config set logging.syslog.remote.port=<BINDPLANE_PORT> hsctl config apply ALL hsctl service restart s3 iam hyperstore firewall --nodes=ALL hsctl config set monitoring.agent.logging.level=INFO hsctl config apply monitoring- 將
<BINDPLANE_IP>替換為 Bindplane 代理程式 IP 位址。 - 將
<UDP_OR_TCP>替換為 Bindplane 代理程式中設定的通訊協定。 - 將
<BINDPLANE_PORT>替換為 Bindplane 代理程式通訊埠編號。
- 將
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
description |
metadata.description |
直接對應 |
datetime |
metadata.event_timestamp |
剖析為 RFC 3339 |
method |
network.http.method |
已重新命名/對應 |
url |
network.http.referral_url |
直接對應 |
status_code |
network.http.response_code |
已重新命名/對應 |
session_id |
network.session_id |
直接對應 |
application |
principal.application |
直接對應 |
hostname |
principal.hostname |
直接對應 |
source_ip |
principal.ip |
已合併 |
request_id |
principal.process.pid |
直接對應 |
target_ip |
target.ip |
已合併 |
port |
target.port |
已重新命名/對應 |
file_path |
target.process.file.full_path |
直接對應 |
user |
target.user.user_display_name |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:NETWORK_CONNECTION |
| 不適用 | metadata.product_name |
常數:Cloudian Hyperstore |
| 不適用 | metadata.vendor_name |
常數:Cloudian |
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。