Planifier des rapports de tableau de bord
Cette page explique comment planifier l'envoi de rapports de tableaux de bord Google SecOps par e-mail.
Vous pouvez planifier l'envoi de rapports Google SecOps pour les tableaux de bord par défaut et personnalisés. Lorsque vous planifiez la diffusion d'un rapport de tableau de bord Google SecOps, vous effectuez les tâches suivantes :
- Planifiez l'envoi du rapport de tableau de bord immédiatement ou de manière récurrente.
- Spécifiez les adresses e-mail auxquelles envoyer le rapport.
- Spécifiez le format du rapport (fichier CSV, PDF ou PNG, par exemple).
- Filtrez le rapport en fonction d'une période spécifiée.
- Définissez les détails de la pagination et testez l'envoi du rapport planifié.
Contrôler l'accès aux rapports du tableau de bord de planification
Pour planifier des rapports de tableau de bord, vous devez disposer du rôle Administrateur ou Éditeur. Pour en savoir plus sur la gestion des utilisateurs et des groupes, ou sur l'attribution de rôles, consultez Contrôle des accès basé sur les rôles.

Figure : Les rôles Administrateur et Éditeur permettent d'accéder à la planification des rapports.
Créer un calendrier d'envoi de rapports
Si vous n'avez pas de planification préexistante pour le rapport du tableau de bord, créez-en une et personnalisez la récurrence, l'adresse e-mail de destination, le format, les filtres et la pagination.
- Sélectionnez le tableau de bord par défaut ou personnalisé pour lequel vous souhaitez planifier l'envoi du rapport.
- Dans la barre de navigation, cliquez sur Tableaux de bord et rapports > Tableaux de bord SIEM. Pour les clients Google Security Operations SIEM, il vous suffit de cliquer sur Tableaux de bord.
- Dans la liste des tableaux de bord par défaut et personnels, sélectionnez celui pour lequel vous souhaitez programmer l'envoi du rapport.
- Pour planifier l'envoi d'un rapport de tableau de bord, cliquez sur l'icône Plus more_vert sur la page du tableau de bord, puis sélectionnez Planifier l'envoi. Si des plannings de rapports existent pour le tableau de bord, la boîte de dialogue Plannings s'affiche avec des options permettant de modifier ou de créer des plannings. Si aucune planification de rapport n'existe pour le tableau de bord, la boîte de dialogue Planifier s'affiche avec le nom du tableau de bord ajouté au format suivant : Planifier <Dashboard Name>.
Dans la boîte de dialogue Planifier, spécifiez les informations suivantes dans l'onglet Paramètres :
- Sélectionnez l'intervalle d'envoi dans la liste Récurrence, puis l'heure d'envoi. Vous pouvez également spécifier le fuseau horaire de diffusion dans l'onglet Options avancées.
Dans le champ Adresses e-mail, saisissez une liste d'adresses e-mail séparées par une virgule auxquelles vous souhaitez envoyer le rapport. Le domaine de messagerie doit être identique au domaine utilisateur que vous utilisez pour vous connecter à Google SecOps. Par exemple, si vous vous connectez à Google SecOps à l'aide de
sara@altostrat.com, vous ne pouvez spécifier que les adresses e-mail utilisant le domainealtostrat.com, commealex@altostrat.com. Par défaut, vous ne pouvez pas envoyer d'e-mails vers d'autres domaines de messagerie externes.Pour envoyer des e-mails à un domaine supplémentaire ou autoriser l'envoi d'e-mails à n'importe quel domaine en désactivant la validation du domaine de messagerie, contactez l'assistance Google SecOps.
Dans la liste Format, sélectionnez le format de fichier CSV, PDF ou PNG pour le rapport.
Dans l'onglet Filtres, spécifiez la période sur laquelle vous souhaitez filtrer le rapport. Si le tableau de bord ne contient pas de filtres, un message indiquant qu'il n'en comporte aucun s'affiche.
- Pour spécifier un filtre, cliquez sur le champ Période, puis indiquez la condition de filtre, le mois et l'année.
- Pour ajouter d'autres filtres temporels, cliquez sur l'icône Ajouter add.
Dans l'onglet Options avancées, spécifiez les options de pagination pour l'e-mail.
- Pour inclure un message personnalisé dans l'e-mail, ajoutez-le dans le champ Message personnalisé.
- Si nécessaire, sélectionnez les options suivantes :
- Inclure des liens : inclut des liens dans les e-mails vers les tableaux de bord pour lesquels vous avez programmé l'envoi de rapports.
- Développez les tableaux pour afficher toutes les lignes.
- Disposer les vignettes du tableau de bord en une seule colonne
- Dans la liste Format du papier, sélectionnez le format du papier.
- Dans la liste Fuseau horaire de diffusion, sélectionnez le fuseau horaire pour la diffusion du message.
Pour tester l'envoi du rapport par e-mail, cliquez sur Tester maintenant.
Cliquez sur Enregistrer. La boîte de dialogue Programmes s'affiche.
Pour modifier, dupliquer ou supprimer la diffusion programmée, cliquez sur l'icône more_vert Plus dans la boîte de dialogue Programmes.
Pour envoyer le rapport immédiatement, cliquez sur Envoyer maintenant.
Pour créer une autre programmation, cliquez sur Nouveau.
Pour fermer la boîte de dialogue, cliquez sur OK.
Utiliser une programmation existante pour l'envoi de rapports
S'il existe une programmation pour l'envoi du rapport du tableau de bord, vous pouvez l'envoyer immédiatement ou modifier les options d'envoi.
- Sélectionnez le tableau de bord par défaut ou personnalisé pour lequel vous souhaitez modifier la planification des rapports.
- Dans la barre de navigation, cliquez sur Tableaux de bord et rapports > Tableaux de bord SIEM.
- Dans la liste des tableaux de bord par défaut et personnels, sélectionnez celui pour lequel vous souhaitez programmer l'envoi du rapport.
- Sur la page du tableau de bord, cliquez sur l'icône more_vert Plus, puis sélectionnez Planifier l'envoi. Si des plannings de rapports existent pour le tableau de bord, la boîte de dialogue Plannings s'affiche avec des options permettant de modifier ou de créer des plannings.
- Pour modifier, dupliquer ou supprimer la diffusion programmée, cliquez sur l'icône more_vert Plus dans la boîte de dialogue Programmes.
- Pour envoyer le rapport immédiatement, cliquez sur Envoyer maintenant.
- Pour créer une autre programmation, cliquez sur Nouveau.
- Pour fermer la boîte de dialogue, cliquez sur OK.
Vous avez encore besoin d'aide ? Obtenez des réponses de membres de la communauté et de professionnels Google SecOps.