PTC Windchill 로그 수집
이 문서에서는 Bindplane을 사용하여 PTC Windchill 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
PTC Windchill은 엔지니어링 및 제조팀 전반에서 제품 데이터, 프로세스, 협업을 관리하는 데 사용되는 제품 수명 주기 관리 (PLM) 플랫폼입니다. 플랫폼은 온프레미스 서버 배포에서 액세스, 감사, 구성 변경 로그를 생성합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 PTC Windchill 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 관리자 권한으로 PTC Windchill 서버에 대한 권한 액세스
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 신규 배포: Chronicle API (옵션 1)를 사용합니다.
- 기존 배포: 2027년 7월 20일에 수집 API가 지원 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다 (예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가 > 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector
서비스가 RUNNING으로 표시됩니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector
서비스가 활성 (실행 중)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/windchill: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: WINDCHILL raw_log_field: body service: pipelines: logs/windchill_to_chronicle: receivers: - tcplog exporters: - chronicle/windchill
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514은 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우1514사용).
내보내기 도구 구성:
creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDlocation:<LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다 (예:us,europe또는asia-southeast1). 내보내기 도구는 이 값으로chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참고하세요.project:<PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.endpoint:chronicle.googleapis.com로 설정된 상태를 유지합니다.
기존 수집 API 내보내기 도구
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/windchill: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: WINDCHILL raw_log_field: body
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순으로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 안내를 따르세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
PTC Windchill syslog 전달 구성
- 관리자로 PTC Windchill 서버에 로그인합니다.
Windchill 애플리케이션 로그를 전달하도록 rsyslog 또는 syslog 에이전트를 구성합니다. rsyslog 구성을 수정합니다.
sudo nano /etc/rsyslog.d/windchill.confWindchill 로그 파일을 Bindplane 에이전트로 전달하려면 다음 줄을 추가하세요.
# Forward PTC Windchill logs to Bindplane agent module(load="imfile") input(type="imfile" File="/path/to/windchill/logs/*.log" Tag="windchill" Severity="info" Facility="local0") if $syslogtag == 'windchill' then @@<bindplane-ip>:514/path/to/windchill/logs/를 실제 Windchill 로그 디렉터리 경로로 바꿉니다.<bindplane-ip>를 Bindplane 에이전트 호스트의 IP 주소로 바꿉니다.
rsyslog 서비스를 다시 시작합니다.
sudo systemctl restart rsyslogBindplane 에이전트 로그를 확인하여 로그가 전송되고 있는지 확인합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
| eventlabel | metadata.description | 값이 직접 복사됨 |
| eventtime | metadata.event_timestamp | SYSLOGTIMESTAMP, ISO8601 형식의 날짜 필터를 사용하여 변환됨 |
| metadata.event_type | has_principal == 'true', has_principal_user == 'true', has_target == 'true'이면 'USER_LOGIN'으로 설정, has_target_resource == 'true'이면 'USER_RESOURCE_ACCESS'로 설정, has_principal == 'true', has_principal_user == 'true'이면 'USER_UNCATEGORIZED'로 설정, has_principal == 'true'이면 'STATUS_UPDATE'로 설정, 그 밖의 경우에는 'GENERIC_EVENT'로 설정 | |
| dbschema | metadata.ingestion_labels | db_schema 객체와 병합됨 (key="DBSCHEMA", value=dbschema) |
| dbname | metadata.product_deployment_id | 값이 직접 복사됨 |
| eventlabel, description | metadata.product_event_type | 비어 있지 않은 경우 설명의 값, 비어 있는 경우 eventlabel의 값 |
| context | metadata.product_log_id | 값이 직접 복사됨 |
| 버전 | metadata.product_version | 값이 직접 복사됨 |
| ohost | observer.hostname | ohost가 IP가 아닌 경우 값이 직접 복사됨 |
| ohost | observer.ip | ohost가 IP인 경우 값이 직접 복사됨 |
| domainpath | principal.administrative_domain | 값이 직접 복사됨 |
| ipaddress | principal.asset.hostname | ipaddress가 IP가 아닌 경우 값이 직접 복사됨 |
| ipaddress | principal.asset.ip | ipaddress가 IP인 경우 값이 직접 복사됨 |
| ipaddress, phost | principal.hostname | IP가 아닌 경우 ipaddress의 값, IP가 아닌 경우 phost의 값 |
| ipaddress, phost | principal.ip | IP인 경우 ipaddress의 값, IP가 아닌 경우 phost의 값 |
| folderpath | principal.process.file.full_path | 값이 직접 복사됨 |
| user_product_object_id | principal.user.product_object_id | 값이 직접 복사됨 |
| user_display_name | principal.user.user_display_name | 값이 직접 복사됨 |
| username, user_userid | principal.user.userid | 비어 있지 않으면 사용자 이름의 값, 비어 있으면 user_userid의 값 |
| domain_name | target.domain.name | 값이 직접 복사됨 |
| target_path | target.file.full_path | 값이 직접 복사됨 |
| 네임스페이스 | target.namespace | 값이 직접 복사됨 |
| lifecyclestate, targetname, targetnumber, targettype | target.resource.attribute.labels | lifecyclestate_label (key="lifecyclestate", value=lifecyclestate), targetname_label (key="targetname", value=targetname), targetnumber_label (key="targetnumber", value=targetnumber), targettype_label (key="targettype", value=targettype)과 병합됨 |
| target_number | target.resource.id | 값이 직접 복사됨 |
| target_name | target.resource.name | 값이 직접 복사됨 |
| target_identity | target.resource.product_object_id | 값이 직접 복사됨 |
| target_subtype | target.resource.resource_subtype | 값이 직접 복사됨 |
| metadata.product_name | '체감 온도'로 설정 | |
| metadata.vendor_name | 'PTC'로 설정 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.