전압 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Voltage SecureMail 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Voltage SecureMail은 이메일 암호화/복호화 이벤트, 정책 시행, 관리 작업을 위한 syslog 메시지를 생성하는 이메일 암호화 플랫폼입니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 Voltage SecureMail 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Voltage SecureMail 관리 콘솔에 대한 액세스 권한
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 수집 인증 파일을 다운로드합니다.
Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/voltage: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: VOLTAGE raw_log_field: body service: pipelines: logs/voltage_to_chronicle: receivers: - udplog exporters: - chronicle/voltage
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 비루트의 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Voltage SecureMail에서 syslog 구성
- Voltage SecureMail 관리 콘솔에 로그인합니다.
- 시스템 > Syslog 설정으로 이동합니다.
- 다음 구성 세부정보를 제공합니다.
- 서버 주소: Bindplane 에이전트 IP 주소를 입력합니다.
- 포트:
514를 입력합니다. - 프로토콜: UDP를 선택합니다.
- 기능: 적절한 syslog 기능을 선택합니다.
- 로그 수준: 원하는 로그 수준을 선택합니다.
- 저장을 클릭합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
attemptedAuthMethods_label |
additional.fields |
병합됨 |
authTokens_label |
additional.fields |
병합됨 |
elapsedTimeMillis_label |
additional.fields |
병합됨 |
isUserPassSet_label |
additional.fields |
병합됨 |
keyId_label |
additional.fields |
병합됨 |
leadingDigits_label |
additional.fields |
병합됨 |
masked_label |
additional.fields |
병합됨 |
merchantId_label |
additional.fields |
병합됨 |
out_label |
additional.fields |
병합됨 |
phaseBit_label |
additional.fields |
병합됨 |
proxyType_label |
additional.fields |
병합됨 |
rollover_label |
additional.fields |
병합됨 |
trailingDigits_label |
additional.fields |
병합됨 |
AuthenticationMethod |
extensions.auth.mechanism |
매핑됨: USER_PASSWORD → mechanism |
mechanism |
extensions.auth.mechanism |
병합됨 |
has_principal |
extensions.auth.type |
매핑됨: true → AUTHTYPE_UNSPECIFIED |
proxyConnectionIp |
intermediary.asset.ip |
병합됨 |
inter_hostname |
intermediary.hostname |
직접 매핑됨 |
proxyConnectionIp |
intermediary.ip |
병합됨 |
description |
metadata.description |
직접 매핑됨 |
has_principal |
metadata.event_type |
매핑됨: true → USER_LOGIN, true → NETWORK_CONNECTION, true → STATUS_UPDATE |
has_user |
metadata.event_type |
매핑됨: true → USER_UNCATEGORIZED |
prod_event_name |
metadata.product_event_type |
직접 매핑됨 |
event_id |
metadata.product_log_id |
직접 매핑됨 |
cef_product |
metadata.product_name |
직접 매핑됨 |
version |
metadata.product_version |
직접 매핑됨 |
request |
network.http.referral_url |
직접 매핑됨 |
length |
network.received_bytes |
직접 매핑됨 |
requestTimeMillis |
network.session_duration.nanos |
직접 매핑됨 |
timeMillis |
network.session_duration.seconds |
직접 매핑됨 |
sessionid |
network.session_id |
직접 매핑됨 |
cvProduct |
observer.application |
직접 매핑됨 |
cvapi_label |
observer.labels |
병합됨 |
cvdevice_label |
observer.labels |
병합됨 |
cvframework_label |
observer.labels |
병합됨 |
cvos |
observer.platform |
매핑됨: Li → LINUX, Win → WINDOWS |
requestClientApplication |
principal.application |
직접 매핑됨 |
src_hostname |
principal.asset.hostname |
직접 매핑됨 |
ip |
principal.asset.ip |
병합됨 |
src_ip |
principal.asset.ip |
병합됨 |
src_hostname |
principal.hostname |
직접 매핑됨 |
ip |
principal.ip |
병합됨 |
src_ip |
principal.ip |
병합됨 |
src_port |
principal.port |
이름이 변경됨/매핑됨 |
identity |
principal.user.email_addresses |
매핑됨: (.*)@(.*) → identity |
user |
principal.user.userid |
직접 매핑됨 |
username |
principal.user.userid |
직접 매핑됨 |
sec_action |
security_result.action |
병합됨 |
msg |
security_result.description |
직접 매핑됨 |
CachedAuthentication_label |
security_result.detection_fields |
병합됨 |
acceptBadData_label |
security_result.detection_fields |
병합됨 |
algorithm_label |
security_result.detection_fields |
병합됨 |
authMethodName_label |
security_result.detection_fields |
병합됨 |
authTimeMillis_label |
security_result.detection_fields |
병합됨 |
authType_label |
security_result.detection_fields |
병합됨 |
format_label |
security_result.detection_fields |
병합됨 |
fullIdentity_label |
security_result.detection_fields |
병합됨 |
hsmEnabled_label |
security_result.detection_fields |
병합됨 |
returnEncryptedKeyOption_label |
security_result.detection_fields |
병합됨 |
returnFullIdentity_label |
security_result.detection_fields |
병합됨 |
wrappedMode_label |
security_result.detection_fields |
병합됨 |
severity |
security_result.severity |
매핑됨: "0", "1", "2" → INFORMATIONAL, "3", "4" → LOW, "5", "6" → MEDIUM, `"7", ... |
severity |
security_result.severity_details |
직접 매핑됨 |
district |
target.administrative_domain |
직접 매핑됨 |
shost |
target.asset.hostname |
직접 매핑됨 |
dst_ip |
target.asset.ip |
병합됨 |
shost |
target.hostname |
직접 매핑됨 |
dst_ip |
target.ip |
병합됨 |
cmd_line |
target.process.command_line |
직접 매핑됨 |
pid |
target.process.pid |
직접 매핑됨 |
path |
target.resource.name |
직접 매핑됨 |
tar_user |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | extensions.auth.type |
상수: AUTHTYPE_UNSPECIFIED |
| 해당 사항 없음 | metadata.event_type |
상수: USER_LOGIN |
| 해당 사항 없음 | metadata.product_name |
상수: VOLTAGE |
| 해당 사항 없음 | metadata.vendor_name |
상수: VOLTAGE |
| 해당 사항 없음 | observer.platform |
상수: LINUX |
| 해당 사항 없음 | security_result.severity |
상수: INFORMATIONAL |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.