Trend Micro Email Security 로그 수집

다음에서 지원:

이 문서에서는 Bindplane을 사용하여 Trend Micro Email Security 로그를 Google Security Operations로 수집하는 방법을 설명합니다. Trend Micro Email Security는 클라우드 기반 이메일 게이트웨이로, 스팸, 멀웨어, 피싱, 랜섬웨어, 지능형 표적 공격이 사용자의 메일함에 도달하기 전에 조직을 보호합니다. 인바운드 및 아웃바운드 이메일 트래픽에 URL 필터링, 첨부파일 샌드박싱, 데이터 손실 방지 기능을 제공합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • systemd가 있는 Windows 2016 이상 또는 Linux 호스트
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Trend Micro Email Security 관리 콘솔에 대한 권한 있는 액세스

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Bindplane 에이전트를 Google SecOps에 인증하려면 다음 방법 중 하나를 선택합니다.

  • 새 배포: Chronicle API (옵션 1)를 사용합니다.
  • 기존 배포: 수집 API가 2027년 7월 20일에 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정 으로 이동합니다.
  3. 서비스 계정 만들기 를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다 (예: Bindplane agent log ingestion).
  5. 만들고 계속하기 를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택 을 클릭하고 Chronicle 편집자 를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기 를 클릭합니다.
  10. JSON 을 선택하고 만들기 를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (/opt/observiq-otel-collector/ingestion-auth.json on Linux 또는 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json on Windows)에 ingestion-auth.json으로 저장하거나 config.yaml에서 creds_file_path를 저장하는 경로와 일치하도록 업데이트합니다.
  12. IAM 및 관리자 > 설정 으로 이동하여 프로젝트 번호 를 복사합니다. 내보내기 구성에 필요합니다.

옵션 2: 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트 로 이동합니다.
  3. 수집 인증 파일 을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필 로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID 를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell 을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
    

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
    

추가 설치 리소스

추가 설치 옵션은 이 설치 가이드를 참고하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

  1. 구성 파일에 액세스합니다.

    • config.yaml 파일을 찾습니다. 일반적으로 Linux의 /opt/observiq-otel-collector/ 디렉터리 또는 Windows의 설치 디렉터리에 있습니다.
    • 텍스트 편집기 (예: nano, vi, 메모장)를 사용하여 파일을 엽니다.
  2. 다음과 같이 config.yaml 파일을 수정합니다.

    receivers:
      tcplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: YOUR_CUSTOMER_ID
        endpoint: chronicle.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'TRENDMICRO_EMAIL_SECURITY'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - tcplog
          exporters:
            - chronicle/chronicle_w_labels
    
  • 인프라에서 필요한 경우 포트와 IP 주소를 바꿉니다.
  • <LOCATION>을 Google SecOps 인스턴스의 리전 (예: us, europe, 또는 asia-southeast1)으로 바꿉니다. 내보내기는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다.
  • <PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
  • YOUR_CUSTOMER_ID를 실제 고객 ID로 바꿉니다.
  • 1단계에서 서비스 계정 키 파일 (옵션 1)이 저장된 파일 경로로 /path/to/ingestion-authentication-file.json을 업데이트합니다.

기존 수집 API 내보내기

  • 옵션 2의 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: YOUR_CUSTOMER_ID
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'TRENDMICRO_EMAIL_SECURITY'
        raw_log_field: body
        ingestion_labels:
    

Bindplane 에이전트를 다시 시작하여 변경사항 적용

  1. Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
  2. Windows에서 Bindplane 에이전트를 다시 시작하려면 서비스 콘솔을 사용하거나 다음 명령어를 입력하면 됩니다.

    net stop observiq-otel-collector && net start observiq-otel-collector
    

Trend Micro Email Security syslog 전달 구성

syslog를 통해 로그를 Bindplane 에이전트로 전달하도록 Trend Micro Email Security를 구성하려면 다음 단계를 따르세요.

  1. Trend Micro Email Security 관리 콘솔에 로그인합니다.
  2. 관리 > Syslog 설정 으로 이동합니다.
  3. 추가 를 클릭하여 새 시스템로그 서버 프로필을 만듭니다.

  4. 다음 구성 세부정보를 제공합니다.

    • 서버 주소: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예: 192.168.1.100).
    • 포트: 514 (또는 Bindplane 에이전트에서 구성된 포트)를 입력합니다.
    • 프로토콜: TCP 를 선택합니다.
    • 형식: CEF (Common Event Format)를 선택합니다.
  5. 로그 유형 섹션에서 전달할 로그 카테고리를 선택합니다.

    • 정책 이벤트 - 이메일 필터링 정책 작업
    • 스팸 감지 - 스팸 및 그레이메일 이벤트
    • 멀웨어 감지 - 바이러스 및 멀웨어 감지 이벤트
    • 랜섬웨어 감지 - 랜섬웨어 감지 이벤트
    • URL 분석 - URL 클릭 및 클릭 시 보호 이벤트
    • 지능형 위협 방어 - 샌드박스 분석 이벤트
    • 데이터 손실 방지 - DLP 정책 위반 이벤트
    • 콘텐츠 필터링 - 콘텐츠 필터 규칙 이벤트
  6. 저장 을 클릭합니다.

  7. 연결 테스트 를 클릭하여 로그가 Bindplane 에이전트로 전송되고 있는지 확인합니다.

  8. Bindplane 에이전트 로그를 확인하여 로그가 도착하는지 확인합니다.

자세한 내용은 Trend Micro Email Security 문서를 참고하세요.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
additional_cn1 additional.fields 병합됨
additional_cs1 additional.fields 병합됨
additional_cs2 additional.fields 병합됨
additional_cs3 additional.fields 병합됨
additional_cs4 additional.fields 병합됨
additional_cs5 additional.fields 병합됨
additional_cs6 additional.fields 병합됨
message extensions.auth.type 매핑됨: login → AUTHTYPE_UNSPECIFIED
msg metadata.description 직접 매핑됨
rt metadata.event_timestamp ISO8601로 파싱됨
cs1 metadata.event_type 매핑됨: phishing → SCAN_UNCATEGORIZED
message metadata.event_type 매핑됨: CEF:0 → GENERIC_EVENT, login → USER_LOGIN
cs1 metadata.product_event_type 직접 매핑됨
network_direction network.direction 매핑됨: INCOMING → INBOUND, OUTGOING → OUTBOUND
cs2 principal.hostname 직접 매핑됨
principal_ip principal.hostname 직접 매핑됨
principal_ip principal.ip 병합됨
message principal.user.userid 매핑됨: login → target.user.userid
suser principal.user.userid 직접 매핑됨
act security_result.action 매핑됨: ALLOW → act, DENY → security_result_action, QUARANTINE → act
security_result_action security_result.action 병합됨
act security_result.action_details 직접 매핑됨
cs5 security_result.rule_name 직접 매핑됨
severity security_result.severity 매핑됨: "0", "1", "2", "3", "LOW" → LOW, `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"...
cs6 target.url 직접 매핑됨
duser target.user.email_addresses 매핑됨: ; → emailId
emailId target.user.email_addresses 병합됨
duser target.user.userid 직접 매핑됨
principal.user.userid target.user.userid 이름 변경/매핑됨
해당 사항 없음 extensions.auth.type 상수: AUTHTYPE_UNSPECIFIED
해당 사항 없음 metadata.event_type 상수: GENERIC_EVENT
해당 사항 없음 network.direction 상수: INBOUND
해당 사항 없음 principal.user.userid 상수: target.user.userid
해당 사항 없음 security_result.severity 상수: LOW

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.