TCPWave DDI 로그 수집
이 문서에서는 Bindplane을 사용하여 TCPWave DDI 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
TCPWave DDI는 엔터프라이즈 네트워크 인프라를 위한 DNS, DHCP, IPAM 관리 플랫폼입니다. 온프레미스 환경 전반에서 IP 주소 할당, DNS 확인, DHCP 서비스를 중앙에서 관리할 수 있습니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 TCPWave DDI 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 관리자 권한으로 TCPWave DDI에 대한 권한 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector
서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector
서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/tcpwave_ddi: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: TCPWAVE_DDI raw_log_field: body service: pipelines: logs/tcpwave_ddi_to_chronicle: receivers: - udplog exporters: - chronicle/tcpwave_ddi
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 비루트의 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 지역 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 명령 프롬프트 또는 PowerShell(관리자 권한)
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
TCPWave DDI syslog 전달 구성
- TCPWave DDI 관리 콘솔에 로그인합니다.
- 관리 > 시스템 설정 > Syslog 구성으로 이동합니다.
- 추가를 클릭하여 새 syslog 대상을 만듭니다.
- 다음 구성 세부정보를 제공합니다.
- Syslog Server IP: Bindplane 에이전트 호스트의 IP 주소를 입력합니다.
- 포트:
514를 입력합니다. - 프로토콜: UDP를 선택합니다.
- Facility: Local0 또는 원하는 시설을 선택합니다.
- 심각도: 정보 이상을 선택합니다.
- 전달할 로그 카테고리 (DNS 쿼리, DHCP 이벤트, IPAM 변경사항, 시스템 이벤트)를 선택합니다.
- 저장을 클릭하여 구성을 적용합니다.
- Bindplane 에이전트 로그를 확인하여 로그가 전송되고 있는지 확인합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
dhcp_pool_backup_label |
additional.fields |
병합됨 |
dhcp_pool_free_label |
additional.fields |
병합됨 |
dhcp_pool_lts_label |
additional.fields |
병합됨 |
dhcp_pool_max_misbal_label |
additional.fields |
병합됨 |
dhcp_pool_max_own_label |
additional.fields |
병합됨 |
dhcp_pool_range_label |
additional.fields |
병합됨 |
dhcp_pool_total_label |
additional.fields |
병합됨 |
pool_id_label |
additional.fields |
병합됨 |
intermediary_entry |
intermediary |
병합됨 |
description |
metadata.description |
직접 매핑됨 |
ts |
metadata.event_timestamp |
MMM d HH:mm:ss로 파싱됨 |
description |
metadata.event_type |
매핑된 값 (총 5개, 예: DHCPDISCOVER → NETWORK_DHCP, DHCPACK → NETWORK_DHCP, `D... |
client_label |
metadata.ingestion_labels |
병합됨 |
label |
metadata.ingestion_labels |
병합됨 |
smb_stage_label |
metadata.ingestion_labels |
병합됨 |
zone_label |
metadata.ingestion_labels |
병합됨 |
product_event_type |
metadata.product_event_type |
직접 매핑됨 |
description |
network.application_protocol |
매핑된 값 (총 5개, 예: DHCPDISCOVER → DHCP, DHCPACK → DHCP, DHCPREQUEST → `D... |
src_mac |
network.dhcp.chaddr |
직접 매핑됨 |
d_clientID |
network.dhcp.client_identifier |
직접 매핑됨 |
description |
network.dhcp.type |
매핑된 값 (총 5개, 예: DHCPDISCOVER → DISCOVER, DHCPACK → ACK, DHCPREQUEST →...) |
intermediary_host |
principal.hostname |
직접 매핑됨 |
smb_host |
principal.hostname |
직접 매핑됨 |
field.value |
principal.location.country_or_region |
직접 매핑됨 |
filepath |
principal.process.file.full_path |
직접 매핑됨 |
smb_uid |
principal.user.userid |
직접 매핑됨 |
description |
security_result.action |
매핑됨: rejected → security_action |
security_action |
security_result.action |
병합됨 |
des |
security_result.description |
직접 매핑됨 |
product_event_type |
security_result.severity |
매핑됨: info → INFORMATIONAL, error → ERROR |
thread |
security_result.summary |
직접 매핑됨 |
src |
src.hostname |
직접 매핑됨 |
src_mac |
src.mac |
병합됨 |
d_domain |
target.administrative_domain |
직접 매핑됨 |
application |
target.application |
직접 매핑됨 |
d_host |
target.hostname |
직접 매핑됨 |
d_ip |
target.ip |
병합됨 |
target_ip |
target.ip |
병합됨 |
d_mac |
target.mac |
병합됨 |
port |
target.port |
직접 매핑됨 |
pid |
target.process.pid |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: NETWORK_DHCP |
| 해당 사항 없음 | metadata.product_name |
상수: TCPWAVE_DDI |
| 해당 사항 없음 | metadata.vendor_name |
상수: TCPWAVE_DDI |
| 해당 사항 없음 | network.application_protocol |
상수: DHCP |
| 해당 사항 없음 | network.dhcp.client_identifier |
상수: bytes |
| 해당 사항 없음 | network.dhcp.type |
상수: DISCOVER |
| 해당 사항 없음 | security_result.severity |
상수: INFORMATIONAL |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.