Symantec Web Isolation 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Symantec Web Isolation 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Symantec Web Isolation은 웹 탐색 세션, URL 액세스 이벤트, 파일 다운로드 활동, 정책 시행, 기기 관리 이벤트에 대한 syslog 메시지를 생성하는 브라우저 격리 플랫폼입니다. 파서는 JSON 형식 로그에서 필드를 추출하여 통합 데이터 모델 (UDM)에 매핑합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 Symantec Web Isolation 플랫폼 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Symantec Web Isolation 웹 UI에 대한 관리 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 활성 (실행 중)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/symantec_web_isolation: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' < custome>r_id: 'customer_id' endpoint: malachiteingestion-pa.googleapis.com log_type: SYMANTEC_WEB_ISOLATION raw_log_field: body service: pipelines: logs/symantec_web_isolation_to_chronicle: receivers: - udplog exporters: - chronicle/symantec_web_isolation
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 지역 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순으로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Symantec Web Isolation 플랫폼에서 syslog 구성
- Symantec Web Isolation 웹 UI에 로그인합니다.
- 시스템 구성 > 외부 로그 서버 > 새 외부 로그 서버 > Syslog 서버로 이동합니다.
- 다음 구성 세부정보를 제공합니다.
- 상태: 체크박스를 선택하여 사용 설정합니다.
- 호스트: Bindplane 에이전트 IP 주소를 입력합니다.
- 포트: Bindplane 에이전트 포트 번호를 입력합니다 (예: UDP의 경우
514). - 프로토콜: UDP를 선택합니다.
- Appname: 웹 격리 플랫폼을 식별하는 태그를 입력합니다.
- Facility: Web Isolation 로그와 관련된 Syslog 기능 이름입니다.
- 만들기를 클릭합니다.
- 보고서 > 로그 전달로 이동합니다.
- 수정을 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 활동 로그: 새로 추가된 Bindplane 서버를 선택합니다.
- 관리 감사 로그: 새로 추가된 Bindplane 서버를 선택합니다.
- 게이트웨이 감사 로그: 새로 추가된 Bindplane 서버를 선택합니다.
- 업데이트를 클릭합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
action |
security_result.summary |
action_reason와 연결되어 요약을 형성합니다. |
action_reason |
security_result.summary |
action와 연결되어 요약을 형성합니다. |
content_action |
security_result.action_details |
직접 매핑 |
createdAt |
metadata.event_timestamp |
UNIX_MS 형식을 사용하여 타임스탬프로 변환되었습니다. |
creationDate |
metadata.event_timestamp |
UNIX_MS 형식을 사용하여 타임스탬프로 변환되었습니다. |
data.level |
security_result.severity |
값에 따라 INFORMATIONAL, LOW 또는 HIGH에 매핑됩니다. |
data.properties.environment.str |
intermediary.location.name |
직접 매핑 |
data.properties.hostname.str |
intermediary.hostname |
직접 매핑 |
destination_ip |
target.ip |
직접 매핑 |
destination_ip_country_name |
target.location.country_or_region |
직접 매핑 |
device.current_risk_warnings |
security_result.category_details |
직접 매핑 |
device.identifier |
target.asset.product_object_id |
직접 매핑 |
device.model |
hardware.model |
직접 매핑 |
device.os_version |
target.asset.platform_software.platform_version |
직접 매핑 |
device.serial_number |
hardware.serial_number |
직접 매핑 |
device.udid |
target.asset.asset_id |
매핑 전에 'UDID:'가 앞에 붙습니다. |
device.user.email |
target.user.email_addresses |
직접 매핑 |
device.user.id |
target.user.userid |
직접 매핑 |
device.user.name |
target.user.user_display_name |
직접 매핑 |
device.user.organization.id |
target.user.groupid |
직접 매핑 |
device.user.organization.name |
target.user.group_identifiers |
직접 매핑 |
event |
metadata.product_event_type |
직접 매핑 |
event_type |
metadata.event_type |
로그 데이터를 기반으로 'GENERIC_EVENT' 또는 'NETWORK_HTTP'로 설정됩니다. |
file_name |
target.file.names |
직접 매핑 |
file_type |
about.labels, about.resource.attribute.labels |
키가 'file_type'인 라벨로 추가되었습니다. |
id |
metadata.product_log_id |
직접 매핑 |
isolation_session_id |
network.parent_session_id |
직접 매핑 |
level |
security_result.severity |
값에 따라 INFORMATIONAL, LOW 또는 HIGH에 매핑됩니다. |
original_source_ip |
principal.ip |
직접 매핑 |
policy_version |
security_result.rule_version |
직접 매핑 |
properties.environment |
intermediary.location.name |
직접 매핑 |
properties.hostname |
intermediary.hostname |
직접 매핑 |
referer_url |
network.http.referral_url |
직접 매핑 |
request_method |
network.http.method |
직접 매핑 |
resource_response_headers.x-nauthilus-traceid |
network.community_id |
직접 매핑 |
response_status_code |
network.http.response_code |
직접 매핑 |
rule_id |
security_result.rule_id |
직접 매핑 |
rule_name_at_log_time |
security_result.rule_name |
직접 매핑 |
rule_type |
security_result.rule_type |
직접 매핑 |
service |
principal.application |
직접 매핑 |
session_id |
network.session_id |
직접 매핑 |
severity |
security_result.severity |
값에 따라 LOW, MEDIUM 또는 HIGH에 매핑됩니다. |
source_ip |
principal.ip |
직접 매핑 |
source_ip_country_name |
principal.location.country_or_region |
직접 매핑 |
source_port |
principal.port |
직접 매핑 |
sub_type |
security_result.summary |
직접 매핑 |
target.asset.type |
target.asset.type |
device.model에 'ipad' 또는 'iphone'이 포함된 경우 'MOBILE'로 설정됩니다. |
target.asset.platform_software.platform |
target.asset.platform_software.platform |
device.model에 'ipad' 또는 'iphone'이 포함된 경우 'MAC'으로 설정됩니다. |
timestamp |
metadata.event_timestamp |
yyyy-MM-dd HH:mm:ss.SSS Z 형식을 사용하여 파싱됩니다. |
total_bytes |
network.received_bytes |
0보다 큰 경우 직접 매핑 |
traceId |
metadata.product_log_id |
직접 매핑 |
type |
metadata.product_event_type |
직접 매핑 |
url |
target.url |
직접 매핑 |
url_host |
principal.hostname |
직접 매핑 |
user_download_usage_bytes |
network.received_bytes |
직접 매핑 |
user_total_usage_bytes |
about.labels, about.resource.attribute.labels |
'user_total_usage_bytes' 키가 있는 라벨로 추가되었습니다. |
user_upload_usage_bytes |
network.sent_bytes |
직접 매핑 |
username |
principal.user.user_display_name |
직접 매핑 |
vendor_name |
metadata.vendor_name |
'Broadcom Inc.'로 설정합니다. |
product_name |
metadata.product_name |
'Symantec Web Isolation'으로 설정합니다. |
log_type |
metadata.log_type |
'SYMANTEC_WEB_ISOLATION'으로 설정합니다. |
sandbox |
about.labels, about.resource.attribute.labels |
키가 'Sandbox'이고 URL에서 추출한 값이 있는 라벨로 추가됩니다. |
utub |
about.labels, about.resource.attribute.labels |
'user_total_usage_bytes' 키가 있는 라벨로 추가되었습니다. |
userid |
target.user.userid |
URL에서 추출됩니다. |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.