Stealthbits 감사 로그 수집

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Stealthbits 감사 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Stealthbits StealthAUDIT (현재 Netwrix StealthAUDIT)는 Active Directory 모니터링, 파일 시스템 감사, 액세스 권한 관리에 사용되는 IT 감사 및 데이터 거버넌스 플랫폼입니다. Netwrix Activity Monitor 구성요소는 실시간 이벤트 전송을 위한 기본 syslog 전달을 지원합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Stealthbits StealthAUDIT 서버 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Netwrix Enterprise Auditor (StealthAUDIT) 콘솔 및 활동 모니터에 대한 권한 액세스

Google SecOps 수집 인증 파일 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 실행 중으로 표시되어야 합니다.

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 활성 (실행 중)으로 표시되어야 합니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/stealthbits_audit:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: STEALTHBITS_AUDIT
            raw_log_field: body
    
    service:
        pipelines:
            logs/stealthbits_audit_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/stealthbits_audit
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신기 구성:

    • listen_address: 리슨할 IP 주소 및 포트입니다.
      • 0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)
      • 포트 514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우 1514 사용).
  • 내보내기 도구 구성:

    • creds_file_path: 수집 인증 파일의 전체 경로입니다.
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps 콘솔에서 복사한 고객 ID
    • endpoint: 지역 엔드포인트 URL:
      • 미국: malachiteingestion-pa.googleapis.com
      • 유럽: europe-malachiteingestion-pa.googleapis.com
      • 아시아: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 전체 목록은 리전 엔드포인트를 참고하세요.

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X 순으로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R 키를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Stealthbits StealthAUDIT syslog 전달 구성

  1. Netwrix Activity Monitor 콘솔을 엽니다.
  2. 모니터링된 호스트로 이동하여 타겟 호스트를 선택합니다.
  3. 출력 탭을 클릭한 다음 Syslog를 선택합니다.
  4. 다음 설정을 구성합니다.

    설정 값
    시스템로그 서버 SERVER:PORT 형식 (예: 192.168.1.100:514)으로 Bindplane 에이전트 IP 주소와 포트를 입력합니다.
    프로토콜 UDP를 선택합니다.
    메시지 템플릿 이벤트 스트림에 포함되는 데이터를 제어하도록 syslog 메시지 템플릿 구성
  5. 저장을 클릭하여 구성을 적용합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
Operation additional.fields 매핑됨: Change → additional_old_value, Change → additional_new_value
additional_field additional.fields 병합됨
additional_new_value additional.fields 병합됨
additional_old_value additional.fields 병합됨
intermediary_domain intermediary.hostname 직접 매핑됨
event_description metadata.description 직접 매핑됨
event_timestamp metadata.event_timestamp yyyy-MM-dd HH:mm:ss.SSS로 파싱됨
product_event_type metadata.event_type 매핑됨: Windows File System Update → FILE_MODIFICATION, `Active Directory Object Modifie…
product_event_type metadata.product_event_type 직접 매핑됨
ClientHost principal.hostname 직접 매핑됨
ClientAddress principal.ip 병합됨
NewAttributeValue principal.process.command_line 직접 매핑됨
blocked_event security_result.action 병합됨
Operation security_result.category_details 병합됨
target_administrative_domain target.administrative_domain 직접 매핑됨
file_path target.file.full_path 이름이 변경됨/매핑됨
target_hostname target.hostname 직접 매핑됨
target_ip target.ip 병합됨
ModifiedObject target.resource.name 직접 매핑됨
해당 사항 없음 metadata.event_type 상수: FILE_MODIFICATION
해당 사항 없음 metadata.product_name 상수: StealthINTERCEPT
해당 사항 없음 metadata.vendor_name 상수: Stealthbits

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.