Semperis DSP 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Semperis Directory Services Protector (DSP) 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Semperis Directory Services Protector (DSP)는 AD 변경사항과 공격을 모니터링하여 실시간 알림과 자동 수정 기능을 제공하는 Active Directory 위협 탐지 및 대응 플랫폼입니다. 파서는 DSP 로그 항목에서 필드를 추출하여 통합 데이터 모델 (UDM)에 매핑하고 AD 객체 수정, 인증 이벤트, DNS 변경사항, 보안 결과를 캡처합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 있는 Linux 호스트 - Bindplane 에이전트와 Semperis DSP 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 관리자 권한으로 Semperis DSP 관리 콘솔에 대한 권한 있는 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트 로 이동합니다.
- 수집 인증 파일 을 다운로드합니다.
Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필 로 이동합니다.
조직 세부정보 섹션에서 고객 ID 를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 관리자 권한으로 명령 프롬프트 또는 PowerShell 을 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중 으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 활성 (실행 중) 으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 수정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/semperis_dsp: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SEMPERIS_DSP raw_log_field: body service: pipelines: logs/semperis_dsp: receivers: - tcplog exporters: - chronicle/semperis_dsp
구성 매개변수
다음 자리표시자를 바꿉니다.
수신 도구 구성:
tcplog: 프로토콜을 기반으로 하는 수신 도구 유형:- UDP syslog의 경우
udplog - TCP syslog의 경우
tcplog - RFC 3164/5424 syslog의 경우
syslog
- UDP syslog의 경우
0.0.0.0: 리슨할 IP 주소:- 모든 인터페이스에서 리슨하려면
0.0.0.0(권장) - 하나의 인터페이스에서 리슨할 특정 IP 주소
- 모든 인터페이스에서 리슨하려면
514: 리슨할 포트 번호 (예:514,1514,6514)
내보내기 구성:
<customer_id>: 이전 단계의 고객 IDmalachiteingestion-pa.googleapis.com: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참조하세요.
- 미국:
- 플랫폼에 따라
creds_file_path를 조정합니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O를 누른 다음Enter를 누르고Ctrl+X를 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
Bindplane 에이전트를 다시 시작하여 변경사항 적용
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R을 누르고services.msc를 입력한 후 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector 를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작 을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Semperis DSP syslog 전달 구성
- Semperis DSP 관리 콘솔에 로그인합니다.
- 설정 > SIEM 통합으로 이동합니다.
- Syslog 전달을 사용 설정합니다.
- 다음 구성 세부정보를 제공합니다.
- 호스트: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예:
192.168.1.100). - 포트:
514를 입력합니다 (Bindplane 수신 도구 포트와 일치해야 함). - 프로토콜: TCP를 선택합니다 (Bindplane 수신 도구 유형과 일치해야 함).
- 호스트: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예:
- 저장 을 클릭합니다.
UDM 매핑 표
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
| event_type | extensions.auth.type | ObjectModificationType == 'LoginADSM'인 경우 'SSO'로 설정 |
| 호스트 | intermediary.hostname | 값이 직접 복사됨 |
| ObjectModificationType | metadata.description | 값이 직접 복사됨 |
| event_type | metadata.event_type | ObjectModificationType == 'CreateObject' 및 OriginatingUsers != ''인 경우 RESOURCE_CREATION으로 설정, ObjectModificationType == 'ModifyObject' 및 OriginatingUsers != '' 및 AttributeName에 'Password'가 포함된 경우 RESOURCE_WRITTEN으로 설정, ObjectModificationType == 'ModifyObject' 및 OriginatingUsers != ''인 경우 RESOURCE_WRITTEN으로 설정, ObjectModificationType == 'DeleteObject' 및 OriginatingUsers != ''인 경우 RESOURCE_DELETION으로 설정, ObjectModificationType == 'LoginADSM' 및 OriginatingUsers != ''인 경우 USER_LOGIN으로 설정, ObjectModificationType == 'OperationRequest' 및 OriginatingUsers != ''인 경우 RESOURCE_WRITTEN으로 설정, principal_present == 'true'인 경우 STATUS_UPDATE로 설정, principal_user_present == 'true'인 경우 USER_UNCATEGORIZED로 설정, 그 외의 경우 GENERIC_EVENT로 설정 |
| metadata.product_name | 'SEMPERIS_DSP'로 설정 | |
| metadata.vendor_name | 'SEMPERIS'로 설정 | |
| StringValueFrom | network.dns.answers.data | 정리 후 값이 직접 복사됨 |
| NameNode | network.dns.answers.name | 값이 직접 복사됨 |
| Ttl | network.dns.answers.ttl | 값이 직접 복사되고 uinteger로 변환됨 |
| 유형 | network.dns.answers.type | Type =~ 'DNS_TYPE_A'인 경우 '1'로 설정, Type =~ 'DNS_TYPE_PTR'인 경우 '12'로 설정, uinteger로 변환 |
| OriginatingServer | principal.asset.hostname | 값이 직접 복사됨 |
| ip | principal.asset.ip | 유효성 검사 및 정리 후 값이 직접 복사됨 |
| OriginatingServer | principal.hostname | 값이 직접 복사됨 |
| ip | principal.ip | 유효성 검사 및 정리 후 값이 직접 복사됨 |
| DistinguishedName | principal.user.group_identifiers | 값이 직접 병합됨 |
| ForestId | principal.user.product_object_id | 값이 직접 복사됨 |
| OriginatingUsers | principal.user.userid | OperationType != 'LoginADSM'인 경우 값이 직접 복사됨 |
| security_action | security_result.action | 값이 직접 복사됨 |
| RequestedAction | security_result.summary | OperationResult =~ 'Granted' 또는 'Denied'인 경우 값이 직접 복사됨 |
| AttributeName | target.resource.name | AttributeName != '' 및 AttributeName != 'isDeleted'인 경우 값이 직접 복사됨 |
| ClassName | target.resource.resource_subtype | 값이 직접 복사됨 |
| OriginatingUsers | target.user.userid | OperationType == 'LoginADSM'인 경우 값이 직접 복사됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.