Quest 파일 액세스 감사 로그 수집

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Quest File Access Audit 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Quest Change Auditor (이전 명칭: Quest File Access Audit)는 Windows 환경 전반에서 파일 액세스 활동, 권한 변경사항, 관리 작업을 모니터링하고 보고하는 파일 서버 및 Active Directory 감사 플랫폼입니다. Change Auditor는 이벤트 구독을 통한 syslog 전달을 비롯한 기본 제공 SIEM 통합 기능을 제공합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Quest Change Auditor 코디네이터 서버 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Quest Change Auditor 클라이언트 또는 코디네이터 서버에 대한 권한 있는 액세스

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 새 배포: Chronicle API를 사용합니다 (옵션 1).
  • 기존 배포: 2027년 7월 20일에 수집 API가 지원 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명 (예: Bindplane agent log ingestion)을 입력합니다.
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가> 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path을 저장된 경로와 일치하도록 업데이트합니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 RUNNING으로 표시됩니다.

Linux 설치

  1. 루트 또는 sudo 권한이 있는 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 활성 (실행 중)으로 표시되어야 합니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.

syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/quest_file_audit:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: QUEST_FILE_AUDIT
        raw_log_field: body
    
    service:
      pipelines:
        logs/quest_file_audit_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/quest_file_audit
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신자 구성:

    • listen_address: 리슨할 IP 주소 및 포트:
      • 0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)
      • 포트 514은 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우 1514 사용).
  • 내보내기 도구 구성:

    • creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps 콘솔에서 복사한 고객 ID
    • location: <LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다 (예: us, europe 또는 asia-southeast1). 내보내기 도구는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참고하세요.
    • project: <PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • endpoint: chronicle.googleapis.com로 설정된 상태를 유지합니다.

기존 수집 API 내보내기

  • 옵션 2의 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com를 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/quest_file_audit:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: QUEST_FILE_AUDIT
        raw_log_field: body
    

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X를 차례로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R 키를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼으로 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Quest Change Auditor syslog 전달 구성

옵션 1: Change Auditor 클라이언트를 사용하여 syslog 전달 구성

  1. Change Auditor 클라이언트 애플리케이션을 엽니다.
  2. 관리 > 이벤트 구독으로 이동합니다.
  3. 새로 만들기를 클릭하고 구독 유형으로 Syslog를 선택합니다.
  4. Syslog 이벤트 구독 마법사에서 다음을 구성합니다.
    • 호스트: Bindplane 에이전트 호스트의 IP 주소를 입력합니다.
    • 포트: 514를 입력합니다.
    • 메시지 형식: CEF (Common Event Format) 또는 LEEF (Log Event Extended Format)를 선택합니다.
    • 하위 시스템: 전달할 이벤트 하위 시스템을 선택합니다 (예: 파일 시스템).
  5. 완료를 클릭하여 구독을 만듭니다.

옵션 2: PowerShell을 사용하여 syslog 전달 구성

  1. Change Auditor 코디네이터 서버에서 PowerShell을 열고 Change Auditor 모듈을 가져옵니다.
  2. syslog 이벤트 구독을 만듭니다.

    $subsystems = Get-CAEventExportSubsystems | Where-Object { $_.Name -like "*File*" }
    New-CASyslogEventSubscription -Host "<BINDPLANE_AGENT_IP>" -Port 514 -SyslogFormat "CEF" -Subsystems $subsystems
    
  3. 구독이 생성되었는지 확인합니다.

    Get-CASyslogEventSubscriptions
    

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
Keywords, EventType, Task, ThreadID, Channel, Opcode additional.fields 이벤트에 대한 추가 정보
EventTime metadata.event_timestamp 이벤트가 발생한 시점의 타임스탬프
event_type metadata.event_type 이벤트 유형
EventReceivedTime metadata.ingested_timestamp 이벤트가 수집된 시점의 타임스탬프
EventID metadata.product_event_type 제품에서 정의한 이벤트 유형
RecordNumber metadata.product_log_id 제품에서 할당한 로그 ID
metadata.product_name 이벤트를 생성한 제품의 이름입니다.
metadata.vendor_name 이벤트를 생성한 공급업체의 이름입니다.
SourceModuleType observer.application 관찰자가 사용하는 애플리케이션
SourceModuleName observer.resource.attribute.labels 옵저버 리소스와 연결된 라벨
도메인 principal.administrative_domain 주 구성원의 관리 도메인
SourceName principal.application 주 구성원이 사용하는 애플리케이션
호스트 이름 principal.asset.hostname 주 구성원과 연결된 애셋의 호스트 이름
ip_address principal.asset.ip 주 구성원과 연결된 애셋의 IP 주소
호스트 이름 principal.hostname 주 구성원의 호스트 이름
ip_address principal.ip 주 구성원의 IP 주소
ProcessID principal.process.pid 프로세스 ID
logonID principal.user.attribute.labels 사용자와 연결된 라벨
AccountType principal.user.attribute.roles 사용자와 연결된 역할
AccountName principal.user.userid 사용자 ID
UserID principal.user.windows_sid 사용자의 Windows SID
설명 security_result.description 보안 결과에 대한 설명
SeverityValue security_result.severity 보안 결과의 심각도
심각도 security_result.severity_details 심각도 세부정보
카테고리 security_result.summary 보안 결과 요약
file_path target.file.full_path 타겟 파일의 전체 경로
file_path target.process.file.full_path 대상 프로세스와 연결된 파일의 전체 경로

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.