Preempt Auth 로그 수집

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Preempt Auth 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Preempt Auth는 Active Directory 환경에 대한 상세한 인증 로그를 생성하는 인증 이벤트 모니터링 솔루션입니다. 엔드포인트 전반에서 로그인 성공 및 실패 이벤트, LDAP 검색, 서비스 액세스, 인증 유형을 캡처합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Preempt 서버 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • 관리자 권한으로 Preempt Auth(CrowdStrike Identity Protection)에 대한 권한 액세스

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 새 배포: Chronicle API를 사용합니다(옵션 1).
  • 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일(옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다(예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다(예: Bindplane agent log ingestion).
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리(Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드(기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. 설정 > 데이터 관리 > 수집 에이전트로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. 설정 > 관리 > 프로필로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 RUNNING으로 표시됩니다.

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 active (running)으로 표시됩니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/preempt_auth:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: chronicle.googleapis.com
        log_type: PREEMPT_AUTH
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/preempt_auth_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/preempt_auth
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신자 구성:

    • tcplog: TCP를 통해 syslog를 수신합니다. Preempt 배포가 UDP를 통해 전달되는 경우 udplog을 사용합니다.
    • 0.0.0.0:514: 포트 514의 모든 인터페이스에서 수신 대기합니다. 필요한 경우 포트를 변경합니다(예: 루트가 아닌 Linux의 경우 1514).
  • 내보내기 도구 구성:

    • <CREDS_FILE_PATH>: 서비스 계정 JSON 키 파일의 전체 경로(옵션 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <CUSTOMER_ID>: Google SecOps 고객 ID 가져오기 단계의 고객 ID입니다.
    • location: <LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다(예: us, europe 또는 asia-southeast1). 내보내기 도구는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.
    • project: <PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • endpoint: chronicle.googleapis.com로 설정된 상태로 유지합니다.

기존 수집 API 내보내기 도구

  • 옵션 2의 데이터 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com를 리전 엔드포인트(예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/preempt_auth:
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: PREEMPT_AUTH
        raw_log_field: body
        ingestion_labels:
          env: production
    

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X를 차례로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼으로 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Preempt Auth syslog 전달 구성

  1. Preempt 관리 콘솔에 로그인합니다.
  2. 설정 > SIEM 통합으로 이동합니다.
  3. 인증 이벤트에 syslog 전달을 사용 설정합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 프로토콜: TCP를 선택합니다(Bindplane 에이전트 수신기 구성과 일치해야 함).
    • 시스템로그 서버 주소: Bindplane 에이전트 호스트의 IP 주소를 입력합니다(예: 192.168.1.100).
    • 포트: 514를 입력합니다(Bindplane 에이전트 수신자 포트와 일치해야 함).
  5. 전달할 인증 이벤트 유형을 선택합니다.
    • 인증 성공 이벤트
    • 인증 실패 이벤트
    • LDAP 검색
    • 서비스 액세스 이벤트
  6. 저장 또는 적용을 클릭합니다.
  7. Bindplane 에이전트 로그를 확인하여 로그가 전송되고 있는지 확인합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
authenticationType extensions.auth.type authenticationType이 SSO_LOGIN 또는 LDAP_AUTHENTICATION과 일치하는 경우 'SSO'로 설정, DOMAIN_LOGIN인 경우 'MACHINE', NTLM_AUTHENTICATION인 경우 'AUTHTYPE_UNSPECIFIED'로 설정
extensions.auth.mechanism 'MECHANISM_UNSPECIFIED'로 설정합니다.
inter_ip intermediary.hostname inter_ip가 유효한 IP 주소가 아닌 경우 설정
inter_ip intermediary.ip inter_ip가 유효한 IP 주소인 경우 설정
eventLabel metadata.description 값이 직접 복사됨
eventType metadata.event_type eventType이 SUCCESSFUL_AUTHENTICATION 또는 FAILED_AUTHENTICATION인 경우 'USER_LOGIN'으로 설정되고, SERVICE_ACCESS 또는 LDAP_SEARCH이고 principal_host_set이 true인 경우 'SERVICE_UNSPECIFIED'로 설정됩니다.
eventType metadata.product_event_type 값이 직접 복사됨
endpointDisplayName, ipAddress principal.hostname endpointDisplayName != ipAddress 및 endpointDisplayName != ""인 경우 설정됩니다.
ipAddress, inter_ip principal.ip ipAddress != inter_ip인 경우 ipAddress의 값, 그렇지 않으면 inter_ip의 값
networkType principal.resource.name 값이 직접 복사됨
principal.resource.type '네트워크 유형'으로 설정
userDisplayName principal.user.email_addresses userDisplayName이 이메일 정규식과 일치하는 경우 설정
userDisplayName principal.user.user_display_name 값이 직접 복사됨
userEntity.secondaryDisplayName, userDisplayName principal.user.userid userEntity.secondaryDisplayName이 비어 있지 않은 경우 userEntity.secondaryDisplayName의 값, userEntity.secondaryDisplayName이 비어 있는 경우 userDisplayName의 값
eventType security_result.action SUCCESSFUL_AUTHENTICATION인 경우 'ALLOW'로 설정하고 FAILED_AUTHENTICATION인 경우 'BLOCK'으로 설정합니다.
eventSeverity security_result.severity_details 값이 직접 복사됨
authenticationType security_result.summary 값이 직접 복사됨
targetEntity.primaryDisplayName, targetServiceIdentifier, eventType, targetEntity.type target.application targetEntity.type == 'CLOUD_SERVICE'인 경우 targetEntity.primaryDisplayName의 값, 그렇지 않고 targetServiceIdentifier != ''이고 이전에 설정되지 않은 경우 targetServiceIdentifier의 값, 그렇지 않고 eventType == 'LDAP_SEARCH'이고 이전에 설정되지 않은 경우 'LDAP'
targetEntity.primaryDisplayName, targetEntity.type target.hostname targetEntity.type == 'ENDPOINT'인 경우 설정됩니다.
targetServiceType target.resource.name targetServiceType != '' 및 != 'UNKNOWN'인 경우 설정됩니다.
targetServiceType target.resource.type targetServiceType != "" 및 != "UNKNOWN"인 경우 '서비스 유형'으로 설정됩니다.
targetEntity.primaryDisplayName, targetEntity.type target.user.user_display_name targetEntity.type == 'USER'인 경우 설정됩니다.
targetEntity.secondaryDisplayName, targetEntity.type target.user.userid targetEntity.type == 'USER'인 경우 설정됩니다.
metadata.product_name 'PREEMPT_AUTH'로 설정합니다.
metadata.vendor_name '선점'으로 설정

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.