Nokia 라우터 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Nokia 라우터 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Nokia 서비스 라우터는 BGP 이벤트, 인터페이스 상태 변경, MKA 세션, LLDP 인접 항목 검색, IS-IS 라우팅, 보안 필터 일치에 대한 syslog 메시지를 생성하는 네트워크 라우터입니다. 파서는 grok 패턴을 사용하여 syslog 형식 로그에서 필드를 추출하고 통합 데이터 모델 (UDM)에 매핑합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 Nokia 서비스 라우터 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Nokia 라우터에 대한 액세스 권한
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Bindplane 에이전트를 Google SecOps에 인증하려면 다음 방법 중 하나를 선택하세요.
- 새 배포: Chronicle API를 사용합니다 (옵션 1).
- 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명 (예:
Bindplane agent log ingestion)을 입력합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 생성한 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가 > 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 RUNNING으로 표시됩니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시됩니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.
syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/nokia_router: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: NOKIA_ROUTER raw_log_field: body service: pipelines: logs/nokia_router_to_chronicle: receivers: - udplog exporters: - chronicle/nokia_router
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트:0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514은 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우1514사용).
내보내기 도구 구성:
creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDlocation:<LOCATION>을 Google SecOps 인스턴스의 리전 (예:us,europe,asia-southeast1)으로 바꿉니다. 내보내기 프로그램은chronicle.googleapis.com에 이 값을 접두사로 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.project:<PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.endpoint:chronicle.googleapis.com로 설정된 상태로 유지합니다.
기존 수집 API 내보내기 도구
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/nokia_router: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NOKIA_ROUTER raw_log_field: body
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순으로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Nokia 서비스 라우터에서 syslog 구성
구성 모드로 진입합니다.
config# logsyslog 대상을 정의합니다.
config>log# syslog 1syslog 파라미터를 구성합니다.
config>log>syslog# address <syslog-server-ip> config>log>syslog# port <port-number> config>log>syslog# facility local0 config>log>syslog# level info config>log>syslog# log-prefix "Nokia-SR" config>log>syslog# description "Syslog to Bindplane"- I can help you with that. Please provide the
<syslog-server-ip>Bindplane agent IP address and the<port-number>port you want to use.514
- I can help you with that. Please provide the
syslog 대상을 로그 파일에 적용합니다.
config>log# log-id 1 config>log>log-id# to syslog 1로그 파일을 사용 설정합니다.
config>log>log-id# no shutdown구성을 저장합니다.
config>log>log-id# exit config>log# save
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
%{SYSLOGTIMESTAMP:date_time} |
metadata.event_timestamp |
원시 로그에서 추출되어 타임스탬프로 변환됩니다. |
%{IP:src_ip} |
principal.ip |
원시 로그에서 추출했습니다. |
%{HOSTNAME:host_name} |
principal.hostname |
원시 로그에서 추출됩니다. |
%{INT:sequence_id} |
metadata.product_log_id |
원시 로그에서 추출됩니다. |
%{DATA:router_name} |
metadata.product_name |
원시 로그에서 추출됩니다. |
%{DATA:application} |
target.application |
원시 로그에서 추출됩니다. |
%{WORD:severity} |
security_result.severity |
다음 로직에 따라 원시 로그 심각도에서 매핑됩니다. - CLEARED, INFO -> INFORMATIONAL - MINOR -> ERROR - WARNING -> LOW - MAJOR -> HIGH - CRITICAL -> CRITICAL |
%{DATA:event_name} |
metadata.product_event_type |
원시 로그에서 추출했습니다. |
%{INT:event_id} |
additional.fields.value.string_value |
원시 로그에서 추출되어 Event Id 키와 함께 additional fields 내에 배치됩니다. |
%{GREEDYDATA:message1} |
event_name에 따라 다양한 필드를 추출하는 데 사용됩니다. 아래에서 특정 필드의 로직을 참고하세요. |
|
Group %{NOTSPACE:group_id} |
target.group.product_object_id |
event_name이 BGP 이벤트와 관련된 경우 message1에서 추출됩니다. |
%{WORD} %{IP:dest_ip} |
target.ip |
event_name이 BGP 이벤트와 관련된 경우 message1에서 추출됩니다. |
%{GREEDYDATA:desc} |
security_result.description |
다양한 event_name 시나리오를 위해 message1에서 추출되었습니다. |
SAP %{DATA:sap_id} |
additional.fields.value.string_value |
event_name이 sapStatusChanged인 경우 message1에서 추출되며 키 SAP Id이 있는 additional fields 내에 배치됩니다. |
in service %{INT:service_id} |
additional.fields.value.string_value |
event_name가 sapStatusChanged일 때 message1에서 추출되어 Service Id 키를 사용하여 additional fields 내에 배치됩니다. |
\\(customer %{INT:customer_id}\\) |
additional.fields.value.string_value |
event_name가 sapStatusChanged일 때 message1에서 추출되어 Customer Id 키를 사용하여 additional fields 내에 배치됩니다. |
admin=%{WORD:admin_status} |
additional.fields.value.string_value |
event_name가 sapStatusChanged일 때 message1에서 추출되어 Admin Status 키를 사용하여 additional fields 내에 배치됩니다. |
oper=%{WORD:operation_status} |
additional.fields.value.string_value |
event_name가 sapStatusChanged일 때 message1에서 추출되어 Operation Status 키를 사용하여 additional fields 내에 배치됩니다. |
flags=%{WORD:flag} |
additional.fields.value.string_value |
event_name가 sapStatusChanged일 때 message1에서 추출되어 Flag 키를 사용하여 additional fields 내에 배치됩니다. |
with MI:SCI %{DATA:mi_sci} |
additional.fields.value.string_value |
event_name가 tmnxMkaSessionEstablished일 때 message1에서 추출되어 MI:SCI 키를 사용하여 additional fields 내에 배치됩니다. |
on port %{DATA:port_id} |
additional.fields.value.string_value |
event_name가 tmnxMkaSessionEstablished일 때 message1에서 추출되어 Port Id 키를 사용하여 additional fields 내에 배치됩니다. |
sub-port %{INT:sub_port_id} |
additional.fields.value.string_value |
event_name가 tmnxMkaSessionEstablished일 때 message1에서 추출되어 Sub-port Id 키를 사용하여 additional fields 내에 배치됩니다. |
CA %{INT:ca} |
additional.fields.value.string_value |
event_name가 tmnxMkaSessionEstablished일 때 message1에서 추출되어 CA 키를 사용하여 additional fields 내에 배치됩니다. |
EAPOL-destination %{MAC:dest_mac} |
target.mac |
event_name이 tmnxMkaSessionEstablished일 때 message1에서 추출됩니다. |
local port-id %{DATA:local_port_id} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 local_port_id가 있는 target.resource.attribute.labels 내에 배치됩니다. |
dest-mac-type %{NOTSPACE:mac_type} |
target.resource.attribute.labels.value |
특정 event_name 값의 message1에서 추출되어 mac_type 키를 사용하여 target.resource.attribute.labels 내에 배치됩니다. |
remote system name %{HOSTNAME:dest_host} |
target.hostname |
특정 event_name 값에 대해 message1에서 추출됩니다. |
remote chassis-id %{DATA:dest_mac} |
target.mac |
특정 event_name 값의 message1에서 추출되었습니다. |
remote port-id %{DATA:port_id} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 port_id가 있는 target.resource.attribute.labels 내에 배치됩니다. |
remote-index %{INT:remote_index} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 remote_index가 있는 target.resource.attribute.labels 내에 배치됩니다. |
remote management address %{IP:dest_ip} |
target.ip |
특정 event_name 값의 message1에서 추출되었습니다. |
advRtr:%{HOSTNAME:dest_host}%{GREEDYDATA}, ip@:%{IP:dest_ip}/%{INT:dest_port} |
target.hostname, target.ip, target.port |
특정 event_name 값의 message1에서 추출되었습니다. |
SID:%{INT:sid} |
network.session_id |
특정 event_name 값의 message1에서 추출되었습니다. |
level:%{DATA:level} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 level가 있는 target.resource.attribute.labels 내에 배치됩니다. |
mtid:%{INT:mtid} |
target.resource.attribute.labels.value |
특정 event_name 값의 message1에서 추출되어 mtid 키를 사용하여 target.resource.attribute.labels 내에 배치됩니다. |
type:%{WORD:type} |
target.resource.attribute.labels.value |
특정 event_name 값의 message1에서 추출되어 type 키를 사용하여 target.resource.attribute.labels 내에 배치됩니다. |
flags:%{WORD:flag} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 flag가 있는 target.resource.attribute.labels 내에 배치됩니다. |
, algo:%{INT:algo} |
target.resource.attribute.labels.value |
특정 event_name 값에 대해 message1에서 추출되고 키 algo가 있는 target.resource.attribute.labels 내에 배치됩니다. |
Description:%{GREEDYDATA:desc}. |
security_result.description |
event_name이 mafEntryMatch일 때 message1에서 추출됩니다. |
SrcIP |
principal.ip |
event_name이 mafEntryMatch인 경우 kv_data 필드에서 추출됩니다. |
SrcIP: %{INT:src_port} |
principal.port |
event_name가 mafEntryMatch인 경우 kv_data 필드에서 추출됩니다. |
DstIP |
target.ip |
event_name가 mafEntryMatch인 경우 kv_data 필드에서 추출됩니다. |
DstIP: %{INT:dest_port} |
target.port |
event_name가 mafEntryMatch인 경우 kv_data 필드에서 추출됩니다. |
Protocol |
network.ip_protocol |
event_name이 mafEntryMatch인 경우 kv_data 필드에서 추출됩니다. |
| 해당 사항 없음 | metadata.vendor_name |
NOKIA_ROUTER로 설정합니다. |
| 해당 사항 없음 | metadata.event_type |
추출된 필드의 존재 여부와 조합에 따라 결정됩니다. - src_ip, dest_ip, network가 있는 경우 -> NETWORK_CONNECTION- principal가 있는 경우 -> STATUS_UPDATE- 그 외의 경우 -> GENERIC_EVENT |
%{GREEDYDATA:description} |
metadata.description |
event_name이 tmnxMkaSessionEstablished인 경우 message1에서 추출됩니다. |
src_ip |
event.idm.read_only_udm.intermediary.ip |
변경 로그에서 매핑됨 |
src_ip |
event.idm.read_only_udm.intermediary.asset.ip |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.