OpenText Access Manager (이전 NetIQ Access Manager) 로그 수집
이 문서에서는 Bindplane을 사용하여 OpenText Access Manager (이전 명칭: NetIQ Access Manager) 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
OpenText Access Manager는 웹 애플리케이션 및 서비스에 대한 싱글 사인온 (SSO), 다중 인증, 페더레이션, 정책 기반 액세스 제어를 제공하는 온프레미스 ID 및 액세스 관리 솔루션입니다. 사용자와 보호된 리소스 간의 보안 게이트웨이 역할을 하며 엔터프라이즈 환경 전반에서 인증 및 승인 정책을 적용합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows 2016 이상을 실행하는 호스트 또는
systemd가 있는 Linux 호스트 - 네트워크 연결: 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- OpenText Access Manager 관리 콘솔에 대한 액세스 권한
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 새 배포: Chronicle API를 사용합니다 (옵션 1).
- 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다 (예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가 > 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
- 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
다음 명령어를 실행합니다.
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
추가 설치 리소스
추가 설치 옵션은 이 설치 가이드를 참고하세요.
Syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일에 액세스합니다.
config.yaml파일을 찾습니다. 일반적으로 Linux에서는/opt/observiq-otel-collector디렉터리에 있고 Windows에서는 설치 디렉터리에 있습니다.- 텍스트 편집기 (예:
nano,vi, 메모장)를 사용하여 파일을 엽니다.
다음과 같이
config.yaml파일을 수정합니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: NETIQ_ACCESS_MANAGER raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 인프라에 필요한 대로 포트와 IP 주소를 바꿉니다.
<LOCATION>을 Google SecOps 인스턴스의 리전 (예:us,europe,asia-southeast1)으로 바꿉니다. 내보내기 도구는chronicle.googleapis.com에 이 값을 접두사로 추가합니다.<PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.<customer_id>를 실제 고객 ID로 바꿉니다./path/to/ingestion-authentication-file.json를 이전 단계에서 서비스 계정 키 파일 (옵션 1)이 저장된 파일 경로로 업데이트합니다.
기존 수집 API 내보내기
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com를 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NETIQ_ACCESS_MANAGER raw_log_field: body ingestion_labels:
Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collectorWindows에서 Bindplane 에이전트를 다시 시작하려면 서비스 콘솔을 사용하거나 다음 명령어를 입력하면 됩니다.
net stop observiq-otel-collector && net start observiq-otel-collector
OpenText Access Manager syslog 전달 구성
- OpenText Access Manager Administration Console에 로그인합니다.
- 감사 > Syslog로 이동합니다.
- Syslog 사용 설정 체크박스를 선택합니다.
- 다음 구성 세부정보를 제공합니다.
- Syslog 서버 주소: Bindplane 에이전트 호스트의 IP 주소를 입력합니다.
- 포트:
514를 입력합니다. - 기능: 적절한 syslog 기능 (예: LOCAL0)을 선택합니다.
- 감사 이벤트 섹션에서 전달할 이벤트 카테고리를 선택합니다.
- 인증 이벤트
- 승인 이벤트
- 관리 이벤트
- 시스템 이벤트
- 적용을 클릭하여 syslog 구성을 저장합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
version |
about.resource.attribute.labels |
병합됨 |
_field |
additional.fields |
병합됨 |
I |
extensions.auth.type |
매핑됨: "002E0505","002E001E","002E0046" → AUTHTYPE_UNSPECIFIED, "002E0007","002E000C"… |
host_name |
intermediary.hostname |
직접 매핑됨 |
D |
metadata.description |
직접 매핑됨 |
stringValue3 |
metadata.description |
직접 매핑됨 |
timestamp |
metadata.event_timestamp |
RFC 3339(으)로 파싱됨 |
I |
metadata.event_type |
매핑됨: "002E0505","002E001E","002E0046" → USER_LOGIN, 002E0525 → `NETWORK_UNCATEGORIZ… |
has_principal |
metadata.event_type |
매핑됨: true → NETWORK_CONNECTION, true → STATUS_UPDATE |
has_user |
metadata.event_type |
매핑됨: true → USER_UNCATEGORIZED |
id_sub_event |
metadata.product_event_type |
직접 매핑됨 |
I |
metadata.product_log_id |
직접 매핑됨 |
eventId |
metadata.product_log_id |
직접 매핑됨 |
event_id |
metadata.product_log_id |
직접 매핑됨 |
product |
metadata.product_name |
직접 매핑됨 |
product_version |
metadata.product_version |
직접 매핑됨 |
vendor |
metadata.vendor_name |
직접 매핑됨 |
T |
network.http.user_agent |
직접 매핑됨 |
L |
network.session_id |
직접 매핑됨 |
subTarget |
network.session_id |
직접 매핑됨 |
F |
principal.application |
직접 매핑됨 |
appName |
principal.application |
직접 매핑됨 |
host |
principal.asset.hostname |
직접 매핑됨 |
host_name |
principal.asset.hostname |
직접 매핑됨 |
originator |
principal.asset.hostname |
직접 매핑됨 |
src_ip |
principal.asset.ip |
병합됨 |
host |
principal.hostname |
직접 매핑됨 |
host_name |
principal.hostname |
직접 매핑됨 |
originator |
principal.hostname |
직접 매핑됨 |
src_ip |
principal.ip |
병합됨 |
stringValue1 |
principal.user.userid |
직접 매핑됨 |
I |
security_result.action |
매핑됨: "002E0505","002E001E","002E0046" → security_action, 002E0525 → `security_actio… |
security_action |
security_result.action |
병합됨 |
name |
security_result.action_details |
직접 매핑됨 |
g_label |
security_result.detection_fields |
병합됨 |
h_label |
security_result.detection_fields |
병합됨 |
impersonatee_session_id_label |
security_result.detection_fields |
병합됨 |
m_label |
security_result.detection_fields |
병합됨 |
v_label |
security_result.detection_fields |
병합됨 |
priority |
security_result.priority_details |
직접 매핑됨 |
A |
security_result.rule_id |
직접 매핑됨 |
severity |
security_result.severity_details |
매핑된 값 (총 5개, 예: 1 → TRACE, 2 → DEBUG, 4 → INFO) |
result |
security_result.summary |
직접 매핑됨 |
process_name |
target.application |
직접 매핑됨 |
dst_ip |
target.asset.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
B |
target.resource.id |
직접 매핑됨 |
O |
target.resource.name |
직접 매핑됨 |
Y |
target.url |
직접 매핑됨 |
_group_identifier |
target.user.group_identifiers |
병합됨 |
U |
target.user.userid |
직접 매핑됨 |
device_name |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | extensions.auth.type |
상수: AUTHTYPE_UNSPECIFIED |
| 해당 사항 없음 | metadata.event_type |
상수: USER_LOGIN |
| 해당 사항 없음 | metadata.product_name |
상수: Netiq_Access_Manager |
| 해당 사항 없음 | metadata.vendor_name |
상수: Netiq |
| 해당 사항 없음 | security_result.severity_details |
상수: TRACE |
"2" |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
"3" |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
"host_name" |
event.idm.read_only_udm.intermediary.hostname |
변경 로그에서 매핑됨 |
1 |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
stringValue2 |
event.idm.read_only_udm.security_result.detection_fields |
변경 로그에서 매핑됨 |
eventId |
event.idm.read_only_udm.metadata.product_log_id |
변경 로그에서 매핑됨 |
subTarget |
event.idm.read_only_udm.network.session_id |
변경 로그에서 매핑됨 |
stringValue1 |
event.idm.read_only_udm.principal.user.userid |
변경 로그에서 매핑됨 |
stringValue3 |
event.idm.read_only_udm.metadata.description |
변경 로그에서 매핑됨 |
originator |
event.idm.read_only_udm.principal.asset.hostname |
변경 로그에서 매핑됨 |
originator |
event.idm.read_only_udm.principal.hostname |
변경 로그에서 매핑됨 |
G","H","M" and "V |
security_result.detection_fields |
변경 로그에서 매핑됨 |
L |
event.idm.read_only_udm.network.session_id |
변경 로그에서 매핑됨 |
T |
event.idm.read_only_udm.network.http.user_agent |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.