MicroStrategy 로그 수집
이 문서에서는 Bindplane을 사용하여 MicroStrategy 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
MicroStrategy는 비즈니스 인텔리전스 및 분석 플랫폼입니다. 보고서 실행, 사용자 세션, 데이터 액세스, 관리자 작업에 대한 감사 로그를 생성합니다. 파서는 MicroStrategy 로그 메시지에서 필드를 추출하여 통합 데이터 모델 (UDM)에 매핑하고 사용자 ID, 세션 세부정보, 서버 정보, 보안 메타데이터를 캡처합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 MicroStrategy Intelligence Server 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- MicroStrategy Intelligence Server에 대한 권한이 있는 액세스 (관리자 역할 또는 서버 파일 시스템 액세스)
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector
서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector
서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo systemctl status observiq-otel-collectorWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/microstrategy: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: MICROSTRATEGY raw_log_field: body service: pipelines: logs/microstrategy: receivers: - tcplog exporters: - chronicle/microstrategy
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
tcplog: 프로토콜 기반 수신기 유형입니다.- UDP syslog용
udplog - TCP syslog용
tcplog - RFC 3164/5424 시스템 로그의 경우
syslog
- UDP syslog용
0.0.0.0: 리슨할 IP 주소:0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 하나의 인터페이스에서 수신 대기할 특정 IP 주소
514: 수신할 포트 번호입니다 (예:514,1514,6514).
내보내기 도구 구성:
<customer_id>: 이전 단계의 고객 IDmalachiteingestion-pa.googleapis.com: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
- 플랫폼에 따라
creds_file_path를 조정합니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
MicroStrategy syslog 전달 구성
MicroStrategy Intelligence Server는 로그 파일을 로컬로 파일 시스템에 씁니다. 시스템 syslog 데몬을 사용하여 syslog 전달을 구성하여 이러한 로그를 Bindplane 에이전트로 전송합니다.
MicroStrategy 로그 디렉터리를 찾습니다.
- Windows:
C:\Program Files\Common Files\MicroStrategy\Log\ - Linux:
/var/log/Strategy/
- Windows:
MicroStrategy 로그 파일을 모니터링하고 Bindplane 에이전트로 전달하도록 시스템 syslog 데몬을 구성합니다.
Linux (rsyslog)의 경우:
새 rsyslog 구성 파일을 만듭니다.
sudo nano /etc/rsyslog.d/microstrategy-forward.confMicroStrategy 로그를 전달하려면 다음 콘텐츠를 추가하세요.
module(load="imfile") input(type="imfile" File="/var/log/Strategy/DSSErrors.log" Tag="microstrategy" Severity="info" Facility="local0") local0.* @BINDPLANE_AGENT_IP:514rsyslog 서비스를 다시 시작합니다.
sudo systemctl restart rsyslog
Windows:
로그 전달자 유틸리티 (예: NXLog 또는 Snare)를 사용하여 MicroStrategy 로그 디렉터리를 모니터링하고 syslog를 통해 Bindplane 에이전트 IP 및 포트로 이벤트를 전달합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
| Account_Creation_Timestamp, Account_Modification_Timestamp, Timestamp | additional.fields | 비어 있지 않은 경우 필드에서 생성된 라벨과 병합됨 |
| Authentication_message | metadata.description | 값이 직접 복사됨 |
| Event_start | metadata.event_timestamp | 'MMM dd HH:mm:ss' 형식의 날짜 필터를 사용하여 변환됨 |
| metadata.event_type | has_principal 및 has_target가 모두 있는 경우 'USER_UNCATEGORIZED', has_principal만 있는 경우 'STATUS_UPDATE', 그 밖의 경우 'GENERIC_EVENT'로 설정됩니다. | |
| 세션 | network.session_id | 값이 직접 복사됨 |
| Source_server | principal.application | 값이 직접 복사됨 |
| 호스트 이름 | principal.asset.hostname | 값이 직접 복사됨 |
| server_ip | principal.asset.ip | 값이 직접 복사됨 |
| 호스트 이름 | principal.hostname | 값이 직접 복사됨 |
| server_ip | principal.ip | 값이 직접 복사됨 |
| 레벨 | principal.platform_patch_level | 값이 직접 복사됨 |
| User_Group_Name | principal.user.group_identifiers | 값이 직접 복사됨 |
| Account_Name, User | principal.user.user_display_name | 비어 있지 않으면 Account_Name의 값, 그렇지 않으면 User |
| id, Account_Login, Account | principal.user.userid | 비어 있지 않으면 ID의 값, 비어 있지 않으면 Account_Login, 비어 있으면 Account |
| Log_level | security_result.detection_fields | 비어 있지 않은 경우 필드에서 생성된 라벨과 병합됨 |
| Source_host | src.asset.hostname | 값이 직접 복사됨 |
| Source_host | src.hostname | 값이 직접 복사됨 |
| module | target.application | 값이 직접 복사됨 |
| client_ip | target.asset.ip | 값이 직접 복사됨 |
| client_ip | target.ip | 값이 직접 복사됨 |
| PID | target.process.pid | 값이 직접 복사됨 |
| Thread_ID, SID, method, Account_Status_DESC | target.resource.attribute.labels | 비어 있지 않은 경우 필드에서 생성된 라벨과 병합됨 |
| OID | target.resource.id | 값이 직접 복사됨 |
| Object_Owner_Name | target.resource.name | 값이 직접 복사됨 |
| 사용자 | target.user.user_display_name | 값이 직접 복사됨 |
| UID | target.user.userid | 값이 직접 복사됨 |
| metadata.product_name | 'MICROSTRATEGY'로 설정 | |
| metadata.vendor_name | 'MICROSTRATEGY'로 설정 |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.