Skyhigh Secure Web Gateway (이전 McAfee Web Gateway) 로그 수집
이 문서에서는 Bindplane을 사용하여 Skyhigh Secure Web Gateway (이전 명칭: McAfee Web Gateway) 로그를 Google Security Operations에 수집하는 방법을 설명합니다.
Skyhigh Secure Web Gateway는 HTTP, HTTPS, FTP 트래픽을 검사하여 조직을 웹 기반 위협으로부터 보호하는 온프레미스 웹 프록시 어플라이언스입니다. URL 필터링, 멀웨어 방지 검사, SSL 검사, 데이터 손실 방지, 애플리케이션 제어 기능을 제공합니다. 어플라이언스는 웹 액세스 정책을 적용하고 규정 준수 및 보안 모니터링을 위해 모든 웹 활동에 대한 상세 로깅을 제공합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스입니다.
- Windows 2016 이상 또는
systemd가 설치된 Linux 호스트 - 프록시 뒤에서 실행하는 경우 방화벽 포트가 열려 있는지 확인합니다.
- Skyhigh Secure Web Gateway 관리 콘솔에 대한 권한 있는 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
- 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
추가 설치 리소스
추가 설치 옵션은 설치 가이드를 참고하세요.
Syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일에 액세스합니다.
config.yaml파일을 찾습니다. 일반적으로 Linux에서는/observiq-otel-collector/디렉터리에 있고 Windows에서는 설치 디렉터리에 있습니다.- 텍스트 편집기 (예:
nano,vi또는 메모장)를 사용하여 파일을 엽니다.
다음과 같이
config.yaml파일을 수정합니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/mcafee_webproxy: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: 'MCAFEE_WEBPROXY' raw_log_field: body ingestion_labels: service: pipelines: logs/mcafee_webproxy_to_chronicle: receivers: - tcplog exporters: - chronicle/mcafee_webproxy
- 인프라에 필요한 대로 포트와 IP 주소를 바꿉니다.
<customer_id>를 실제 고객 ID로 바꿉니다.- Google SecOps 수집 인증 파일 가져오기 섹션에서 인증 파일이 저장된 경로로
/path/to/ingestion-authentication-file.json를 업데이트합니다.
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 명령 프롬프트 또는 PowerShell(관리자 권한)
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Skyhigh Secure Web Gateway에서 syslog 전달 구성
- Skyhigh Secure Web Gateway 관리 콘솔에 로그인합니다.
- 정책 > 설정 > 로깅 > Syslog로 이동합니다.
- 추가를 클릭하여 새 syslog 대상을 만듭니다.
- 다음 구성 세부정보를 제공합니다.
- Syslog Server: Bindplane 에이전트 IP 주소 (예:
192.168.1.100)를 입력합니다. - 포트:
514를 입력합니다. - 프로토콜: TCP를 선택합니다.
- 로그 수준: 원하는 로그 수준 (예: 정보 이상)을 선택합니다.
- 형식: 권장사항 액세스 로그 또는 원하는 로그 형식을 선택합니다.
- Syslog Server: Bindplane 에이전트 IP 주소 (예:
- 전달할 로그 유형을 선택합니다.
- 액세스 로그 - 게이트웨이를 통과하는 모든 웹 트래픽을 기록합니다.
- 차단 로그 - 차단된 요청을 기록합니다.
- 스캔 로그 - 멀웨어 방지 스캔 결과를 기록합니다.
- 변경사항 저장을 클릭합니다.
문제 해결 > 변경사항 확인으로 이동하여 변경사항 저장을 클릭하여 구성을 적용합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
entry_format |
about |
매핑됨: json_format → about, kv_format1 → about |
deviceNtDomain |
about.administrative_domain |
이름이 변경됨/매핑됨 |
deviceExternalId |
about.asset.asset_id |
직접 매핑됨 |
device_product |
about.asset.asset_id |
직접 매핑됨 |
device_vendor |
about.asset.asset_id |
직접 매핑됨 |
fileHash |
about.file.full_path |
직접 매핑됨 |
filePath |
about.file.full_path |
이름이 변경됨/매핑됨 |
_hash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fileHash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fsize |
about.file.size |
이름이 변경됨/매핑됨 |
dvchost |
about.hostname |
이름이 변경됨/매핑됨 |
entry_format |
about.ip |
매핑됨: json_format → ips, kv_format1 → ips |
ips |
about.ip |
병합됨 |
dvc_mac |
about.mac |
매핑됨: slot → mac_address |
dvcmac |
about.mac |
병합됨 |
entry_format |
about.mac |
매핑됨: json_format → mac_address, json_format → dvcmac, kv_format1 → `mac_address... |
mac_address |
about.mac |
병합됨 |
deviceTranslatedAddress |
about.nat_ip |
병합됨 |
entry_format |
about.nat_ip |
매핑됨: json_format → deviceTranslatedAddress, kv_format1 → deviceTranslatedAddress |
Emne |
about.process.command_line |
직접 매핑됨 |
Path |
about.process.command_line |
직접 매핑됨 |
Subject |
about.process.command_line |
직접 매핑됨 |
deviceProcessName |
about.process.command_line |
이름이 변경됨/매핑됨 |
dvcpid |
about.process.pid |
이름이 변경됨/매핑됨 |
entry_format |
about.resource.attribute.permissions |
매핑됨: json_format → permissions, kv_format1 → permissions |
permissions |
about.resource.attribute.permissions |
병합됨 |
additional_cfp1 |
additional.fields |
병합됨 |
additional_cfp2 |
additional.fields |
병합됨 |
additional_cfp3 |
additional.fields |
병합됨 |
additional_cfp4 |
additional.fields |
병합됨 |
additional_cn1 |
additional.fields |
병합됨 |
additional_cn2 |
additional.fields |
병합됨 |
additional_cn3 |
additional.fields |
병합됨 |
additional_cs1 |
additional.fields |
병합됨 |
additional_cs2 |
additional.fields |
병합됨 |
additional_cs3 |
additional.fields |
병합됨 |
additional_cs4 |
additional.fields |
병합됨 |
additional_cs5 |
additional.fields |
병합됨 |
additional_cs6 |
additional.fields |
병합됨 |
additional_cs7 |
additional.fields |
병합됨 |
additional_devicePayloadId |
additional.fields |
병합됨 |
additional_eventId |
additional.fields |
병합됨 |
additional_flexString1 |
additional.fields |
병합됨 |
additional_fname |
additional.fields |
병합됨 |
application_name_label |
additional.fields |
병합됨 |
block_id_label |
additional.fields |
병합됨 |
cs2 |
additional.fields |
매핑됨: arc_test → additional_cs2 |
cs5_label |
additional.fields |
병합됨 |
entry_format |
additional.fields |
매핑된 값 (총 43개, 예: json_format → additional_eventId, json_format → `additio... |
facility_label |
additional.fields |
병합됨 |
priority_label |
additional.fields |
병합됨 |
reputation_label |
additional.fields |
병합됨 |
entry_format |
intermediary |
매핑됨: json_format → intermediary, kv_format1 → intermediary |
intermediary_hostname |
intermediary.hostname |
직접 매핑됨 |
intermediary_ip |
intermediary.ip |
병합됨 |
json_entry.client_ip |
intermediary.ip |
병합됨 |
_metadata |
metadata |
이름이 변경됨/매핑됨 |
msg |
metadata.description |
이름이 변경됨/매핑됨 |
Generated |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss로 파싱됨 |
Received |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss로 파싱됨 |
_timestamp |
metadata.event_timestamp |
RFC 3339로 파싱됨 |
rt |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ssZ로 파싱됨 |
ts |
metadata.event_timestamp |
dd/MM/yyyy:HH:mm:ss Z로 파싱됨 |
entry_format |
metadata.event_type |
매핑됨: json_format → PROCESS_UNCATEGORIZED, json_format → SCAN_UNCATEGORIZED, `kv_f... |
event_name |
metadata.event_type |
매핑됨: "LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
event_type |
metadata.event_type |
직접 매핑됨 |
device_event_class_id |
metadata.product_event_type |
직접 매핑됨 |
event_name |
metadata.product_event_type |
직접 매핑됨 |
externalId |
metadata.product_log_id |
직접 매핑됨 |
device_product |
metadata.product_name |
직접 매핑됨 |
device_version |
metadata.product_version |
직접 매핑됨 |
device_vendor |
metadata.vendor_name |
이름이 변경됨/매핑됨 |
_network |
network |
이름이 변경됨/매핑됨 |
app_protocol_output |
network.application_protocol |
직접 매핑됨 |
proto |
network.application_protocol |
직접 매핑됨 |
proto_version |
network.application_protocol_version |
직접 매핑됨 |
deviceDirection |
network.direction |
매핑됨: 0 → INBOUND, 1 → OUTBOUND |
entry_format |
network.direction |
매핑됨: json_format → INBOUND, json_format → OUTBOUND, kv_format1 → INBOUND, `kv... |
http_method |
network.http.method |
직접 매핑됨 |
requestMethod |
network.http.method |
이름이 변경됨/매핑됨 |
userAgent |
network.http.parsed_user_agent |
이름이 변경됨/매핑됨 |
requestContext |
network.http.referral_url |
직접 매핑됨 |
http_response |
network.http.response_code |
직접 매핑됨 |
requestClientApplication |
network.http.user_agent |
이름이 변경됨/매핑됨 |
userAgent |
network.http.user_agent |
직접 매핑됨 |
ip_protocol_out |
network.ip_protocol |
직접 매핑됨 |
proto |
network.ip_protocol |
직접 매핑됨 |
bytesToClient |
network.received_bytes |
직접 매핑됨 |
entry_format |
network.received_bytes |
매핑됨: json_format → uinteger, kv_format1 → uinteger |
in |
network.received_bytes |
이름이 변경됨/매핑됨 |
bytesFromClient |
network.sent_bytes |
직접 매핑됨 |
entry_format |
network.sent_bytes |
매핑됨: json_format → uinteger, kv_format1 → uinteger |
out |
network.sent_bytes |
이름이 변경됨/매핑됨 |
_principal |
principal |
이름이 변경됨/매핑됨 |
sntdom |
principal.administrative_domain |
이름이 변경됨/매핑됨 |
sourceServiceName |
principal.application |
이름이 변경됨/매핑됨 |
clientIP |
principal.asset.ip |
병합됨 |
entry_format |
principal.asset.ip |
매핑됨: json_format → clientIP, json_format → principal_ip, kv_format1 → `clientIP... |
principal_ip |
principal.asset.ip |
병합됨 |
Group_name |
principal.group.group_display_name |
직접 매핑됨 |
Gruppenavn |
principal.group.group_display_name |
직접 매핑됨 |
Device_name |
principal.hostname |
직접 매핑됨 |
Enhetsnavn |
principal.hostname |
직접 매핑됨 |
principal_hostname |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
이름이 변경됨/매핑됨 |
clientIP |
principal.ip |
병합됨 |
entry_format |
principal.ip |
매핑된 값 (총 6개, 예: json_format → principal_ip, json_format → shost, `json_... |
principal_ip |
principal.ip |
병합됨 |
shost |
principal.ip |
병합됨 |
entry_format |
principal.mac |
매핑됨: json_format → mac, kv_format1 → mac |
mac |
principal.mac |
병합됨 |
entry_format |
principal.nat_ip |
매핑됨: json_format → sourceTranslatedAddress, kv_format1 → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
병합됨 |
sourceTranslatedPort |
principal.nat_port |
이름이 변경됨/매핑됨 |
spt |
principal.port |
이름이 변경됨/매핑됨 |
sproc |
principal.process.command_line |
이름이 변경됨/매핑됨 |
fileType |
principal.process.file.mime_type |
직접 매핑됨 |
spid |
principal.process.pid |
이름이 변경됨/매핑됨 |
entry_format |
principal.user.attribute.roles |
매핑됨: json_format → principal_role, kv_format1 → principal_role |
principal_role |
principal.user.attribute.roles |
병합됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
suid |
principal.user.userid |
이름이 변경됨/매핑됨 |
userName |
principal.user.userid |
직접 매핑됨 |
entry_format |
security_result |
매핑됨: json_format → security_result, kv_format1 → security_result |
_action |
security_result.action |
병합됨 |
act |
security_result.action |
매핑됨: accept → _action, deny → _action |
action |
security_result.action |
병합됨 |
cn1_Label |
security_result.action |
매핑됨: Block Reason → action |
entry_format |
security_result.action |
매핑된 값 (총 6개, 예: json_format → _action, json_format → action, `json_form... |
security_action |
security_result.action |
병합됨 |
Action_Taken |
security_result.action_details |
직접 매핑됨 |
act |
security_result.action_details |
직접 매핑됨 |
_security_category |
security_result.category |
병합됨 |
entry_format |
security_result.category |
매핑됨: json_format → _security_category, kv_format1 → _security_category |
_category_details |
security_result.category_details |
병합됨 |
cat |
security_result.category_details |
병합됨 |
entry_format |
security_result.category_details |
매핑됨: json_format → cat, json_format → _category_details, kv_format1 → cat, `k... |
sec_result_category_details |
security_result.category_details |
병합됨 |
Scan_Type |
security_result.description |
직접 매핑됨 |
Type |
security_result.description |
직접 매핑됨 |
msg_data_2 |
security_result.description |
직접 매핑됨 |
entry_format |
security_result.detection_fields |
매핑된 값 (총 14개, 예: json_format → operation_label, json_format → `operasjon_... |
infection_channel_label |
security_result.detection_fields |
병합됨 |
operasjon_label |
security_result.detection_fields |
병합됨 |
operation_label |
security_result.detection_fields |
병합됨 |
permission_label |
security_result.detection_fields |
병합됨 |
spyware_Grayware_Type_label |
security_result.detection_fields |
병합됨 |
threat_probability_label |
security_result.detection_fields |
병합됨 |
tillatelse_label |
security_result.detection_fields |
병합됨 |
mwProfile |
security_result.rule_name |
직접 매핑됨 |
policy |
security_result.rule_name |
직접 매핑됨 |
rule_name |
security_result.rule_name |
직접 매핑됨 |
entry_format |
security_result.severity |
매핑된 값 (총 8개, 예: json_format → LOW, json_format → MEDIUM, json_format ... |
risk |
security_result.severity |
매핑됨: High Risk → HIGH, Medium Risk → MEDIUM |
severity |
security_result.severity |
매핑됨: "0", "1", "2", "3", "LOW" → LOW, `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
risk |
security_result.severity_details |
직접 매핑됨 |
Result |
security_result.summary |
직접 매핑됨 |
appcategory |
security_result.summary |
직접 매핑됨 |
av_status |
security_result.summary |
직접 매핑됨 |
block_reason |
security_result.summary |
직접 매핑됨 |
content |
security_result.summary |
직접 매핑됨 |
icap_status |
security_result.summary |
직접 매핑됨 |
reason |
security_result.summary |
이름이 변경됨/매핑됨 |
summary |
security_result.summary |
직접 매핑됨 |
Spyware |
security_result.threat_name |
직접 매핑됨 |
Unknown_Threat |
security_result.threat_name |
직접 매핑됨 |
Virus_Malware_Name |
security_result.threat_name |
직접 매핑됨 |
oldFilePath |
src.file.full_path |
이름이 변경됨/매핑됨 |
oldFileSize |
src.file.size |
이름이 변경됨/매핑됨 |
entry_format |
src.resource.attribute.permissions |
매핑됨: json_format → old_permissions, kv_format1 → old_permissions |
old_permissions |
src.resource.attribute.permissions |
병합됨 |
_target |
target |
이름이 변경됨/매핑됨 |
dntdom |
target.administrative_domain |
이름이 변경됨/매핑됨 |
appname |
target.application |
직접 매핑됨 |
destinationServiceName |
target.application |
이름이 변경됨/매핑됨 |
tar_host |
target.asset.hostname |
직접 매핑됨 |
tar_host |
target.hostname |
직접 매핑됨 |
target_hostname |
target.hostname |
직접 매핑됨 |
temp_dhost |
target.hostname |
직접 매핑됨 |
IPv6_Address |
target.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
entry_format |
target.ip |
매핑됨: json_format → dst_ip, json_format → IPv6_Address, kv_format1 → dst_ip, `... |
ipv6 |
target.ip |
매핑됨: - → IPv6_Address |
entry_format |
target.mac |
매핑됨: json_format → mac_address, kv_format1 → mac_address |
mac_address |
target.mac |
병합됨 |
destination_translated_address |
target.nat_ip |
병합됨 |
entry_format |
target.nat_ip |
매핑됨: json_format → destination_translated_address, kv_format1 → `destination_transl... |
destinationTranslatedPort |
target.nat_port |
이름이 변경됨/매핑됨 |
dpt |
target.port |
이름이 변경됨/매핑됨 |
tar_port |
target.port |
직접 매핑됨 |
dproc |
target.process.command_line |
이름이 변경됨/매핑됨 |
File_name |
target.process.file.full_path |
직접 매핑됨 |
Infected_Resource |
target.process.file.full_path |
직접 매핑됨 |
Object |
target.process.file.full_path |
직접 매핑됨 |
Objekt |
target.process.file.full_path |
직접 매핑됨 |
dpid |
target.process.pid |
이름이 변경됨/매핑됨 |
entry_format |
target.resource.attribute.labels |
매핑됨: json_format → resource_Type_label, kv_format1 → resource_Type_label |
resource_Type_label |
target.resource.attribute.labels |
병합됨 |
request |
target.url |
직접 매핑됨 |
tar_host |
target.url |
직접 매핑됨 |
tar_port |
target.url |
직접 매핑됨 |
entry_format |
target.user.attribute.roles |
매핑됨: json_format → target_role, kv_format1 → target_role |
target_role |
target.user.attribute.roles |
병합됨 |
CustomerName |
target.user.user_display_name |
직접 매핑됨 |
temp_duser |
target.user.user_display_name |
직접 매핑됨 |
Bruker |
target.user.userid |
직접 매핑됨 |
User_value |
target.user.userid |
직접 매핑됨 |
temp_duid |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: PROCESS_UNCATEGORIZED |
| 해당 사항 없음 | network.direction |
상수: INBOUND |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
url |
event.idm.read_only_udm.target.url |
변경 로그에서 매핑됨 |
categories |
event.idm.read_only_udm.security_result.category_details |
변경 로그에서 매핑됨 |
rt |
event.idm.read_only_udm.metadata.event_timestamp |
변경 로그에서 매핑됨 |
reputationString |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
blockID |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
applicationName |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
facility |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
priority |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
userName |
event.idm.read_only_udm.principal.user.userid |
변경 로그에서 매핑됨 |
appname |
event.idm.read_only_udm.target.application |
변경 로그에서 매핑됨 |
http_method |
event.idm.read_only_udm.network.http.method |
변경 로그에서 매핑됨 |
proto_version |
event.idm.read_only_udm.network.application_protocol_version |
변경 로그에서 매핑됨 |
userAgent |
event.idm.read_only_udm.network.http.user_agent |
변경 로그에서 매핑됨 |
userAgent |
event.idm.read_only_udm.network.http.parsed_user_agent |
변경 로그에서 매핑됨 |
bytesFromClient |
event.idm.read_only_udm.network.sent_bytes |
변경 로그에서 매핑됨 |
bytesToClient |
event.idm.read_only_udm.network.received_bytes |
변경 로그에서 매핑됨 |
clientIP |
event.idm.read_only_udm.principal.ip |
변경 로그에서 매핑됨 |
clientIP |
event.idm.read_only_udm.principal.asset.ip |
변경 로그에서 매핑됨 |
fileType |
event.idm.read_only_udm.principal.process.file.mime_type |
변경 로그에서 매핑됨 |
Type |
event.idm.read_only_udm.target.file.mime_type |
변경 로그에서 매핑됨 |
sr_bytes |
network.send_bytes |
변경 로그에서 매핑됨 |
requested_host" and "requested_path |
target.url |
변경 로그에서 매핑됨 |
username |
principal.user.userid |
변경 로그에서 매핑됨 |
destination_ip |
target.ip |
변경 로그에서 매핑됨 |
destination_port |
target.port |
변경 로그에서 매핑됨 |
target_ip |
target.ip |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.