ManageEngine AD360 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 ManageEngine AD360 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
ManageEngine AD360은 Active Directory 변경사항, 인증 이벤트, 네트워크 연결, 보안 정책 위반에 대한 syslog 메시지를 생성하는 통합 ID 및 액세스 관리 솔루션입니다. 파서는 grok 패턴을 사용하여 syslog 형식 로그에서 필드를 추출하고 이를 통합 데이터 모델 (UDM)에 매핑합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 ManageEngine AD360 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- ManageEngine AD360 웹 UI에 대한 관리 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/manage_engine_ad360: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: MANAGE_ENGINE_AD360 raw_log_field: body service: pipelines: logs/manage_engine_ad360_to_chronicle: receivers: - udplog exporters: - chronicle/manage_engine_ad360
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 비루트의 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 지역 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.
명령 프롬프트 또는 PowerShell(관리자 권한)
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
ManageEngine AD360 syslog 내보내기 구성
- AD360 웹 UI에 로그인합니다.
- 관리 > 관리 > SIEM 통합으로 이동합니다.
- ADSelfService 구성요소 옆에 있는 지금 구성 링크를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서버 유형: Syslog를 선택합니다.
- 서버 이름/IP: Bindplane 에이전트 IP 주소를 입력합니다.
- 포트: Bindplane 에이전트 포트 번호를 입력합니다.
- 프로토콜: UDP를 선택합니다.
- Syslog 표준: RFC 5424를 선택합니다.
- 고급 목록을 클릭합니다.
- 심각도: 정보를 선택합니다.
- 구성을 클릭하여 저장합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
| AccessControlRuleName | security_result.rule_name | AccessControlRuleName 필드에서 가져온 값(있는 경우), 그렇지 않으면 rule_name 필드에서 가져온 값 |
| ACPolicy | security_result.rule_labels.value | ACPolicy 필드에서 가져온 값 |
| action | security_result.action_details | UDM에 직접 매핑됨 |
| action_id | security_result.detection_fields.value | action_id 필드에서 가져온 값 |
| application_protocol | network.application_protocol | UDM에 직접 매핑됨 |
| 바이트 | network.sent_bytes | UDM에 직접 매핑됨 |
| client_ip | principal.ip | UDM에 직접 매핑됨 |
| ConnectionID | network.session_id | connection_id 필드에서 가져온 값(있는 경우), 그렇지 않으면 ConnectionID 필드에서 가져온 값, 그렇지 않으면 ses 필드에서 가져온 값 |
| destination_ip | target.ip | UDM에 직접 매핑됨 |
| destination_port | target.port | UDM에 직접 매핑됨 |
| DeviceUUID | target.asset_id | DeviceUUID 필드에서 가져온 값(있는 경우), 그렇지 않으면 distinguished_name_device_id 필드에서 가져온 값 |
| distinguished_name_device_id | target.asset_id | DeviceUUID 필드에서 가져온 값(있는 경우), 그렇지 않으면 distinguished_name_device_id 필드에서 가져온 값 |
| distinguished_name_user | target.user.userid | UDM에 직접 매핑됨 |
| DST : 디지털 서비스세 | target.ip | DST 필드에서 가져온 값(있는 경우), 그렇지 않으면 DstIP 필드에서 가져온 값 |
| DPT | target.port | DPT 필드에서 가져온 값(있는 경우), 그렇지 않으면 DstPort 필드에서 가져온 값, 그렇지 않으면 destination_port 필드에서 가져온 값 |
| DstIP | target.ip | DST 필드에서 가져온 값(있는 경우), 그렇지 않으면 DstIP 필드에서 가져온 값 |
| DstPort | target.port | DPT 필드에서 가져온 값(있는 경우), 그렇지 않으면 DstPort 필드에서 가져온 값, 그렇지 않으면 destination_port 필드에서 가져온 값 |
| EgressInterface | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| EgressZone | target.location.name | UDM에 직접 매핑됨 |
| EventPriority | security_result.severity | EventPriority 필드의 값에 따라 다른 심각도 수준에 매핑됩니다. |
| exe | principal.process.command_line | UDM에 직접 매핑됨 |
| geoip.city_name | principal.location.city | UDM에 직접 매핑됨 |
| geoip.country_name | principal.location.country_or_region | UDM에 직접 매핑됨 |
| geoip.latitude | principal.location.region_latitude | UDM에 직접 매핑됨 |
| geoip.longitude | principal.location.region_longitude | UDM에 직접 매핑됨 |
| http_status | network.http.response_code | UDM에 직접 매핑됨 |
| id | metadata.product_log_id | UDM에 직접 매핑됨 |
| IngressInterface | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| IngressZone | principal.location.name | UDM에 직접 매핑됨 |
| LEN | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| message_number | 매핑되지 않음 | |
| NAPPolicy | security_result.rule_labels.value | NAPPolicy 필드에서 가져온 값 |
| network_direction | network.direction | UDM에 직접 매핑됨 |
| OUT | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| pid | target.process.pid | UDM에 직접 매핑됨 |
| ppid | target.process.parent_process.pid | UDM에 직접 매핑됨 |
| PREC | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| principal_hostname | principal.hostname | UDM에 직접 매핑됨 |
| product_event_type | metadata.product_event_type | UDM에 직접 매핑됨 |
| 프로토콜 | network.ip_protocol | PROTO 필드를 채우는 데 사용된 후 참고표를 사용하여 UDM에 매핑됩니다. |
| PROTO | network.ip_protocol | 프로토콜 번호를 기반으로 참고표를 사용하여 UDM에 매핑되었습니다. |
| request_method | network.http.method | UDM에 직접 매핑됨 |
| rule_name | security_result.rule_name | AccessControlRuleName 필드에서 가져온 값(있는 경우), 그렇지 않으면 rule_name 필드에서 가져온 값 |
| ses | network.session_id | connection_id 필드에서 가져온 값(있는 경우), 그렇지 않으면 ConnectionID 필드에서 가져온 값, 그렇지 않으면 ses 필드에서 가져온 값 |
| source_ip | principal.ip | UDM에 직접 매핑됨 |
| source_port | principal.port | UDM에 직접 매핑됨 |
| SPT | principal.port | SPT 필드에서 가져온 값(있는 경우), 그렇지 않으면 SrcPort 필드에서 가져온 값, 그렇지 않으면 source_port 필드에서 가져온 값 |
| SRC | principal.ip | SRC 필드에서 가져온 값(있는 경우), 그렇지 않으면 SrcIP 필드에서 가져온 값, 그렇지 않으면 client_ip 필드에서 가져온 값 |
| SrcIP | principal.ip | SRC 필드에서 가져온 값(있는 경우), 그렇지 않으면 SrcIP 필드에서 가져온 값, 그렇지 않으면 client_ip 필드에서 가져온 값 |
| SrcPort | principal.port | SPT 필드에서 가져온 값(있는 경우), 그렇지 않으면 SrcPort 필드에서 가져온 값, 그렇지 않으면 source_port 필드에서 가져온 값 |
| 타임스탬프 | metadata.event_timestamp | UDM에 직접 매핑됨 |
| TOS | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| TTL | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| URL | target.url | UDM에 직접 매핑됨 |
| user_agent | network.http.user_agent | UDM에 직접 매핑됨 |
| WINDOW | additional.fields.value.string_value | UDM에 직접 매핑됨 |
| metadata.vendor_name | 값이 MANAGE_ENGINE_AD360로 하드코딩됨 |
|
| metadata.product_name | 값이 MANAGE_ENGINE_AD360로 하드코딩됨 |
|
| metadata.log_type | 값이 MANAGE_ENGINE_AD360로 하드코딩됨 |
|
| metadata.event_type | SRC 및 DST 필드가 모두 있으면 NETWORK_CONNECTION로 설정되고, SRC 또는 principal_hostname이 있으면 STATUS_UPDATE로 설정됩니다. 이러한 조건이 충족되지 않으면 기본값은 GENERIC_EVENT입니다. |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.