LogonBox 로그 수집
이 문서에서는 Bindplane을 사용하여 LogonBox 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
LogonBox는 셀프 서비스 비밀번호 관리 및 ID 확인 플랫폼입니다. 비밀번호 재설정, 본인 인증 이벤트, 관리자 작업에 대한 감사 로그를 생성합니다. 파서는 LogonBox 감사 데이터를 통합 데이터 모델 (UDM)에 매핑하여 사용자 ID, 인증 이벤트, 리소스 수정, 그룹 관리 작업을 캡처합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 LogonBox 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- LogonBox 관리 콘솔에 대한 액세스 권한
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
데이터 수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector
서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector
서비스가 활성 (실행 중)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo systemctl status observiq-otel-collectorWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/logonbox: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: LOGONBOX raw_log_field: body service: pipelines: logs/logonbox: receivers: - udplog exporters: - chronicle/logonbox
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
udplog: 프로토콜 기반 수신기 유형:- UDP syslog의
udplog - TCP syslog의 경우
tcplog - RFC 3164/5424 syslog의
syslog
- UDP syslog의
0.0.0.0: 리슨할 IP 주소입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 하나의 인터페이스에서 수신 대기할 특정 IP 주소
514: 수신할 포트 번호입니다 (예:514,1514,6514).
내보내기 도구 구성:
<customer_id>: 이전 단계의 고객 IDmalachiteingestion-pa.googleapis.com: 지역 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
- 플랫폼에 따라
creds_file_path를 조정합니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순으로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음을 실행하세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
LogonBox syslog 전달 구성
- 관리자로 LogonBox 관리 콘솔에 로그인합니다.
- 보고서> 감사 로그로 이동합니다.
- syslog 내보내기 설정을 구성합니다.
- Syslog 서버: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예:
192.168.1.100). - 포트:
514를 입력합니다 (Bindplane 수신기 포트와 일치해야 함). - 프로토콜: UDP를 선택합니다 (Bindplane 수신기 유형과 일치해야 함).
- Syslog 서버: Bindplane 에이전트 호스트의 IP 주소를 입력합니다 (예:
- 전달할 이벤트 카테고리 (예: 비밀번호 재설정, ID 확인, 사용자 및 그룹 관리)를 선택합니다.
- 저장을 클릭합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
| additional.fields | 조건에 따라 attr_associatedPrincipals_label, sAMAccountName_label, attr_local_label, msDS-PrincipalName_label, attr_realmType_label, attr_selfCreated_label, attr_administrative_label에서 병합됨 | |
| attr_principalDesc, desc | metadata.description | product_event_type이 changePassword|SessionService와 일치하는 경우 attr_principalDesc의 값, 그렇지 않은 경우 비어 있지 않으면 attr_principalDesc의 값, 그렇지 않은 경우 desc의 값 |
| event_type | metadata.event_type | 조건부 로직이 product_event_type 및 presence 플래그에 따라 설정한 후 event_type에서 직접 복사한 값 |
| product_event_type | metadata.product_event_type | 값이 직접 복사됨 |
| metadata.product_name | 'LogonBox'로 설정 | |
| metadata.vendor_name | 'LOGONBOX'로 설정 | |
| network.application_protocol | product_event_type이 AnswerService와 일치하고 조건이 충족되면 'DNS'로 설정됩니다. | |
| dns_answer | network.dns.answers | dns_answer에서 병합됨 |
| dns_question | network.dns.questions | dns_question에서 병합됨 |
| attr_userAgent, attr_userAgentVersion | network.http.parsed_user_agent | attr_userAgent와 attr_userAgentVersion이 모두 있는 경우 연결되고, 그렇지 않으면 attr_userAgent에서 연결된 후 parseduseragent로 변환되고 이름이 변경됩니다. |
| attr_userAgent, attr_userAgentVersion | network.http.user_agent | attr_userAgent와 attr_userAgentVersion이 모두 있는 경우 연결되고, 그렇지 않으면 attr_userAgent에서 연결됩니다. |
| 호스트 이름 | principal.asset.hostname | 값이 직접 복사됨 |
| attr_ipAddress | principal.asset.ip | 값이 직접 복사됨 |
| 호스트 이름 | principal.hostname | 값이 직접 복사됨 |
| attr_ipAddress | principal.ip | 값이 직접 복사됨 |
| attr_os | principal.platform | (?i)LINUX|MAC|WINDOWS와 일치하는 경우 대문자로 변환되어 설정됩니다. |
| attr_osVersion | principal.platform_version | (?i)unknown과 일치하지 않는 경우 값이 직접 복사됨 |
| attr_principalRealm_label, attr_unassignedRoles_label, attr_assignedRoles_label, attr_oldResourceName_label, attr_roles_label, attr_resumedPrincipalName_label, attr_resumedPrincipalRealm_label, attr_resumedPrincipal_label, attr_module_label, reconcile_map_label, users_map_label, groups_map_label, createUser_map_label, user_map_label, mobile_map_label | principal.resource.attribute.labels | 조건에 따라 attr_principalRealm, attr_unassignedRoles, attr_assignedRoles, attr_oldResourceName, attr_roles, attr_resumedPrincipalName, attr_resumedPrincipalRealm, attr_resumedPrincipal, attr_module에서 생성된 다양한 라벨과 조정, 사용자, 그룹, createUser, 사용자, 모바일의 매핑에서 병합됨 |
| attr_resourceName | principal.resource.name | 값이 직접 복사됨 |
| attr_resourceId | principal.resource.product_object_id | 값이 직접 복사됨 |
| principal.user.email_addresses | 메일이 유효한 이메일인 경우 병합됨 | |
| ImmutableID, attr_uuid | principal.user.product_object_id | product_event_type이 changePassword|userUpdated|userCreated|setPassword|answer|accountUnlockNoSuspension과 일치하는 경우 ImmutableID의 값, 그렇지 않은 경우 attr_uuid의 값 |
| attr_scheme | principal.user.role_name | 값이 직접 복사됨 |
| attr_principalDesc | principal.user.user_display_name | product_event_type이 changePassword|SessionService와 일치하는 경우 직접 복사된 값 |
| attr_principalName | principal.user.userid | 값이 직접 복사됨 |
| authy_code_length_label, authy_window_length_label, authy_step_size_label, msauthenticator_code_length_label, msauthenticator_window_length_label, msauthenticator_step_size_label, googleUser_code_length_label, googleUser_window_length_label, googleUser_step_size_label | security_result.detection_fields | authy.code.length, authy.window.length, authy.step.size, msauthenticator.code.length, msauthenticator.window.length, msauthenticator.step.size, googleUser.code.length, googleUser.window.length, googleUser.step.size에서 생성된 라벨이 있는 경우 병합됨 |
| cn | target.resource.attribute.labels | cn에서 생성된 full_name_label과 attr_disabledRealm의 attr_disabledRealm_label이 병합됨 |
| attr_lastModified | target.resource.attribute.last_update_time | ISO8601 또는 d MMM yyyy HH:mm:ss를 사용하여 attr_lastModified에서 파싱된 날짜 |
| attr_created | target.resource.attribute.creation_time | ISO8601 또는 d MMM yyyy HH:mm:ss를 사용하여 attr_created에서 파싱된 날짜 |
| givenName | target.user.first_name | 값이 직접 복사됨 |
| ou | target.user.group_identifiers | product_event_type이 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension과 일치하는 경우 ou에서 병합됨 |
| sn | target.user.last_name | 값이 직접 복사됨 |
| attr_uuid, attr_disabledPrincipal | target.user.product_object_id | product_event_type이 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 또는 groupCreated|groupUpdated 또는 attr_group 또는 group과 일치하는 경우 attr_uuid의 값, 그렇지 않고 accountDisabled인 경우 attr_disabledPrincipal의 값 |
| displayName, description | target.user.user_display_name | displayName이 비어 있지 않으면 displayName의 값, 그렇지 않고 product_event_type이 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension과 일치하면 description의 값 |
| userPrincipalName, attr_user, attr_associatedPrincipals, attr_disabledPrincipalName | target.user.userid | product_event_type이 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension과 일치하는 경우 userPrincipalName의 값, 그렇지 않고 설정되지 않은 경우 attr_user, 그렇지 않고 groupCreated|groupUpdated인 경우 attr_associatedPrincipals 또는 attr_group, 그렇지 않고 그룹인 경우 attr_user, 그렇지 않고 accountDisabled인 경우 attr_disabledPrincipalName |
| attr_group | target.group.group_display_name | product_event_type이 groupCreated|groupUpdated와 일치하거나 attr_group이 있으면 직접 복사된 값 |
| attr_uuid | target.group.product_object_id | product_event_type이 groupCreated|groupUpdated와 일치하거나 attr_group이 있으면 직접 복사된 값 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.