IBM Guardium 로그 수집

다음에서 지원:

이 문서에서는 Bindplane을 사용하여 IBM Guardium 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

IBM Guardium은 데이터베이스 및 파일 시스템에 대한 실시간 모니터링, 감사, 보호 기능을 제공하는 데이터베이스 활동 모니터링 및 데이터 보호 플랫폼입니다. Guardium은 취약점 평가, 데이터 검색 및 분류, 데이터베이스 활동 모니터링, 규정 준수 보고 기능을 제공합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 IBM Guardium Collector 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • IBM Guardium CLI에 대한 권한 액세스
  • 암호화된 syslog 지원을 위한 IBM Guardium 버전 9.1 이상 (선택사항)

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 신규 배포: Chronicle API (옵션 1)를 사용합니다.
  • 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명 (예: Bindplane agent log ingestion)을 입력합니다.
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 생성한 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path을 저장된 경로와 일치하도록 업데이트합니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

서비스가 RUNNING으로 표시됩니다.

Linux 설치

  1. 루트 또는 sudo 권한이 있는 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

서비스가 활성 (실행 중)으로 표시되어야 합니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/guardium:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: 'YOUR_CUSTOMER_ID'
        endpoint: chronicle.googleapis.com
        log_type: GUARDIUM
        raw_log_field: body
        ingestion_labels:
          log_source: guardium
    
    service:
      pipelines:
        logs/guardium_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/guardium
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신자 구성:

    • UDP syslog에 udplog을 사용합니다 (Guardium에서 가장 일반적임).
    • 필요한 경우 TCP syslog에 tcplog를 사용합니다.
    • 수신 대기 주소 0.0.0.0:514는 포트 514의 모든 인터페이스에서 수신 대기합니다.
  • 내보내기 도구 구성:

    • creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: 이전 단계의 고객 ID입니다.
    • location: <LOCATION>을 Google SecOps 인스턴스의 리전 (예: us, europe, asia-southeast1)으로 바꿉니다. 내보내기 프로그램은 chronicle.googleapis.com에 이 값을 접두사로 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.
    • project: <PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • endpoint: chronicle.googleapis.com로 설정된 상태를 유지합니다.
    • log_type: GUARDIUM이어야 합니다.
    • ingestion_labels: YAML 형식의 선택적 라벨입니다.

기존 수집 API 내보내기 도구

  • 옵션 2의 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com를 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/guardium:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: 'YOUR_CUSTOMER_ID'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: GUARDIUM
        raw_log_field: body
        ingestion_labels:
          log_source: guardium
    

구성 파일 저장

수정 후 파일을 저장합니다.

  • Linux: Ctrl+O, Enter, Ctrl+X 순으로 누릅니다.
  • Windows: 파일 > 저장을 클릭합니다.

Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

        sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

        sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R를 누르고 services.msc를 입력한 후 Enter를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.

      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

IBM Guardium syslog 전달 구성

CLI를 통해 syslog 대상 구성

IBM Guardium에서 이벤트의 syslog 대상을 만들려면 명령줄 인터페이스에 로그인하고 Bindplane 에이전트 호스트의 IP 주소를 정의해야 합니다.

  1. SSH를 사용하여 CLI 사용자로 IBM Guardium Collector에 로그인합니다.
  2. 다음 명령어를 입력하여 syslog 대상을 구성합니다.

    • UDP syslog (권장):

      store remotelog add non_encrypted daemon.all BINDPLANE_AGENT_IP udp
      
    • TCP syslog의 경우:

      store remotelog add non_encrypted daemon.all BINDPLANE_AGENT_IP:514 tcp
      
    • 특정 심각도 수준:

      store remotelog add non_encrypted daemon.alert BINDPLANE_AGENT_IP udp
      store remotelog add non_encrypted daemon.err BINDPLANE_AGENT_IP udp
      store remotelog add non_encrypted daemon.warning BINDPLANE_AGENT_IP udp
      
      • BINDPLANE_AGENT_IP를 Bindplane 에이전트가 설치된 호스트의 IP 주소로 바꿉니다.
  3. 다음을 실행하여 구성을 확인합니다.

    show remotelog
    

    출력에 구성된 원격 syslog 대상이 표시되어야 합니다.

암호화된 syslog 구성 (선택사항)

암호화된 syslog 전달이 필요한 경우 IBM Guardium 버전 9.1 이상에서는 TCP를 통한 TLS 암호화를 지원합니다.

  1. 원격 syslog 수신기에서 사용하는 인증 기관에서 PEM 형식의 공개 인증서를 가져옵니다.
  2. Guardium Collector에서 CLI에 로그인합니다.
  3. 다음 명령어를 입력합니다.

    store remotelog add encrypted daemon.all BINDPLANE_AGENT_IP:6514 tcp
    
  4. 메시지가 표시되면 BEGIN 및 END 줄을 포함하여 PEM 형식의 CA 인증서를 붙여넣은 다음 Ctrl+D를 누릅니다.

  5. Guardium은 인증서를 /etc/pki/rsyslog/ca.pem로 저장합니다.

메시지 템플릿 구성 (선택사항)

Guardium은 CEF (Common Event Format) 및 LEEF (Log Event Extended Format)를 비롯한 여러 메시지 형식을 지원합니다. 기본 형식은 대부분의 배포에 적합합니다.

메시지 템플릿을 맞춤설정하려면 다음 단계를 따르세요.

  1. 관리자 권한이 있는 사용자로 Guardium 어플라이언스 GUI에 로그인합니다.
  2. Administration Console(관리 콘솔) > Configuration(구성) > Global Profile(전역 프로필)로 이동합니다.
  3. 메시지 템플릿 섹션에서 원하는 형식으로 템플릿을 수정합니다.
  4. 저장을 클릭합니다.

syslog에 알림을 보내도록 정책 구성

IBM Guardium의 정책은 이벤트에 반응하고 이벤트 정보를 원격 syslog 수신기로 전달하는 역할을 합니다.

정책 알림 작업 구성

  1. Guardium 어플라이언스 GUI에 로그인합니다.
  2. 도구 탭을 클릭합니다.
  3. 왼쪽 탐색 메뉴에서 정책 작성 도구를 선택합니다.
  4. 정책 찾기 도구 창에서 기존 정책을 선택하고 규칙 수정을 클릭합니다.
  5. 이 규칙을 개별적으로 수정을 클릭합니다.
  6. 액세스 규칙 정의가 표시됩니다.
  7. 작업 추가를 클릭합니다.
  8. 작업 목록에서 다음 알림 유형 중 하나를 선택합니다.
    • 일치 항목당 알림: 정책 위반이 발생할 때마다 알림이 제공됩니다.
    • 일일 알림: 해당 날짜에 정책 위반이 처음 발생하면 알림이 제공됩니다.
    • 세션당 한 번 알림: 고유 세션의 정책 위반당 알림이 제공됩니다.
    • 시간 단위별 알림: 선택한 기간별로 알림이 제공됩니다.
  9. 메시지 템플릿 목록에서 필요한 템플릿을 선택하거나 기본값을 유지합니다.
  10. 알림 유형에서 SYSLOG를 선택합니다.
  11. 추가를 클릭한 다음 적용을 클릭합니다.
  12. 저장을 클릭합니다.
  13. Google SecOps로 전달하려는 정책 내의 모든 규칙에 대해 이 프로세스를 반복합니다.

정책 설치

업데이트된 알림 작업 또는 규칙 변경사항이 발생하려면 먼저 IBM Guardium에서 새 정책 또는 수정된 정책을 설치해야 합니다.

  1. 관리 콘솔 탭을 클릭합니다.
  2. 왼쪽 탐색 메뉴에서 구성 > 정책 설치를 선택합니다.
  3. 정책 설치 프로그램 창에서 이전 단계에서 수정한 정책을 선택합니다.
  4. 드롭다운 목록에서 설치 및 재정의를 선택합니다.
  5. 모든 검사 엔진에 정책을 설치하라는 확인 메시지가 표시됩니다.
  6. 확인을 클릭합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
deviceNtDomain about.administrative_domain about 엔티티의 관리 도메인
deviceExternalId about.asset.asset_id 애셋 식별자
filePath, fileHash about.file.full_path 파일의 전체 경로
_hash, fileHash about.file.sha256 파일의 SHA256 해시
fsize about.file.size 파일의 크기
dvchost about.hostname about 항목의 호스트 이름
dvc about.ip 관련 항목의 IP 주소
smac, dmac, dvcmac about.mac 정보 항목의 MAC 주소
deviceProcessName, Subject, Emne, Path about.process.command_line 프로세스의 명령줄
dvcpid about.process.pid 프로세스 ID
filePermission about.resource.attribute.permissions 리소스와 연결된 권한
extensions.auth.type 인증 유형
sender_ip intermediary.ip 중개자의 IP 주소
intermediary 중개 법인 세부정보
수신됨, 생성됨, 타임스탬프 metadata.collected_timestamp 이벤트가 수집된 타임스탬프
msg, signature_name metadata.description 이벤트의 설명
metadata.event_type 이벤트 유형 (예: USER_LOGIN, NETWORK_CONNECTION)
device_event_class_id, event_name, eventType metadata.product_event_type 제품별 이벤트 유형
externalId metadata.product_log_id 제품 로그 식별자
metadata.product_version 제품 버전
network.application_protocol 네트워크 연결에 사용되는 애플리케이션 프로토콜
deviceDirection network.direction 네트워크 트래픽의 방향
requestMethod network.http.method 요청에 사용된 HTTP 메서드
requestClientApplication network.http.user_agent HTTP 요청의 사용자 에이전트 문자열
proto network.ip_protocol 사용된 IP 프로토콜
in network.received_bytes 수신된 바이트 수
어떨까요? network.sent_bytes 전송된 바이트 수
session_id network.session_id 네트워크 연결의 세션 식별자
sntdom, Domain, Domene principal.administrative_domain 주 구성원의 관리 도메인
sourceServiceName, source_program principal.application 주 구성원과 연결된 애플리케이션
prin_host, Device_name, Enhetsnavn, shost, principal_hostname, client_hostname principal.asset.hostname 기본 애셋의 호스트 이름
sender_ip, src_ip, src, principal_ip, client_ip principal.asset.ip 기본 애셋의 IP 주소
Group_name, Gruppenavn principal.group.group_display_name 주 구성원 그룹의 표시 이름
prin_host, Device_name, Enhetsnavn, shost, principal_hostname, client_hostname principal.hostname 주 구성원의 호스트 이름
sender_ip, src_ip, src, principal_ip, client_ip principal.ip 주 구성원의 IP 주소
smac principal.mac 주체의 MAC 주소
sourceTranslatedAddress principal.nat_ip 주 구성원의 NAT IP 주소
sourceTranslatedPort principal.nat_port 주 구성원의 NAT 포트
spt, client_port principal.port 주 구성원이 사용하는 포트
sproc principal.process.command_line 기본 프로세스의 명령줄
spid principal.process.pid 보안 주체의 프로세스 ID
spriv principal.user.attribute.roles 주 사용자에게 연결된 역할
suser, usrName, CustomerName principal.user.user_display_name 주 사용자의 표시 이름
dbUser, usrName, db_user, os_user, suid, db_username principal.user.userid 주 구성원의 사용자 ID
security_result 보안 결과 세부정보
security_result.action 보안 결과에서 취한 조치
act, Action_Taken security_result.action_details 취해진 조치의 세부정보
고양이 security_result.category_details 보안 결과의 카테고리 세부정보
msg_data_2, alert_description, Type, Scan_Type security_result.description 보안 결과 설명
operation_label, operasjon_label, permission_label, tillatelse_label, infection_channel_label, spyware_Grayware_Type_label, threat_probability_label security_result.detection_fields 보안 결과에서 감지에 사용되는 필드
mwProfile, alert_name security_result.rule_name 보안 결과를 트리거한 규칙의 이름
severity, event_severity security_result.severity 보안 결과의 심각도 수준
reason, ruleDesc, appcategory, Result security_result.summary 보안 결과 요약
스파이웨어, Virus_Malware_Name, Unknown_Threat security_result.threat_name 감지된 위협의 이름
oldFilePath src.file.full_path 소스 파일의 전체 경로
oldFileSize src.file.size 소스 파일 크기
oldFilePermission src.resource.attribute.permissions 소스 리소스의 권한
os_user src.user.userid 원본 사용자의 사용자 ID
dntdom target.administrative_domain 타겟의 관리 도메인
destinationServiceName, service_name target.application 대상과 연결된 애플리케이션
prin_host, dest_host, server_hostname target.asset.hostname 타겟 애셋의 호스트 이름
dst_ip, dest_ip, server_ip, IPv6_Address target.asset.ip 대상 애셋의 IP 주소
temp_dhost, dest_host, server_hostname target.hostname 대상 호스트 이름
dst_ip, dst, dest_ip, server_ip, IPv6_Address target.ip 타겟의 IP 주소
dmac target.mac 타겟의 MAC 주소
destinationTranslatedAddress target.nat_ip 타겟의 NAT IP 주소
destinationTranslatedPort target.nat_port 타겟의 NAT 포트
dpt, dstPort, dest_port, server_port target.port 대상에서 사용하는 포트
dproc, full_sql target.process.command_line 타겟 프로세스의 명령줄
File_name, Object, Objekt, Infected_Resource target.process.file.full_path 대상 프로세스 파일의 전체 경로
dpid, full_sql_id target.process.pid 타겟의 프로세스 ID
session_start target.resource.attribute.creation_time 타겟 리소스의 생성 시간
additional_environment_name, additional_db_protocol_version, additional_dbProtocolVersion, additional_operation_name, additional_signature_id, resource_Type_label target.resource.attribute.labels 대상 리소스와 연결된 라벨
session_end target.resource.attribute.last_update_time 타겟 리소스의 마지막 업데이트 시간
db_name, database_name target.resource.name 타겟 리소스의 이름
db_type, server_type target.resource.resource_subtype 타겟 리소스의 하위 유형
target.resource.resource_type 타겟 리소스 유형
요청 target.url 타겟과 연결된 URL
dpriv, roles target.user.attribute.roles 타겟 사용자와 연결된 역할
temp_duser, CustomerName target.user.user_display_name 타겟 사용자의 표시 이름
temp_duid, User, Bruker, db_username target.user.userid 타겟의 사용자 ID
metadata.product_name 제품 이름
metadata.vendor_name 공급업체 이름
query additional.fields 변경 로그에서 매핑됨

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.