Extreme Wireless 로그 수집

파서 버전: 2.0

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Extreme Wireless 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Extreme Networks 무선 컨트롤러는 클라이언트 연결 및 연결 해제 이벤트, 인증, RADIUS 상호작용, 액세스 포인트 상태 변경에 대한 syslog 메시지를 생성합니다. 파서는 grok 패턴을 사용하여 필드를 추출하고 통합 데이터 모델 (UDM)에 매핑합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Extreme Networks CloudIQ 컨트롤러 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Extreme Networks CloudIQ에 대한 액세스 권한 관리

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 신규 배포: Chronicle API (옵션 1)를 사용합니다.
  • 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명 (예: Bindplane agent log ingestion)을 입력합니다.
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 RUNNING으로 표시됩니다.

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 active (running)으로 표시됩니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/extreme_wireless:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: EXTREME_WIRELESS
        raw_log_field: body
    
    service:
      pipelines:
        logs/extreme_wireless_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/extreme_wireless
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신자 구성:

    • listen_address: 리슨할 IP 주소 및 포트:
      • 0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)
      • 포트 514은 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우 1514 사용).
  • 내보내기 도구 구성:

    • creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps 콘솔에서 복사한 고객 ID
    • location: <LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다 (예: us, europe 또는 asia-southeast1). 내보내기 도구는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.
    • project: <PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • endpoint: chronicle.googleapis.com로 설정된 상태를 유지합니다.

기존 수집 API 내보내기

  • 옵션 2의 데이터 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/extreme_wireless:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: EXTREME_WIRELESS
        raw_log_field: body
    

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X 순으로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Extreme Networks CloudIQ에서 syslog 구성

  1. CloudIQ 웹 UI에 로그인합니다.
  2. 구성 > 공통 객체 > 관리 > Syslog 서버로 이동합니다.
  3. +를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 이름: 서버의 고유한 이름을 입력합니다.
    • 심각도: 정보를 선택합니다.
    • 선택 메뉴에서 기존 syslog IP 주소를 선택하거나 +를 클릭합니다.
    • Bindplane 에이전트 IP 주소를 입력합니다.
    • Bindplane 에이전트 포트 번호를 입력합니다.
    • 추가를 클릭합니다.
  5. 시스템 로그 서버 저장을 클릭합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
action security_result.detection_fields.key 원시 로그의 action 필드 값이 security_result.detection_fields.key에 매핑됩니다.
action security_result.detection_fields.value action 필드의 원시 로그 값이 security_result.detection_fields.value에 매핑됩니다.
BSSID principal.resource.attribute.labels.key 문자열 'BSSID'가 principal.resource.attribute.labels.key에 할당됩니다.
BSSID principal.resource.attribute.labels.value 원시 로그의 BSSID 필드 값이 principal.resource.attribute.labels.value에 매핑됩니다.
collection_time.nanos metadata.event_timestamp.nanos 원시 로그의 collection_time.nanos 값이 metadata.event_timestamp.nanos에 매핑됩니다.
collection_time.seconds metadata.event_timestamp.seconds 원시 로그의 collection_time.seconds 값이 metadata.event_timestamp.seconds에 매핑됩니다.
collection_time.seconds timestamp.seconds 원시 로그의 collection_time.seconds 값이 timestamp.seconds에 매핑됩니다.
collection_time.nanos timestamp.nanos 원시 로그의 collection_time.nanos 값이 timestamp.nanos에 매핑됩니다.
data security_result.description 원치 않는 문자와 '해당 사항 없음' 값을 삭제하기 위해 여러 gsub 변환을 거친 후 원시 로그의 data 필드 값이 security_result.description 필드에 매핑됩니다.
description security_result.description grok 파서로 추출된 description 필드의 값은 security_result.description 필드에 매핑됩니다.
first security_result.detection_fields.key 문자열 'first'가 security_result.detection_fields.key에 할당됩니다.
first security_result.detection_fields.value first 필드의 원시 로그 값이 security_result.detection_fields.value에 매핑됩니다.
hostname principal.asset.hostname 원시 로그의 hostname 필드 값이 principal.asset.hostname 및 principal.hostname 필드에 매핑됩니다.
hostname principal.hostname 원시 로그의 hostname 필드 값이 principal.asset.hostname 및 principal.hostname 필드에 매핑됩니다.
IP principal.asset.ip 원시 로그의 IP 필드 값이 principal.asset.ip 및 principal.ip 필드에 매핑됩니다.
IP principal.ip 원시 로그의 IP 필드 값이 principal.asset.ip 및 principal.ip 필드에 매핑됩니다.
MAC principal.resource.attribute.labels.key 'MAC' 문자열이 principal.resource.attribute.labels.key에 할당됩니다.
MAC principal.resource.attribute.labels.value 원시 로그의 MAC 필드 값이 principal.resource.attribute.labels.value에 매핑됩니다.
medium security_result.detection_fields.key 'medium' 문자열이 security_result.detection_fields.key에 할당됩니다.
medium security_result.detection_fields.value medium 필드의 원시 로그 값이 security_result.detection_fields.value에 매핑됩니다. metadata.event_type는 파서 내의 로직에 의해 결정됩니다. principal 및 target 머신 ID가 모두 있는 경우 NETWORK_CONNECTION로 설정됩니다. principal 또는 target 사용자 ID가 있는 경우 USER_UNCATEGORIZED로 설정됩니다. principal 머신 ID만 있는 경우 STATUS_UPDATE로 설정됩니다. 그렇지 않으면 기본값은 GENERIC_EVENT입니다. 'EXTREME WIRELESS' 문자열이 metadata.product_name에 할당됩니다.
prod_event_type metadata.product_event_type prod_event_type 필드의 원시 로그 값이 metadata.product_event_type 필드에 매핑됩니다.
port principal.port 원시 로그의 port 필드 값이 정수로 변환되어 principal.port 필드에 매핑됩니다.
problem_summary security_result.summary 원시 로그의 problem_summary 필드 값이 security_result.summary 필드에 매핑됩니다.
SSID principal.resource.attribute.labels.key 'SSID' 문자열이 principal.resource.attribute.labels.key에 할당됩니다.
SSID principal.resource.attribute.labels.value 원시 로그의 SSID 필드 값이 principal.resource.attribute.labels.value에 매핑됩니다.
station principal.asset.hostname 원시 로그의 station 필드 값이 principal.asset.hostname 및 principal.hostname 필드에 매핑됩니다.
station principal.hostname 원시 로그의 station 필드 값이 principal.asset.hostname 및 principal.hostname 필드에 매핑됩니다.
target_host target.asset.hostname 원시 로그의 target_host 필드 값이 target.asset.hostname 및 target.hostname 필드에 매핑됩니다.
target_host target.hostname 원시 로그의 target_host 필드 값이 target.asset.hostname 및 target.hostname 필드에 매핑됩니다.
target_ip target.asset.ip 원시 로그의 target_ip 필드 값이 target.asset.ip 및 target.ip 필드에 매핑됩니다.
target_ip target.ip 원시 로그의 target_ip 필드 값이 target.asset.ip 및 target.ip 필드에 매핑됩니다.
target_port target.port 원시 로그의 target_port 필드 값이 정수로 변환되어 target.port 필드에 매핑됩니다.
target_user target.user.userid target_user 필드의 원시 로그 값이 target.user.userid 필드에 매핑됩니다.
user-profile security_result.detection_fields.key '사용자 프로필' 문자열이 security_result.detection_fields.key에 할당됩니다.
user-profile security_result.detection_fields.value 원시 로그의 user-profile 필드 값이 security_result.detection_fields.value에 매핑됩니다.
username principal.user.userid 원시 로그의 username 필드 값이 principal.user.userid 필드에 매핑됩니다. 'EXTREME_WIRELESS' 문자열이 metadata.vendor_name에 할당됩니다.

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.