Digi 모뎀 로그 수집

파서 버전: 1.0

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Digi Modems 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Digi 모뎀은 로그인 이벤트, 인증 시도, 네트워크 연결에 대한 syslog 메시지를 생성하는 산업용 셀룰러 모뎀입니다. 파서는 grok 패턴을 사용하여 필드를 추출하고 통합 데이터 모델 (UDM)에 매핑합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Digi 모뎀 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Digi Remote Manager 또는 로컬 Digi 모뎀 웹 UI에 대한 권한 액세스

Google SecOps 수집 인증 파일 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 실행 중으로 표시되어야 합니다.

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 활성 (실행 중)으로 표시되어야 합니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/digi_modems:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: DIGI_MODEMS
            raw_log_field: body
    
    service:
        pipelines:
            logs/digi_modems_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/digi_modems
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신기 구성:

    • listen_address: 리슨할 IP 주소 및 포트입니다.
      • 0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)
      • 포트 514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우 1514 사용).
  • 내보내기 도구 구성:

    • creds_file_path: 수집 인증 파일의 전체 경로입니다.
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps 콘솔에서 복사한 고객 ID
    • endpoint: 지역 엔드포인트 URL:
      • 미국: malachiteingestion-pa.googleapis.com
      • 유럽: europe-malachiteingestion-pa.googleapis.com
      • 아시아: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 전체 목록은 리전 엔드포인트를 참고하세요.

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X 순으로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R 키를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Digi 모뎀에서 시스템 로그 서버 구성

  1. Digi Remote Manager 또는 로컬 Digi Modem 웹 UI에 로그인합니다.
  2. 원격 관리자로 기기 구성에 액세스합니다.
    • syslog를 구성할 기기를 찾습니다.
    • 기기 ID > 설정 > 구성을 클릭합니다.
  3. 로컬 Digi 모뎀 웹 UI로 기기 구성에 액세스합니다.
    • 시스템 > 구성 > 기기 구성을 클릭합니다.
  4. 시스템 > 로그로 이동합니다.
  5. 클릭하여 서버 목록을 펼칩니다.
  6. 서버 추가 +를 클릭합니다.
  7. 다음 구성 세부정보를 제공합니다.
    • 서버: Bindplane 에이전트 IP 주소를 입력합니다.
    • 서버로 전송할 이벤트 카테고리를 선택합니다 (기본적으로 모든 이벤트 카테고리가 사용 설정됨).
    • Syslog egress Port: Bindplane 에이전트 포트 번호를 입력합니다 (기본값은 514).
    • 프로토콜: UDP를 선택합니다.
  8. 적용을 클릭합니다.

지원되는 Digi 모뎀 샘플 로그

  • SYSLOG

    {
      "priority": 14,
      "timestamp": "Dec 28 17:27:45",
      "hostname": "host-device.router",
      "tag": "Eventlog",
      "message": "17:27:33, 28 Dec 2006,Login failure by Host: 10.0.0.25:23: CMD,Telnet"
    }
    
  • SYSLOG

    {
      "priority": 14,
      "timestamp": "May 25 11:03:55",
      "hostname": "internal-srv-01",
      "tag": "Eventlog",
      "message": "11:03:55, 25 May 2023,Login failure by sanitized_user: WEB"
    }
    
  • SYSLOG

    {
      "priority": 14,
      "timestamp": "Jun 11 23:58:26",
      "hostname": "internal-srv-01",
      "tag": "Eventlog",
      "message": "23:58:26, 11 Jun 2023,Login failure by GET /masked_path HTTP/1.0: CMD,Telnet"
    }
    
  • SYSLOG

    {
      "priority": 14,
      "timestamp": "Jun 19 19:52:19",
      "hostname": "gateway-device-02",
      "tag": "Eventlog",
      "message": "19:52:18, 19 Jun 2023,WEB Login OK by internal_admin lvl 0"
    }
    

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
콘텐츠 security_result.description 초기 grok 파싱 후 content 필드에서 직접 매핑됩니다.
http_method network.http.method grok 패턴을 사용하여 content 필드에서 추출됩니다.
http_version network.application_protocol_version grok 패턴을 사용하여 content 필드에서 추출됩니다.
호스트 이름 principal.hostname grok 패턴을 사용하여 로그 메시지에서 추출됩니다.
ip target.ip grok 패턴을 사용하여 content 필드에서 추출됩니다.
포트 target.port grok 패턴을 사용하여 content 필드에서 추출하고 정수로 변환했습니다.
proto network.application_protocol grok 패턴을 사용하여 content 필드에서 추출됩니다.
ts metadata.event_timestamp grok 패턴을 사용하여 로그 메시지에서 추출하고 타임스탬프로 변환했습니다.
유형 login_type_label.value grok 패턴을 사용하여 content 필드에서 추출됩니다.
extensions.auth.type 파서 로직에 의해 MACHINE로 설정됩니다.
login_type_label.key 파서 로직에 의해 Login type로 설정됩니다.
metadata.event_type ip 또는 user과 같은 특정 필드의 존재 여부에 따라 결정되며 NETWORK_CONNECTION 또는 USER_LOGIN로 설정됩니다.
metadata.log_type 파서 로직에 의해 DIGI_MODEMS로 설정됩니다.
metadata.product_event_type 로그 메시지의 product_type 필드에서 추출됩니다.
metadata.product_name 파서 로직에 의해 DIGI_MODEMS로 설정됩니다.
metadata.vendor_name 파서 로직에 의해 DIGI_MODEMS로 설정됩니다.
security_result.action 메일에 Login OK 또는 Login failure가 있는지에 따라 결정되며 각각 ALLOW 또는 BLOCK로 설정됩니다.
사용자 target.user.userid grok 패턴을 사용하여 content 필드에서 추출됩니다.

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.