Dell 스위치 로그 수집
파서 버전: 11.0
이 문서에서는 Bindplane 에이전트를 사용하여 Dell 스위치 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
이 파서는 Dell 스위치 로그를 추출하고, 타임스탬프를 정규화하고, grok 패턴을 사용하여 로그 메시지를 키-값 쌍으로 구조화합니다. 그런 다음 추출된 필드를 통합 데이터 모델 (UDM)에 매핑하여 다양한 로그 형식을 처리하고, 자산 세부정보 및 보안 심각도와 같은 컨텍스트 정보로 데이터를 보강합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 Dell 스위치 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Dell 스위치의 활성 연결 및 관리 사용자 인증 정보
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/dell_switch: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DELL_SWITCH raw_log_field: body service: pipelines: logs/dell_switch_to_chronicle: receivers: - udplog exporters: - chronicle/dell_switch
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 비루트의 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 지역 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.
명령 프롬프트 또는 PowerShell(관리자 권한)
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Dell 스위치에서 syslog 내보내기 구성
- SSH 또는 콘솔 포트를 사용하여 Dell 스위치에 연결합니다.
- 관리 사용자 인증 정보로 로그인합니다.
다음 명령어를 사용하여 syslog 서버의 IP 주소 또는 호스트 이름을 지정합니다 (
<syslog-server-ip>,<udp|tcp>,<syslog-port-number>를 실제 세부정보로 대체).logging host <syslog-server-ip> transport <udp|tcp> port <syslog-port-number>선택사항: syslog 서버로 전송할 메시지의 최소 심각도 수준을 정의합니다. 예를 들어 정보 메시지 이상을 로깅하려면 다음을 실행합니다.
logging level informational변경사항이 재부팅 시에도 유지되도록 실행 중인 구성을 시작 구성에 저장합니다.
copy running-config startup-config구성을 저장합니다.
write memory
지원되는 Dell Switch 샘플 로그
SYSLOG
{ "priority": 165, "version": 1, "timestamp": "2023-10-12T12:37:17.249566+00:00", "hostname": "switch-lon-01", "app_name": "dn_alm", "proc_id": "940", "message": "Node.1-Unit.1:PRI [event], Dell EMC (OS10) %ALM_AUTH_EVENT: Authentication event was raised MESSAGE=pam_unix(sshd:session): session opened for user service_account by (uid=0)" }JSON
{ "appname": "SNOOP", "facility": 23, "hostname": "access-switch-a1", "message": "snooping.c(2177) 70820228 %% DBG Report from intf Gi6/0/11 ignored -- no router ports on vlan 193", "priority": 191, "proc_id": "snoopTask" }KV / 이벤트 형식
Events: Eventid = {38812} Occurrencetime = {3 Sept 2024 00:06:06} Eventseverity = {Minor} Jobid = {30506} Computer = {backup-server-01} Program = {DatabaseAgent} Description = {Block Change Tracking is found DISABLED on Oracle DB [PROD_DB]. Incremental backups may run slow.}감사 SYSLOG
{ "priority": 110, "version": 1, "timestamp": "2023-12-12T00:58:26.893679+00:00", "hostname": "core-switch-palf", "app_name": ".clish", "proc_id": "29156", "message": "Node.1-Unit.1:PRI [audit], User sec_admin on /dev/pts/0 from 10.0.0.50 used cmd: 'terminal length 0' - completed" }SNMP 트랩 / TRAPMGR 형식
{ "priority": 189, "version": 1, "timestamp": "2023-12-28T23:37:27.394Z", "hostname": "dist-switch-01", "app_name": "TRAPMGR", "proc_id": "trapTask", "extensions": { "origin_ip": "192.168.1.1", "software": "N3000_Series", "swVersion": "6.3.2.3" }, "message": "traputil.c(721) 1056839 %% Gi1/0/5 is transitioned from the Learning state to the Forwarding state" }
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
acct |
principal.user.userid |
user 필드가 없는 경우 userid로 사용됩니다. |
addr |
principal.asset.ip, principal.ip |
IP 주소로 파싱되며 유효한 IP이고 호스트 이름과 다른 경우 주 구성원의 IP 및 애셋 IP에 사용됩니다. |
application |
principal.application |
직접 매핑됩니다. |
asset |
principal.asset.attribute.labels.value |
키가 '애셋 이름'으로 하드코딩되어 애셋 라벨 값에 직접 매핑됩니다. 애셋 필드가 비어 있고 메시지에 'Dell'이 포함되어 있으면 애셋이 'Dell'로 설정됩니다. |
auid |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 auid인 라벨에 직접 매핑됩니다. |
datetime |
metadata.event_timestamp |
메시지 필드의 다양한 형식에서 파싱되어 타임스탬프로 변환됩니다. |
dest_ip |
target.asset.ip, target.ip |
타겟 IP 및 타겟 애셋 IP에 매핑됩니다. |
enterpriseId |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 enterpriseId인 라벨에 매핑됩니다. |
exe |
sec_result.detection_fields.value |
키가 exe인 감지 필드에 매핑됩니다. |
File |
target.file.full_path |
직접 매핑됩니다. |
grantors |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 grantors인 라벨에 매핑됩니다. |
host |
principal.hostname, principal.asset.hostname, metadata.event_type |
기본 호스트 이름 및 애셋 호스트 이름으로 사용됩니다. host이 있으면 metadata.event_type이 STATUS_UPDATE로 설정됩니다. 호스트 이름은 있지만 호스트가 없는 경우 호스트 이름이 호스트로 사용됩니다. |
hostname |
principal.asset.ip, principal.ip, host |
유효한 IP인 경우 주 구성원 IP 및 애셋 IP에 사용됩니다. host이 비어 있으면 host으로 사용됩니다. |
ID |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 ID인 라벨에 매핑됩니다. |
ip |
principal.asset.ip, principal.ip |
주요 IP 및 애셋 IP에 매핑됩니다. |
is_synced |
sec_result.detection_fields.value |
키가 is_synced인 감지 필드에 매핑됩니다. |
local |
target.asset.ip, target.ip, target.port |
파싱되어 로컬 IP와 포트를 추출하고 대상 IP, 대상 애셋 IP, 대상 포트에 매핑됩니다. |
local_ip |
target.asset.ip, target.ip |
local 필드에서 추출되어 대상 IP 및 대상 애셋 IP에 매핑됩니다. |
local_port |
target.port |
local 필드에서 추출되어 타겟 포트에 매핑됩니다. |
mac |
principal.mac |
유효한 MAC 주소인 경우 기본 MAC 주소에 매핑됩니다. |
msg |
metadata.description |
있는 경우 이벤트 설명으로 사용됩니다. 추가 필드도 파싱되었습니다. |
msg1 |
metadata.description |
msg2이 없는 경우 이벤트 설명으로 사용됩니다. |
msg2 |
sec_result.description, metadata.event_type, extensions.auth.type |
보안 결과 설명으로 사용됩니다. 'opened for user'가 포함된 경우 이벤트 유형은 USER_LOGIN로, 인증 유형은 MACHINE로 설정됩니다. 'closed for user'가 포함된 경우 이벤트 유형은 USER_LOGOUT로, 인증 유형은 MACHINE로 설정됩니다. |
op |
metadata.product_event_type |
있는 경우 제품 이벤트 유형으로 사용됩니다. |
pid |
principal.process.pid |
직접 매핑됩니다. |
port |
principal.port |
직접 매핑됩니다. |
prod_event_type |
metadata.product_event_type |
있는 경우 제품 이벤트 유형으로 사용됩니다. |
res |
sec_result.summary |
직접 매핑됩니다. |
sec_description |
sec_result.description, target.url, target.ip, target.asset.ip, sec_result.action_details |
타겟 URL, IP, 작업 세부정보를 파싱하고 보안 결과 설명으로 사용됩니다. |
Server_ID |
target.resource.product_object_id |
직접 매핑됩니다. |
server |
principal.asset.ip, principal.ip, principal.port |
서버 IP와 포트를 추출하기 위해 파싱되고, 주 구성원 IP, 주 구성원 애셋 IP, 주 구성원 포트에 매핑됩니다. |
server_ip |
principal.asset.ip, principal.ip |
server 필드에서 추출되어 주 구성원 IP 및 주 구성원 애셋 IP에 매핑됩니다. |
server_port |
principal.port |
server 필드에서 추출하여 주 구성원 포트에 매핑했습니다. |
ses |
network.session_id |
직접 매핑됩니다. |
severity |
sec_result.severity, metadata.product_event_type |
특정 값을 기반으로 보안 결과 심각도와 제품 이벤트 유형을 결정하는 데 사용됩니다. |
software |
principal.asset.software |
직접 매핑됩니다. |
softwareName |
software.name |
직접 매핑됩니다. |
Status |
sec_result.summary |
res이 없는 경우 보안 결과 요약으로 사용됩니다. |
subj |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 subj인 라벨에 매핑됩니다. |
swVersion |
software.version |
직접 매핑됩니다. |
target_host |
target.hostname, target.asset.hostname |
대상 호스트 이름 및 대상 애셋 호스트 이름에 직접 매핑됩니다. |
target_ip |
target.asset.ip, target.ip |
타겟 IP 및 타겟 애셋 IP에 직접 매핑됩니다. |
target_url |
target.url |
직접 매핑됩니다. |
target_user_id |
target.user.userid |
직접 매핑됩니다. |
terminal |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 terminal인 라벨에 매핑됩니다. |
tzknown |
sec_result.detection_fields.value |
키가 tzknown인 감지 필드에 매핑됩니다. |
uid |
principal.resource.attribute.labels.value |
principal.resource.attribute.labels 내에서 키가 uid인 라벨에 매핑됩니다. |
user |
principal.user.userid, metadata.event_type |
기본 사용자 ID로 사용됩니다. user이 있으면 metadata.event_type이 USER_UNCATEGORIZED로 설정됩니다. |
username |
target.user.userid |
대상 사용자 ID에 직접 매핑됩니다. |
| 해당 사항 없음 | metadata.vendor_name |
'Dell'로 하드코딩됨 |
| 해당 사항 없음 | metadata.product_name |
'Dell Switch'로 하드코딩됨 |
| 해당 사항 없음 | extensions.auth.type |
특정 로그인/로그아웃 이벤트의 경우 MACHINE로 설정됩니다. |
| 해당 사항 없음 | metadata.event_type |
다양한 필드와 조건을 기반으로 하는 복잡한 논리에 따라 결정되며, 달리 설정하지 않는 한 기본값은 GENERIC_EVENT입니다. USER_LOGIN, USER_LOGOUT, USER_UNCATEGORIZED, NETWORK_CONNECTION, NETWORK_UNCATEGORIZED, STATUS_UPDATE 또는 GENERIC_EVENT일 수 있습니다. |
reason_code |
event.idm.read_only_udm.security_result.detection_fields |
변경 로그에서 매핑됨 |
Eventid |
metadata.product_log_id |
변경 로그에서 매핑됨 |
Eventseverity |
security_result.severity |
변경 로그에서 매핑됨 |
Computer |
principal.hostname |
변경 로그에서 매핑됨 |
Program |
principal.application |
변경 로그에서 매핑됨 |
Description |
security_result.description |
변경 로그에서 매핑됨 |
tzknown", "is_synced" and "exe |
security_result.detection_fields |
변경 로그에서 매핑됨 |
res |
security_result.summary |
변경 로그에서 매핑됨 |
status |
security_result.summary |
변경 로그에서 매핑됨 |
uid", "enterpriseId", "auid", "terminal", "subj", "grantors", and "ID |
principal.resource.attribute.labels |
변경 로그에서 매핑됨 |
sec_description |
security_result.description |
변경 로그에서 매핑됨 |
action_details |
security_result.action_details |
변경 로그에서 매핑됨 |
softwareName |
principal.asset.software.name |
변경 로그에서 매핑됨 |
swVersion |
principal.asset.software.version |
변경 로그에서 매핑됨 |
port |
principal_port |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.