איסוף יומנים של Datadog

גרסת המנתח: 4.0

נתמך ב:

במאמר הזה מוסבר איך להטמיע יומנים של Datadog ב-Google Security Operations. Datadog היא פלטפורמה מבוססת-ענן לניטור ולניתוח, שאוספת מדדים, יומני מעקב ורישומים ביומן מאפליקציות, מתשתיות וממשירותי ענן. אתם יכולים לשתף יומנים של Datadog עם Google SecOps באמצעות Cloud Storage או webhook.

לפני שמתחילים

חשוב לוודא שמתקיימות דרישות הסף הבאות:

  • מופע של Google SecOps
  • גישת משתמשים עם הרשאות ל-Datadog
  • גישה למסוף Google Cloud (ליצירת מפתח API או להגדרת Cloud Storage)

אפשרות 1: שיתוף יומנים של Datadog דרך הגדרת Cloud Storage

הגדרת השילוב של Datadog עם Google Cloud

מגדירים שילוב של Google Cloudב-Datadog. מידע נוסף זמין במאמר הגדרת השילוב של Google Cloud Datadog.

יצירת קטגוריה של Cloud Storage

  1. נכנסים למסוף Google Cloud .
  2. נכנסים לדף Cloud Storage Buckets.

    כניסה לדף Buckets

  3. לוחצים על Create.

  4. ממלאים את פרטי הקטגוריה בדף Create a bucket. אחרי כל אחד מהשלבים הבאים, לוחצים על המשך כדי לעבור לשלב הבא:

    1. בקטע Get started:

      1. מזינים שם ייחודי שעומד בדרישות לשמות של קטגוריות (לדוגמה, datadog-data).
      2. כדי להפעיל את מרחב השמות ההיררכי, לוחצים על החץ להרחבה כדי להרחיב את הקטע Optimize for file oriented and data-intensive workloads (אופטימיזציה לעומסי עבודה שמתמקדים בקבצים ובנתונים), ואז בוחרים באפשרות Enable Hierarchical namespace on this bucket (הפעלת מרחב שמות היררכי בדלי הזה).

      3. כדי להוסיף תווית של מאגר, לוחצים על החץ להרחבה כדי להרחיב את הקטע תוויות.

      4. לוחצים על הוספת תווית ומציינים מפתח וערך לתווית.

    2. בקטע Choose where to store your data, מבצעים את הפעולות הבאות:

      1. בוחרים סוג מיקום.
      2. בתפריט הנפתח של סוג המיקום, בוחרים מיקום שבו נתוני האובייקטים בקטגוריה יישמרו באופן קבוע.
    3. בקטע Choose a storage class for your data, בוחרים default storage class לקטגוריה, או בוחרים ב-Autoclass לניהול אוטומטי של סוג האחסון (storage class) של נתוני הקטגוריה.

    4. בקטע Choose how to control access to objects, בוחרים באפשרות not כדי לא לאכוף public access prevention, ובוחרים access control model לאובייקטים של הקטגוריה.

    5. בקטע Choose how to protect object data:

      1. בוחרים באחת מהאפשרויות בקטע Data protection (הגנה על נתונים) שרוצים להגדיר לקטגוריה.
      2. כדי לבחור איך להצפין את נתוני האובייקט, לוחצים על החץ להרחבה של Data encryption ובוחרים Data encryption method.
  5. לוחצים על יצירה.

יצירת Google Cloud חשבון שירות

  1. נכנסים אל IAM & Admin > Service Accounts (ניהול הרשאות גישה (IAM) & אדמין > חשבונות שירות).
  2. יוצרים חשבון שירות חדש.
  3. נותנים לו שם תיאורי (לדוגמה, datadog-user).
  4. מקצים לחשבון השירות את התפקיד אדמין של אובייקטים של אחסון בקטגוריית Cloud Storage שיצרתם בשלב הקודם.
  5. יוצרים מפתח לחשבון השירות ובוחרים באפשרות JSON בתור סוג המפתח.
  6. מורידים את קובץ מפתח ה-JSON של חשבון השירות. חשוב לשמור על הקובץ הזה מאובטח.

הגדרת Datadog לשליחת יומנים ל-Cloud Storage

  1. נכנסים ל-Datadog באמצעות חשבון עם הרשאות.
  2. עוברים אל Logs > Log Forwarding.
  3. לוחצים על + יצירת ארכיון חדש.
  4. בוחרים באפשרות Google Cloud Storage.
  5. מזינים את הפרמטרים הנדרשים ולוחצים על שמירה.

הגדרת פיד ב-Google SecOps להטמעה של יומנים מקטגוריית Cloud Storage

  1. עוברים אל SIEM Settings > Feeds (הגדרות SIEM > פידים).
  2. לוחצים על הוספת פיד חדש.
  3. בדף הבא, לוחצים על הגדרת פיד יחיד.
  4. בשדה שם הפיד, מזינים שם לפיד (לדוגמה, Datadog Logs GCS).
  5. בוחרים באפשרות Google Cloud Storage V2 בתור סוג המקור.
  6. בוחרים באפשרות Datadog בתור Log type.
  7. לוחצים על Get Service Account (קבלת חשבון שירות) כדי לקבל את חשבון השירות הייחודי של הפיד הזה.
  8. מקצים לחשבון השירות הזה את התפקיד צפייה באובייקט אחסון בקטגוריה של Cloud Storage שנוצרה קודם.
  9. לוחצים על הבא.
  10. מציינים ערכים לפרמטרים הבאים של הקלט:
    • ‫Storage Bucket URI: ה-URI של קטגוריית Cloud Storage בפורמט gs://datadog-data.
    • אפשרות מחיקת המקור: בוחרים את אפשרות המחיקה הרצויה.
    • הגיל המקסימלי של הקובץ: כולל קבצים שעברו שינוי במספר הימים האחרון. ברירת המחדל היא 180 ימים.
    • מרחב השמות של הנכס: מרחב השמות של הנכס.
    • תוויות הטמעה: התווית שנוספה לאירועים מהפיד הזה.
  11. לוחצים על הבא.
  12. בודקים את הגדרות הפיד במסך סיום ולוחצים על שליחה.

אפשרות 2: שיתוף יומנים של Datadog באמצעות הגדרת Webhook

הגדרת פידים

כדי להגדיר פיד:

  1. עוברים אל SIEM Settings > Feeds (הגדרות SIEM > פידים).
  2. לוחצים על הוספת פיד חדש.
  3. בדף הבא, לוחצים על הגדרת פיד יחיד.
  4. בשדה שם הפיד, מזינים שם לפיד (לדוגמה, Datadog Logs).
  5. בוחרים באפשרות Webhook בתור סוג המקור.
  6. בוחרים באפשרות Datadog בתור סוג היומן.
  7. לוחצים על הבא.
  8. אופציונלי: מציינים ערכים לפרמטרים הבאים של הקלט:
    • תו מפריד לפיצול: התו המפריד שמשמש להפרדת שורות ביומן, כמו \n.
  9. לוחצים על הבא.
  10. בודקים את הגדרות הפיד במסך סיום ולוחצים על שליחה.
  11. לוחצים על יצירת מפתח סודי כדי ליצור מפתח סודי לאימות הפיד הזה.
  12. מעתיקים את המפתח הסודי ושומרים אותו. לא ניתן להציג שוב את המפתח הסודי הזה. במקרה הצורך, אפשר ליצור מחדש מפתח סודי חדש, אבל הפעולה הזו מייתרת את המפתח הסודי הקודם.
  13. בכרטיסייה פרטים, מעתיקים את כתובת ה-URL של נקודת הקצה של הפיד מהשדה פרטי נקודת הקצה. צריך לציין את כתובת ה-URL של נקודת הקצה הזו באפליקציית הלקוח.
  14. לוחצים על סיום.

יצירת מפתח API ל-Webhook Feed

  1. עוברים אל Google Cloud console > Credentials: לדף Credentials.
  2. לוחצים על Create credentials ואז על מפתח API.
  3. הגבלת הגישה של מפתח ה-API ל-Chronicle API.

ציון כתובת ה-URL של נקודת הקצה

  1. באפליקציית הלקוח, מציינים את כתובת ה-URL של נקודת הקצה של HTTPS שמופיעה בפיד ה-webhook.
  2. כדי להפעיל אימות, מציינים את מפתח ה-API ואת המפתח הסודי כחלק מהכותרת המותאמת אישית בפורמט הבא:

    X-goog-api-key = API_KEY
    X-Webhook-Access-Key = SECRET
    

    המלצה: כדאי לציין את מפתח ה-API ככותרת במקום לציין אותו בכתובת ה-URL.

  3. אם לקוח ה-webhook שלכם לא תומך בכותרות בהתאמה אישית, אתם יכולים לציין את מפתח ה-API ואת המפתח הסודי באמצעות פרמטרים של שאילתות בפורמט הבא:

    ENDPOINT_URL?key=API_KEY&secret=SECRET
    

    מחליפים את מה שכתוב בשדות הבאים:

    • ‫ENDPOINT_URL: כתובת ה-URL של נקודת הקצה של הפיד.
    • ‫API_KEY: מפתח ה-API לאימות ב-Google Security Operations.
    • ‫SECRET: המפתח הסודי שיצרתם כדי לאמת את הפיד.

הגדרת Datadog לשליחת יומנים ל-webhook

  1. נכנסים ל-Datadog באמצעות חשבון עם הרשאות.
  2. עוברים אל Logs > Log Forwarding.
  3. בוחרים באפשרות יעדים מותאמים אישית.
  4. לוחצים על + יצירת יעד חדש.
  5. מציינים ערכים לפרמטרים הבאים של הקלט:
    • בחירת סוג יעד: בוחרים באפשרות HTTP.
    • נותנים שם ליעד: מציינים שם תיאורי ל-webhook (לדוגמה, Google SecOps Webhook).
    • מגדירים את היעד: מדביקים את ENDPOINT_URL של הפיד. בוחרים אחת מאפשרויות האימות הבאות (לא את שתיהן):
      • אפשרות א' (מומלצת): משאירים את כתובת ה-URL בלי פרטי כניסה ומעבירים את API_KEY ואת SECRET ככותרות מותאמות אישית (מוגדרות בשלב הבא).
      • אפשרות ב': לצרף את פרטי הכניסה לכתובת ה-URL כפרמטרים של שאילתה, בפורמט ENDPOINT_URL?key=API_KEY&secret=SECRET. משתמשים באפשרות הזו רק אם הלקוח לא יכול לשלוח כותרות מותאמות אישית.
    • הגדרת הגדרות אימות: כדי לשמור את היעד, צריך להגדיר לפחות כותרת אימות אחת ב-Datadog. מוסיפים את הכותרת הבאה. נקודת הקצה של ה-webhook מתעלמת מהשדה הזה, כך שהוא לא משפיע על הבקשה.
      • שם הכותרת: Authorization.
      • ערך הכותרת: application/json.
  6. לוחצים על Save.

טבלת מיפוי UDM

שדה ביומן מיפוי UDM היגיון
additional_field additional.fields ממוזג
anonymous_label additional.fields ממוזג
as_domain_label additional.fields ממוזג
as_name_label additional.fields ממוזג
as_number_label additional.fields ממוזג
as_type_label additional.fields ממוזג
auth_method_label additional.fields ממוזג
category_label additional.fields ממוזג
emitted_source_label additional.fields ממוזג
event_type_label additional.fields ממוזג
geo_continent_code_label additional.fields ממוזג
geo_continent_label additional.fields ממוזג
geo_continent_name_label additional.fields ממוזג
geo_country_code_label additional.fields ממוזג
geo_latitude_label additional.fields ממוזג
geo_longitude_label additional.fields ממוזג
geo_subdivision_code_label additional.fields ממוזג
geo_subdivision_name_label additional.fields ממוזג
geo_timezone_label additional.fields ממוזג
http_level_label additional.fields ממוזג
indicator_label additional.fields ממוזג
indicators_matched_label additional.fields ממוזג
infrastructure_label additional.fields ממוזג
intention_label additional.fields ממוזג
iso_code_label additional.fields ממוזג
new_template_variable_name_label additional.fields ממוזג
new_template_variable_preset_name_label additional.fields ממוזג
new_template_variable_value_label additional.fields ממוזג
new_widget_definition_background_color_label additional.fields ממוזג
new_widget_definition_layout_type_label additional.fields ממוזג
new_widget_definition_show_title_label additional.fields ממוזג
new_widget_definition_title_label additional.fields ממוזג
new_widget_definition_type_label additional.fields ממוזג
new_widget_id_label additional.fields ממוזג
new_widget_layout_height_label additional.fields ממוזג
new_widget_layout_width_label additional.fields ממוזג
new_widget_layout_x_label additional.fields ממוזג
new_widget_layout_y_label additional.fields ממוזג
record_attributes_asset_id_label additional.fields ממוזג
record_attributes_asset_name_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_author_handle_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_author_name_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_description_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_id_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_reflow_type_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_title_label additional.fields ממוזג
record_attributes_asset_new_value_dashboard_definition_url_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_author_handle_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_author_name_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_description_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_id_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_reflow_type_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_title_label additional.fields ממוזג
record_attributes_asset_prev_value_dashboard_definition_url_label additional.fields ממוזג
record_attributes_asset_type_label additional.fields ממוזג
record_attributes_contextMap_cfRay_label additional.fields ממוזג
record_attributes_contextMap_tradingAccountId_label additional.fields ממוזג
record_attributes_evt_name_label additional.fields ממוזג
record_attributes_network_client_geoip_as_number_label additional.fields ממוזג
record_attributes_network_client_geoip_as_type_label additional.fields ממוזג
record_attributes_network_client_geoip_location_latitude_label additional.fields ממוזג
record_attributes_network_client_geoip_location_longitude_label additional.fields ממוזג
record_attributes_network_client_geoip_subdivision_iso_code_label additional.fields ממוזג
record_attributes_network_client_geoip_subdivision_name_label additional.fields ממוזג
record_attributes_network_client_geoip_timezone_label additional.fields ממוזג
record_trace_id_label additional.fields ממוזג
request_id_label additional.fields ממוזג
risk_label additional.fields ממוזג
service_label additional.fields ממוזג
source_name_label additional.fields ממוזג
source_type_label additional.fields ממוזג
source_url_label additional.fields ממוזג
span_id_label additional.fields ממוזג
symbol_label additional.fields ממוזג
tag_label additional.fields ממוזג
template_variable_name_label additional.fields ממוזג
template_variable_preset_name_label additional.fields ממוזג
template_variable_value_label additional.fields ממוזג
timezone_label additional.fields ממוזג
tunnels_operator_label additional.fields ממוזג
tunnels_type_label additional.fields ממוזג
type_label additional.fields ממוזג
type_label1 additional.fields ממוזג
url_details_host_label additional.fields ממוזג
url_details_path_label additional.fields ממוזג
user_created_timestamp_label additional.fields ממוזג
widget_definition_background_color_label additional.fields ממוזג
widget_definition_layout_type_label additional.fields ממוזג
widget_definition_show_title_label additional.fields ממוזג
widget_definition_title_label additional.fields ממוזג
widget_definition_type_label additional.fields ממוזג
widget_id_label additional.fields ממוזג
widget_layout_height_label additional.fields ממוזג
widget_layout_width_label additional.fields ממוזג
widget_layout_x_label additional.fields ממוזג
widget_layout_y_label additional.fields ממוזג
eventMessage metadata.description מיפוי ישיר
date1 metadata.event_timestamp ניתוח הכתובות שברשימה: ISO8601
record.date1 metadata.event_timestamp ניתוח הכתובות שברשימה: ISO8601
event_type metadata.event_type מיפוי ישיר
has_principal metadata.event_type מיפוי: true ← NETWORK_CONNECTION, ‏ true ← STATUS_UPDATE
has_user metadata.event_type מופה: true ← USER_UNCATEGORIZED
attributes._trace.origin.operation metadata.product_event_type מיפוי ישיר
eventType metadata.product_event_type מיפוי ישיר
record_attributes_contextMap_eventType metadata.product_event_type מיפוי ישיר
source metadata.product_event_type מיפוי ישיר
_id metadata.product_log_id מיפוי ישיר
record_attributes_thread_id metadata.product_log_id מיפוי ישיר
threadID metadata.product_log_id מיפוי ישיר
service metadata.product_name מיפוי ישיר
attributes.@version metadata.product_version מיפוי ישיר
attributes.http.method network.http.method מיפוי ישיר
agnt network.http.parsed_user_agent מיפוי ישיר
record_attributes_contextMap_userAgent network.http.parsed_user_agent מיפוי ישיר
attributes.http.status_code network.http.response_code שם שונה/מיפוי
agnt network.http.user_agent מיפוי ישיר
attributes.http.useragent network.http.user_agent מיפוי ישיר
record_attributes_contextMap_userAgent network.http.user_agent מיפוי ישיר
attributes.logger_name principal.application מיפוי ישיר
service principal.application מיפוי ישיר
attributes._trace.baggage.device_id principal.asset.asset_id מיפוי ישיר
attributes.metadata.host_metadata.hostname principal.asset.hostname מיפוי ישיר
attributes.usr.id principal.asset.hostname מיפוי ישיר
attributes.network.client.geoip.ipAddress principal.asset.ip ממוזג
attributes.network.client.ip principal.asset.ip ממוזג
ip1 principal.asset.ip ממוזג
ipAddress principal.asset.ip מיפוי ישיר
principal_ip_address principal.asset.ip ממוזג
record_attributes_network_client_ip principal.asset.ip ממוזג
org principal.group.group_display_name מיפוי ישיר
attributes.org.uuid principal.group.product_object_id מיפוי ישיר
attributes.metadata.host_metadata.hostname principal.hostname מיפוי ישיר
attributes.usr.id principal.hostname מיפוי ישיר
host principal.hostname מיפוי ישיר
record_host principal.hostname מיפוי ישיר
attributes.network.client.geoip.ipAddress principal.ip ממוזג
attributes.network.client.ip principal.ip ממוזג
ip1 principal.ip ממוזג
ipAddress principal.ip מיפוי ישיר
principal_ip_address principal.ip ממוזג
record_attributes_network_client_ip principal.ip ממוזג
record_attributes_http_url_details_host_label principal.labels ממוזג
record_attributes_http_url_details_path_label principal.labels ממוזג
record_attributes_http_useragent_label principal.labels ממוזג
record_attributes_network_client_geoip_as_domain_label principal.labels ממוזג
record_attributes_network_client_geoip_as_route_label principal.labels ממוזג
record_attributes_network_client_geoip_city_name_label principal.labels ממוזג
record_attributes_network_client_geoip_continent_code_label principal.labels ממוזג
record_attributes_network_client_geoip_continent_name_label principal.labels ממוזג
record_attributes_network_client_geoip_country_iso_code_label principal.labels ממוזג
record_attributes_network_client_geoip_country_name_label principal.labels ממוזג
record_attributes_usr_id_label principal.labels ממוזג
attributes.network.client.geoip.city.name principal.location.city מיפוי ישיר
attributes.network.client.geoip.country.name principal.location.country_or_region מיפוי ישיר
port principal.port שם שונה/מיפוי
client_as_route_label principal.resource.attribute.labels ממוזג
client_type_label principal.resource.attribute.labels ממוזג
org_name_label principal.resource.attribute.labels ממוזג
record_attributes_usr_uuid_label principal.user.attribute.labels ממוזג
roles principal.user.attribute.roles ממוזג
attributes.usr.email principal.user.email_addresses ממוזג
email_id principal.user.email_addresses ממוזג
record_attributes_usr_email principal.user.email_addresses ממוזג
attributes.evt.actor.type principal.user.role_name מיפוי ישיר
attributes.metadata.user_uuid principal.user.userid מיפוי ישיר
attributes.usr.uuid principal.user.userid מיפוי ישיר
record_attributes_contextMap_user principal.user.userid מיפוי ישיר
user principal.user.userid מיפוי ישיר
BusArch_label security_result.about.resource.attribute.labels ממוזג
CANDBVersion_label security_result.about.resource.attribute.labels ממוזג
alert_label security_result.about.resource.attribute.labels ממוזג
caller_label security_result.about.resource.attribute.labels ממוזג
component_label security_result.about.resource.attribute.labels ממוזג
esn_label security_result.about.resource.attribute.labels ממוזג
ftcpVersion_label security_result.about.resource.attribute.labels ממוזג
ingestMessageId_label security_result.about.resource.attribute.labels ממוזג
label security_result.about.resource.attribute.labels ממוזג
level_label security_result.about.resource.attribute.labels ממוזג
msg_label security_result.about.resource.attribute.labels ממוזג
query_label security_result.about.resource.attribute.labels ממוזג
redactedVin_label security_result.about.resource.attribute.labels ממוזג
updated_query_label security_result.about.resource.attribute.labels ממוזג
vehicleId_label security_result.about.resource.attribute.labels ממוזג
category1 security_result.category_details ממוזג
_id_label security_result.detection_fields ממוזג
action_label security_result.detection_fields ממוזג
org_uuid_label security_result.detection_fields ממוזג
record_attributes_http_method_label security_result.detection_fields ממוזג
record_message_label security_result.detection_fields ממוזג
record_source_label security_result.detection_fields ממוזג
record_status_label security_result.detection_fields ממוזג
status security_result.severity מיפוי: "INFO", "DEBUG", "debug", "info" ← LOW, ‏ (?i)WARN ← MEDIUM
status security_result.severity_details מיפוי ישיר
context.AlertName security_result.threat_name מיפוי ישיר
src_ip_address src.ip ממוזג
record_attributes_contextMap_dd_service target.application מיפוי ישיר
target_ip_address target.asset.ip מופה: ^(?:[0-9]{1,3}[.]){3}[0-9]{1,3}$ ← target_ip_address
target_ip_address target.ip מופה: ^(?:[0-9]{1,3}[.]){3}[0-9]{1,3}$ ← target_ip_address
record_attributes_contextMap_dd_version target.platform_version מיפוי ישיר
logger_fqcn_label target.resource.attribute.labels ממוזג
logger_label target.resource.attribute.labels ממוזג
modified_fields_label target.resource.attribute.labels ממוזג
asset_name target.resource.name מיפוי ישיר
asset_id target.resource.product_object_id מיפוי ישיר
asset_type target.resource.type מיפוי ישיר
record_attributes_contextMap_dd_env target.resource.type מיפוי ישיר
record_attributes_contextMap_userId target.user.userid מיפוי ישיר
record_attributes_user target.user.userid מיפוי ישיר
לא רלוונטי metadata.event_type קבוע: NETWORK_CONNECTION
לא רלוונטי network.http.parsed_user_agent קבוע: parseduseragent
לא רלוונטי security_result.severity קבוע: LOW
org_name event.idm.read_only_udm.principal.resource.attribute.labels מופה מיומן השינויים
modified_field event.idm.read_only_udm.target.resource.attribute.labels מופה מיומן השינויים
asset_name event.idm.read_only_udm.target.resource.name מופה מיומן השינויים
asset_id event.idm.read_only_udm.target.resource.product_object_id מופה מיומן השינויים
asset_type event.idm.read_only_udm.target.resource.type מופה מיומן השינויים
query event.idm.read_only_udm.security_result.about.resource.attribute.labels מופה מיומן השינויים
updated_query event.idm.read_only_udm.security_result.about.resource.attribute.labels מופה מיומן השינויים
request_id event.idm.read_only_udm.additional.fields מופה מיומן השינויים
http_level event.idm.read_only_udm.additional.fields מופה מיומן השינויים
timezone event.idm.read_only_udm.additional.fields מופה מיומן השינויים
iso_code event.idm.read_only_udm.additional.fields מופה מיומן השינויים
user_created_timestamp event.idm.read_only_udm.additional.fields מופה מיומן השינויים
client_as_route event.idm.read_only_udm.principal.resource.attribute.labels מופה מיומן השינויים
client_type event.idm.read_only_udm.principal.resource.attribute.labels מופה מיומן השינויים
source event.idm.read_only_udm.metadata.product_event_type מופה מיומן השינויים
status event.idm.read_only_udm.security_result.severity_details מופה מיומן השינויים
record.attributes.user event.idm.read_only_udm.target.user.userid מופה מיומן השינויים
user event.idm.read_only_udm.principal.user.userid מופה מיומן השינויים
eventType event.idm.read_only_udm.metadata.product_event_type מופה מיומן השינויים
ipAddress event.idm.read_only_udm.principal.ip מופה מיומן השינויים
ipAddress event.idm.read_only_udm.principal.asset.ip מופה מיומן השינויים
threadID event.idm.read_only_udm.metadata.product_log_id מופה מיומן השינויים
status event.idm.read_only_udm.security_result.severity מופה מיומן השינויים
service event.idm.read_only_udm.principal.application מופה מיומן השינויים
eventMessage event.idm.read_only_udm.metadata.description מופה מיומן השינויים
tags event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.attributes.contextMap.userId event.idm.read_only_udm.target.user.userid מופה מיומן השינויים
record.attributes.contextMap.user event.idm.read_only_udm.principal.user.userid מופה מיומן השינויים
record.attributes.contextMap.eventType event.idm.read_only_udm.metadata.product_event_type מופה מיומן השינויים
record.attributes.contextMap.userAgent event.idm.read_only_udm.network.http.user_agent מופה מיומן השינויים
record.attributes.contextMap.userAgent event.idm.read_only_udm.network.http.parsed_user_agent מופה מיומן השינויים
record.attributes.contextMap.tradingAccountId event.idm.read_only_udm.additional.fields מופה מיומן השינויים
principal_ip_address event.idm.read_only_udm.principal.ip מופה מיומן השינויים
principal_ip_address event.idm.read_only_udm.principal.asset.ip מופה מיומן השינויים
target_ip_address event.idm.read_only_udm.target.ip מופה מיומן השינויים
target_ip_address event.idm.read_only_udm.target.asset.ip מופה מיומן השינויים
record.attributes.contextMap.cfRay event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.attributes.contextMap.symbol event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.attributes.contextMap.dd.version event.idm.read_only_udm.target.platform_version מופה מיומן השינויים
record.attributes.contextMap.dd.env event.idm.read_only_udm.target.resource.type מופה מיומן השינויים
record.attributes.contextMap.dd.service event.idm.read_only_udm.target.application מופה מיומן השינויים
record.attributes.logger event.idm.read_only_udm.target.resource.attribute.labels מופה מיומן השינויים
record.attributes.loggerFqcn event.idm.read_only_udm.target.resource.attribute.labels מופה מיומן השינויים
record.attributes.threadId event.idm.read_only_udm.metadata.product_log_id מופה מיומן השינויים
record.trace_id event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.span_id event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.service event.idm.read_only_udm.additional.fields מופה מיומן השינויים
record.attributes.level event.idm.read_only_udm.security_result.about.resource.attribute.labels מופה מיומן השינויים
record.host event.idm.read_only_udm.principal.hostname מופה מיומן השינויים

יומן שינויים

צפייה ביומן השינויים של כלי הניתוח הזה

הבעיה עדיין לא נפתרה? קבלת תשובות מחברי הקהילה וממומחי Google SecOps.