איסוף יומנים של Cloudian HyperStore
גרסת כלי הניתוח: 2.0
במאמר הזה מוסבר איך להטמיע יומנים של Cloudian HyperStore ב-Google Security Operations באמצעות סוכן Bindplane.
הכלי לניתוח מחלץ שדות מהודעות syslog של Cloudian HyperStore באמצעות דפוסי grok, כולל חותמות זמן, כתובות IP, שמות משתמשים ותיאורים. הוא ממפה את השדות שחולצו למודל הנתונים המאוחד (UDM) ומגדיר את סוג האירוע המתאים על סמך הפעילות שזוהתה.
לפני שמתחילים
חשוב לוודא שמתקיימות הדרישות המוקדמות הבאות:
- מופע של Google SecOps
- Windows Server 2016 ואילך, או מארח Linux עם
systemd - קישוריות רשת בין סוכן Bindplane לבין מערכת Cloudian HyperStore
- אם מריצים מאחורי שרת proxy, מוודאים שיציאות חומת האש פתוחות בהתאם לדרישות של סוכן Bindplane
- גישה עם הרשאות ל-Cloudian HyperStore
קבלת קובץ אימות להטמעת נתונים ב-Google SecOps
- נכנסים למסוף Google SecOps.
- עוברים אל SIEM Settings > Collection Agents.
- מורידים את קובץ האימות להטמעת נתונים.
שומרים את הקובץ בצורה מאובטחת במערכת שבה יותקן סוכן Bindplane.
איך מוצאים את מספר הלקוח ב-Google SecOps
- נכנסים למסוף Google SecOps.
- עוברים אל SIEM Settings > Profile (הגדרות SIEM > פרופיל).
מעתיקים את מזהה הלקוח מהקטע פרטי הארגון ושומרים אותו.
התקנת סוכן Bindplane
מתקינים את סוכן Bindplane במערכת ההפעלה Windows או Linux לפי ההוראות הבאות.
התקנה ב-Windows
- פותחים את שורת הפקודה או את PowerShell כאדמין.
מריצים את הפקודה הבאה:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietמחכים שההתקנה תסתיים.
כדי לוודא שההתקנה בוצעה, מריצים את הפקודה:
sc query observiq-otel-collectorהשירות צריך להופיע עם הערך RUNNING.
התקנה ב-Linux
- פותחים טרמינל עם הרשאות root או sudo.
מריצים את הפקודה הבאה:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shמחכים שההתקנה תסתיים.
כדי לוודא שההתקנה בוצעה, מריצים את הפקודה:
sudo systemctl status observiq-otel-collectorהשירות צריך להופיע כפעיל (פועל).
מקורות מידע נוספים להתקנה
אפשרויות התקנה נוספות ופתרון בעיות מפורטים במדריך להתקנת סוכן Bindplane.
הגדרה של סוכן Bindplane לקליטת syslog ושליחה ל-Google SecOps
איתור קובץ ההגדרות
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
עריכת קובץ ההגדרות
מחליפים את כל התוכן של
config.yamlבהגדרה הבאה:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/cloudian_hyperstore: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CLOUDIAN_HYPERSTORE raw_log_field: body service: pipelines: logs/cloudian_hyperstore_to_chronicle: receivers: - udplog exporters: - chronicle/cloudian_hyperstore
פרמטרים להגדרה
מחליפים את ה-placeholders הבאים:
הגדרת מקלט:
-
listen_address: כתובת ה-IP והיציאה להאזנה:-
0.0.0.0כדי להאזין בכל הממשקים (מומלץ) - יציאה
514היא יציאת syslog רגילה (נדרשת הרשאת root ב-Linux; אפשר להשתמש ב-1514ללא הרשאת root)
-
-
הגדרת כלי הייצוא:
-
creds_file_path: הנתיב המלא לקובץ האימות להטמעת נתונים:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
-
customer_id: מספר הלקוח שהועתק ממסוף Google SecOps -
endpoint: כתובת ה-URL של נקודת הקצה האזורית:- ארה"ב:
malachiteingestion-pa.googleapis.com - אירופה:
europe-malachiteingestion-pa.googleapis.com - אסיה:
asia-southeast1-malachiteingestion-pa.googleapis.com - רשימה מלאה מופיעה במאמר בנושא נקודות קצה אזוריות.
- ארה"ב:
-
שמירת קובץ ההגדרות
- אחרי שמסיימים לערוך, שומרים את הקובץ:
- Linux: מקישים על
Ctrl+O, אחר כך עלEnterואז עלCtrl+X. - Windows: לוחצים על קובץ > שמירה.
- Linux: מקישים על
מפעילים מחדש את סוכן Bindplane כדי להחיל את השינויים.
כדי להפעיל מחדש את סוכן Bindplane ב-Linux, מריצים את הפקודה הבאה:
sudo systemctl restart observiq-otel-collectorמוודאים שהשירות פועל:
sudo systemctl status observiq-otel-collectorבודקים אם יש שגיאות ביומנים:
sudo journalctl -u observiq-otel-collector -f
כדי להפעיל מחדש את סוכן Bindplane ב-Windows, בוחרים באחת מהאפשרויות הבאות:
שורת הפקודה או PowerShell כאדמין:
net stop observiq-otel-collector && net start observiq-otel-collectorמסוף השירותים:
- מקישים על
Win+R, מקלידיםservices.mscומקישים על Enter. - מחפשים את observIQ OpenTelemetry Collector.
- לוחצים לחיצה ימנית ובוחרים באפשרות הפעלה מחדש.
מוודאים שהשירות פועל:
sc query observiq-otel-collectorבודקים אם יש שגיאות ביומנים:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- מקישים על
הגדרת Cloudian HyperStore syslog
- נכנסים לצומת HyperStore Config Controller באמצעות CLI.
מריצים את הפקודות הבאות:
hsctlhsctl config set logging.syslog.remote.enabled=true hsctl config set logging.syslog.remote.host=<BINDPLANE_IP> hsctl config set logging.syslog.remote.protocol=<UDP_OR_TCP> hsctl config set logging.syslog.remote.port=<BINDPLANE_PORT> hsctl config apply ALL hsctl service restart s3 iam hyperstore firewall --nodes=ALL hsctl config set monitoring.agent.logging.level=INFO hsctl config apply monitoring- מחליפים את
<BINDPLANE_IP>בכתובת ה-IP של סוכן Bindplane. - מחליפים את
<UDP_OR_TCP>בפרוטוקול שהוגדר בסוכן Bindplane. - מחליפים את
<BINDPLANE_PORT>במספר היציאה של סוכן Bindplane.
- מחליפים את
טבלת מיפוי UDM
| שדה ביומן | מיפוי UDM | היגיון |
|---|---|---|
description |
metadata.description |
מיפוי ישיר |
datetime |
metadata.event_timestamp |
ניתוח הכתובות שברשימה: RFC 3339 |
method |
network.http.method |
שם שונה/מיפוי |
url |
network.http.referral_url |
מיפוי ישיר |
status_code |
network.http.response_code |
שם שונה/מיפוי |
session_id |
network.session_id |
מיפוי ישיר |
application |
principal.application |
מיפוי ישיר |
hostname |
principal.hostname |
מיפוי ישיר |
source_ip |
principal.ip |
ממוזג |
request_id |
principal.process.pid |
מיפוי ישיר |
target_ip |
target.ip |
ממוזג |
port |
target.port |
שם שונה/מיפוי |
file_path |
target.process.file.full_path |
מיפוי ישיר |
user |
target.user.user_display_name |
מיפוי ישיר |
| לא רלוונטי | extensions.auth.type |
קבוע: AUTHTYPE_UNSPECIFIED |
| לא רלוונטי | metadata.event_type |
קבוע: NETWORK_CONNECTION |
| לא רלוונטי | metadata.product_name |
קבוע: Cloudian Hyperstore |
| לא רלוונטי | metadata.vendor_name |
קבוע: Cloudian |
הבעיה עדיין לא נפתרה? קבלת תשובות מחברי הקהילה וממומחי Google SecOps.