Cisco VCS 로그 수집

파서 버전: 2.0

다음에서 지원:

이 문서에서는 Bindplane을 사용하여 Cisco VCS(Video Communication Service)(ExpressWay를 통해 제어됨) 로그를 Google Security Operations로 수집하는 방법을 설명합니다. 파서는 syslog 메시지에서 필드를 추출하고, 이를 통합 데이터 모델(UDM)로 정규화하고, IP 주소, 포트, 작업과 같은 추출된 세부정보를 기반으로 이벤트 유형을 분류합니다. 다양한 로그 형식을 처리하고, 키-값 쌍을 추출하고, 보안 분석을 위해 심각도 수준을 표준화된 값에 매핑합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows 2016 이상 또는 systemd가 설치된 Linux 호스트
  • 프록시 뒤에서 실행되는 경우 방화벽 포트가 열려 있음
  • Cisco ExpressWay에 대한 액세스 권한 관리

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 새 배포: Chronicle API를 사용합니다(옵션 1).
  • 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일(옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다(예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다(예: Bindplane agent log ingestion).
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리(Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드(기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. 설정 > 데이터 관리 > 수집 에이전트로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. 설정 > 관리 > 프로필로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

추가 설치 리소스

추가 설치 옵션은 설치 가이드를 참조하세요.

Syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

  1. 구성 파일에 액세스합니다.
    • config.yaml 파일을 찾습니다. 일반적으로 Linux의 /opt/observiq-otel-collector/ 디렉터리 또는 Windows의 설치 디렉터리에 있습니다.
    • 텍스트 편집기(예: nano, vi 또는 메모장)를 사용하여 파일을 엽니다.
  2. 다음과 같이 config.yaml 파일을 수정합니다.

    receivers:
        udplog:
            # Replace the port and IP address as required
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/chronicle_w_labels:
            protocol: https
            # Region of your instance, for example us, europe, asia-southeast1
            location: <LOCATION>
            # Project number of the Google Cloud project linked to the instance
            project: '<PROJECT_NUMBER>'
            compression: gzip
            # Adjust the path to the credentials file you downloaded in Step 1
            creds_file_path: '/path/to/ingestion-authentication-file.json'
            # Replace with your actual customer ID from Step 2
            customer_id: <customer_id>
            endpoint: chronicle.googleapis.com
            # Add optional ingestion labels for better organization
            log_type: 'CISCO_VCS'
            raw_log_field: body
            ingestion_labels:
    
    service:
        pipelines:
            logs/source0__chronicle_w_labels-0:
                receivers:
                    - udplog
                exporters:
                    - chronicle/chronicle_w_labels
    
    • 인프라에서 필요한 대로 포트와 IP 주소를 바꿉니다.
    • <LOCATION>을 Google SecOps 인스턴스의 리전(예: us, europe 또는 asia-southeast1)으로 바꿉니다. 내보내기 도구는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다.
    • <PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • <customer_id>를 실제 고객 ID로 바꿉니다.
    • Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기 섹션에서 서비스 계정 키 파일(옵션 1)이 저장된 경로로 /path/to/ingestion-authentication-file.json를 업데이트합니다.

기존 수집 API 내보내기 도구

  • 옵션 2의 데이터 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com를 리전 엔드포인트(예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
        chronicle/chronicle_w_labels:
            compression: gzip
            # Adjust the path to the credentials file you downloaded in Step 1
            creds_file_path: '/path/to/ingestion-authentication-file.json'
            # Replace with your actual customer ID from Step 2
            customer_id: <customer_id>
            endpoint: malachiteingestion-pa.googleapis.com
            # Add optional ingestion labels for better organization
            log_type: 'CISCO_VCS'
            raw_log_field: body
            ingestion_labels:
    

Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart bindplane-agent
    
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 서비스 콘솔을 사용하거나 다음 명령어를 입력합니다.

    net stop BindPlaneAgent && net start BindPlaneAgent
    

Cisco ExpressWay용 Syslog 구성

  1. Cisco ExpressWay 웹 UI에 로그인합니다.
  2. 유지보수 > 로깅으로 이동합니다.
  3. Bindplane 에이전트 IP 주소를 원격 시스템로그 서버로 입력합니다.
  4. 옵션을 클릭합니다.
  5. 다음 구성 세부정보를 제공합니다.
    • 전송: UDP를 선택합니다.
    • 포트: Bindplane 에이전트 포트 번호를 입력합니다.
    • 메시지 형식: BSD를 선택합니다. 다른 옵션은 IETF입니다.
    • 심각도로 필터링: 정보를 선택합니다.
  6. 저장을 클릭합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
작업 read_only_udm.security_result.action_details 원시 로그의 Action 필드 값입니다.
코드 read_only_udm.network.http.response_code 원시 로그의 Code 필드 값으로, 정수로 변환됩니다. Response-code가 없는 경우에 사용됩니다.
세부정보 read_only_udm.security_result.description 원시 로그의 Detail 필드 값입니다.
Dst-ip read_only_udm.target.ip 원시 로그의 Dst-ip 필드 값입니다. Action가 Received가 아닌 경우에 사용됩니다.
Dst-port read_only_udm.target.port 원시 로그의 Dst-port 필드 값으로, 정수로 변환됩니다. Action가 Received가 아닌 경우에 사용됩니다.
이벤트 read_only_udm.metadata.product_event_type 원시 로그의 Event 필드 값입니다.
수준 read_only_udm.security_result.severity_details 원시 로그의 Level 필드 값입니다.
수준 read_only_udm.security_result.severity 원시 로그의 Level 필드 값에 따라 매핑됩니다.
- 9, 10, VERY-HIGH: 심각
- error, warning, 7, 8, HIGH: 높음
- notice, 4, 5, 6, MEDIUM: 중간
- information, info, 0, 1, 2, 3, LOW: 낮음
Local-ip read_only_udm.principal.ip 원시 로그의 Local-ip 필드 값입니다. Action가 Received가 아닌 경우에 사용됩니다.
Local-ip read_only_udm.target.ip 원시 로그의 Local-ip 필드 값입니다. Action가 Received인 경우에 사용됩니다.
Local-port read_only_udm.principal.port 원시 로그의 Local-port 필드 값으로, 정수로 변환됩니다. Action가 Received가 아닌 경우에 사용됩니다.
Local-port read_only_udm.target.port 원시 로그의 Local-port 필드 값으로, 정수로 변환됩니다. Action가 Received인 경우에 사용됩니다.
메서드 read_only_udm.network.http.method 원시 로그의 Method 필드 값입니다.
모듈 read_only_udm.additional.fields.value.string_value 원시 로그의 Module 필드 값입니다.
노드 read_only_udm.additional.fields.value.string_value 원시 로그의 Node 필드 값입니다.
프로토콜 read_only_udm.network.ip_protocol 원시 로그의 Protocol 필드 값으로, parse_ip_protocol.include 로직을 사용하여 파싱되고 해당 IP 프로토콜 이름에 매핑됩니다.
Response-code read_only_udm.network.http.response_code 원시 로그의 Response-code 필드 값으로, 정수로 변환됩니다.
Src-ip read_only_udm.principal.ip 원시 로그의 Src-ip 필드 값입니다. Action가 Received인 경우에 사용됩니다.
Src-ip read_only_udm.principal.ip 원시 로그의 Src-ip 필드 값입니다. Action가 Received가 아니고 Local-ip가 없는 경우에 사용됩니다.
Src-port read_only_udm.principal.port 원시 로그의 Src-port 필드 값으로, 정수로 변환됩니다. Action가 Received인 경우에 사용됩니다.
Src-port read_only_udm.principal.port 원시 로그의 Src-port 필드 값으로, 정수로 변환됩니다. Action가 Received가 아니고 Local-port가 없는 경우에 사용됩니다.
애플리케이션 read_only_udm.target.application 원시 로그의 application 필드 값입니다.
설명 read_only_udm.security_result.description 원시 로그의 description 필드 값입니다.
inner_msg read_only_udm.security_result.description 원시 로그의 inner_msg 필드 값입니다. inner_msg_grok_failure가 발생할 때 사용됩니다.
principal_hostname read_only_udm.principal.hostname 원시 로그의 principal_hostname 필드 값입니다.
타임스탬프 read_only_udm.metadata.event_timestamp.seconds 원시 로그의 timestamp 필드에서 추출된 에포크 타임스탬프입니다.
타임스탬프 read_only_udm.events.timestamp.seconds 원시 로그의 timestamp 필드에서 추출된 에포크 타임스탬프입니다.
read_only_udm.additional.fields.key 하드코딩된 값: Module, Node
read_only_udm.metadata.log_type 하드코딩된 값: CISCO_VCS
read_only_udm.metadata.product_name 하드코딩된 값: CISCO VCS
read_only_udm.metadata.vendor_name 하드코딩된 값: CISCO VCS
read_only_udm.metadata.event_type Action, Src-ip, principal_hostname, Local-ip, Dst-ip 필드의 값을 기준으로 결정됩니다.
- NETWORK_CONNECTION: (Action가 Received이고 Local-ip가 있는 경우) 또는 (Action가 Received가 아니고 Dst-ip가 있는 경우)
- STATUS_UPDATE: 그 외의 경우

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.