CipherTrust Manager 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 CipherTrust Manager 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 CipherTrust Manager 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- CipherTrust Manager 웹 콘솔에 대한 권한 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 수집 인증 파일을 다운로드합니다.
Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/ciphertrust_manager: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CIPHERTRUST_MANAGER raw_log_field: body service: pipelines: logs/ciphertrust_manager_to_chronicle: receivers: - udplog exporters: - chronicle/ciphertrust_manager
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 비루트의 경우1514사용).
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDendpoint: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
CipherTrust Manager의 syslog 구성
- CipherTrust Manager 웹 콘솔에 로그인합니다.
- 관리 설정 > 알림 > Syslog로 이동합니다.
- New Syslog Server(새 Syslog 서버)를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 호스트: Bindplane 에이전트 IP 주소를 입력합니다.
- 포트: Bindplane 에이전트 포트 번호 (기본값 514)를 입력합니다.
- 로그 형식: RFC 5424를 선택합니다.
- 전송: UDP를 선택합니다.
- 저장을 클릭합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
message |
about |
매핑됨: CEF → about |
deviceNtDomain |
about.administrative_domain |
이름이 변경됨/매핑됨 |
deviceExternalId |
about.asset.asset_id |
직접 매핑됨 |
device_product |
about.asset.asset_id |
직접 매핑됨 |
device_vendor |
about.asset.asset_id |
직접 매핑됨 |
fileHash |
about.file.full_path |
직접 매핑됨 |
filePath |
about.file.full_path |
이름이 변경됨/매핑됨 |
_hash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fileHash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fsize |
about.file.size |
이름이 변경됨/매핑됨 |
dvchost |
about.hostname |
이름이 변경됨/매핑됨 |
ips |
about.ip |
병합됨 |
message |
about.ip |
매핑됨: CEF → ips |
dvc_mac |
about.mac |
매핑됨: slot → mac_address |
dvcmac |
about.mac |
병합됨 |
mac_address |
about.mac |
병합됨 |
message |
about.mac |
매핑됨: CEF → mac_address, CEF → dvcmac |
deviceTranslatedAddress |
about.nat_ip |
병합됨 |
message |
about.nat_ip |
매핑됨: CEF → deviceTranslatedAddress |
Emne |
about.process.command_line |
직접 매핑됨 |
Path |
about.process.command_line |
직접 매핑됨 |
Subject |
about.process.command_line |
직접 매핑됨 |
deviceProcessName |
about.process.command_line |
이름이 변경됨/매핑됨 |
dvcpid |
about.process.pid |
이름이 변경됨/매핑됨 |
message |
about.resource.attribute.permissions |
매핑됨: CEF → permissions |
permissions |
about.resource.attribute.permissions |
병합됨 |
Internal_label |
additional.fields |
병합됨 |
additional_alias_alias_field |
additional.fields |
병합됨 |
additional_alias_index_field |
additional.fields |
병합됨 |
additional_alias_type_field |
additional.fields |
병합됨 |
additional_cfp1 |
additional.fields |
병합됨 |
additional_cfp2 |
additional.fields |
병합됨 |
additional_cfp3 |
additional.fields |
병합됨 |
additional_cfp4 |
additional.fields |
병합됨 |
additional_cn1 |
additional.fields |
병합됨 |
additional_cn2 |
additional.fields |
병합됨 |
additional_cn3 |
additional.fields |
병합됨 |
additional_cs1 |
additional.fields |
병합됨 |
additional_cs2 |
additional.fields |
병합됨 |
additional_cs3 |
additional.fields |
병합됨 |
additional_cs4 |
additional.fields |
병합됨 |
additional_cs5 |
additional.fields |
병합됨 |
additional_cs6 |
additional.fields |
병합됨 |
additional_cs7 |
additional.fields |
병합됨 |
additional_devicePayloadId |
additional.fields |
병합됨 |
additional_eventId |
additional.fields |
병합됨 |
additional_flexString1 |
additional.fields |
병합됨 |
additional_fname |
additional.fields |
병합됨 |
algorithm_label |
additional.fields |
병합됨 |
app_connector_type_label |
additional.fields |
병합됨 |
assignSelfAsOwner_label |
additional.fields |
병합됨 |
auth_domain_label |
additional.fields |
병합됨 |
client_name_label |
additional.fields |
병합됨 |
client_type_label |
additional.fields |
병합됨 |
codeDesc_label |
additional.fields |
병합됨 |
code_label |
additional.fields |
병합됨 |
createdAt_label |
additional.fields |
병합됨 |
cs2 |
additional.fields |
매핑됨: arc_test → additional_cs2 |
cs5_label |
additional.fields |
병합됨 |
customAttributes_label |
additional.fields |
병합됨 |
deatils_domain_id_label |
additional.fields |
병합됨 |
details_user_metadata_current_domain_id_label |
additional.fields |
병합됨 |
details_user_metadata_current_persistedData_label |
additional.fields |
병합됨 |
details_user_metadata_current_persistedData_paging_label |
additional.fields |
병합됨 |
domain_id_label |
additional.fields |
병합됨 |
domain_label |
additional.fields |
병합됨 |
emptyMaterial_label |
additional.fields |
병합됨 |
feature_label |
additional.fields |
병합됨 |
format_label |
additional.fields |
병합됨 |
generateKeyId_label |
additional.fields |
병합됨 |
idType_label |
additional.fields |
병합됨 |
id_label |
additional.fields |
병합됨 |
identifier_label |
additional.fields |
병합됨 |
interfaceName_label |
additional.fields |
병합됨 |
interfaceType_label |
additional.fields |
병합됨 |
label_label |
additional.fields |
병합됨 |
message |
additional.fields |
매핑된 값 (총 71개, 예: CEF → additional_eventId, CEF → `additional_devicePayloa... |
messageFormat_label |
additional.fields |
병합됨 |
meta_label |
additional.fields |
병합됨 |
objectType_label |
additional.fields |
병합됨 |
ownerId_label |
additional.fields |
병합됨 |
padded_label |
additional.fields |
병합됨 |
permissions_label |
additional.fields |
병합됨 |
record_type_id_label |
additional.fields |
병합됨 |
refresh_token_counts_label |
additional.fields |
병합됨 |
refresh_token_counts_no_label |
additional.fields |
병합됨 |
refresh_token_counts_total_label |
additional.fields |
병합됨 |
refresh_token_id_label |
additional.fields |
병합됨 |
renew_refresh_token_label |
additional.fields |
병합됨 |
requestId_label |
additional.fields |
병합됨 |
requestIdentifierType_label |
additional.fields |
병합됨 |
requestIdentifier_label |
additional.fields |
병합됨 |
scope_label |
additional.fields |
병합됨 |
service_label |
additional.fields |
병합됨 |
switch_domain_id_label |
additional.fields |
병합됨 |
undeletable_label |
additional.fields |
병합됨 |
unexportable_label |
additional.fields |
병합됨 |
version_label |
additional.fields |
병합됨 |
xts_label |
additional.fields |
병합됨 |
zone_id_label |
additional.fields |
병합됨 |
details_grant_type |
extensions.auth.auth_details |
직접 매핑됨 |
logon_type_temp |
extensions.auth.mechanism |
병합됨 |
message |
extensions.auth.mechanism |
매핑됨: CEF → logon_type_temp, Get User → logon_type_temp |
message |
intermediary |
매핑됨: CEF → intermediary |
proxy_ip |
intermediary.ip |
병합됨 |
msg |
metadata.description |
이름이 변경됨/매핑됨 |
Generated |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss로 파싱됨 |
Received |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss로 파싱됨 |
event_time |
metadata.event_timestamp |
ISO8601로 파싱됨 |
rt |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ssZ로 파싱됨 |
syslog_timestamp |
metadata.event_timestamp |
MMM dd HH:mm:ss로 파싱됨 |
syslog_timestamp_with_year |
metadata.event_timestamp |
MMM dd HH:mm:ss yyyy로 파싱됨 |
cef_message |
metadata.event_type |
매핑됨: (Use Key/Update Key/Export Key) → USER_RESOURCE_UPDATE_CONTENT |
event_name |
metadata.event_type |
매핑됨: "LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
has_principal |
metadata.event_type |
매핑됨: true → NETWORK_CONNECTION |
has_user |
metadata.event_type |
매핑됨: true → USER_UNCATEGORIZED |
message |
metadata.event_type |
매핑된 값 (총 12개, 예: CEF → PROCESS_UNCATEGORIZED, CEF → SCAN_UNCATEGORIZED,... |
device_event_class_id |
metadata.product_event_type |
직접 매핑됨 |
event_name |
metadata.product_event_type |
직접 매핑됨 |
externalId |
metadata.product_log_id |
직접 매핑됨 |
id |
metadata.product_log_id |
직접 매핑됨 |
uid |
metadata.product_log_id |
직접 매핑됨 |
device_product |
metadata.product_name |
직접 매핑됨 |
product |
metadata.product_name |
직접 매핑됨 |
product_name |
metadata.product_name |
직접 매핑됨 |
device_version |
metadata.product_version |
직접 매핑됨 |
device_vendor |
metadata.vendor_name |
이름이 변경됨/매핑됨 |
app_protocol_output |
network.application_protocol |
직접 매핑됨 |
deviceDirection |
network.direction |
매핑됨: 0 → INBOUND, 1 → OUTBOUND |
message |
network.direction |
매핑됨: CEF → INBOUND, CEF → OUTBOUND |
requestMethod |
network.http.method |
이름이 변경됨/매핑됨 |
requestClientApplication |
network.http.user_agent |
이름이 변경됨/매핑됨 |
ip_protocol_out |
network.ip_protocol |
직접 매핑됨 |
in |
network.received_bytes |
이름이 변경됨/매핑됨 |
out |
network.sent_bytes |
이름이 변경됨/매핑됨 |
sntdom |
principal.administrative_domain |
이름이 변경됨/매핑됨 |
sourceServiceName |
principal.application |
이름이 변경됨/매핑됨 |
syslog_host |
principal.asset.hostname |
직접 매핑됨 |
details_user_metadata_current_domain_name |
principal.domain.name |
직접 매핑됨 |
Group_name |
principal.group.group_display_name |
직접 매핑됨 |
Gruppenavn |
principal.group.group_display_name |
직접 매핑됨 |
Device_name |
principal.hostname |
직접 매핑됨 |
Enhetsnavn |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
이름이 변경됨/매핑됨 |
syslog_host |
principal.hostname |
직접 매핑됨 |
client_ip |
principal.ip |
병합됨 |
message |
principal.ip |
매핑됨: CEF → principal_ip, CEF → shost, CEF → client_ip, `(SSL 핸드셰이크 실패... |
principal_ip |
principal.ip |
병합됨 |
shost |
principal.ip |
병합됨 |
mac |
principal.mac |
병합됨 |
message |
principal.mac |
매핑됨: CEF → mac |
message |
principal.nat_ip |
매핑됨: CEF → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
병합됨 |
sourceTranslatedPort |
principal.nat_port |
이름이 변경됨/매핑됨 |
spt |
principal.port |
이름이 변경됨/매핑됨 |
sproc |
principal.process.command_line |
이름이 변경됨/매핑됨 |
spid |
principal.process.pid |
이름이 변경됨/매핑됨 |
acc_label |
principal.resource.attribute.labels |
병합됨 |
acct_label |
principal.resource.attribute.labels |
병합됨 |
iss_label |
principal.resource.attribute.labels |
병합됨 |
jti_label |
principal.resource.attribute.labels |
병합됨 |
message |
principal.resource.attribute.labels |
매핑된 값 (총 5개, 예: CEF → acct_label, CEF → acc_label, CEF → iss_label) |
sub_label |
principal.resource.attribute.labels |
병합됨 |
message |
principal.user.attribute.roles |
매핑됨: CEF → principal_role |
principal_role |
principal.user.attribute.roles |
병합됨 |
details_username |
principal.user.user_display_name |
직접 매핑됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
username |
principal.user.user_display_name |
직접 매핑됨 |
details_user_id |
principal.user.userid |
직접 매핑됨 |
details_userid |
principal.user.userid |
직접 매핑됨 |
suid |
principal.user.userid |
이름이 변경됨/매핑됨 |
user_id |
principal.user.userid |
직접 매핑됨 |
username |
principal.user.userid |
직접 매핑됨 |
_security_result |
security_result |
병합됨 |
message |
security_result |
매핑됨: CEF → security_result |
_action |
security_result.action |
병합됨 |
act |
security_result.action |
매핑됨: accept → _action, deny → _action |
message |
security_result.action |
매핑됨: CEF → _action |
Action_Taken |
security_result.action_details |
직접 매핑됨 |
act |
security_result.action_details |
직접 매핑됨 |
details_errorMessage |
security_result.action_details |
직접 매핑됨 |
cat |
security_result.category_details |
병합됨 |
message |
security_result.category_details |
매핑됨: CEF → cat |
Scan_Type |
security_result.description |
직접 매핑됨 |
Type |
security_result.description |
직접 매핑됨 |
message |
security_result.description |
직접 매핑됨 |
msg_data_2 |
security_result.description |
직접 매핑됨 |
infection_channel_label |
security_result.detection_fields |
병합됨 |
message |
security_result.detection_fields |
매핑된 값 (총 7개, 예: CEF → operation_label, CEF → operasjon_label, CEF → `... |
operasjon_label |
security_result.detection_fields |
병합됨 |
operation_label |
security_result.detection_fields |
병합됨 |
permission_label |
security_result.detection_fields |
병합됨 |
spyware_Grayware_Type_label |
security_result.detection_fields |
병합됨 |
threat_probability_label |
security_result.detection_fields |
병합됨 |
tillatelse_label |
security_result.detection_fields |
병합됨 |
mwProfile |
security_result.rule_name |
직접 매핑됨 |
message |
security_result.severity |
매핑됨: CEF → LOW, CEF → MEDIUM, CEF → HIGH, CEF → CRITICAL |
severity |
security_result.severity |
매핑됨: "0", "1", "2", "3", "LOW" → LOW, `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
Result |
security_result.summary |
직접 매핑됨 |
appcategory |
security_result.summary |
직접 매핑됨 |
reason |
security_result.summary |
이름이 변경됨/매핑됨 |
success |
security_result.summary |
직접 매핑됨 |
Spyware |
security_result.threat_name |
직접 매핑됨 |
Unknown_Threat |
security_result.threat_name |
직접 매핑됨 |
Virus_Malware_Name |
security_result.threat_name |
직접 매핑됨 |
oldFilePath |
src.file.full_path |
이름이 변경됨/매핑됨 |
oldFileSize |
src.file.size |
이름이 변경됨/매핑됨 |
client_ip |
src.ip |
병합됨 |
message |
src.ip |
매핑됨: CEF → client_ip |
message |
src.resource.attribute.permissions |
매핑됨: CEF → old_permissions |
old_permissions |
src.resource.attribute.permissions |
병합됨 |
cust_client_id |
src.user.product_object_id |
직접 매핑됨 |
details_client_id |
src.user.product_object_id |
직접 매핑됨 |
dntdom |
target.administrative_domain |
이름이 변경됨/매핑됨 |
destinationServiceName |
target.application |
이름이 변경됨/매핑됨 |
service |
target.application |
직접 매핑됨 |
service_name |
target.application |
직접 매핑됨 |
application |
target.domain.name |
직접 매핑됨 |
details.size |
target.file.size |
이름이 변경됨/매핑됨 |
details.host |
target.hostname |
직접 매핑됨 |
target_hostname |
target.hostname |
직접 매핑됨 |
temp_dhost |
target.hostname |
직접 매핑됨 |
IPv6_Address |
target.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
ipv6 |
target.ip |
매핑됨: - → IPv6_Address |
message |
target.ip |
매핑됨: CEF → dst_ip, CEF → IPv6_Address |
mac_address |
target.mac |
병합됨 |
message |
target.mac |
매핑됨: CEF → mac_address |
destination_translated_address |
target.nat_ip |
병합됨 |
message |
target.nat_ip |
매핑됨: CEF → destination_translated_address |
destinationTranslatedPort |
target.nat_port |
이름이 변경됨/매핑됨 |
details.port |
target.port |
이름이 변경됨/매핑됨 |
dpt |
target.port |
이름이 변경됨/매핑됨 |
dproc |
target.process.command_line |
이름이 변경됨/매핑됨 |
File_name |
target.process.file.full_path |
직접 매핑됨 |
Infected_Resource |
target.process.file.full_path |
직접 매핑됨 |
Object |
target.process.file.full_path |
직접 매핑됨 |
Objekt |
target.process.file.full_path |
직접 매핑됨 |
dpid |
target.process.pid |
이름이 변경됨/매핑됨 |
account_label |
target.resource.attribute.labels |
병합됨 |
connection_label |
target.resource.attribute.labels |
병합됨 |
message |
target.resource.attribute.labels |
매핑된 값 (총 6개, 예: CEF → resource_Type_label, CEF → name_label, CEF → `u... |
name_label |
target.resource.attribute.labels |
병합됨 |
resource_Type_label |
target.resource.attribute.labels |
병합됨 |
uri_label |
target.resource.attribute.labels |
병합됨 |
usageMask_label |
target.resource.attribute.labels |
병합됨 |
source |
target.resource.name |
직접 매핑됨 |
request |
target.url |
직접 매핑됨 |
message |
target.user.attribute.roles |
매핑됨: CEF → target_role |
target_role |
target.user.attribute.roles |
병합됨 |
CustomerName |
target.user.user_display_name |
직접 매핑됨 |
temp_duser |
target.user.user_display_name |
직접 매핑됨 |
Bruker |
target.user.userid |
직접 매핑됨 |
User_value |
target.user.userid |
직접 매핑됨 |
temp_duid |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: GENERIC_EVENT |
| 해당 사항 없음 | network.direction |
상수: INBOUND |
| 해당 사항 없음 | network.ip_protocol |
상수: UDP |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.