איסוף יומני Broadcom Carbon Black EDR
גרסת המנתח: 17.0
במסמך הזה מוסבר איך להטמיע יומני Broadcom Carbon Black EDR ב-Google Security Operations באמצעות סוכן Bindplane או Amazon S3.
Broadcom Carbon Black EDR (לשעבר VMware Carbon Black EDR) הוא פתרון לזיהוי ותגובה בנקודות קצה (EDR) שמספק חשיפה רציפה לפעילות בנקודות הקצה. הוא מתעד ומאחסן נתונים מקיפים של נקודות קצה, ומאפשר לאתר איומים, להגיב לאירועים ולזהות איומים מתקדמים בזמן אמת בכל הארגון. הרכיב cb-event-forwarder נרשם לאפיק האירועים של EDR ומייצא אירועים בפורמט JSON או LEEF ליעדים חיצוניים, כולל שרתי syslog וקטגוריות של Amazon S3.
לפני שמתחילים
חשוב לוודא שיש לכם את הדברים הבאים:
- מכונה של Google SecOps
- גישה עם הרשאות (root או sudo) לשרת Carbon Black EDR
- הרכיב cb-event-forwarder שמותקן בשרת Carbon Black EDR (הוראות להתקנה מפורטות במאמר cb-event-forwarder ב-GitHub)
- טוקן גישה תקין מפורטל התמיכה של Broadcom להורדת החבילה cb-event-forwarder
- פרטי הכניסה ל-RabbitMQ משרת ה-EDR (
/etc/cb/cb.conf) אם cb-event-forwarder מותקן במארח נפרד
אפשרות 1: הטמעת Syslog באמצעות סוכן Bindplane
קבלת פרטי כניסה ל-Google SecOps בשביל סוכן Bindplane
כדי לאמת את סוכן Bindplane ב-Google SecOps, בוחרים באחת מהשיטות הבאות:
- פריסות חדשות: משתמשים ב-Chronicle API (אפשרות 1).
- פריסות קודמות: ממשיכים להשתמש בקובץ האימות להטמעת נתונים (אפשרות 2) עד שה-Ingestion API יופסק ב-20 ביולי 2027.
אפשרות 1: יצירת חשבון שירות ל-Chronicle API (מומלץ)
- נכנסים למסוףGoogle Cloud ובוחרים את הפרויקט ב- Google Cloud שמקושר למכונה של Google SecOps.
- נכנסים לדף IAM & Admin > Service Accounts.
- לוחצים על Create service account.
- מזינים את פרטי ההגדרה הבאים:
- Service account name: מזינים שם לחשבון (לדוגמה,
bindplane-ingest). - Service account description: מזינים תיאור (לדוגמה,
Bindplane agent log ingestion).
- Service account name: מזינים שם לחשבון (לדוגמה,
- לוחצים על Create and continue.
- בקטע Grant this service account access to project, לוחצים על Select a role ובוחרים באפשרות Chronicle Editor.
- לוחצים על המשך ואז על סיום.
- לוחצים על חשבון השירות שיצרתם ועוברים לכרטיסייה Keys.
- לוחצים על Add key > Create new key.
- בוחרים באפשרות JSON ולוחצים על Create. קובץ המפתח יורד למחשב.
- שומרים את קובץ המפתח בתור
ingestion-auth.jsonבספריית Bindplane collector (/opt/observiq-otel-collector/ingestion-auth.jsonב-Linux אוC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.jsonב-Windows), או מעדכנים אתcreds_file_pathב-config.yamlכך שיתאים לנתיב שבו שמרתם אותו. - עוברים אל IAM & Admin > Settings ומעתיקים את הערך של Project number. תצטרכו אותו כדי להגדיר את הייצוא.
אפשרות 2: הורדה של קובץ האימות להטמעת נתונים (גרסה קודמת)
- נכנסים למסוף Google SecOps.
- עוברים אל הגדרות > ניהול נתונים > סוכני איסוף. אם אתם משתמשים בפלטפורמת SIEM בלבד, עוברים אל הגדרות > סוכני איסוף.
- מורידים את קובץ האימות להטמעת נתונים.
- שומרים את הקובץ בצורה מאובטחת במערכת שבה יותקן הסוכן של Bindplane.
איך מקבלים את מספר הלקוח ב-Google SecOps
- נכנסים למסוף Google SecOps.
- עוברים אל הגדרות > ניהול > פרופיל. אם אתם משתמשים בפלטפורמה של SIEM בלבד, עוברים אל הגדרות > פרופיל.
- מעתיקים את מספר הלקוח מהקטע פרטי הארגון ושומרים אותו.
התקנת הסוכן של Bindplane
מתקינים את הסוכן של Bindplane במערכת ההפעלה Windows או Linux לפי ההוראות הבאות.
התקנת חלונות
- פותחים את שורת הפקודה או את PowerShell כאדמין.
מריצים את הפקודה הבאה:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietמחכים שההתקנה תסתיים.
כדי לוודא שההתקנה בוצעה, מריצים את הפקודה:
sc query observiq-otel-collector
השירות אמור להופיע כ-RUNNING.
התקנה ב-Linux
- פותחים טרמינל עם הרשאות root או sudo.
מריצים את הפקודה הבאה:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shמחכים שההתקנה תסתיים.
כדי לוודא שההתקנה בוצעה, מריצים את הפקודה:
sudo systemctl status observiq-otel-collector
השירות אמור להופיע כפעיל (פועל).
מקורות מידע נוספים בנושא התקנה
במדריך להתקנת הסוכן של Bindplane מפורטות אפשרויות התקנה נוספות ופתרונות לבעיות.
הגדרת סוכן Bindplane להטמעת syslog ושליחה אל Google SecOps
מאתרים את קובץ התצורה
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
עריכת קובץ התצורה
מחליפים את כל התוכן של
config.yamlבהגדרות הבאות:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/cb_edr: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<your-customer-id>' endpoint: chronicle.googleapis.com log_type: CB_EDR raw_log_field: body ingestion_labels: env: production service: pipelines: logs/cb_edr_to_chronicle: receivers: - tcplog exporters: - chronicle/cb_edr
פרמטרים להגדרה
מחליפים את ה-placeholders הבאים:
-
creds_file_path: הנתיב המלא לקובץ המפתח של חשבון השירות בפורמט JSON (אפשרות 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: מספר הלקוח שהועתק ממסוף Google SecOps-
location: מחליפים את<LOCATION>באזור של המכונה של Google SecOps (לדוגמה,us,europeאוasia-southeast1). המייצא מוסיף את הערך הזה בתחילתchronicle.googleapis.com. לרשימה המלאה, ראו נקודות קצה אזוריות. -
project: מחליפים את<PROJECT_NUMBER>במספר הפרויקט שמופיע בקטע IAM & Admin > Settings. -
endpoint: משאירים את הערךchronicle.googleapis.com.
-
מייצא API להטמעה מדור קודם
אם אתם משתמשים בקובץ האימות להטמעת נתונים מאפשרות 2, החליפו את הבלוק
exportersבקוד הבא. מגדירים אתcreds_file_pathלנתיב של קובץ האימות להטמעת נתונים. אם המכונה נמצאת מחוץ לארה"ב, מחליפים אתmalachiteingestion-pa.googleapis.comבנקודת הקצה האזורית (לדוגמה,europe-malachiteingestion-pa.googleapis.com).exporters: chronicle/cb_edr: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<your-customer-id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CB_EDR raw_log_field: body ingestion_labels: env: production
שמירת קובץ התצורה
- אחרי שמסיימים לערוך, שומרים את הקובץ:
- Linux: לוחצים על
Ctrl+O, אחר כך עלEnterואז עלCtrl+X - Windows: לוחצים על קובץ > שמירה
- Linux: לוחצים על
מפעילים מחדש את הסוכן של Bindplane כדי להחיל את השינויים.
כדי להפעיל מחדש את הסוכן של Bindplane ב-Linux, מריצים את הפקודה הבאה:
sudo systemctl restart observiq-otel-collectorמוודאים שהשירות פועל:
sudo systemctl status observiq-otel-collectorבודקים אם יש שגיאות ביומנים:
sudo journalctl -u observiq-otel-collector -f
כדי להפעיל מחדש את הסוכן של Bindplane ב-Windows, בוחרים באחת מהאפשרויות הבאות:
- שורת הפקודה או PowerShell כאדמין:
net stop observiq-otel-collector && net start observiq-otel-collectorמסוף השירותים:
- לוחצים על
Win+R, מקלידיםservices.mscולוחצים על Enter. - מאתרים את observIQ OpenTelemetry Collector.
- לוחצים לחיצה ימנית ובוחרים באפשרות הפעלה מחדש.
מוודאים שהשירות פועל:
sc query observiq-otel-collectorבודקים אם יש שגיאות ביומנים:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- לוחצים על
הגדרת cb-event-forwarder של Carbon Black EDR לפלט של syslog
- נכנסים לשרת Carbon Black EDR באמצעות SSH.
פותחים את קובץ התצורה של cb-event-forwarder:
sudo nano /etc/cb/integrations/event-forwarder/cb-event-forwarder.confבקטע
[bridge], קובעים את ההגדרות הבאות:[bridge] server_name=cbserverאם cb-event-forwarder מותקן במארח נפרד משרת ה-EDR, צריך לספק את פרטי הכניסה ואת שם המארח של RabbitMQ. אפשר למצוא את הערכים האלה ב-
/etc/cb/cb.confבשרת ה-EDR:rabbit_mq_username=cb rabbit_mq_password=<RABBITMQ_PASSWORD> cb_server_hostname=<EDR_SERVER_IP_OR_HOSTNAME>אופציונלי: מגדירים את
cb_server_urlכדי להפעיל קישורי עומק באירועים שהועברו שמפנים חזרה למסוף ה-EDR:cb_server_url=https://<YOUR_EDR_SERVER_FQDN>מגדירים את סוג הפלט והפורמט של מסירת syslog:
output_type=tcp output_format=json tcpout=<BINDPLANE_AGENT_IP>:514מגדירים אילו אירועים להעביר. ההגדרות הבאות קובעות את המינויים לאירועים:
events_raw_sensor=0 events_watchlist=ALL events_feed=ALL events_alert=ALLשומרים וסוגרים את קובץ התצורה.
מפעילים מחדש את השירות cb-event-forwarder:
sudo systemctl restart cb-event-forwarderמוודאים שהשירות פועל:
sudo systemctl status cb-event-forwarderכדי לוודא שהיומנים נשלחים, בודקים את היומנים של סוכן Bindplane.
מידע נוסף זמין במאגר cb-event-forwarder ב-GitHub.
אפשרות 2: הטמעה של Amazon S3
הגדרת cb-event-forwarder של Carbon Black EDR לפלט S3
- נכנסים לשרת Carbon Black EDR באמצעות SSH.
פותחים את קובץ התצורה של cb-event-forwarder:
sudo nano /etc/cb/integrations/event-forwarder/cb-event-forwarder.confבקטע
[bridge], קובעים את ההגדרות הבאות:[bridge] server_name=cbserverאם cb-event-forwarder מותקן במארח נפרד משרת ה-EDR, צריך לספק את פרטי הכניסה ואת שם המארח של RabbitMQ:
rabbit_mq_username=cb rabbit_mq_password=<RABBITMQ_PASSWORD> cb_server_hostname=<EDR_SERVER_IP_OR_HOSTNAME>אופציונלי: מגדירים את
cb_server_urlכדי להפעיל קישורי עומק באירועים שהועברו:cb_server_url=https://<YOUR_EDR_SERVER_FQDN>מגדירים את סוג הפלט והפורמט למסירה ב-S3:
output_type=s3 output_format=json s3out=<TEMP_DIR>:<AWS_REGION>:<S3_BUCKET_NAME>אופציונלי: קובעים הגדרות S3 נוספות בקטע
[s3]:[s3] bundle_send_timeout=300 upload_empty_files=false bundle_size_max=10485760מגדירים אילו אירועים להעביר:
events_raw_sensor=0 events_watchlist=ALL events_feed=ALL events_alert=ALLשומרים וסוגרים את קובץ התצורה.
מפעילים מחדש את השירות cb-event-forwarder:
sudo systemctl restart cb-event-forwarderמוודאים שהשירות פועל:
sudo systemctl status cb-event-forwarder
מידע נוסף זמין במאגר cb-event-forwarder ב-GitHub.
הגדרת קטגוריית AWS S3 ו-IAM ל-Google SecOps
- יוצרים קטגוריה של Amazon S3 לפי המדריך למשתמש: יצירת קטגוריה.
- שומרים את הערכים של Name ו-Region של הקטגוריה לשימוש עתידי.
- יוצרים משתמש לפי המדריך למשתמש: יצירת משתמש IAM.
- בוחרים את המשתמש שנוצר.
- לוחצים על הכרטיסייה פרטי כניסה מאובטחים.
- בקטע Access Keys, לוחצים על Create Access Key.
- בוחרים באפשרות שירות של צד שלישי בתור תרחיש לדוגמה.
- לוחצים על הבא.
- אופציונלי: מוסיפים תג תיאור.
- לוחצים על יצירת מפתח גישה.
- לוחצים על Download .csv file כדי לשמור את Access Key ואת Secret Access Key לשימוש עתידי.
- לוחצים על סיום.
- לוחצים על הכרטיסייה הרשאות.
- בקטע מדיניות הרשאות, לוחצים על הוספת הרשאות.
- לוחצים על הוספת הרשאות.
- בוחרים באפשרות Attach policies directly.
- מחפשים את המדיניות AmazonS3FullAccess.
- בוחרים את המדיניות.
- לוחצים על הבא.
- לוחצים על הוספת הרשאות.
הגדרת פיד ב-Google SecOps כדי להטמיע יומני Carbon Black EDR
- עוברים אל הגדרות > ניהול נתונים > פידים. אם אתם משתמשים בפלטפורמה של SIEM בלבד, עוברים אל הגדרות > פידים.
- לוחצים על הוספת פיד חדש.
- בדף הבא, לוחצים על הגדרת פיד יחיד.
- מזינים שם ייחודי בשדה שם הפיד.
- בוחרים באפשרות Amazon S3 V2 בתור סוג המקור.
- בוחרים באפשרות Carbon Black EDR בתור סוג היומן.
- לוחצים על הבא ואז על שליחה.
מציינים ערכים בשדות הבאים:
- S3 URI:
s3://<S3_BUCKET_NAME>/ - אפשרות מחיקת מקור: בוחרים את אפשרות המחיקה לפי ההעדפה שלכם.
- גיל הקובץ המקסימלי: כולל קבצים ששונו במספר הימים האחרונים (ברירת המחדל היא 180 ימים)
- מזהה מפתח הגישה: מפתח גישה של משתמש עם גישה לקטגוריית S3
- מפתח גישה סודי: מפתח סודי של משתמש עם גישה לקטגוריית S3
- מרחב השמות של הנכס: מרחב השמות של הנכס
- תוויות הטמעה: התווית שתתווסף לאירועים מהפיד הזה
- S3 URI:
לוחצים על הבא ואז על שליחה.
טבלת מיפוי UDM
| שדה ביומן | מיפוי UDM | Logic (פונקציה לוגית) |
|---|---|---|
ioc_about |
about |
ממוזג |
ioc_attrs_highlights_about |
about |
ממוזג |
ioc_qs_about |
about |
ממוזג |
local_about |
about |
ממוזג |
remote_about |
about |
ממוזג |
additional_blocked_threat_category |
additional.fields |
ממוזג |
additional_cmdline |
additional.fields |
ממוזג |
additional_created_by_event_id |
additional.fields |
ממוזג |
additional_crossproc_api |
additional.fields |
ממוזג |
additional_crossproc_guid |
additional.fields |
ממוזג |
additional_crossproc_md5 |
additional.fields |
ממוזג |
additional_crossproc_rep |
additional.fields |
ממוזג |
additional_crossproc_sha256 |
additional.fields |
ממוזג |
additional_crossproc_target |
additional.fields |
ממוזג |
additional_data |
additional.fields |
ממוזג |
additional_device_location |
additional.fields |
ממוזג |
additional_dns_name |
additional.fields |
ממוזג |
additional_event_id |
additional.fields |
ממוזג |
additional_fileless_scriptload_cmdline_length |
additional.fields |
ממוזג |
additional_fileless_scriptload_hash |
additional.fields |
ממוזג |
additional_first_event_time |
additional.fields |
ממוזג |
additional_ioc_confidence |
additional.fields |
ממוזג |
additional_ioc_query_index |
additional.fields |
ממוזג |
additional_ioc_query_string |
additional.fields |
ממוזג |
additional_ioc_type |
additional.fields |
ממוזג |
additional_ja3 |
additional.fields |
ממוזג |
additional_ja3s |
additional.fields |
ממוזג |
additional_last_event_time |
additional.fields |
ממוזג |
additional_last_update_time |
additional.fields |
ממוזג |
additional_not_blocked_threat_category |
additional.fields |
ממוזג |
additional_parent_name |
additional.fields |
ממוזג |
additional_path |
additional.fields |
ממוזג |
additional_policy_applied |
additional.fields |
ממוזג |
additional_policy_id |
additional.fields |
ממוזג |
additional_process_name |
additional.fields |
ממוזג |
additional_process_name_field |
additional.fields |
ממוזג |
additional_process_sha256 |
additional.fields |
ממוזג |
additional_reason_code |
additional.fields |
ממוזג |
additional_regmod_count |
additional.fields |
ממוזג |
additional_report_id |
additional.fields |
ממוזג |
additional_run_state |
additional.fields |
ממוזג |
additional_scriptload_count |
additional.fields |
ממוזג |
additional_scriptload_rep |
additional.fields |
ממוזג |
additional_start |
additional.fields |
ממוזג |
additional_status |
additional.fields |
ממוזג |
additional_threat_cause_actor_process_pid |
additional.fields |
ממוזג |
additional_threat_cause_actor_sha256 |
additional.fields |
ממוזג |
additional_threat_cause_cause_event_id |
additional.fields |
ממוזג |
additional_threat_cause_reputation |
additional.fields |
ממוזג |
additional_threat_cause_threat_category |
additional.fields |
ממוזג |
additional_threat_cause_vector |
additional.fields |
ממוזג |
additional_username |
additional.fields |
ממוזג |
additional_watchlist_id |
additional.fields |
ממוזג |
additional_watchlist_name |
additional.fields |
ממוזג |
additional_workflow_changed_by |
additional.fields |
ממוזג |
additional_workflow_comment |
additional.fields |
ממוזג |
additional_workflow_remediation |
additional.fields |
ממוזג |
additional_workflow_state |
additional.fields |
ממוזג |
alert_origin_label |
additional.fields |
ממוזג |
change_timestamp_label |
additional.fields |
ממוזג |
changed_by_label |
additional.fields |
ממוזג |
changed_by_type_label |
additional.fields |
ממוזג |
closure_reason_label |
additional.fields |
ממוזג |
comms_ip_label |
additional.fields |
ממוזג |
detection_timestamp_label |
additional.fields |
ממוזג |
index_type_label |
additional.fields |
ממוזג |
last_event_timestamp_label |
additional.fields |
ממוזג |
last_update_label |
additional.fields |
ממוזג |
parent_effective_reputation_label |
additional.fields |
ממוזג |
parent_reputation_label |
additional.fields |
ממוזג |
primary_event_id_label |
additional.fields |
ממוזג |
process_effective_reputation_label |
additional.fields |
ממוזג |
process_issuer_label |
additional.fields |
ממוזג |
process_publisher_label |
additional.fields |
ממוזג |
product_name_label |
additional.fields |
ממוזג |
search_query_label |
additional.fields |
ממוזג |
segment_id_label |
additional.fields |
ממוזג |
start_time_label |
additional.fields |
ממוזג |
status_label |
additional.fields |
ממוזג |
vendor_name_label |
additional.fields |
ממוזג |
_intermediary |
intermediary |
ממוזג |
intermediary |
intermediary |
ממוזג |
device_name |
intermediary.asset.hostname |
מיפוי ישיר |
device_internal_ip |
intermediary.asset.ip |
ממוזג |
device_name |
intermediary.hostname |
מיפוי ישיר |
comms_ip |
intermediary.ip |
ממוזג |
device_internal_ip |
intermediary.ip |
ממוזג |
intermediary_ip |
intermediary.ip |
ממוזג |
description |
metadata.description |
מיפוי ישיר |
event_description |
metadata.description |
שינוי שם/מיפוי |
reason |
metadata.description |
מיפוי ישיר |
action |
metadata.product_event_type |
מיפוי ישיר |
type |
metadata.product_event_type |
מיפוי ישיר |
id |
metadata.product_log_id |
מיפוי ישיר |
cb_version |
metadata.product_version |
מיפוי ישיר |
alert_url |
metadata.url_back_to_product |
מיפוי ישיר |
direction |
network.direction |
מיפוי ישיר |
ioc_attr.direction |
network.direction |
מיפוי ישיר |
ioc_attr.protocol |
network.ip_protocol |
מיפוי ישיר |
ip_protocol_out |
network.ip_protocol |
שינוי שם/מיפוי |
session_id |
network.session_id |
מיפוי ישיר |
proxy_domain |
observer.hostname |
מיפוי ישיר |
proxy_ip |
observer.ip |
ממוזג |
proxy_port |
observer.port |
שינוי שם/מיפוי |
device_username |
principal.administrative_domain |
מיפוי ישיר |
domain |
principal.administrative_domain |
מיפוי ישיר |
orgName |
principal.administrative_domain |
מיפוי ישיר |
deviceInfo.deviceId |
principal.asset.asset_id |
מיפוי ישיר |
device_id |
principal.asset.asset_id |
מיפוי ישיר |
asset_group_label |
principal.asset.attribute.labels |
ממוזג |
device_target_value_label |
principal.asset.attribute.labels |
ממוזג |
device_uem_id_label |
principal.asset.attribute.labels |
ממוזג |
computer_name |
principal.asset.hostname |
מיפוי ישיר |
dev_hostname |
principal.asset.hostname |
מיפוי ישיר |
device_name |
principal.asset.hostname |
מיפוי ישיר |
host |
principal.asset.hostname |
מיפוי ישיר |
clientIp |
principal.asset.ip |
ממוזג |
deviceInfo.internalIpAddress |
principal.asset.ip |
ממוזג |
device_external_ip |
principal.asset.ip |
ממוזג |
device_internal_ip |
principal.asset.ip |
ממוזג |
docs.0.interface_ip |
principal.asset.ip |
ממוזג |
interface_ip |
principal.asset.ip |
ממוזג |
local_ip |
principal.asset.ip |
ממוזג |
remote_ip |
principal.asset.ip |
ממוזג |
device_location |
principal.asset.location.name |
מיפוי ישיר |
deviceInfo.deviceVersion |
principal.asset.platform_software.platform_version |
מיפוי ישיר |
sensor_id |
principal.asset_id |
מיפוי ישיר |
deviceInfo.groupName |
principal.group.group_display_name |
מיפוי ישיר |
device_group |
principal.group.group_display_name |
מיפוי ישיר |
group |
principal.group.group_display_name |
מיפוי ישיר |
computer_name |
principal.hostname |
מיפוי ישיר |
dev_hostname |
principal.hostname |
מיפוי ישיר |
device_name |
principal.hostname |
מיפוי ישיר |
host |
principal.hostname |
מיפוי ישיר |
clientIp |
principal.ip |
ממוזג |
deviceInfo.internalIpAddress |
principal.ip |
ממוזג |
device_external_ip |
principal.ip |
ממוזג |
device_internal_ip |
principal.ip |
ממוזג |
docs.0.interface_ip |
principal.ip |
ממוזג |
interface_ip |
principal.ip |
ממוזג |
local_ip |
principal.ip |
ממוזג |
remote_ip |
principal.ip |
ממוזג |
device_external_ip |
principal.nat_ip |
ממוזג |
normalized_device_os |
principal.platform |
מיפוי ישיר |
device_os_version |
principal.platform_version |
מיפוי ישיר |
local_port |
principal.port |
שינוי שם/מיפוי |
remote_port |
principal.port |
שינוי שם/מיפוי |
process_cmdline |
principal.process.command_line |
מיפוי ישיר |
parent_path |
principal.process.file.full_path |
מיפוי ישיר |
process_name |
principal.process.file.full_path |
מיפוי ישיר |
process_path |
principal.process.file.full_path |
מיפוי ישיר |
doc.process_md5 |
principal.process.file.md5 |
מיפוי ישיר |
md5 |
principal.process.file.md5 |
מיפוי ישיר |
parent_md5 |
principal.process.file.md5 |
מיפוי ישיר |
process_hash.0 |
principal.process.file.md5 |
מיפוי ישיר |
process_md5 |
principal.process.file.md5 |
מיפוי ישיר |
doc.process_sha256 |
principal.process.file.sha256 |
מיפוי ישיר |
process_hash.1 |
principal.process.file.sha256 |
מיפוי ישיר |
process_sha256 |
principal.process.file.sha256 |
מיפוי ישיר |
sha256 |
principal.process.file.sha256 |
מיפוי ישיר |
parent_cmdline |
principal.process.parent_process.command_line |
מיפוי ישיר |
parent_name |
principal.process.parent_process.file.full_path |
מיפוי ישיר |
parent_path |
principal.process.parent_process.file.full_path |
מיפוי ישיר |
val.parent_name |
principal.process.parent_process.file.full_path |
מיפוי ישיר |
parent_hash.0 |
principal.process.parent_process.file.md5 |
מיפוי ישיר |
parent_md5 |
principal.process.parent_process.file.md5 |
מיפוי ישיר |
parent_hash.1 |
principal.process.parent_process.file.sha256 |
מיפוי ישיר |
parent_sha256 |
principal.process.parent_process.file.sha256 |
מיפוי ישיר |
doc.parent_pid |
principal.process.parent_process.pid |
מיפוי ישיר |
parent_pid |
principal.process.parent_process.pid |
מיפוי ישיר |
doc.parent_guid |
principal.process.parent_process.product_specific_process_id |
מיפוי ישיר |
parent_guid |
principal.process.parent_process.product_specific_process_id |
מיפוי ישיר |
parent_username |
principal.process.parent_process.user.userid |
שינוי שם/מיפוי |
doc.process_pid |
principal.process.pid |
מיפוי ישיר |
parent_pid |
principal.process.pid |
מיפוי ישיר |
pid |
principal.process.pid |
מיפוי ישיר |
process_id |
principal.process.pid |
מיפוי ישיר |
process_pid |
principal.process.pid |
מיפוי ישיר |
parent_process_guid |
principal.process.product_specific_process_id |
מיפוי ישיר |
process_guid |
principal.process.product_specific_process_id |
מיפוי ישיר |
org_key_label |
principal.resource.attribute.labels |
ממוזג |
feed_id |
principal.resource.id |
מיפוי ישיר |
feed_name |
principal.resource.name |
מיפוי ישיר |
link_process |
principal.url |
שינוי שם/מיפוי |
process_username |
principal.user.user_display_name |
מיפוי ישיר |
dev_username |
principal.user.userid |
שינוי שם/מיפוי |
process_username |
principal.user.userid |
מיפוי ישיר |
username |
principal.user.userid |
מיפוי ישיר |
_security_result |
security_result |
ממוזג |
_security_result0 |
security_result |
ממוזג |
sec_result |
security_result |
ממוזג |
security_result |
security_result |
ממוזג |
security_result_attack |
security_result |
ממוזג |
sec_action |
security_result.action |
ממוזג |
policy_applied |
security_result.action_details |
מיפוי ישיר |
tactic |
security_result.attack_details.tactics |
ממוזג |
category |
security_result.category_details |
ממוזג |
report_description |
security_result.description |
מיפוי ישיר |
alert_notes_present_label |
security_result.detection_fields |
ממוזג |
childproc_effective_reputation_label |
security_result.detection_fields |
ממוזג |
childproc_publisher_name_label |
security_result.detection_fields |
ממוזג |
childproc_publisher_state_label |
security_result.detection_fields |
ממוזג |
childproc_rep_label |
security_result.detection_fields |
ממוזג |
detection_action |
security_result.detection_fields |
ממוזג |
detection_blocked_threat_category |
security_result.detection_fields |
ממוזג |
detection_crossproc_publisher_name |
security_result.detection_fields |
ממוזג |
detection_crossproc_publisher_state |
security_result.detection_fields |
ממוזג |
detection_event_origin |
security_result.detection_fields |
ממוזג |
detection_event_origin_proc_publisher_name |
security_result.detection_fields |
ממוזג |
detection_event_origin_proc_publisher_state |
security_result.detection_fields |
ממוזג |
detection_fileless_scriptload_cmdline |
security_result.detection_fields |
ממוזג |
detection_ioc_hit |
security_result.detection_fields |
ממוזג |
detection_ioc_id |
security_result.detection_fields |
ממוזג |
detection_not_blocked_threat_category |
security_result.detection_fields |
ממוזג |
detection_policy_name |
security_result.detection_fields |
ממוזג |
detection_report_link |
security_result.detection_fields |
ממוזג |
detection_report_name |
security_result.detection_fields |
ממוזג |
detection_run_state |
security_result.detection_fields |
ממוזג |
detection_scriptload_eff_rep |
security_result.detection_fields |
ממוזג |
detection_scriptload_publisher |
security_result.detection_fields |
ממוזג |
detection_sensor_action |
security_result.detection_fields |
ממוזג |
detection_threat_cause_actor_name |
security_result.detection_fields |
ממוזג |
detection_threat_cause_actor_sha256 |
security_result.detection_fields |
ממוזג |
detection_threat_cause_threat_category |
security_result.detection_fields |
ממוזג |
determination_change_timestamp_label |
security_result.detection_fields |
ממוזג |
determination_changed_by_label |
security_result.detection_fields |
ממוזג |
determination_changed_by_type_label |
security_result.detection_fields |
ממוזג |
determination_value_label |
security_result.detection_fields |
ממוזג |
device_policy_id_label |
security_result.detection_fields |
ממוזג |
id_label |
security_result.detection_fields |
ממוזג |
is_updated_label |
security_result.detection_fields |
ממוזג |
label_alert_severity |
security_result.detection_fields |
ממוזג |
label_device_priority_field |
security_result.detection_fields |
ממוזג |
label_eff_rep |
security_result.detection_fields |
ממוזג |
label_modload_count |
security_result.detection_fields |
ממוזג |
label_modload_md5 |
security_result.detection_fields |
ממוזג |
label_modload_publisher_name |
security_result.detection_fields |
ממוזג |
label_modload_publisher_state |
security_result.detection_fields |
ממוזג |
label_modload_sha256 |
security_result.detection_fields |
ממוזג |
mdr_alert_label |
security_result.detection_fields |
ממוזג |
mdr_alert_notes_present_label |
security_result.detection_fields |
ממוזג |
mdr_threat_notes_present_label |
security_result.detection_fields |
ממוזג |
modload_label |
security_result.detection_fields |
ממוזג |
name_label |
security_result.detection_fields |
ממוזג |
parent_username_label |
security_result.detection_fields |
ממוזג |
process_reputation_label |
security_result.detection_fields |
ממוזג |
process_username_label |
security_result.detection_fields |
ממוזג |
reason_code_label |
security_result.detection_fields |
ממוזג |
run_state_label |
security_result.detection_fields |
ממוזג |
tags_label |
security_result.detection_fields |
ממוזג |
threat_notes_present_label |
security_result.detection_fields |
ממוזג |
workflow_status_label |
security_result.detection_fields |
ממוזג |
device_policy |
security_result.rule_name |
מיפוי ישיר |
severity |
security_result.severity |
מיפוי ישיר |
threat_id |
security_result.threat_id |
מיפוי ישיר |
threat_cause_actor_name |
security_result.threat_name |
מיפוי ישיר |
device_external_ip |
target.asset.ip |
ממוזג |
ioc_value |
target.asset.ip |
ממוזג |
local_ip |
target.asset.ip |
ממוזג |
netconn_ip |
target.asset.ip |
ממוזג |
remote_ip |
target.asset.ip |
ממוזג |
filemod_name |
target.file.full_path |
מיפוי ישיר |
path |
target.file.full_path |
מיפוי ישיר |
process_path |
target.file.full_path |
מיפוי ישיר |
utf8_on_disk_filename |
target.file.full_path |
מיפוי ישיר |
file_md5 |
target.file.md5 |
מיפוי ישיר |
filemod_hash.0 |
target.file.md5 |
שינוי שם/מיפוי |
md5 |
target.file.md5 |
מיפוי ישיר |
file_sha256 |
target.file.sha256 |
מיפוי ישיר |
filemod_hash.1 |
target.file.sha256 |
שינוי שם/מיפוי |
sha256 |
target.file.sha256 |
מיפוי ישיר |
size |
target.file.size |
שינוי שם/מיפוי |
group |
target.group.group_display_name |
מיפוי ישיר |
domain |
target.hostname |
מיפוי ישיר |
netconn_domain |
target.hostname |
מיפוי ישיר |
deviceInfo.externalIpAddress |
target.ip |
ממוזג |
device_external_ip |
target.ip |
ממוזג |
ioc_value |
target.ip |
ממוזג |
local_ip |
target.ip |
ממוזג |
netconn_ip |
target.ip |
ממוזג |
remote_ip |
target.ip |
ממוזג |
normalized_device_os |
target.platform |
מיפוי ישיר |
local_port |
target.port |
שינוי שם/מיפוי |
remote_port |
target.port |
שינוי שם/מיפוי |
requested_access |
target.process.access_mask |
שינוי שם/מיפוי |
child_command_line |
target.process.command_line |
מיפוי ישיר |
childproc_cmdline |
target.process.command_line |
מיפוי ישיר |
cmdline |
target.process.command_line |
מיפוי ישיר |
command_line |
target.process.command_line |
מיפוי ישיר |
docs.0.cmdline |
target.process.command_line |
מיפוי ישיר |
process_cmdline |
target.process.command_line |
מיפוי ישיר |
target_cmdline |
target.process.command_line |
מיפוי ישיר |
childproc_name |
target.process.file.full_path |
מיפוי ישיר |
crossproc_name |
target.process.file.full_path |
מיפוי ישיר |
docs.0.path |
target.process.file.full_path |
מיפוי ישיר |
modload_name |
target.process.file.full_path |
מיפוי ישיר |
path |
target.process.file.full_path |
מיפוי ישיר |
process_path |
target.process.file.full_path |
מיפוי ישיר |
target_path |
target.process.file.full_path |
מיפוי ישיר |
childproc_hash.0 |
target.process.file.md5 |
שינוי שם/מיפוי |
md5 |
target.process.file.md5 |
מיפוי ישיר |
target_md5 |
target.process.file.md5 |
מיפוי ישיר |
childproc_hash.1 |
target.process.file.sha256 |
שינוי שם/מיפוי |
childproc_sha256 |
target.process.file.sha256 |
מיפוי ישיר |
sha256 |
target.process.file.sha256 |
מיפוי ישיר |
target_sha256 |
target.process.file.sha256 |
מיפוי ישיר |
parent_path |
target.process.parent_process.file.full_path |
מיפוי ישיר |
docs.0.parent_pid |
target.process.parent_process.pid |
מיפוי ישיר |
parent_pid |
target.process.parent_process.pid |
מיפוי ישיר |
docs.0.parent_guid |
target.process.parent_process.product_specific_process_id |
מיפוי ישיר |
child_pid |
target.process.pid |
מיפוי ישיר |
childproc_pid |
target.process.pid |
שינוי שם/מיפוי |
docs.0.process_pid |
target.process.pid |
מיפוי ישיר |
pid |
target.process.pid |
מיפוי ישיר |
process_pid |
target.process.pid |
מיפוי ישיר |
target_pid |
target.process.pid |
מיפוי ישיר |
child_process_guid |
target.process.product_specific_process_id |
מיפוי ישיר |
childproc_guid |
target.process.product_specific_process_id |
מיפוי ישיר |
docs.0.process_guid |
target.process.product_specific_process_id |
מיפוי ישיר |
process_guid |
target.process.product_specific_process_id |
מיפוי ישיר |
target_process_guid |
target.process.product_specific_process_id |
מיפוי ישיר |
path |
target.registry.registry_key |
מיפוי ישיר |
path1 |
target.registry.registry_key |
מיפוי ישיר |
regmod_key |
target.registry.registry_key |
מיפוי ישיר |
regmod_name |
target.registry.registry_key |
מיפוי ישיר |
regmod_value |
target.registry.registry_value_name |
מיפוי ישיר |
value_name |
target.registry.registry_value_name |
מיפוי ישיר |
product_id_label |
target.resource.attribute.labels |
ממוזג |
serial_number_label |
target.resource.attribute.labels |
ממוזג |
vendor_id_label |
target.resource.attribute.labels |
ממוזג |
report_id |
target.resource.id |
מיפוי ישיר |
watchlist_id |
target.resource.id |
מיפוי ישיר |
external_device_friendly_name |
target.resource.name |
מיפוי ישיר |
watchlist_name |
target.resource.name |
מיפוי ישיר |
docs.0.link_process |
target.url |
מיפוי ישיר |
loginName |
target.user.email_addresses |
ממוזג |
child_username |
target.user.userid |
מיפוי ישיר |
childproc_username |
target.user.userid |
מיפוי ישיר |
docs.0.username |
target.user.userid |
שינוי שם/מיפוי |
loginName |
target.user.userid |
מיפוי ישיר |
| לא רלוונטי | about |
קבוע: local_about |
| לא רלוונטי | additional.fields |
קבוע: additional_data |
| לא רלוונטי | extensions.auth.type |
קבוע: AUTHTYPE_UNSPECIFIED |
| לא רלוונטי | intermediary |
קבוע: _intermediary |
| לא רלוונטי | intermediary.asset.ip |
קבוע: device_internal_ip |
| לא רלוונטי | intermediary.ip |
קבוע: device_internal_ip |
| לא רלוונטי | metadata.event_type |
קבוע: GENERIC_EVENT |
| לא רלוונטי | metadata.product_name |
קבוע: EDR |
| לא רלוונטי | metadata.vendor_name |
קבוע: Carbon Black |
| לא רלוונטי | network.direction |
קבוע: INBOUND |
| לא רלוונטי | network.ip_protocol |
קבוע: TCP |
| לא רלוונטי | observer.ip |
קבוע: proxy_ip |
| לא רלוונטי | principal.asset.attribute.labels |
קבוע: device_uem_id_label |
| לא רלוונטי | principal.asset.ip |
קבוע: local_ip |
| לא רלוונטי | principal.asset.platform_software.platform |
קבוע: WINDOWS |
| לא רלוונטי | principal.ip |
קבוע: local_ip |
| לא רלוונטי | principal.nat_ip |
קבוע: device_external_ip |
| לא רלוונטי | principal.platform |
קבוע: WINDOWS |
| לא רלוונטי | principal.resource.attribute.labels |
קבוע: org_key_label |
| לא רלוונטי | principal.resource.resource_subtype |
קבוע: Feed |
| לא רלוונטי | security_result |
קבוע: security_result |
| לא רלוונטי | security_result.action |
קבוע: sec_action |
| לא רלוונטי | security_result.alert_state |
קבוע: ALERTING |
| לא רלוונטי | security_result.attack_details.tactics |
קבוע: tactic |
| לא רלוונטי | security_result.category_details |
קבוע: category |
| לא רלוונטי | security_result.detection_fields |
קבוע: process_reputation_label |
| לא רלוונטי | security_result.severity |
קבוע: LOW |
| לא רלוונטי | target.asset.ip |
קבוע: device_external_ip |
| לא רלוונטי | target.ip |
קבוע: device_external_ip |
| לא רלוונטי | target.resource.attribute.labels |
קבוע: vendor_id_label |
| לא רלוונטי | target.resource.name |
קבוע: report_id |
| לא רלוונטי | target.resource.type |
קבוע: watchlist |
| לא רלוונטי | target.user.email_addresses |
קבוע: loginName |
org_key |
event.idm.read_only_udm.principal.resource.attribute.labels |
מופה מיומן השינויים |
workflow.changed_by |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
primary_event_id |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
workflow.closure_reason |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
workflow.changed_by_type |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
alert_origin |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
device_username |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
vendor_name |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
product_name |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
tags |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
run_state |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
workflow.status |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
alert_notes_present |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
threat_notes_present |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
is_updated |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
device_policy_id |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
mdr_alert |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
mdr_alert_notes_present |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
mdr_threat_notes_present |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
determination.changed_by |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
determination.changed_by_type |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
determination.value |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
reason_code |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
device_uem_id |
event.idm.read_only_udm.principal.asset.attribute.labels |
מופה מיומן השינויים |
device_target_value |
event.idm.read_only_udm.principal.asset.attribute.labels |
מופה מיומן השינויים |
asset_group |
event.idm.read_only_udm.principal.asset.attribute.labels |
מופה מיומן השינויים |
device_policy |
event.idm.read_only_udm.security_result.rule_name |
מופה מיומן השינויים |
device_location |
event.idm.read_only_udm.principal.asset.location.name |
מופה מיומן השינויים |
device_os_version |
event.idm.read_only_udm.principal.platform_version |
מופה מיומן השינויים |
vendor_id |
event.idm.read_only_udm.target.resource.attribute.labels |
מופה מיומן השינויים |
product_id |
event.idm.read_only_udm.target.resource.attribute.labels |
מופה מיומן השינויים |
serial_number |
event.idm.read_only_udm.target.resource.attribute.labels |
מופה מיומן השינויים |
external_device_friendly_name |
event.idm.read_only_udm.target.resource.name |
מופה מיומן השינויים |
first_event_timestamp |
event.idm.read_only_udm.metadata.event_timestamp |
מופה מיומן השינויים |
policy_applied |
event.idm.read_only_udm.security_result.action_details |
מופה מיומן השינויים |
device_internal_ip |
event.idm.read_only_udm.principal.ip וגם event.idm.read_only_udm.principal.asset.ip |
מופה מיומן השינויים |
threat_id |
event.idm.read_only_udm.security_result.threat_id |
מופה מיומן השינויים |
severity |
event.idm.read_only_udm.security_result.severity |
מופה מיומן השינויים |
id |
event.idm.read_only_udm.metadata.product_log_id |
מופה מיומן השינויים |
feed_id |
event.idm.read_only_udm.principal.resource.id |
מופה מיומן השינויים |
intermediary_ip |
event.idm.read_only_udm.intermediary.ip |
מופה מיומן השינויים |
session_id |
event.idm.read_only_udm.network.session_id |
מופה מיומן השינויים |
interface_ip |
event.idm.read_only_udm.principal.ip וגם event.idm.read_only_udm.principal.asset.ip |
מופה מיומן השינויים |
host |
event.idm.read_only_udm.principal.hostname וגם event.idm.read_only_udm.principal.asset.hostname |
מופה מיומן השינויים |
reason |
event.idm.read_only_udm.metadata.description |
מופה מיומן השינויים |
segment_id |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
index_type |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
search_query |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
start_time |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
last_update |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
watchlist_id |
event.idm.read_only_udm.target.resource.id |
מופה מיומן השינויים |
watchlist_name |
event.idm.read_only_udm.target.resource.name |
מופה מיומן השינויים |
group |
event.idm.read_only_udm.target.group.group_display_name |
מופה מיומן השינויים |
report_id |
event.idm.read_only_udm.target.resource.id |
מופה מיומן השינויים |
report_id |
event.idm.read_only_udm.target.resource.name |
מופה מיומן השינויים |
process_sha256 |
event.idm.read_only_udm.principal.process.file.sha256 |
מופה מיומן השינויים |
alliance_data_attackframework |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
alliance_updated_attackframework |
event.idm.read_only_udm.security_result.detection_fields |
מופה מיומן השינויים |
alliance_score_attackframework |
event.idm.read_only_udm.security_result.confidence_score |
מופה מיומן השינויים |
alliance_link_attackframework |
event.idm.read_only_udm.security_result.url_back_to_product |
מופה מיומן השינויים |
comms_ip |
event.idm.read_only_udm.additional.fields |
מופה מיומן השינויים |
יומן שינויים
הצגת יומן השינויים של המנתח הזה
הבעיה עדיין לא נפתרה? קבלת תשובות מחברי הקהילה וממומחי Google SecOps.