Broadcom CA PAM 로그 수집
파서 버전: 1.0
이 문서에서는 Bindplane을 사용하여 Broadcom CA Privileged Access Manager 로그를 Google Security Operations로 수집하는 방법을 설명합니다. Broadcom CA Privileged Access Manager (PAM)는 중요 시스템에 대한 권한이 있는 사용자 액세스를 제어, 모니터링, 감사하는 엔터프라이즈 권한 액세스 관리 솔루션입니다. 하이브리드 환경에서 사용자 인증 정보 보관, 세션 기록, 액세스 정책 적용을 제공합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스입니다.
- systemd가 있는 Windows 2016 이상 또는 Linux 호스트
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Broadcom 권한 액세스 관리 웹 UI에 대한 권한 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정> 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다. Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
- 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
추가 설치 리소스
추가 설치 옵션은 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일에 액세스합니다.
config.yaml파일을 찾습니다. 일반적으로 Linux에서는/observiq-otel-collector/디렉터리에 있고 Windows에서는 설치 디렉터리에 있습니다.- 텍스트 편집기 (예:
nano,vi, 메모장)를 사용하여 파일을 엽니다.
다음과 같이
config.yaml파일을 수정합니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/broadcom_ca_pam: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: BROADCOM_CA_PAM raw_log_field: body ingestion_labels: service: pipelines: logs/broadcom_ca_pam: receivers: - tcplog exporters: - chronicle/broadcom_ca_pam
- 인프라에 필요한 대로 포트와 IP 주소를 바꿉니다.
<customer_id>를 실제 고객 ID로 바꿉니다.- Google SecOps 수집 인증 파일 가져오기 섹션에서 인증 파일이 저장된 경로로
/path/to/ingestion-authentication-file.json를 업데이트합니다.
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음을 실행하세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 단계를 따르세요.
다음 옵션 중 하나를 선택합니다.
- 관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Broadcom CA PAM에서 원격 syslog 구성
- Privileged Access Management 웹 UI에 로그인합니다.
- 구성 > 로그 > Syslog로 이동합니다.
- Syslog Enabled(Syslog 사용 설정됨) 전환 버튼을 선택합니다.
- 메시지 형식 목록에서 공백으로 구분을 선택합니다.
- 서버 추가를 클릭합니다.
새 행에 다음 구성 세부정보를 입력합니다.
- 서버: Bindplane 에이전트 IP 주소 (예:
192.168.1.100)를 입력합니다. - 포트:
514(또는 구성된 Bindplane 에이전트 포트)를 입력합니다. 포트를 비워 두면 기본값은514입니다. - 프로토콜: TCP를 선택합니다.
- 서버: Bindplane 에이전트 IP 주소 (예:
업데이트를 클릭하여 설정을 저장합니다.
Bindplane 에이전트 로그를 확인하여 로그가 전송되고 있는지 확인합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
UserGroup_label |
additional.fields |
병합됨 |
access_protocol |
metadata.access_protocol |
직접 매핑됨 |
Details |
metadata.description |
직접 매핑됨 |
has_principal |
metadata.event_type |
매핑됨: true → SCAN_UNCATEGORIZED, true → STATUS_UPDATE |
has_user |
metadata.event_type |
매핑됨: true → USER_UNCATEGORIZED |
host |
principal.asset.hostname |
직접 매핑됨 |
host |
principal.hostname |
직접 매핑됨 |
NatIP |
principal.nat_ip |
병합됨 |
Port |
principal.port |
직접 매핑됨 |
pid |
principal.process.pid |
직접 매핑됨 |
DeviceName |
principal.resource.name |
직접 매핑됨 |
User |
principal.user.userid |
직접 매핑됨 |
sec_res |
security_result |
병합됨 |
detection_fields |
security_result.detection_fields |
병합됨 |
Service_App |
target.application |
직접 매핑됨 |
Address |
target.asset.hostname |
직접 매핑됨 |
Address |
target.hostname |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: SCAN_UNCATEGORIZED |
| 해당 사항 없음 | metadata.product_name |
상수: Broadcom CA Pam |
| 해당 사항 없음 | metadata.vendor_name |
상수: Broadcom |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.