BeyondTrust 원격 지원 로그 수집
파서 버전: 33.0
이 문서에서는 Bindplane을 사용하여 BeyondTrust Remote Support (이전 명칭: Bomgar) 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
BeyondTrust Remote Support는 세션 활동, 계정 이벤트, 로그인 이벤트, 구성 변경에 대한 syslog 메시지를 생성하는 원격 액세스 솔루션입니다. 파서는 필드를 정규화하고 통합 데이터 모델 (UDM)에 매핑합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 BeyondTrust 원격 지원 어플라이언스 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- BeyondTrust Remote Support에 대한 관리 액세스 권한
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 신규 배포: Chronicle API (옵션 1)를 사용합니다.
- 기존 배포: 2027년 7월 20일에 수집 API가 지원 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API용 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다 (예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가> 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 RUNNING으로 표시됩니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시됩니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/bomgar: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: BOMGAR raw_log_field: body service: pipelines: logs/bomgar_to_chronicle: receivers: - tcplog exporters: - chronicle/bomgar
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
listen_address: 리슨할 IP 주소 및 포트:0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 포트
514는 표준 syslog 포트입니다 (Linux에서 루트 필요, 루트가 아닌 경우1514사용).
내보내기 도구 구성:
creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps 콘솔에서 복사한 고객 IDlocation:<LOCATION>을 Google SecOps 인스턴스의 리전 (예:us,europe,asia-southeast1)으로 바꿉니다. 내보내기 프로그램은chronicle.googleapis.com에 이 값을 접두사로 추가합니다. 전체 목록은 리전 엔드포인트를 참고하세요.project:<PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.endpoint:chronicle.googleapis.com로 설정된 상태를 유지합니다.
기존 수집 API 내보내기 도구
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/bomgar: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: BOMGAR raw_log_field: body
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X를 차례로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
```bash sudo systemctl status observiq-otel-collector ```로그에서 오류를 확인합니다.
```bash sudo journalctl -u observiq-otel-collector -f ```
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼으로 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
BeyondTrust 원격 지원에서 syslog 내보내기 구성
- BeyondTrust Remote Support에 로그인합니다.
- 보안 > 어플라이언스 관리로 이동합니다.
- Syslog 섹션으로 이동하여 다음 값을 설정합니다.
- 원격 Syslog 서버: Syslog 호스트 서버 (Bindplane)의 호스트 이름 또는 IP 주소를 입력합니다. 시스템로그 서버는 최대 3개까지 추가할 수 있습니다.
- 메시지 형식: RFC 5424를 선택합니다.
- 포트: syslog 호스트 서버 (Bindplane)의 포트를 입력합니다.
- 제출을 클릭합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
message |
about |
매핑됨: CEF → about |
deviceNtDomain |
about.administrative_domain |
이름 변경/매핑됨 |
deviceExternalId |
about.asset.asset_id |
직접 매핑됨 |
device_product |
about.asset.asset_id |
직접 매핑됨 |
device_vendor |
about.asset.asset_id |
직접 매핑됨 |
fileHash |
about.file.full_path |
직접 매핑됨 |
filePath |
about.file.full_path |
이름이 변경됨/매핑됨 |
_hash |
about.file.sha256 |
이름 변경/매핑됨 |
fileHash |
about.file.sha256 |
이름 변경/매핑됨 |
fsize |
about.file.size |
이름 변경/매핑됨 |
dvchost |
about.hostname |
이름 변경/매핑됨 |
ips |
about.ip |
병합됨 |
message |
about.ip |
매핑됨: CEF → ips |
dvc_mac |
about.mac |
매핑됨: slot → mac_address |
dvcmac |
about.mac |
병합됨 |
mac_address |
about.mac |
병합됨 |
message |
about.mac |
매핑됨: CEF → mac_address, CEF → dvcmac |
deviceTranslatedAddress |
about.nat_ip |
병합됨 |
message |
about.nat_ip |
매핑됨: CEF → deviceTranslatedAddress |
Emne |
about.process.command_line |
직접 매핑됨 |
Path |
about.process.command_line |
직접 매핑됨 |
Subject |
about.process.command_line |
직접 매핑됨 |
deviceProcessName |
about.process.command_line |
이름이 변경됨/매핑됨 |
dvcpid |
about.process.pid |
이름 변경/매핑됨 |
message |
about.resource.attribute.permissions |
매핑됨: CEF → permissions |
permissions |
about.resource.attribute.permissions |
병합됨 |
additional_cfp1 |
additional.fields |
병합됨 |
additional_cfp2 |
additional.fields |
병합됨 |
additional_cfp3 |
additional.fields |
병합됨 |
additional_cfp4 |
additional.fields |
병합됨 |
additional_cn1 |
additional.fields |
병합됨 |
additional_cn2 |
additional.fields |
병합됨 |
additional_cn3 |
additional.fields |
병합됨 |
additional_cs1 |
additional.fields |
병합됨 |
additional_cs2 |
additional.fields |
병합됨 |
additional_cs3 |
additional.fields |
병합됨 |
additional_cs4 |
additional.fields |
병합됨 |
additional_cs5 |
additional.fields |
병합됨 |
additional_cs6 |
additional.fields |
병합됨 |
additional_cs7 |
additional.fields |
병합됨 |
additional_devicePayloadId |
additional.fields |
병합됨 |
additional_eventId |
additional.fields |
병합됨 |
additional_flexString1 |
additional.fields |
병합됨 |
additional_fname |
additional.fields |
병합됨 |
cs2 |
additional.fields |
매핑됨: arc_test → additional_cs2 |
cs5_label |
additional.fields |
병합됨 |
message |
additional.fields |
매핑된 값 (총 19개, 예: CEF → additional_eventId, CEF → `additional_devicePayloa… |
_extensions |
extensions |
이름 변경/매핑됨 |
_intermediary |
intermediary |
병합됨 |
message |
intermediary |
매핑됨: CEF → _intermediary |
_metadata |
metadata |
이름이 변경됨/매핑됨 |
meta_desc |
metadata.description |
직접 매핑됨 |
msg |
metadata.description |
이름 변경/매핑됨 |
Generated |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss(으)로 파싱됨 |
Received |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ss(으)로 파싱됨 |
datetime |
metadata.event_timestamp |
RFC 3339(으)로 파싱됨 |
dtPostTime |
metadata.event_timestamp |
yyyy-dd-MM HH:mm:ss(으)로 파싱됨 |
rt |
metadata.event_timestamp |
yyyy-MM-ddTHH:mm:ssZ(으)로 파싱됨 |
when |
metadata.event_timestamp |
UNIX로 파싱됨 |
_event_type |
metadata.event_type |
직접 매핑됨 |
event_name |
metadata.event_type |
매핑됨: "LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
message |
metadata.event_type |
매핑됨: CEF → PROCESS_UNCATEGORIZED, CEF → SCAN_UNCATEGORIZED, CEF → `USER_RESOURC… |
device_event_class_id |
metadata.product_event_type |
직접 매핑됨 |
eventName |
metadata.product_event_type |
직접 매핑됨 |
event_name |
metadata.product_event_type |
직접 매핑됨 |
sEventID |
metadata.product_event_type |
직접 매핑됨 |
externalId |
metadata.product_log_id |
직접 매핑됨 |
when |
metadata.product_log_id |
직접 매핑됨 |
device_product |
metadata.product_name |
직접 매핑됨 |
message |
metadata.product_name |
매핑됨: CEF → BeyondTrust Remote Support |
device_version |
metadata.product_version |
직접 매핑됨 |
device_vendor |
metadata.vendor_name |
이름이 변경됨/매핑됨 |
message |
metadata.vendor_name |
매핑됨: CEF → BeyondTrust Bomgar |
app_protocol_output |
network.application_protocol |
직접 매핑됨 |
deviceDirection |
network.direction |
매핑됨: 0 → INBOUND, 1 → OUTBOUND |
message |
network.direction |
매핑됨: CEF → INBOUND, CEF → OUTBOUND |
requestMethod |
network.http.method |
이름 변경/매핑됨 |
requestClientApplication |
network.http.user_agent |
이름이 변경됨/매핑됨 |
ip_protocol_out |
network.ip_protocol |
직접 매핑됨 |
in |
network.received_bytes |
이름이 변경됨/매핑됨 |
out |
network.sent_bytes |
이름 변경/매핑됨 |
_principal |
principal |
이름 변경/매핑됨 |
sntdom |
principal.administrative_domain |
이름 변경/매핑됨 |
sourceServiceName |
principal.application |
이름이 변경됨/매핑됨 |
Group_name |
principal.group.group_display_name |
직접 매핑됨 |
Gruppenavn |
principal.group.group_display_name |
직접 매핑됨 |
Device_name |
principal.hostname |
직접 매핑됨 |
Enhetsnavn |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
이름이 변경됨/매핑됨 |
message |
principal.ip |
매핑됨: CEF → principal_ip, CEF → shost |
principal_ip |
principal.ip |
병합됨 |
shost |
principal.ip |
병합됨 |
mac |
principal.mac |
병합됨 |
message |
principal.mac |
매핑됨: CEF → mac |
message |
principal.nat_ip |
매핑됨: CEF → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
병합됨 |
sourceTranslatedPort |
principal.nat_port |
이름 변경/매핑됨 |
spt |
principal.port |
이름 변경/매핑됨 |
sproc |
principal.process.command_line |
이름 변경/매핑됨 |
spid |
principal.process.pid |
이름이 변경됨/매핑됨 |
message |
principal.user.attribute.roles |
매핑됨: CEF → principal_role |
principal_role |
principal.user.attribute.roles |
병합됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
suid |
principal.user.userid |
이름이 변경됨/매핑됨 |
_security_result |
security_result |
병합됨 |
message |
security_result |
매핑됨: CEF → security_result, CEF → _security_result |
_action |
security_result.action |
병합됨 |
act |
security_result.action |
매핑됨: accept → _action, deny → _action |
message |
security_result.action |
매핑됨: CEF → _action |
Action_Taken |
security_result.action_details |
직접 매핑됨 |
act |
security_result.action_details |
직접 매핑됨 |
cat |
security_result.category_details |
병합됨 |
message |
security_result.category_details |
매핑됨: CEF → cat |
Scan_Type |
security_result.description |
직접 매핑됨 |
Type |
security_result.description |
직접 매핑됨 |
msg_data_2 |
security_result.description |
직접 매핑됨 |
infection_channel_label |
security_result.detection_fields |
병합됨 |
message |
security_result.detection_fields |
매핑된 값 (총 7개, 예: CEF → operation_label, CEF → operasjon_label, CEF → `… |
operasjon_label |
security_result.detection_fields |
병합됨 |
operation_label |
security_result.detection_fields |
병합됨 |
permission_label |
security_result.detection_fields |
병합됨 |
spyware_Grayware_Type_label |
security_result.detection_fields |
병합됨 |
threat_probability_label |
security_result.detection_fields |
병합됨 |
tillatelse_label |
security_result.detection_fields |
병합됨 |
mwProfile |
security_result.rule_name |
직접 매핑됨 |
message |
security_result.severity |
매핑됨: CEF → LOW, CEF → MEDIUM, CEF → HIGH, CEF → CRITICAL |
severity |
security_result.severity |
매핑됨: "0", "1", "2", "3", "LOW" → LOW, `"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"… |
Result |
security_result.summary |
직접 매핑됨 |
appcategory |
security_result.summary |
직접 매핑됨 |
reason |
security_result.summary |
이름이 변경됨/매핑됨 |
Spyware |
security_result.threat_name |
직접 매핑됨 |
Unknown_Threat |
security_result.threat_name |
직접 매핑됨 |
Virus_Malware_Name |
security_result.threat_name |
직접 매핑됨 |
oldFilePath |
src.file.full_path |
이름이 변경됨/매핑됨 |
oldFileSize |
src.file.size |
이름이 변경됨/매핑됨 |
message |
src.resource.attribute.permissions |
매핑됨: CEF → old_permissions |
old_permissions |
src.resource.attribute.permissions |
병합됨 |
_target |
target |
이름 변경/매핑됨 |
dntdom |
target.administrative_domain |
이름 변경/매핑됨 |
destinationServiceName |
target.application |
이름이 변경됨/매핑됨 |
temp_dhost |
target.hostname |
직접 매핑됨 |
IPv6_Address |
target.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
ipv6 |
target.ip |
매핑됨: - → IPv6_Address |
message |
target.ip |
매핑됨: CEF → dst_ip, CEF → IPv6_Address |
mac_address |
target.mac |
병합됨 |
message |
target.mac |
매핑됨: CEF → mac_address |
destination_translated_address |
target.nat_ip |
병합됨 |
message |
target.nat_ip |
매핑됨: CEF → destination_translated_address |
destinationTranslatedPort |
target.nat_port |
이름 변경/매핑됨 |
dpt |
target.port |
이름 변경/매핑됨 |
dproc |
target.process.command_line |
이름이 변경됨/매핑됨 |
File_name |
target.process.file.full_path |
직접 매핑됨 |
Infected_Resource |
target.process.file.full_path |
직접 매핑됨 |
Object |
target.process.file.full_path |
직접 매핑됨 |
Objekt |
target.process.file.full_path |
직접 매핑됨 |
dpid |
target.process.pid |
이름 변경/매핑됨 |
message |
target.resource.attribute.labels |
매핑됨: CEF → resource_Type_label |
resource_Type_label |
target.resource.attribute.labels |
병합됨 |
request |
target.url |
직접 매핑됨 |
message |
target.user.attribute.roles |
매핑됨: CEF → target_role |
target_role |
target.user.attribute.roles |
병합됨 |
CustomerName |
target.user.user_display_name |
직접 매핑됨 |
temp_duser |
target.user.user_display_name |
직접 매핑됨 |
Bruker |
target.user.userid |
직접 매핑됨 |
User_value |
target.user.userid |
직접 매핑됨 |
temp_duid |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | metadata.event_type |
상수: PROCESS_UNCATEGORIZED |
| 해당 사항 없음 | metadata.product_name |
상수: BeyondTrust Remote Support |
| 해당 사항 없음 | metadata.vendor_name |
상수: BeyondTrust Bomgar |
| 해당 사항 없음 | network.direction |
상수: INBOUND |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
exc |
event.idm.read_only_udm.principal.process.pid |
변경 로그에서 매핑됨 |
loggerHost |
event.idm.read_only_udm.principal.asset.hostname |
변경 로그에서 매핑됨 |
loggerHost |
event.idm.read_only_udm.intermediary.hostname 및 event.idm.read_only_udm.intermediary.asset.hostname |
변경 로그에서 매핑됨 |
product |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
sequenceId |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
site_id |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
segment |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
total_segment |
event.idm.read_only_udm.additional.fields |
변경 로그에서 매핑됨 |
who |
event.idm.read_only_udm.principal.user.userid |
변경 로그에서 매핑됨 |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.