Aruba Central 로그 수집

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 HPE Aruba Networking Central 로그를 Google SecOps로 수집하는 방법을 보여줍니다. 파서는 Aruba Central syslog 형식 로그에서 필드를 추출합니다. grok 또는 kv를 사용하여 로그 메시지를 파싱한 후 이러한 값을 통합 데이터 모델 (UDM)에 매핑합니다. 이벤트 소스 및 유형의 기본 메타데이터 값을 설정합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • systemd가 있는 Windows 2016 이상 또는 Linux 호스트
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Aruba Central Management 콘솔에 대한 권한 있는 액세스

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Bindplane 에이전트를 Google SecOps에 인증하려면 다음 방법 중 하나를 선택하세요.

  • 새 배포: Chronicle API (옵션 1)를 사용합니다.
  • 기존 배포: 수집 API가 2027년 7월 20일에 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정 으로 이동합니다.
  3. 서비스 계정 만들기 를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다 (예: Bindplane agent log ingestion).
  5. 만들고 계속하기 를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택 을 클릭하고 Chronicle 편집자 를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기 를 클릭합니다.
  10. JSON 을 선택하고 만들기 를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (/opt/observiq-otel-collector/ingestion-auth.json on Linux 또는 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json on Windows)에 ingestion-auth.json으로 저장하거나 config.yaml에서 creds_file_path를 저장하는 경로와 일치하도록 업데이트합니다.
  12. IAM 및 관리자 > 설정 으로 이동하여 프로젝트 번호 를 복사합니다. 내보내기 구성에 필요합니다.

옵션 2: 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트 로 이동합니다.
  3. 수집 인증 파일 을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필 로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID 를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 명령 프롬프트 또는 PowerShell 을 관리자로 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

추가 설치 리소스

추가 설치 옵션은 이 설치 가이드를 참고하세요.

Syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

  1. 구성 파일에 액세스합니다.

    • config.yaml 파일을 찾습니다. 일반적으로 Linux의 /opt/observiq-otel-collector/ 디렉터리 또는 Windows의 설치 디렉터리에 있습니다.
    • 텍스트 편집기 (예: nano, vi 또는 메모장)를 사용하여 파일을 엽니다.
  2. 다음과 같이 config.yaml 파일을 수정합니다.

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <customer_id>
        endpoint: chronicle.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'ARUBA_CENTRAL'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - udplog
          exporters:
            - chronicle/chronicle_w_labels
    
    • 인프라에 필요한 포트와 IP 주소를 바꿉니다.
    • <LOCATION>을 Google SecOps 인스턴스의 리전 (예: us, europe 또는 asia-southeast1)으로 바꿉니다. 내보내기는 이 값으로 chronicle.googleapis.com에 프리픽스를 추가합니다.
    • <PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • <customer_id>를 실제 고객 ID로 바꿉니다.
    • 1단계에서 서비스 계정 키 파일 (옵션 1)이 저장된 파일 경로로 /path/to/ingestion-authentication-file.json을 업데이트합니다.

기존 수집 API 내보내기

  • 옵션 2의 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <customer_id>
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'ARUBA_CENTRAL'
        raw_log_field: body
        ingestion_labels:
    

Bindplane 에이전트를 다시 시작하여 변경사항 적용

  1. Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
  2. Windows 에서 Bindplane 에이전트를 다시 시작하려면 서비스 콘솔을 사용하거나 다음 명령어를 입력하면 됩니다.

    net stop observiq-otel-collector && net start observiq-otel-collector
    

Aruba Central에서 Syslog 구성

  1. Aruba Central 웹 UI에 로그인합니다.
  2. 대시보드에서 구성하려는 기기 가 포함된 그룹 을 찾거나 전역 설정을 위해 필터를 모든 기기 로 설정합니다.
  3. 구성하려는 기기 또는 그룹을 클릭합니다.
  4. 구성 > 시스템 > 로깅 으로 이동합니다.
  5. Syslog 서버 섹션을 찾아 + 버튼을 클릭합니다.
    • 서버 이름: 고유하고 설명적인 이름을 입력합니다.
    • 서버 IP: Bindplane 에이전트 IP 주소를 입력합니다.
    • 서버 포트: Bindplane 에이전트 포트 번호를 입력합니다.
    • 로깅 형식: Syslog를 선택합니다.
    • 카테고리 및 기능: 로그를 전송할 카테고리 및 기능을 선택합니다.
    • 로깅 수준: 정보를 선택합니다.
  6. 설정 저장 을 클릭합니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
additional_amm additional.fields 병합됨
additional_nid additional.fields 병합됨
additional_setting_id additional.fields 병합됨
additional_webhook additional.fields 병합됨
dev_type_label additional.fields 병합됨
operation_label additional.fields 병합됨
datetime metadata.event_timestamp RFC 3339로 파싱됨
timestamp metadata.event_timestamp RFC 3339로 파싱됨
event_type metadata.event_type 직접 매핑됨
alert_type metadata.product_event_type 직접 매핑됨
event_data metadata.product_event_type 직접 매핑됨
id metadata.product_log_id 직접 매핑됨
details.__base_url metadata.url_back_to_product 직접 매핑됨
network_ssid network.session_id 직접 매핑됨
app principal.application 직접 매핑됨
cluster_hostname principal.asset.hostname 직접 매핑됨
host principal.asset.hostname 직접 매핑됨
princ_mac principal.asset.mac 병합됨
details.group_name principal.group.group_display_name 직접 매핑됨
details.group principal.group.product_object_id 직접 매핑됨
cluster_hostname principal.hostname 직접 매핑됨
host principal.hostname 직접 매핑됨
princ_mac principal.mac 병합됨
pid principal.process.pid 직접 매핑됨
cid principal.user.product_object_id 직접 매핑됨
details.user principal.user.userid 직접 매핑됨
device_id principal.user.userid 직접 매핑됨
labels security_result.about.labels 병합됨
description security_result.description 직접 매핑됨
state_label security_result.detection_fields 병합됨
severity security_result.severity 매핑된 값 (총 5개, 예: "LOG_INFO", "LOG_DEBUG" → LOW, LOG_WARN → MEDIUM, `LOG_...
details.config_change security_result.summary 직접 매핑됨
target_mac target.asset.mac 병합됨
target_mac target.mac 병합됨
alert_type target.resource.type 매핑됨: DEVICE_CONFIG_CHANGE_DETECTED → DEVICE
target_userid target.user.userid 직접 매핑됨
userid target.user.userid 직접 매핑됨
해당 사항 없음 metadata.product_name 상수: ARUBA_CENTRAL
해당 사항 없음 metadata.vendor_name 상수: ARUBA CENTRAL
해당 사항 없음 security_result.severity 상수: LOW
해당 사항 없음 target.resource.type 상수: DEVICE
nid" , "setting_id" , "details.dev_type" , "webhook" and "operation additional.fields 변경 로그에서 매핑됨
details.labels security_result.about.labels 변경 로그에서 매핑됨

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.