Airlock Digital Application Allowlisting 로그 수집
파서 버전: 1.0
이 문서에서는 Bindplane 에이전트를 사용하여 Airlock Digital Application Allowlisting 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Airlock Digital은 엔드포인트에 기본 거부 보안 모델을 적용하여 신뢰할 수 있는 애플리케이션, 스크립트, 프로세스만 실행할 수 있도록 하는 애플리케이션 허용 목록 및 실행 제어 플랫폼입니다. 이 플랫폼은 파일, 경로, 게시자, 상위 프로세스 수준에서 세분화된 정책 제어를 제공하며, 규정 준수 및 위협 관리를 위한 포괄적인 감사 추적을 지원합니다. Airlock Digital은 실행 이벤트, 차단된 실행, 정책 변경, 관리 작업에 대한 로그를 생성하며, 이는 syslog, CEF, JSON 또는 HTTP(S)를 사용하여 SIEM 솔루션으로 전달할 수 있습니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 Airlock Digital 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 관리자 액세스 권한이 있는 Airlock Digital 서버 (온프레미스 또는 클라우드)
- Airlock Digital v4.7 이상 (syslog 외부 로깅 지원)
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 새 배포: Chronicle API를 사용합니다 (옵션 1).
- 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기 (권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다 (예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다 (예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 생성한 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가> 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path을 저장된 경로와 일치하도록 업데이트합니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드 (기존)
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 RUNNING으로 표시됩니다.
Linux 설치
- 루트 또는 sudo 권한이 있는 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 활성 (실행 중)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/airlock_digital: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: AIRLOCK_DIGITAL raw_log_field: body service: pipelines: logs/airlock_digital: receivers: - tcplog exporters: - chronicle/airlock_digital
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
tcplog: 프로토콜에 따른 수신자 유형:- UDP syslog의 경우
udplog - TCP syslog의 경우
tcplog - RFC 3164/5424 syslog의 경우
syslog
- UDP syslog의 경우
0.0.0.0: 리슨할 IP 주소입니다.0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 하나의 인터페이스에서 수신 대기할 특정 IP 주소
514: 수신 대기할 포트 번호 (예:514,1514,6514)
내보내기 도구 구성:
<customer_id>: 이전 단계의 고객 IDlocation:<LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다 (예:us,europe또는asia-southeast1). 내보내기 도구는 이 값으로chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참고하세요.project:<PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.endpoint:chronicle.googleapis.com로 설정된 상태로 유지합니다.- 플랫폼에 따라
creds_file_path를 서비스 계정 JSON 키 파일의 경로로 조정합니다 (옵션 1).- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
기존 수집 API 내보내기 도구
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com를 리전 엔드포인트 (예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/airlock_digital: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: AIRLOCK_DIGITAL raw_log_field: body
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X를 차례로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택하세요.
관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Airlock Digital 외부 로깅 구성
syslog를 사용하여 로그를 Bindplane 에이전트로 전달하도록 Airlock Digital Server를 구성합니다. Airlock Digital은 일반 Syslog, CEF, JSON, HTTP(S), GELF를 비롯한 여러 외부 로깅 형식을 지원합니다.
- 관리자 계정으로 Airlock Digital Server Console에 로그인합니다.
- 시스템 > 외부 로깅으로 이동합니다.
- 추가를 클릭하여 새 외부 로깅 구성을 만듭니다.
로깅 유형 드롭다운에서 일반 Syslog를 선택합니다.
다음 구성 세부정보를 제공합니다.
- 서버 주소: Bindplane 에이전트 호스트의 IP 주소 또는 호스트 이름을 입력합니다 (예:
192.168.1.100). - 포트:
514(또는 Bindplane 에이전트에 구성된 포트)를 입력합니다. - 프로토콜: TCP 선택
- 서버 주소: Bindplane 에이전트 호스트의 IP 주소 또는 호스트 이름을 입력합니다 (예:
로그 카테고리 섹션에서 전달할 이벤트 유형을 선택합니다.
- 실행 이벤트 (차단 및 허용된 실행)
- 정책 변경사항
- 관리 작업
- 에이전트 이벤트
- 서버 활동
저장을 클릭하여 외부 로깅 구성을 적용합니다.
Bindplane 에이전트 로그를 확인하거나 Airlock Digital 서버 콘솔에서 외부 로깅 상태를 검토하여 로그가 전달되고 있는지 확인합니다.
Airlock Digital SIEM 통합에 대한 자세한 내용은 Airlock Digital SIEM 통합 페이지를 참조하세요.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 로직 |
|---|---|---|
event_type |
extensions.auth.type |
매핑됨: ServerActivityMessage → SSO |
product_event_type |
extensions.auth.type |
매핑됨: (?i)Login → SSO |
task |
extensions.auth.type |
매핑됨: Login → AUTHTYPE_UNSPECIFIED, Logout → AUTHTYPE_UNSPECIFIED |
intermediary_hostname |
intermediary.hostname |
직접 매핑됨 |
description |
metadata.description |
직접 매핑됨 |
metadata_description |
metadata.description |
직접 매핑됨 |
event_timestamp |
metadata.event_timestamp |
yyyy-MM-dd HH:mm:ss.SSS로 파싱됨 |
ingestion_time |
metadata.event_timestamp |
RFC 3339로 파싱됨 |
event_type |
metadata.event_type |
매핑됨: FileActivityMessage → STATUS_UPDATE, ServerActivityMessage → USER_LOGIN, `Se… |
has_principal |
metadata.event_type |
매핑됨: true → FILE_UNCATEGORIZED |
product_event_type |
metadata.event_type |
매핑됨: (?i)Login → USER_LOGIN |
task |
metadata.event_type |
매핑됨: Login → USER_LOGIN, Logout → USER_LOGOUT |
event_type |
metadata.product_event_type |
직접 매핑됨 |
product_event_type |
metadata.product_event_type |
직접 매핑됨 |
checkpoint |
metadata.product_log_id |
직접 매핑됨 |
browser |
network.http.user_agent |
직접 매핑됨 |
netdomain |
principal.administrative_domain |
직접 매핑됨 |
asset_category |
principal.asset.category |
직접 매핑됨 |
hostname |
principal.asset.hostname |
직접 매핑됨 |
srcip |
principal.asset.ip |
병합됨 |
software |
principal.asset.software |
병합됨 |
hostname |
principal.hostname |
직접 매핑됨 |
principal_hostname |
principal.hostname |
직접 매핑됨 |
srcip |
principal.ip |
병합됨 |
process_file_path |
principal.process.file.full_path |
직접 매핑됨 |
file_md5 |
principal.process.file.md5 |
직접 매핑됨 |
process_file_name |
principal.process.file.names |
병합됨 |
file_sha256 |
principal.process.file.sha256 |
직접 매핑됨 |
parent_process_file |
principal.process.parent_process.file.full_path |
직접 매핑됨 |
principal_user_userid |
principal.user.userid |
직접 매핑됨 |
description |
security_result.action |
매핑됨: Invalid login attempt → security_result_action |
metadata_description |
security_result.action |
매핑됨: logged in success → security_result_action |
security_result_action |
security_result.action |
병합됨 |
file_sha128_label |
security_result.detection_fields |
병합됨 |
policyname_label |
security_result.detection_fields |
병합됨 |
policyver_label |
security_result.detection_fields |
병합됨 |
ppolicy_label |
security_result.detection_fields |
병합됨 |
sha128_label |
security_result.detection_fields |
병합됨 |
sha384_label |
security_result.detection_fields |
병합됨 |
sha512_label |
security_result.detection_fields |
병합됨 |
type_label |
security_result.detection_fields |
병합됨 |
source_file |
src.file.full_path |
직접 매핑됨 |
source_file_name |
src.file.full_path |
직접 매핑됨 |
filename |
target.file.full_path |
직접 매핑됨 |
sha256 |
target.file.sha256 |
직접 매핑됨 |
commandline |
target.process.command_line |
직접 매핑됨 |
filename |
target.process.file.full_path |
직접 매핑됨 |
InstanceURL |
target.url |
직접 매핑됨 |
principal_user_userid |
target.user.userid |
직접 매핑됨 |
user |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | extensions.auth.type |
상수: AUTHTYPE_UNSPECIFIED |
| 해당 사항 없음 | metadata.event_type |
상수: USER_LOGIN |
| 해당 사항 없음 | metadata.product_name |
상수: Airlock Digital |
| 해당 사항 없음 | metadata.vendor_name |
상수: Airlock Digital |
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.