PTC Windchill ログを収集する
このドキュメントでは、Bindplane を使用して PTC Windchill ログを Google Security Operations に取り込む方法について説明します。
PTC Windchill は、エンジニアリング チームと製造チーム全体で製品データ、プロセス、コラボレーションを管理するために使用される製品ライフサイクル管理(PLM)プラットフォームです。このプラットフォームは、オンプレミス サーバーのデプロイからアクセスログ、監査ログ、構成変更ログを生成します。
始める前に
次の前提条件を満たしていることを確認してください。
- Google SecOps インスタンス
- Windows Server 2016 以降、または
systemdを使用する Linux ホスト - Bindplane エージェントと PTC Windchill サーバー間のネットワーク接続
- プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します
- 管理者権限を持つ PTC Windchill サーバーへの特権アクセス
Google SecOps の取り込み認証ファイルを取得する
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [コレクション エージェント] に移動します。
取り込み認証ファイル をダウンロードします。Bindplane をインストールするシステムにファイルを安全に保存します。
Google SecOps のお客様 ID を取得する
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [プロファイル] に移動します。
[組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。
Bindplane エージェントをインストールする
次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。
Windows のインストール
- 管理者としてコマンド プロンプトまたは PowerShell を開きます。
次のコマンドを実行します。
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sc query observiq-otel-collector
サービスは RUNNING と表示されます。
Linux のインストール
- root 権限または sudo 権限でターミナルを開きます。
次のコマンドを実行します。
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sudo systemctl status observiq-otel-collector
サービスが [アクティブ(実行中)] と表示されます。
その他のインストール リソース
その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。
Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する
構成ファイルを探す
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
構成ファイルを編集します。
config.yamlの内容全体を次の構成に置き換えます。receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/windchill: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: WINDCHILL raw_log_field: body service: pipelines: logs/windchill_to_chronicle: receivers: - tcplog exporters: - chronicle/windchill
構成パラメータ
各プレースホルダを次のように置き換えます。
レシーバーの構成:
listen_address: リッスンする IP アドレスとポート:- すべてのインターフェースでリッスンする
0.0.0.0(推奨) - ポート
514は標準の syslog ポートです(Linux で root が必要。root 以外の場合は1514を使用)
- すべてのインターフェースでリッスンする
エクスポータの構成:
creds_file_path: 取り込み認証ファイルのフルパス:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps コンソールからコピーしたお客様 IDendpoint: リージョン エンドポイント URL:- 米国:
malachiteingestion-pa.googleapis.com - ヨーロッパ:
europe-malachiteingestion-pa.googleapis.com - アジア:
asia-southeast1-malachiteingestion-pa.googleapis.com - 完全なリストについては、リージョン エンドポイントをご覧ください。
- 米国:
構成ファイルを保存する
- 編集後、ファイルを保存します。
- Linux:
Ctrl+O、Enter、Ctrl+Xの順に押します。 - Windows: [ファイル> 保存] をクリックします。
- Linux:
Bindplane エージェントを再起動して変更を適用する
Linux で Bindplane エージェントを再起動するには:
次のコマンドを実行します。
sudo systemctl restart observiq-otel-collectorサービスが実行されていることを確認します。
sudo systemctl status observiq-otel-collectorログでエラーを確認します。
sudo journalctl -u observiq-otel-collector -f
Windows で Bindplane エージェントを再起動するには:
次のいずれかのオプションを選択します。
- 管理者としてコマンド プロンプトまたは PowerShell を開きます。
net stop observiq-otel-collector && net start observiq-otel-collector- サービス コンソール:
Win+Rキーを押して「services.msc」と入力し、Enter キーを押します。- observIQ OpenTelemetry Collector を見つけます。
- 右クリックして [再起動] を選択します。
サービスが実行されていることを確認します。
sc query observiq-otel-collectorログでエラーを確認します。
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
PTC Windchill の syslog 転送を構成する
- 管理者として PTC Windchill サーバーにログインします。
Windchill アプリケーション ログを転送するように rsyslog または syslog エージェントを構成します。rsyslog 構成を編集します。
sudo nano /etc/rsyslog.d/windchill.conf次の行を追加して、Windchill ログファイルを Bindplane エージェントに転送します。
# Forward PTC Windchill logs to Bindplane agent module(load="imfile") input(type="imfile" File="/path/to/windchill/logs/*.log" Tag="windchill" Severity="info" Facility="local0") if $syslogtag == 'windchill' then @@<bindplane-ip>:514/path/to/windchill/logs/は、実際の Windchill ログ ディレクトリのパスに置き換えます。<bindplane-ip>は、Bindplane エージェント ホストの IP アドレスに置き換えます。
rsyslog サービスを再起動します。
sudo systemctl restart rsyslogBindplane エージェントのログを調べて、ログが送信されていることを確認します。
UDM マッピング テーブル
| ログフィールド | UDM マッピング | ロジック |
|---|---|---|
| eventlabel | metadata.description | 値を直接コピー |
| eventtime | metadata.event_timestamp | 日付フィルタ(SYSLOGTIMESTAMP、ISO8601 形式)を使用して変換されました |
| metadata.event_type | has_principal == 「true」、has_principal_user == 「true」、has_target == 「true」の場合は「USER_LOGIN」、has_target_resource == 「true」の場合は「USER_RESOURCE_ACCESS」、has_principal == 「true」、has_principal_user == 「true」の場合は「USER_UNCATEGORIZED」、has_principal == 「true」の場合は「STATUS_UPDATE」、それ以外の場合は「GENERIC_EVENT」に設定します。 | |
| dbschema | metadata.ingestion_labels | db_schema オブジェクト(key="DBSCHEMA"、value=dbschema)と統合されました |
| dbname | metadata.product_deployment_id | 値を直接コピー |
| eventlabel、description | metadata.product_event_type | 説明の値(空でない場合)、または eventlabel の値 |
| コンテキスト | metadata.product_log_id | 値を直接コピー |
| version | metadata.product_version | 値を直接コピー |
| ohost | observer.hostname | ohost が IP でない場合は値が直接コピーされる |
| ohost | observer.ip | ohost が IP の場合は値が直接コピーされる |
| domainpath | principal.administrative_domain | 値を直接コピー |
| ipaddress | principal.asset.hostname | ipaddress が IP でない場合は値が直接コピーされる |
| ipaddress | principal.asset.ip | ipaddress が IP の場合、値が直接コピーされる |
| ipaddress、phost | principal.hostname | IP アドレスでない場合は ipaddress の値、IP アドレスでない場合は phost の値 |
| ipaddress、phost | principal.ip | IP の場合は ipaddress からの値、IP の場合は phost からの値 |
| folderpath | principal.process.file.full_path | 値を直接コピー |
| user_product_object_id | principal.user.product_object_id | 値を直接コピー |
| user_display_name | principal.user.user_display_name | 値を直接コピー |
| username、user_userid | principal.user.userid | 空でない場合は username の値、それ以外の場合は user_userid の値 |
| domain_name | target.domain.name | 値を直接コピー |
| target_path | target.file.full_path | 値を直接コピー |
| 名前空間 | target.namespace | 値を直接コピー |
| lifecyclestate、targetname、targetnumber、targettype | target.resource.attribute.labels | lifecyclestate_label(key="lifecyclestate"、value=lifecyclestate)、targetname_label(key="targetname"、value=targetname)、targetnumber_label(key="targetnumber"、value=targetnumber)、targettype_label(key="targettype"、value=targettype)と統合 |
| target_number | target.resource.id | 値を直接コピー |
| target_name | target.resource.name | 値を直接コピー |
| target_identity | target.resource.product_object_id | 値を直接コピー |
| target_subtype | target.resource.resource_subtype | 値を直接コピー |
| metadata.product_name | 「Windchill」に設定 | |
| metadata.vendor_name | 「PTC」に設定 |
変更履歴
さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。