收集 Splunk Attack Analyzer 日志

支持的平台:

本文档介绍了如何使用 Google Cloud Storage V2 将 Splunk Attack Analyzer 日志注入到 Google Security Operations。

Splunk Attack Analyzer(以前称为 TwinWave)是一个自动化威胁分析平台,可通过行为分析来检测钓鱼式攻击和恶意软件。它通过 REST API 提供已完成的作业结果和标准化取证数据。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • 启用了 Cloud Storage API 的 GCP 项目
  • 创建和管理 GCS 存储桶的权限
  • 管理 GCS 存储桶的 IAM 政策的权限
  • 创建 Cloud Run 服务、Pub/Sub 主题和 Cloud Scheduler 作业的权限
  • 通过 API 密钥生成权限对 Splunk Attack Analyzer 进行特权访问

创建 Google Cloud Storage 存储桶

  1. 前往 Google Cloud 控制台。
  2. 选择您的项目或创建一个新项目。
  3. 在导航菜单中,依次前往 Cloud Storage > 存储桶。
  4. 点击创建存储分区。
  5. 提供以下配置详细信息:

    设置 值
    为存储桶命名 输入一个全局唯一的名称(例如 splunk-attack-analyzer-logs)
    位置类型 根据您的需求进行选择(区域级、双区域级、多区域级)
    位置 选择位置(例如 us-central1)
    存储类别 标准(建议用于频繁访问的日志)
    访问权限控制 均匀(推荐)
    保护工具 可选:启用对象版本控制或保留政策
  6. 点击创建。

收集 Splunk Attack Analyzer API 凭据

生成 API 密钥

  1. 登录 Splunk Attack Analyzer。
  2. 选择右上角的用户名,然后选择 API 密钥。
  3. 点击 + 新建密钥。
  4. 为密钥输入一个描述性名称(例如 Google Security Operations Integration)。
  5. 点击创建。
  6. 复制并保存模态框中显示的 API 密钥,并将其保存在安全的位置。

验证权限

如需验证 API 密钥是否具有所需的访问权限,请执行以下操作:

  1. 登录 Splunk Attack Analyzer。
  2. 选择右上角的用户名,然后选择 API 密钥。
  3. 验证 API 密钥是否已列出且处于有效状态。

测试 API 访问权限

  • 在继续进行集成之前,请测试您的凭据:

    # Replace with your actual API key
    API_KEY="your-api-key"
    
    # Test API access - list completed jobs
    curl -v -H "Authorization: Bearer ${API_KEY}" \
      "https://app.twinwave.io/api/v1/jobs?done=true&limit=1"
    

为 Cloud Run 函数创建服务账号

Cloud Run 函数需要一个服务账号,该账号具有写入 GCS 存储桶和被 Pub/Sub 调用的权限。

创建服务账号

  1. 在 GCP 控制台中,依次前往 IAM 和管理 > 服务账号。
  2. 点击创建服务账号。
  3. 提供以下配置详细信息:
    • 服务账号名称:输入 saa-collector-sa。
    • 服务账号说明:输入 Service account for Cloud Run function to collect Splunk Attack Analyzer logs。
  4. 点击创建并继续。
  5. 在向此服务账号授予对项目的访问权限部分,添加以下角色:
    1. 点击选择角色。
    2. 搜索并选择 Storage Object Admin。
    3. 点击 + 添加其他角色。
    4. 搜索并选择 Cloud Run Invoker。
    5. 点击 + 添加其他角色。
    6. 搜索并选择 Cloud Functions Invoker。
  6. 点击继续。
  7. 点击完成。

以下操作需要这些角色:

  • Storage Object Admin:将日志写入 GCS 存储桶并管理状态文件
  • Cloud Run Invoker:允许 Pub/Sub 调用函数
  • Cloud Functions Invoker:允许调用函数

授予对 GCS 存储桶的 IAM 权限

向服务账号授予对 GCS 存储桶的写入权限:

  1. 前往 Cloud Storage > 存储桶。
  2. 点击您的存储桶名称(例如 splunk-attack-analyzer-logs)。
  3. 前往权限标签页。
  4. 点击授予访问权限。
  5. 提供以下配置详细信息:
    • 添加主账号:输入服务账号电子邮件地址(例如 saa-collector-sa@your-project.iam.gserviceaccount.com)。
    • 分配角色:选择 Storage Object Admin。
  6. 点击保存。

创建 Pub/Sub 主题

创建一个 Pub/Sub 主题,供 Cloud Scheduler 发布消息,并供 Cloud Run 函数订阅。

  1. 在 GCP 控制台中,前往 Pub/Sub > 主题。
  2. 点击创建主题。
  3. 提供以下配置详细信息:
    • 主题 ID:输入 saa-trigger。
    • 将其他设置保留为默认值。
  4. 点击创建。

创建 Cloud Run 函数以收集日志

Cloud Run 函数将由来自 Cloud Scheduler 的 Pub/Sub 消息触发,以从 Splunk Attack Analyzer API 中提取日志并将其写入 GCS。

  1. 在 GCP 控制台中,前往 Cloud Run。
  2. 点击创建服务。
  3. 选择函数(使用内嵌编辑器创建函数)。
  4. 在配置部分中,提供以下配置详细信息:

    设置 值
    Service 名称 saa-collector
    区域 选择与您的 GCS 存储桶匹配的区域(例如 us-central1)
    运行时 选择 Python 3.12 或更高版本
  5. 在触发器(可选)部分中:

    1. 点击 + 添加触发器。
    2. 选择 Cloud Pub/Sub。
    3. 在选择 Cloud Pub/Sub 主题中,选择主题 saa-trigger。
    4. 点击保存。
  6. 在身份验证部分中:

    1. 选择需要进行身份验证。
    2. 检查 Identity and Access Management (IAM)。
  7. 向下滚动并展开容器、网络、安全性。

  8. 前往安全标签页:

    • 服务账号:选择服务账号 saa-collector-sa。
  9. 前往容器标签页:

    1. 点击变量和密钥。
    2. 为每个环境变量点击 + 添加变量:
    变量名称 示例值 说明
    GCS_BUCKET splunk-attack-analyzer-logs GCS 存储桶名称
    GCS_PREFIX saa 日志文件的前缀
    STATE_KEY saa/state.json 状态文件路径
    API_KEY your-api-key Splunk Attack Analyzer API 密钥
    API_BASE https://app.twinwave.io API 基本网址
    MAX_RECORDS 5000 每次运行的记录数上限
    PAGE_SIZE 100 每页记录数
    LOOKBACK_HOURS 24 初始回溯期
  10. 在变量和 Secret 标签页中,向下滚动到请求:

    • 请求超时:输入 600 秒(10 分钟)。
  11. 前往容器中的设置标签页:

    • 在资源部分中:
      • 内存:选择 512 MiB 或更高值。
      • CPU:选择 1。
  12. 在修订版本伸缩部分中:

    • 实例数下限:输入 0。
    • 实例数上限:输入 100(或根据预期负载进行调整)。
  13. 点击创建。

  14. 等待服务创建完成(1-2 分钟)。

  15. 创建服务后,系统会自动打开内嵌代码编辑器。

添加函数代码

  1. 在函数入口点中输入 main。
  2. 在内嵌代码编辑器中,创建两个文件:

    • 第一个文件:main.py::

      import functions_framework
      from google.cloud import storage
      import json
      import os
      import urllib3
      from datetime import datetime, timezone, timedelta
      import time
      
      # Initialize HTTP client with timeouts
      http = urllib3.PoolManager(
        timeout=urllib3.Timeout(connect=5.0, read=30.0),
        retries=False,
      )
      
      # Initialize Storage client
      storage_client = storage.Client()
      
      # Environment variables
      GCS_BUCKET = os.environ.get('GCS_BUCKET')
      GCS_PREFIX = os.environ.get('GCS_PREFIX', 'saa')
      STATE_KEY = os.environ.get('STATE_KEY', 'saa/state.json')
      API_KEY = os.environ.get('API_KEY', '')
      API_BASE = os.environ.get('API_BASE', 'https://app.twinwave.io').rstrip('/')
      MAX_RECORDS = int(os.environ.get('MAX_RECORDS', '5000'))
      PAGE_SIZE = int(os.environ.get('PAGE_SIZE', '100'))
      LOOKBACK_HOURS = int(os.environ.get('LOOKBACK_HOURS', '24'))
      
      def parse_datetime(value: str) -> datetime:
        """Parse ISO datetime string to datetime object."""
        if value.endswith("Z"):
          value = value[:-1] + "+00:00"
        return datetime.fromisoformat(value)
      
      @functions_framework.cloud_event
      def main(cloud_event):
        """
        Cloud Run function triggered by Pub/Sub to fetch Splunk Attack Analyzer logs and write to GCS.
      
        Args:
          cloud_event: CloudEvent object containing Pub/Sub message
        """
      
        if not all([GCS_BUCKET, API_KEY]):
          print('Error: Missing required environment variables')
          return
      
        try:
          bucket = storage_client.bucket(GCS_BUCKET)
      
          # Load state
          state = load_state(bucket, STATE_KEY)
      
          # Determine time window
          now = datetime.now(timezone.utc)
          last_time = None
      
          if isinstance(state, dict) and state.get("last_event_time"):
            try:
              last_time = parse_datetime(state["last_event_time"])
              last_time = last_time - timedelta(minutes=2)
            except Exception as e:
              print(f"Warning: Could not parse last_event_time: {e}")
      
          if last_time is None:
            last_time = now - timedelta(hours=LOOKBACK_HOURS)
      
          print(f"Fetching jobs from {last_time.isoformat()} to {now.isoformat()}")
      
          # Fetch completed jobs
          jobs, newest_event_time = fetch_jobs(
            start_time=last_time,
            end_time=now,
            page_size=PAGE_SIZE,
            max_records=MAX_RECORDS,
          )
      
          if not jobs:
            print("No new completed jobs found.")
            save_state(bucket, STATE_KEY, now.isoformat())
            return
      
          # Fetch forensics for each job
          all_records = []
          for job in jobs:
            job_id = job.get('id', '')
            if not job_id:
              continue
      
            forensics = fetch_forensics(job_id)
            if forensics:
              # Combine job metadata with forensics
              record = {
                'job': job,
                'forensics': forensics
              }
              all_records.append(record)
      
          if not all_records:
            print("No forensics data retrieved.")
            save_state(bucket, STATE_KEY, now.isoformat())
            return
      
          # Write to GCS as NDJSON
          timestamp = now.strftime('%Y%m%d_%H%M%S')
          object_key = f"{GCS_PREFIX}/logs_{timestamp}.ndjson"
          blob = bucket.blob(object_key)
      
          ndjson = '\n'.join([json.dumps(record, ensure_ascii=False) for record in all_records]) + '\n'
          blob.upload_from_string(ndjson, content_type='application/x-ndjson')
      
          print(f"Wrote {len(all_records)} records to gs://{GCS_BUCKET}/{object_key}")
      
          if newest_event_time:
            save_state(bucket, STATE_KEY, newest_event_time)
          else:
            save_state(bucket, STATE_KEY, now.isoformat())
      
          print(f"Successfully processed {len(all_records)} records")
      
        except Exception as e:
          print(f'Error processing logs: {str(e)}')
          raise
      
      def load_state(bucket, key):
        """Load state from GCS."""
        try:
          blob = bucket.blob(key)
          if blob.exists():
            state_data = blob.download_as_text()
            return json.loads(state_data)
        except Exception as e:
          print(f"Warning: Could not load state: {e}")
      
        return {}
      
      def save_state(bucket, key, last_event_time_iso: str):
        """Save the last event timestamp to GCS state file."""
        try:
          state = {'last_event_time': last_event_time_iso}
          blob = bucket.blob(key)
          blob.upload_from_string(
            json.dumps(state, indent=2),
            content_type='application/json'
          )
          print(f"Saved state: last_event_time={last_event_time_iso}")
        except Exception as e:
          print(f"Warning: Could not save state: {e}")
      
      def fetch_jobs(start_time: datetime, end_time: datetime, page_size: int, max_records: int):
        """
        Fetch completed jobs from Splunk Attack Analyzer API with pagination and rate limiting.
      
        Args:
          start_time: Start time for job query
          end_time: End time for job query
          page_size: Number of records per page
          max_records: Maximum total records to fetch
      
        Returns:
          Tuple of (jobs list, newest_event_time ISO string)
        """
        endpoint = f"{API_BASE}/api/v1/jobs"
      
        headers = {
          'Authorization': f'Bearer {API_KEY}',
          'Accept': 'application/json',
          'User-Agent': 'GoogleSecOps-SAACollector/1.0'
        }
      
        records = []
        newest_time = None
        page_num = 0
        backoff = 1.0
        offset = 0
      
        while True:
          page_num += 1
      
          if len(records) >= max_records:
            print(f"Reached max_records limit ({max_records})")
            break
      
          current_limit = min(page_size, max_records - len(records))
          url = f"{endpoint}?done=true&limit={current_limit}&offset={offset}"
      
          try:
            response = http.request('GET', url, headers=headers)
      
            if response.status == 429:
              retry_after = int(response.headers.get('Retry-After', str(int(backoff))))
              print(f"Rate limited (429). Retrying after {retry_after}s...")
              time.sleep(retry_after)
              backoff = min(backoff * 2, 30.0)
              continue
      
            backoff = 1.0
      
            if response.status != 200:
              print(f"HTTP Error: {response.status}")
              response_text = response.data.decode('utf-8')
              print(f"Response body: {response_text}")
              return [], None
      
            data = json.loads(response.data.decode('utf-8'))
      
            page_results = data.get('jobs', [])
      
            if not page_results:
              print(f"No more results (empty page)")
              break
      
            # Filter by time window
            filtered = []
            for job in page_results:
              created = job.get('created_at', '')
              if created:
                try:
                  job_time = parse_datetime(created)
                  if start_time <= job_time <= end_time:
                    filtered.append(job)
                    if newest_time is None or job_time > parse_datetime(newest_time):
                      newest_time = created
                except Exception as e:
                  print(f"Warning: Could not parse job time: {e}")
                  filtered.append(job)
      
            print(f"Page {page_num}: Retrieved {len(page_results)} jobs, {len(filtered)} in time window")
            records.extend(filtered)
      
            if len(page_results) < page_size:
              print(f"Reached last page (size={len(page_results)} < limit={page_size})")
              break
      
            offset += len(page_results)
      
          except Exception as e:
            print(f"Error fetching jobs: {e}")
            return [], None
      
        print(f"Retrieved {len(records)} total jobs from {page_num} pages")
        return records, newest_time
      
      def fetch_forensics(job_id: str):
        """
        Fetch normalized forensics for a specific job.
      
        Args:
          job_id: The job ID
      
        Returns:
          Forensics data dict or None
        """
        endpoint = f"{API_BASE}/api/v1/jobs/{job_id}/normalizedforensics"
      
        headers = {
          'Authorization': f'Bearer {API_KEY}',
          'Accept': 'application/json',
          'User-Agent': 'GoogleSecOps-SAACollector/1.0'
        }
      
        backoff = 1.0
        max_retries = 3
      
        for attempt in range(max_retries):
          try:
            response = http.request('GET', endpoint, headers=headers)
      
            if response.status == 429:
              retry_after = int(response.headers.get('Retry-After', str(int(backoff))))
              print(f"Rate limited (429) on forensics for job {job_id}. Retrying after {retry_after}s...")
              time.sleep(retry_after)
              backoff = min(backoff * 2, 30.0)
              continue
      
            if response.status != 200:
              print(f"Warning: Could not fetch forensics for job {job_id}: HTTP {response.status}")
              return None
      
            return json.loads(response.data.decode('utf-8'))
      
          except Exception as e:
            print(f"Warning: Error fetching forensics for job {job_id}: {e}")
            if attempt < max_retries - 1:
              time.sleep(backoff)
              backoff = min(backoff * 2, 30.0)
              continue
            return None
      
        return None
      
    • 第二个文件:requirements.txt::

      functions-framework==3.*
      google-cloud-storage==2.*
      urllib3>=2.0.0
      
  3. 点击部署以保存并部署函数。

  4. 等待部署完成(2-3 分钟)。

创建 Cloud Scheduler 作业

Cloud Scheduler 将定期向 Pub/Sub 主题发布消息,从而触发 Cloud Run 函数。

  1. 在 GCP 控制台中,前往 Cloud Scheduler。
  2. 点击创建作业。
  3. 提供以下配置详细信息:

    设置 值
    名称 saa-collector-hourly
    区域 选择与 Cloud Run 函数相同的区域
    频率 0 * * * *(每小时整点)
    时区 选择时区(建议选择世界协调时间 [UTC])
    目标类型 Pub/Sub
    主题 选择主题 saa-trigger
    消息正文 {}(空 JSON 对象)
  4. 点击创建。

时间表频率选项

根据日志量和延迟时间要求选择频次:

频率 Cron 表达式 使用场景
每隔 5 分钟 */5 * * * * 大容量、低延迟
每隔 15 分钟 */15 * * * * 搜索量中等
每小时 0 * * * * 标准(推荐)
每 6 小时 0 */6 * * * 低量批处理
每天 0 0 * * * 历史数据收集

测试集成

  1. 在 Cloud Scheduler 控制台中,找到您的作业 (saa-collector-hourly)。
  2. 点击强制运行以手动触发。
  3. 等待几秒钟,然后依次前往 Cloud Run > 服务 > saa-collector > 日志。
  4. 验证函数是否已成功执行。查找:

    Fetching jobs from YYYY-MM-DDTHH:MM:SS+00:00 to YYYY-MM-DDTHH:MM:SS+00:00
    Page 1: Retrieved X jobs, Y in time window
    Wrote Z records to gs://splunk-attack-analyzer-logs/saa/logs_YYYYMMDD_HHMMSS.ndjson
    Successfully processed Z records
    
  5. 检查 GCS 存储桶 (splunk-attack-analyzer-logs) 以确认日志是否已写入。

如果您在日志中看到错误,请执行以下操作:

  • HTTP 401:检查环境变量中的 API 密钥
  • HTTP 403:验证 API 密钥是否具有必需的权限
  • HTTP 429:速率限制 - 函数将自动重试并进行退避
  • 缺少环境变量:检查是否已设置所有必需的变量

在 Google SecOps 中配置 Feed 以注入 Splunk Attack Analyzer 日志

  1. 前往 SIEM 设置 > Feed。
  2. 点击添加新 Feed。
  3. 点击配置单个 Feed。
  4. 在 Feed 名称字段中,输入 Feed 的名称(例如 Splunk Attack Analyzer Logs)。
  5. 选择 Google Cloud Storage V2 作为来源类型。
  6. 选择 Splunk Attack Analyzer 作为日志类型。
  7. 点击获取服务账号。系统会显示一个唯一的服务账号电子邮件地址,例如:

    chronicle-12345678@chronicle-gcp-prod.iam.gserviceaccount.com
    
  8. 复制此电子邮件地址。您将在下一步骤中用到它。

  9. 点击下一步。

  10. 为以下输入参数指定值:

    • 存储桶网址:输入带有前缀路径的 GCS 存储桶 URI:

      gs://splunk-attack-analyzer-logs/saa/
      
      • 替换:
        • splunk-attack-analyzer-logs:您的 GCS 存储桶名称。
        • saa:存储日志的可选前缀/文件夹路径(留空表示根目录)。
    • 来源删除选项:根据您的偏好选择删除选项:

      • 永不:转移后永不删除任何文件(建议用于测试)。
      • 删除已转移的文件:成功转移后删除文件。
      • 删除已转移的文件和空目录:成功转移后删除文件和空目录。

    • 文件存在时间上限:包含在过去指定天数内修改过的文件(默认值为 180 天)。

    • 资源命名空间:资源命名空间。

    • 注入标签:要应用于此 Feed 中事件的标签。

  11. 点击下一步。

  12. 在最终确定界面中查看新的 Feed 配置,然后点击提交。

向 Google SecOps 服务账号授予 IAM 权限

Google SecOps 服务账号需要您的 GCS 存储桶的 Storage Object Viewer 角色。

  1. 前往 Cloud Storage > 存储桶。
  2. 点击您的存储桶名称 (splunk-attack-analyzer-logs)。
  3. 前往权限标签页。
  4. 点击授予访问权限。
  5. 提供以下配置详细信息:
    • 添加主账号:粘贴 Google SecOps 服务账号电子邮件地址。
    • 分配角色:选择 Storage Object Viewer。
  6. 点击保存。

UDM 映射表

日志字段 UDM 映射 逻辑
when metadata.event_timestamp 事件发生的时间
deviceName principal.hostname 主账号的主机名
messageid metadata.id 事件的唯一标识符
操作 security_result.action 安全产品采取的操作
协议 network.ip_protocol IP 协议
srcAddr principal.ip 主账号的 IP 地址
srcPort principal.port 主账号的端口号
dstAddr target.ip 目标的 IP 地址
dstPort target.port 目标的端口号
metadata.event_type 事件类型
metadata.product_name 产品名称
metadata.vendor_name 供应商/公司名称
Attack Analyzer metadata.product_name 从更新日志映射
Splunk metadata.vendor_name 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。