SecureAuth Identity Platform のログを収集する
このドキュメントでは、Bindplane エージェントを使用して SecureAuth Identity Platform ログを Google Security Operations に取り込む方法について説明します。
SecureAuth Identity Platform は、認証イベント、セッション アクティビティ、アクセス制御の決定、監査証跡の syslog メッセージを生成するシングル サインオンと ID 管理ソリューションです。パーサーは、grok パターンを使用して syslog と XML 形式のログからフィールドを抽出し、Unified Data Model(UDM)にマッピングします。
始める前に
次の前提条件を満たしていることを確認してください。
- Google SecOps インスタンス
- Windows Server 2016 以降、または
systemdを使用する Linux ホスト - Bindplane エージェントと SecureAuth Identity Platform 間のネットワーク接続
- プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します。
- SecureAuth への特権アクセス
Google SecOps の取り込み認証ファイルを取得する
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [収集エージェント] に移動します。
- 取り込み認証ファイル をダウンロードします。
Bindplane をインストールするシステムにファイルを安全に保存します。
Google SecOps のお客様 ID を取得する
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [プロファイル] に移動します。
[組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。
Bindplane エージェントをインストールする
次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。
Windows のインストール
- 管理者として コマンド プロンプトまたは PowerShell を開きます。
次のコマンドを実行します。
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sc query observiq-otel-collectorサービスは RUNNING と表示されます。
Linux のインストール
- root 権限または sudo 権限でターミナルを開きます。
次のコマンドを実行します。
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sudo systemctl status observiq-otel-collectorサービスは active (running) と表示されます。
その他のインストール リソース
その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。
syslog を構成して Google SecOps に送信する
構成ファイルを探す
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
構成ファイルを編集します。
config.yamlの内容全体を次の構成に置き換えます。receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/secureauth_sso: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SECUREAUTH_SSO raw_log_field: body service: pipelines: logs/secureauth_sso_to_chronicle: receivers: - udplog exporters: - chronicle/secureauth_sso
構成パラメータ
各プレースホルダを次のように置き換えます。
レシーバーの構成:
listen_address: リッスンする IP アドレスとポート:0.0.0.0: すべてのインターフェースでリッスンします(推奨)。- ポート
514は標準の syslog ポートです(Linux で root が必要です。root 以外のユーザーは1514を使用します)。
エクスポータの構成:
creds_file_path: 取り込み認証ファイルのフルパス:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id: Google SecOps コンソールからコピーしたお客様 IDendpoint: リージョン エンドポイント URL:- 米国:
malachiteingestion-pa.googleapis.com - ヨーロッパ:
europe-malachiteingestion-pa.googleapis.com - アジア:
asia-southeast1-malachiteingestion-pa.googleapis.com - 完全なリストについては、リージョン エンドポイントをご覧ください。
- 米国:
構成ファイルを保存する
- 編集後、ファイルを保存します。
- Linux:
Ctrl+O、Enter、Ctrl+Xの順に押します。 - Windows: [ファイル> 保存] をクリックします。
- Linux:
Bindplane エージェントを再起動して変更を適用する
Linux で Bindplane エージェントを再起動するには、次のコマンドを実行します。
sudo systemctl restart observiq-otel-collectorサービスが実行されていることを確認します。
sudo systemctl status observiq-otel-collectorログでエラーを確認します。
sudo journalctl -u observiq-otel-collector -f
Windows で Bindplane エージェントを再起動するには、次のいずれかのオプションを選択します。
管理者としてコマンド プロンプトまたは PowerShell を開きます。
net stop observiq-otel-collector && net start observiq-otel-collectorサービス コンソール:
Win+Rキーを押し、「services.msc」と入力して Enter キーを押します。- observIQ OpenTelemetry Collector を見つけます。
- 右クリックして [再起動] を選択します。
サービスが実行されていることを確認します。
sc query observiq-otel-collectorログでエラーを確認します。
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
SecureAuth Identity Platform を構成する
- 管理者として SecureAuth Identity コンソールにログインします。
- [ログ] を選択します。
- [ログ オプション] セクションで、次の構成情報を指定します。
- ログ インスタンス ID: ログ インスタンス ID、アプリケーション名、またはレルム名(
SecureAuth1など)を入力します。 - 監査ログ: [Syslog] チェックボックスをオンにします。
- エラーログ: [Syslog] チェックボックスをオンにします。
- Syslog サーバー: Bindplane エージェントの IP アドレスを入力します。
- Syslog ポート: Bindplane エージェントのポート番号(例:
514)を入力します。 - Syslog RFC spec: [RFC 5424] を選択します。
- ログ インスタンス ID: ログ インスタンス ID、アプリケーション名、またはレルム名(
- [保存] をクリックします。
UDM マッピング テーブル
| ログフィールド | UDM マッピング | ロジック |
|---|---|---|
| action_msg | read_only_udm.target.process.command_line | action_msg フィールドの値 |
| アプライアンス | read_only_udm.principal.domain.name | Appliance フィールドの値 |
| アプライアンス | read_only_udm.target.administrative_domain | Appliance フィールドの値 |
| BrowserSession | read_only_udm.network.session_id | BrowserSession フィールドの値 |
| 猫 | read_only_udm.metadata.product_event_type | cat フィールドの値 |
| カテゴリ | read_only_udm.metadata.product_event_type | Category フィールドの値 |
| cn1 | security_result.severity | cn1Label が「Priority」の場合、cn1 の値に基づいてマッピングされます。1 - HIGH、2 - MEDIUM、3 または 4 - LOW |
| 会社 | read_only_udm.additional.fields.value.string_value | Company フィールドの値 |
| cs1 | read_only_udm.network.session_id | cs1Label が「BrowserSession」の場合の cs1 フィールドの値 |
| cs3 | read_only_udm.additional.fields.value.string_value | cs3Label が「CompanyName」の場合の cs3 フィールドの値 |
| dst | read_only_udm.target.ip | dst フィールドの値 |
| ドメイン | read_only_udm.principal.domain.name | domain フィールドの値 |
| dvc | read_only_udm.intermediary.ip | dvc フィールドの値 |
| EventID | read_only_udm.metadata.product_log_id | EventID フィールドの値 |
| HostName | read_only_udm.principal.hostname | grok が IP アドレスの照合に失敗した場合の HostName フィールドの値 |
| HostName | read_only_udm.principal.ip | Grok が IP アドレスと一致した場合の HostName フィールドの値 |
| ip | read_only_udm.principal.ip | ip フィールドの値 |
| メッセージ | read_only_udm.metadata.description | Message フィールドの値 |
| メッセージ | security_result.description | Message フィールドの値 |
| nat_ip | read_only_udm.principal.nat_ip | nat_ip フィールドの値 |
| 優先度 | security_result.severity | Priority の値に基づいてマッピングされます。1 - HIGH、2 - MEDIUM、3 または 4 - LOW |
| SAMLConsumerURL | read_only_udm.target.url | SAMLConsumerURL フィールドの値 |
| sec_msg | security_result.description | sec_msg フィールドの値 |
| SecureAuthIdPAppliance | read_only_udm.target.administrative_domain | SecureAuthIdPAppliance フィールドの値 |
| SecureAuthIdPApplianceMachineName | read_only_udm.target.hostname | SecureAuthIdPApplianceMachineName フィールドの値 |
| SecureAuthIdPDestinationSiteUrl | read_only_udm.target.url | SecureAuthIdPDestinationSiteUrl フィールドの値 |
| SecureAuthIdPProductType | read_only_udm.additional.fields.value.string_value | SecureAuthIdPProductType フィールドの値 |
| セッション | read_only_udm.network.session_id | session フィールドの値 |
| spid | read_only_udm.target.process.pid | spid フィールドの値 |
| src | read_only_udm.principal.ip | src フィールドの値 |
| suser | read_only_udm.target.user.userid | suser フィールドの値 |
| UserAgent | read_only_udm.network.http.user_agent | UserAgent フィールドの値 |
| UserHostAddress | read_only_udm.principal.nat_ip | UserHostAddress フィールドの値 |
| UserHostAddress | read_only_udm.target.ip | UserHostAddress フィールドの値 |
| UserID | read_only_udm.principal.user.userid | UserID フィールドの値 |
| バージョン | read_only_udm.metadata.product_version | Version フィールドの値 |
| read_only_udm.additional.fields.key | ハードコードされた値 - 'CompanyName' | |
| read_only_udm.additional.fields.key | ハードコードされた値 - 「Company」 | |
| read_only_udm.additional.fields.key | ハードコードされた値 - 'SecureAuthIdPProductType' | |
| read_only_udm.extensions.auth.type | ハードコードされた値 - 「SSO」 | |
| read_only_udm.metadata.event_type | SecureAuthIdPAuthGuiMode == 0 かつ auth_result == Success の場合は「USER_LOGIN」、SecureAuthIdPAuthGuiMode == 0 かつ auth_result ==WS-Trust success. の場合は「USER_CHANGE_PERMISSIONS」、SecureAuthIdPAuthGuiMode == 0 かつ auth_result == Session Aborted の場合は「USER_LOGOUT」、UserHostAddress != and `HostName` != の場合は「NETWORK_CONNECTION」、ip != or `HostName` != の場合は「STATUS_UPDATE」、UserHostAddress != and `HostName` == かつ UserID != `` の場合は「USER_UNCATEGORIZED」、それ以外の場合は「GENERIC_EVENT」 |
|
| read_only_udm.metadata.log_type | ハードコードされた値 - 「SECUREAUTH_SSO」 | |
| read_only_udm.metadata.product_name | ハードコードされた値 - 「SECUREAUTH_SSO」 | |
| read_only_udm.metadata.vendor_name | ハードコードされた値 - 「SECUREAUTH_SSO」 | |
| read_only_udm.target.user.email_addresses | not_email が false の場合の user_email フィールドの値 |
|
| security_result.severity | cn1Label == Priority かつ cn1 == 1 の場合は 'HIGH'、cn1Label == Priority かつ cn1 == 2 の場合は 'MEDIUM'、cn1Label == Priority かつ cn1 が [3, 4] の場合は 'LOW'、Priority == 1 の場合は 'HIGH'、Priority == 2 の場合は 'MEDIUM'、Priority が [3, 4] の場合は 'LOW' |
|
_timestamp |
event.idm.read_only_udm.metadata.collected_timestamp |
変更履歴からマッピング |
i_ip |
event.idm.read_only_udm.intermediary.ip |
変更履歴からマッピング |
i_port |
event.idm.read_only_udm.intermediary.port |
変更履歴からマッピング |
parsed.LogChannel |
event.idm.read_only_udm.metadata.product_event_type |
変更履歴からマッピング |
parsed.FormatVersion |
event.idm.read_only_udm.metadata.product_version |
変更履歴からマッピング |
parsed.EventID |
event.idm.read_only_udm.metadata.product_log_id |
変更履歴からマッピング |
parsed.CompanyID |
event.idm.read_only_udm.principal.resource.product_object_id |
変更履歴からマッピング |
parsed.Realm |
event.idm.read_only_udm.principal.resource.name |
変更履歴からマッピング |
parsed.UserHostAddress |
event.idm.read_only_udm.principal.ip |
変更履歴からマッピング |
parsed.UserHostAddress |
event.idm.read_only_udm.principal.asset.ip |
変更履歴からマッピング |
host.name |
event.idm.read_only_udm.principal.hostname |
変更履歴からマッピング |
host.name |
event.idm.read_only_udm.principal.asset.hostname |
変更履歴からマッピング |
parsed.RequestID |
event.idm.read_only_udm.metadata.id |
変更履歴からマッピング |
meta.cloud.availability_zone |
event.idm.read_only_udm.principal.location.name |
変更履歴からマッピング |
meta.cloud.region |
event.idm.read_only_udm.principal.location.country_or_region |
変更履歴からマッピング |
host.id |
event.idm.read_only_udm.principal.resource.id |
変更履歴からマッピング |
LogstashPod |
event.idm.read_only_udm.observer.hostname |
変更履歴からマッピング |
fields.ApplianceID |
event.idm.read_only_udm.principal.asset.asset_id |
変更履歴からマッピング |
LogChannel |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
FormatVersion |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
EventID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
Version |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
parsed.UserAgent |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
parsed.ApplianceID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
beat.name |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
beat.hostname |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
beat.version |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
fields.CompanyID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
derived.CompanyIndex |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
_version |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
derived.EventType |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
prospector.type |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
input.type |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
parsed_Message |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
meta.cloud.machine_type |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
ApplianceType |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
parsed.Version |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.architecture |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.os.platform |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.os.version |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.os.build |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.os.family |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
host.os.name |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
meta.cloud.provider |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
derived.LogChannelIndex |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
document_id |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
meta.cloud.instance_id |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
tags |
event.idm.read_only_udm.principal.resource.attribute.labels |
変更履歴からマッピング |
Realm |
event.idm.read_only_udm.target.resource.name |
変更履歴からマッピング |
CompanyID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
PEN |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
ApplianceID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
ApplianceMachineName |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
RequestID |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
UseJava |
event.idm.read_only_udm.additional.fields |
変更履歴からマッピング |
変更ログ
さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。