Preempt Auth ログを収集する

以下でサポートされています。

このドキュメントでは、Bindplane エージェントを使用して Preempt Auth ログを Google Security Operations に取り込む方法について説明します。

Preempt Auth は、Active Directory 環境の詳細な認証ログを生成する認証イベント モニタリング ソリューションです。エンドポイント全体で、ログイン成功イベントとログイン失敗イベント、LDAP 検索、サービス アクセス、認証タイプをキャプチャします。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス
  • Windows Server 2016 以降、または systemd を使用する Linux ホスト
  • Bindplane エージェントと Preempt サーバー間のネットワーク接続
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認する
  • 管理者権限で Preempt Auth(CrowdStrike Identity Protection)への特権アクセス

Bindplane エージェントの Google SecOps 認証情報を取得する

Bindplane エージェントを Google SecOps に対して認証するには、次のいずれかの方法を選択します。

  • 新しいデプロイ: Chronicle API を使用します(オプション 1)。
  • 以前のデプロイ: Ingestion API が 2027 年 7 月 20 日に廃止されるまで、取り込み認証ファイル(オプション 2)を引き続き使用します。
  1. Google Cloud コンソールにログインし、Google SecOps インスタンスにリンクされている Google Cloud プロジェクトを選択します。
  2. [IAM と管理]> [サービス アカウント] に移動します。
  3. [サービス アカウントを作成] をクリックします。
  4. 次の構成情報を指定します。
    • サービス アカウント名: アカウントの名前を入力します(例: bindplane-ingest)。
    • サービス アカウントの説明: 説明を入力します(例: Bindplane agent log ingestion)。
  5. [作成して続行] をクリックします。
  6. [このサービス アカウントにプロジェクトへのアクセスを許可する] セクションで、[ロールを選択] をクリックし、[Chronicle 編集者] を選択します。
  7. [**続行**] をクリックして [**完了**] をクリックします。
  8. 作成したサービス アカウントをクリックし、[キー] タブに移動します。
  9. 「鍵を追加」>「新しい鍵を作成」の順にクリックします。
  10. [JSON] を選択し、[作成] をクリックします。キーファイルがパソコンにダウンロードされます。
  11. キーファイルを Bindplane コレクタ ディレクトリ(Linux の場合は /opt/observiq-otel-collector/ingestion-auth.json、Windows の場合は C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)に ingestion-auth.json として保存するか、保存先のパスに合わせて config.yaml の creds_file_path を更新します。
  12. [IAM と管理][>][設定] に移動し、[プロジェクト番号] をコピーします。エクスポート構成に必要になります。

オプション 2: 取り込み認証ファイルをダウンロードする(レガシー)

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイル をダウンロードします。
  4. Bindplane エージェントをインストールするシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows へのインストール

  1. 管理者としてコマンド プロンプト または PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. インストールが完了するまでお待ちください。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sc query observiq-otel-collector
    

    サービスは [RUNNING] と表示されます。

Linux へのインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. インストールが完了するまでお待ちください。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sudo systemctl status observiq-otel-collector
    

    サービスは [active (running)] と表示されます。

その他のインストール リソース

その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。

Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

構成ファイルを探す

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

構成ファイルを編集する

  • config.yaml の内容全体を次の構成に置き換えます。

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/preempt_auth:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: chronicle.googleapis.com
        log_type: PREEMPT_AUTH
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/preempt_auth_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/preempt_auth
    

構成パラメータ

各プレースホルダを次のように置き換えます。

  • レシーバーの構成:

    • tcplog: TCP 経由で syslog を受信します。Preempt デプロイが UDP 経由で転送する場合は、udplog を使用します。
    • 0.0.0.0:514: ポート 514 のすべてのインターフェースでリッスンします。必要に応じてポートを変更します(例: root 以外の Linux の場合は 1514)。
  • エクスポーターの構成:

    • <CREDS_FILE_PATH>: サービス アカウント JSON キーファイルのフルパス(オプション 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <CUSTOMER_ID>: Google SecOps のお客様 ID を取得する 手順で取得したお客様 ID。
    • location: <LOCATION> を Google SecOps インスタンスのリージョン(us、europe、asia-southeast1 など)に置き換えます。エクスポーターは、この値で chronicle.googleapis.com に接頭辞を付けます。完全なリストについては、リージョン エンドポイントをご覧ください。
    • project: <PROJECT_NUMBER> を [IAM と管理] > [設定] のプロジェクト番号に置き換えます。
    • endpoint: chronicle.googleapis.com に設定したままにします。

レガシー Ingestion API エクスポーター

  • オプション 2 の取り込み認証ファイルを使用する場合は、exporters ブロックを次のように置き換えます。creds_file_path を取り込み認証ファイルのパスに設定します。インスタンスが米国以外にある場合は、malachiteingestion-pa.googleapis.com を リージョン エンドポイント(europe-malachiteingestion-pa.googleapis.com など)に置き換えます。

    exporters:
      chronicle/preempt_auth:
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: PREEMPT_AUTH
        raw_log_field: body
        ingestion_labels:
          env: production
    

構成ファイルを保存する

  • 編集が完了したら、ファイルを保存します。
    • Linux: Ctrl+O、Enter、Ctrl+X を押します。
    • Windows: [File > Save] をクリックします。

Bindplane エージェントを再起動して変更を適用する

  • Linux で Bindplane エージェントを再起動するには、次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
    1. サービスが実行されていることを確認します。

      sudo systemctl status observiq-otel-collector
      
    2. ログでエラーを確認します。

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows で Bindplane エージェントを再起動するには、次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を実行します。

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • サービス コンソール:

      1. Win+R を押して services.msc と入力し、Enter キーを押します。
      2. [observIQ OpenTelemetry Collector] を探します。
      3. 右クリックして [再起動] を選択します。
      4. サービスが実行されていることを確認します。

        sc query observiq-otel-collector
        
      5. ログでエラーを確認します。

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Preempt Auth syslog 転送を構成する

  1. Preempt 管理コンソール にログインします。
  2. [Settings] > [SIEM Integration] に移動します。
  3. 認証イベントの syslog 転送を有効にします。
  4. 次の構成情報を指定します。
    • プロトコル: [TCP] を選択します(Bindplane エージェント レシーバーの構成と一致する必要があります)。
    • Syslog サーバー アドレス: Bindplane エージェント ホストの IP アドレスを入力します(例: 192.168.1.100)。
    • ポート: 514 と入力します(Bindplane エージェント レシーバー ポートと一致する必要があります)。
  5. 転送する認証イベント タイプを選択します。
    • 認証成功イベント
    • 認証失敗イベント
    • LDAP 検索
    • サービス アクセス イベント
  6. [保存] または [適用] をクリックします。
  7. Bindplane エージェント ログを確認して、ログが送信されていることを確認します。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
authenticationType extensions.auth.type authenticationType が SSO_LOGIN または LDAP_AUTHENTICATION と一致する場合は「SSO」、DOMAIN_LOGIN の場合は「MACHINE」、NTLM_AUTHENTICATION の場合は「AUTHTYPE_UNSPECIFIED」に設定します。
extensions.auth.mechanism 「MECHANISM_UNSPECIFIED」に設定します。
inter_ip intermediary.hostname inter_ip が有効な IP アドレスでない場合に設定します。
inter_ip intermediary.ip inter_ip が有効な IP アドレスの場合に設定します。
eventLabel metadata.description 値を直接コピーします。
eventType metadata.event_type eventType が SUCCESSFUL_AUTHENTICATION または FAILED_AUTHENTICATION の場合は「USER_LOGIN」、SERVICE_ACCESS または LDAP_SEARCH で principal_host_set が true の場合は「SERVICE_UNSPECIFIED」に設定します。
eventType metadata.product_event_type 値を直接コピーします。
endpointDisplayName, ipAddress principal.hostname endpointDisplayName != ipAddress かつ endpointDisplayName != "" の場合に設定します。
ipAddress, inter_ip principal.ip ipAddress != inter_ip の場合は ipAddress の値、それ以外の場合は inter_ip の値。
networkType principal.resource.name 値を直接コピーします。
principal.resource.type 「Network type」に設定します。
userDisplayName principal.user.email_addresses userDisplayName がメールの正規表現と一致する場合に設定します。
userDisplayName principal.user.user_display_name 値を直接コピーします。
userEntity.secondaryDisplayName, userDisplayName principal.user.userid userEntity.secondaryDisplayName が空でない場合はその値、userEntity.secondaryDisplayName が空の場合は userDisplayName の値。
eventType security_result.action SUCCESSFUL_AUTHENTICATION の場合は「ALLOW」、FAILED_AUTHENTICATION の場合は「BLOCK」に設定します。
eventSeverity security_result.severity_details 値を直接コピーします。
authenticationType security_result.summary 値を直接コピーします。
targetEntity.primaryDisplayName, targetServiceIdentifier, eventType, targetEntity.type target.application targetEntity.type == "CLOUD_SERVICE" の場合は targetEntity.primaryDisplayName の値。それ以外の場合は、targetServiceIdentifier != "" で、以前に設定されていない場合は targetServiceIdentifier の値。eventType == "LDAP_SEARCH" で、以前に設定されていない場合は「LDAP」。
targetEntity.primaryDisplayName, targetEntity.type target.hostname targetEntity.type == "ENDPOINT" の場合に設定します。
targetServiceType target.resource.name targetServiceType != "" かつ != "UNKNOWN" の場合に設定します。
targetServiceType target.resource.type targetServiceType != "" かつ != "UNKNOWN" の場合は「Service Type」に設定します。
targetEntity.primaryDisplayName, targetEntity.type target.user.user_display_name targetEntity.type == "USER" の場合に設定します。
targetEntity.secondaryDisplayName, targetEntity.type target.user.userid targetEntity.type == "USER" の場合に設定します。
metadata.product_name 「PREEMPT_AUTH」に設定します。
metadata.vendor_name 「Preempt」に設定します。

さらにサポートが必要な場合コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。