LogonBox のログを収集する
このドキュメントでは、Bindplane を使用して LogonBox ログを Google Security Operations に取り込む方法について説明します。
LogonBox は、セルフサービスのパスワード管理と本人確認のプラットフォームです。パスワードの再設定、本人確認イベント、管理者の操作に関する監査ログが生成されます。パーサーは、LogonBox 監査データを統合データモデル(UDM)にマッピングし、ユーザー ID、認証イベント、リソースの変更、グループ管理オペレーションをキャプチャします。
始める前に
次の前提条件を満たしていることを確認してください。
- Google SecOps インスタンス
- Windows Server 2016 以降、または
systemdを使用する Linux ホスト - Bindplane エージェントと LogonBox サーバー間のネットワーク接続
- プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します
- LogonBox 管理コンソールへの特権アクセス
Bindplane エージェントの Google SecOps 認証情報を取得する
Bindplane エージェントを Google SecOps に対して認証するには、次のいずれかの方法を選択します。
- 新規デプロイ: Chronicle API を使用します(オプション 1)。
- 以前のデプロイ: 2027 年 7 月 20 日に Ingestion API が廃止されるまで、取り込み認証ファイル(オプション 2)を引き続き使用します。
オプション 1: Chronicle API のサービス アカウントを作成する(推奨)
- Google Cloud コンソールにログインし、Google SecOps インスタンスにリンクされている Google Cloud プロジェクトを選択します。
- [IAM と管理> サービス アカウント] に移動します。
- [サービス アカウントを作成] をクリックします。
- 次の構成情報を指定します。
- サービス アカウント名: アカウントの名前を入力します(例:
bindplane-ingest)。 - サービス アカウントの説明: 説明を入力します(例:
Bindplane agent log ingestion)。
- サービス アカウント名: アカウントの名前を入力します(例:
- [作成して続行] をクリックします。
- [このサービス アカウントにプロジェクトへのアクセスを許可する] セクションで、[ロールを選択] をクリックし、[Chronicle 編集者] を選択します。
- [続行] をクリックして [完了] をクリックします。
- 作成したサービス アカウントをクリックし、[キー] タブに移動します。
- [鍵を追加] > [新しい鍵を作成] の順にクリックします。
- [JSON] を選択し、[作成] をクリックします。鍵ファイルがパソコンにダウンロードされます。
- 鍵ファイルを
ingestion-auth.jsonとして Bindplane コレクタ ディレクトリ(Linux の場合は/opt/observiq-otel-collector/ingestion-auth.json、Windows の場合はC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)に保存するか、config.yamlのcreds_file_pathを更新して、保存先のパスと一致させます。 - [IAM と管理] > [設定] に移動し、[プロジェクト番号] をコピーします。これはエクスポータの構成に必要です。
オプション 2: 取り込み認証ファイルをダウンロードする(以前のバージョン)
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [収集エージェント] に移動します。
- 取り込み認証ファイルをダウンロードします。
- Bindplane エージェントがインストールされるシステムにファイルを安全に保存します。
Google SecOps のお客様 ID を取得する
- Google SecOps コンソールにログインします。
- [SIEM 設定] > [プロファイル] に移動します。
[組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。
Bindplane エージェントをインストールする
次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。
Windows へのインストール
- 管理者としてコマンド プロンプトまたは PowerShell を開きます。
次のコマンドを実行します。
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quietインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sc query observiq-otel-collector
サービスは RUNNING と表示されます。
Linux のインストール
- root 権限または sudo 権限でターミナルを開きます。
次のコマンドを実行します。
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.shインストールが完了するまで待ちます。
次のコマンドを実行して、インストールの内容を確認します。
sudo systemctl status observiq-otel-collector
サービスが active (running) と表示されます。
その他のインストール リソース
その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。
Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する
構成ファイルを探します。
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
構成ファイルを編集します。
config.yamlの内容全体を次の構成に置き換えます。receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/logonbox: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: LOGONBOX raw_log_field: body service: pipelines: logs/logonbox: receivers: - udplog exporters: - chronicle/logonbox
構成パラメータ
各プレースホルダを次のように置き換えます。
レシーバーの構成:
udplog: プロトコルに基づくレシーバー タイプ。- UDP Syslog の
udplog - TCP Syslog の
tcplog syslog: RFC 3164/5424 syslog
- UDP Syslog の
0.0.0.0: リッスンする IP アドレス:0.0.0.0: すべてのインターフェースでリッスンします(推奨)。- 1 つのインターフェースでリッスンする特定の IP アドレス
514: リッスンするポート番号(514、1514、6514など)
エクスポータの構成:
<customer_id>: 前のステップで取得したお客様 IDlocation:<LOCATION>は、Google SecOps インスタンスのリージョン(us、europe、asia-southeast1など)に置き換えます。エクスポーターは、chronicle.googleapis.comの先頭にこの値を付加します。完全なリストについては、リージョン エンドポイントをご覧ください。project:<PROJECT_NUMBER>を [IAM と管理] > [設定] のプロジェクト番号に置き換えます。endpoint:chronicle.googleapis.comに設定したままにします。creds_file_pathを、プラットフォームに応じてサービス アカウントの JSON キーファイルのパス(オプション 1)に調整します。- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
以前の Ingestion API エクスポータ
オプション 2 の取り込み認証ファイルを使用する場合は、
exportersブロックを次のように置き換えます。creds_file_pathを取り込み認証ファイルのパスに設定します。インスタンスが米国以外にある場合は、malachiteingestion-pa.googleapis.comをリージョン エンドポイント(europe-malachiteingestion-pa.googleapis.comなど)に置き換えます。exporters: chronicle/logonbox: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: LOGONBOX raw_log_field: body
構成ファイルを保存する
- 編集が完了したら、ファイルを保存します。
- Linux:
Ctrl+O、Enter、Ctrl+Xの順に押します。 - Windows: [ファイル> 保存] をクリックします。
- Linux:
Bindplane エージェントを再起動して変更を適用する
Linux で Bindplane エージェントを再起動するには:
次のコマンドを実行します。
sudo systemctl restart observiq-otel-collectorサービスが実行されていることを確認します。
sudo systemctl status observiq-otel-collectorログでエラーを確認します。
sudo journalctl -u observiq-otel-collector -f
Windows で Bindplane エージェントを再起動するには:
次のいずれかのオプションを選択します。
- 管理者としてコマンド プロンプトまたは PowerShell を開きます。
net stop observiq-otel-collector && net start observiq-otel-collector- サービス コンソール:
Win+Rキーを押し、「services.msc」と入力して Enter キーを押します。- observIQ OpenTelemetry Collector を見つけます。
- 右クリックして [再起動] を選択します。
サービスが実行されていることを確認します。
sc query observiq-otel-collectorログでエラーを確認します。
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
LogonBox syslog 転送を構成する
- 管理者として LogonBox 管理コンソールにログインします。
- [レポート] > [監査ログ] に移動します。
- syslog エクスポートの設定を構成します。
- Syslog サーバー: Bindplane エージェント ホストの IP アドレスを入力します(例:
192.168.1.100)。 - ポート: 「
514」と入力します(Bindplane レシーバー ポートと一致する必要があります)。 - プロトコル: [UDP] を選択します(Bindplane レシーバーのタイプと一致する必要があります)。
- Syslog サーバー: Bindplane エージェント ホストの IP アドレスを入力します(例:
- 転送するイベント カテゴリ(パスワードのリセット、ID の確認、ユーザーとグループの管理など)を選択します。
- [保存] をクリックします。
UDM マッピング テーブル
| ログフィールド | UDM マッピング | ロジック |
|---|---|---|
| additional.fields | 条件に基づいて、attr_associatedPrincipals_label、sAMAccountName_label、attr_local_label、msDS-PrincipalName_label、attr_realmType_label、attr_selfCreated_label、attr_administrative_label から統合 | |
| attr_principalDesc, desc | metadata.description | product_event_type が changePassword|SessionService と一致する場合は attr_principalDesc の値、一致しない場合は attr_principalDesc の値(空でない場合)、desc の値 |
| event_type | metadata.event_type | product_event_type とプレゼンス フラグに基づいて条件付きロジックが設定された後、event_type から直接コピーされた値 |
| product_event_type | metadata.product_event_type | 値が直接コピーされる |
| metadata.product_name | 「LogonBox」に設定 | |
| metadata.vendor_name | 「LOGONBOX」に設定 | |
| network.application_protocol | product_event_type が AnswerService と一致し、条件が満たされている場合は「DNS」に設定されます。 | |
| dns_answer | network.dns.answers | dns_answer から統合 |
| dns_question | network.dns.questions | dns_question から統合 |
| attr_userAgent、attr_userAgentVersion | network.http.parsed_user_agent | attr_userAgent と attr_userAgentVersion の両方が存在する場合はそれらを連結し、それ以外の場合は attr_userAgent から連結して、parseduseragent に変換して名前を変更します。 |
| attr_userAgent、attr_userAgentVersion | network.http.user_agent | attr_userAgent と attr_userAgentVersion の両方が存在する場合は、それらを連結した値。それ以外の場合は、attr_userAgent の値。 |
| hostname | principal.asset.hostname | 値が直接コピーされる |
| attr_ipAddress | principal.asset.ip | 値を直接コピーする |
| hostname | principal.hostname | 値を直接コピーする |
| attr_ipAddress | principal.ip | 値が直接コピーされる |
| attr_os | principal.platform | (?i)LINUX|MAC|WINDOWS に一致する場合は大文字に変換されて設定されます。 |
| attr_osVersion | principal.platform_version | (?i)unknown と一致しない場合、値は直接コピーされます。 |
| attr_principalRealm_label、attr_unassignedRoles_label、attr_assignedRoles_label、attr_oldResourceName_label、attr_roles_label、attr_resumedPrincipalName_label、attr_resumedPrincipalRealm_label、attr_resumedPrincipal_label、attr_module_label、reconcile_map_label、users_map_label、groups_map_label、createUser_map_label、user_map_label、mobile_map_label | principal.resource.attribute.labels | attr_principalRealm、attr_unassignedRoles、attr_assignedRoles、attr_oldResourceName、attr_roles、attr_resumedPrincipalName、attr_resumedPrincipalRealm、attr_resumedPrincipal、attr_module から作成されたさまざまなラベルと、reconcile、users、groups、createUser、user、mobile からのマップを条件に基づいてマージ |
| attr_resourceName | principal.resource.name | 値が直接コピーされる |
| attr_resourceId | principal.resource.product_object_id | 値が直接コピーされる |
| principal.user.email_addresses | メールが有効なメールアドレスの場合に統合されます | |
| ImmutableID、attr_uuid | principal.user.product_object_id | product_event_type が changePassword|userUpdated|userCreated|setPassword|answer|accountUnlockNoSuspension と一致する場合は ImmutableID の値、それ以外の場合は attr_uuid の値 |
| attr_scheme | principal.user.role_name | 値が直接コピーされる |
| attr_principalDesc | principal.user.user_display_name | product_event_type が changePassword|SessionService と一致する場合、値は直接コピーされます。 |
| attr_principalName | principal.user.userid | 値を直接コピーする |
| authy_code_length_label, authy_window_length_label, authy_step_size_label, msauthenticator_code_length_label, msauthenticator_window_length_label, msauthenticator_step_size_label, googleUser_code_length_label, googleUser_window_length_label, googleUser_step_size_label | security_result.detection_fields | authy.code.length、authy.window.length、authy.step.size、msauthenticator.code.length、msauthenticator.window.length、msauthenticator.step.size、googleUser.code.length、googleUser.window.length、googleUser.step.size から作成されたラベルから統合(存在する場合) |
| cn | target.resource.attribute.labels | cn から作成された full_name_label と、attr_disabledRealm から作成された attr_disabledRealm_label を統合 |
| attr_lastModified | target.resource.attribute.last_update_time | ISO8601 または d MMM yyyy HH:mm:ss を使用して attr_lastModified から解析された日付 |
| attr_created | target.resource.attribute.creation_time | ISO8601 または d MMM yyyy HH:mm:ss を使用して attr_created から解析された日付 |
| givenName | target.user.first_name | 値が直接コピーされる |
| ou | target.user.group_identifiers | product_event_type が userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension と一致する場合、ou から統合されます。 |
| sn | target.user.last_name | 値を直接コピーする |
| attr_uuid, attr_disabledPrincipal | target.user.product_object_id | product_event_type が userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension、groupCreated|groupUpdated、attr_group、group のいずれかに一致する場合は attr_uuid の値。それ以外の場合は、accountDisabled であれば attr_disabledPrincipal の値。 |
| displayName、description | target.user.user_display_name | displayName が空でない場合は displayName の値、それ以外の場合は product_event_type が userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension と一致する場合は説明の値 |
| userPrincipalName、attr_user、attr_associatedPrincipals、attr_disabledPrincipalName | target.user.userid | product_event_type が userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension と一致する場合は userPrincipalName の値。設定されていない場合は attr_user。groupCreated|groupUpdated または attr_group の場合は attr_associatedPrincipals。group の場合は attr_user。accountDisabled の場合は attr_disabledPrincipalName。 |
| attr_group | target.group.group_display_name | product_event_type が groupCreated|groupUpdated と一致する場合、または attr_group が存在する場合は、値が直接コピーされます |
| attr_uuid | target.group.product_object_id | product_event_type が groupCreated|groupUpdated と一致する場合、または attr_group が存在する場合は、値が直接コピーされます |
変更ログ
さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。