Endpoint Protector DLP ログを収集する

パーサーのバージョン: 2.0

以下でサポートされています。

このドキュメントでは、Bindplane エージェントを使用して Netwrix Endpoint Protector DLP ログを Google Security Operations に取り込む方法について説明します。

Netwrix Endpoint Protector は、デバイス制御、コンテンツ認識保護、ファイル転送イベントの Syslog メッセージを生成するデータ損失防止(DLP)ソリューションです。パーサーは、grok パターンを使用してフィールドを抽出し、Unified Data Model(UDM)にマッピングします。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス
  • Windows Server 2016 以降、または systemd を使用する Linux ホスト
  • Bindplane エージェントと Endpoint Protector サーバー間のネットワーク接続
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認する
  • Netwrix Endpoint Protector への特権アクセス

Google SecOps の取り込み認証ファイルを取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイル をダウンロードします。
  4. Bindplane エージェントをインストールするシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows へのインストール

  1. 管理者としてコマンド プロンプト または PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sc query observiq-otel-collector
    

    サービスは RUNNING と表示されます。

Linux へのインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sudo systemctl status observiq-otel-collector
    

    サービスは active (running) と表示されます。

その他のインストール リソース

その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。

Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

構成ファイルを見つける

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

構成ファイルを編集する

  • config.yaml の内容全体を次の構成に置き換えます。

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/endpoint_protector_dlp:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: ENDPOINT_PROTECTOR_DLP
            raw_log_field: body
    
    service:
        pipelines:
            logs/endpoint_protector_dlp_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/endpoint_protector_dlp
    

構成パラメータ

各プレースホルダを次のように置き換えます。

  • レシーバーの構成:

    • listen_address: リッスンする IP アドレスとポート:
      • すべてのインターフェースでリッスンする場合は 0.0.0.0(推奨)
      • ポート 514 は標準の Syslog ポートです(Linux では root が必要です。root 以外の場合は 1514 を使用してください)。
  • エクスポータの構成:

    • creds_file_path: 取り込み認証ファイルのフルパス:
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps コンソールからコピーしたお客様 ID
    • endpoint: リージョン エンドポイント URL:
      • 米国: malachiteingestion-pa.googleapis.com
      • ヨーロッパ: europe-malachiteingestion-pa.googleapis.com
      • アジア: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 完全なリストについては、リージョン エンドポイントをご覧ください。

構成ファイルを保存する

  • 編集後、ファイルを保存します。
    • Linux: Ctrl+OEnterCtrl+X を押します。
    • Windows: [File > Save] をクリックします。

Bindplane エージェントを再起動して変更を適用する

  • Linux で Bindplane エージェントを再起動するには、次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
    1. サービスが実行されていることを確認します。

      sudo systemctl status observiq-otel-collector
      
    2. ログにエラーがないか確認します。

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows で Bindplane エージェントを再起動するには、次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を開きます。

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • サービス コンソール:

      1. Win+R を押して services.msc と入力し、Enter キーを押します。
      2. observIQ OpenTelemetry Collector を見つけます。
      3. 右クリックして [再起動] を選択します。
      4. サービスが実行されていることを確認します。

        sc query observiq-otel-collector
        
      5. ログにエラーがないか確認します。

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Netwrix Endpoint Protector で Syslog を構成する

  1. Endpoint Protector ウェブ UI にログインします。
  2. [Appliance] > [SIEM Integration] に移動します。
  3. [Add New] をクリックします。
  4. 次の構成の詳細を入力します。
    • SIEM Status: スイッチを切り替えて SIEM サーバーを有効 にします。
    • Disable Logging: スイッチを切り替えてロギングを有効 にします。
    • サーバー名: 一意でわかりやすいサーバー名を入力します。
    • サーバーの説明: この統合の説明を追加します。
    • サーバー IP または DNS: Bindplane エージェントの IP アドレスを入力します。
    • **Server Protocol**: [**UDP**] を選択します。
    • サーバー ポート: Bindplane エージェントのポート番号を入力します(UDP の場合は 514 など)。
    • Exclude Headers: スイッチを切り替えてログヘッダーを有効 にします。
    • ログの種類: SIEM に送信する使用可能なログを選択します。
  5. [保存] をクリックします。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
Client Computer principal.asset.asset_id Client Computer の値は、「Client Computer: 」を先頭に追加してから principal.asset.asset_id に割り当てられます。
Client User principal.user.userid Client User の値は principal.user.userid に割り当てられます。
Content Policy security_result.rule_name Content Policy の値は security_result.rule_name に割り当てられます。
Content Policy Type security_result.rule_id Content Policy Type の値は security_result.rule_id に割り当てられます。
Destination metadata.ingestion_labels.value Destination の値は、key が「Destination」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
Destination Type metadata.ingestion_labels.value Destination Type の値は、key が「Destination Type」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
Device PID metadata.ingestion_labels.value Device PID の値は、key が「Device PID」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
Device Serial metadata.ingestion_labels.value Device Serial の値は、key が「Device Serial」の ingestion_labels オブジェクトの value フィールドに割り当てられます。これは、Device Serial が空でない場合にのみ行われます。
Device VID metadata.ingestion_labels.value Device VID の値は、key が「Device VID」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
File Name target.file.full_path File Name の値は target.file.full_path に割り当てられます。
File Size target.file.size File Size の値は target.file.size に割り当てられ、符号なし整数に変換されます。
IP Address principal.ip IP Address の値は principal.ip に割り当てられます。
Item Details metadata.ingestion_labels.value Item Details の値は、key が「Item Details」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
Log ID metadata.product_log_id Log ID の値は metadata.product_log_id に割り当てられます。
MAC Address principal.mac MAC Address の値は、すべてのハイフンをコロンに置き換えてから principal.mac に割り当てられます。
Matched Item metadata.ingestion_labels.value Matched Item の値は、key が「Matched Item」の ingestion_labels オブジェクトの value フィールドに割り当てられます。
Message security_result.summary Message の値は security_result.summary に割り当てられます。
OS principal.platform OS の値を使用して、principal.platform の値が決定されます。OS に「Windows」が含まれている場合、principal.platform は「WINDOWS」に設定されます。OS に「Mac」が含まれている場合、principal.platform は「MAC」に設定されます。OS に「Lin」が含まれている場合、principal.platform は「LINUX」に設定されます。
Serial Number principal.asset.hardware.serial_number Serial Number の値は principal.asset.hardware.serial_number に割り当てられます。grok を使用してメッセージ フィールドから抽出され、intermediary.hostname に割り当てられます。grok を使用してメッセージ フィールドから抽出され、metadata.description に割り当てられます。Syslog メッセージのタイムスタンプが解析され、metadata.event_timestamp に割り当てられます。値「SCAN_UNCATEGORIZED」が metadata.event_type に割り当てられます。値「ENDPOINT_PROTECTOR_DLP」が metadata.log_type に割り当てられます。値「ENDPOINT_PROTECTOR_DLP」が metadata.product_name に割り当てられます。値「ENDPOINT_PROTECTOR_DLP」が metadata.vendor_name に割り当てられます。grok を使用してメッセージ フィールドから抽出され、principal.hostname に割り当てられます。grok を使用してメッセージ フィールドから抽出され、principal.ip に割り当てられます。Syslog メッセージのタイムスタンプが解析され、トップレベルの timestamp フィールドに割り当てられます。
Destination event.idm.read_only_udm.target.application 変更履歴からマッピング
Matched Item event.idm.read_only_udm.target.file.mime_type 変更履歴からマッピング
intermediary_ip event.idm.read_only_udm.intermediary.ip 変更履歴からマッピング
server_date event.idm.read_only_udm.additional.fields 変更履歴からマッピング
client_date event.idm.read_only_udm.additional.fields 変更履歴からマッピング
server_date_utc event.idm.read_only_udm.additional.fields 変更履歴からマッピング
client_date_utc event.idm.read_only_udm.additional.fields 変更履歴からマッピング
pid event.idm.read_only_udm.principal.process.pid 変更履歴からマッピング
OS event.idm.read_only_udm.principal.platform_version 変更履歴からマッピング

変更履歴

このパーサーの変更履歴を表示する

さらにサポートが必要な場合コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。