Collect Cynet 360 AutoXDR logs

Supported in:

This document explains how to ingest Cynet 360 AutoXDR logs to Google Security Operations using the Bindplane agent.

Before you begin

Make sure you have the following prerequisites:

  • A Google SecOps instance
  • A Windows 2016 or later or Linux host with systemd
  • If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements
  • Privileged access to the Cynet 360 AutoXDR management console

Get Google SecOps ingestion authentication file

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Collection Agents.
  3. Download the Ingestion Authentication File.
  4. Save the file securely on the system where Bindplane will be installed.

Get Google SecOps customer ID

  1. Sign in to the Google SecOps console.
  2. Go to SIEM Settings > Profile.
  3. Copy and save the Customer ID from the Organization Details section.

Install the Bindplane agent

Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.

Windows installation

  1. Open the Command Prompt or PowerShell as an administrator.
  2. Run the following command:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux installation

  1. Open a terminal with root or sudo privileges.
  2. Run the following command:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

Additional installation resources

For additional installation options, see the Bindplane agent installation guide.

Configure the Bindplane agent to ingest Syslog and send to Google SecOps

  1. Access the configuration file:

    • Locate the config.yaml file. Typically, it's in the /opt/observiq-otel-collector/ directory on Linux or in the installation directory on Windows.
    • Open the file using a text editor (for example, nano, vi, or Notepad).
  2. Edit the config.yaml file as follows:

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <CUSTOMER_ID>
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'CYNET_360_AUTOXDR'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - udplog
          exporters:
            - chronicle/chronicle_w_labels
    
    • Replace the port and IP address as required in your infrastructure.
    • Replace <CUSTOMER_ID> with the actual Customer ID.
    • Update /path/to/ingestion-authentication-file.json to the file path where the authentication file was saved in Step 1.

Restart the Bindplane agent to apply the changes

  1. To restart the Bindplane agent in Linux, run the following command:

    sudo systemctl restart observiq-otel-collector
    
  2. To restart the Bindplane agent in Windows, you can either use the Services console or enter the following command:

    net stop observiq-otel-collector && net start observiq-otel-collector
    

Configure Syslog forwarding on Cynet 360 AutoXDR

  1. Sign in to the Cynet 360 AutoXDR Management Console.
  2. Go to Settings > Configuration > SIEM Settings.
  3. Provide the following configuration details:
    • Transmission method: Select UDP.
    • IP address: Enter the Bindplane agent IP address.
    • Port: Enter the Bindplane agent port number (default is 514).
  4. Click Add.
  5. Go to Settings > Advanced.
  6. Select the Send Audit Records to SIEM checkbox.
  7. Save the configuration.

UDM mapping table

Log Field UDM Mapping Logic
Uniqueness_label additional.fields Merged
clientId_label additional.fields Merged
confVer_label additional.fields Merged
epsVer_label additional.fields Merged
etwAlertId_label additional.fields Merged
externalId_label additional.fields Merged
fname_label additional.fields Merged
gpParams_label additional.fields Merged
gpSign_label additional.fields Merged
gpprUser_label additional.fields Merged
gpssdeep_label additional.fields Merged
hostLS_label additional.fields Merged
pParams_label additional.fields Merged
pSign_label additional.fields Merged
pct_label additional.fields Merged
pssdeep_label additional.fields Merged
scanGroupId_label additional.fields Merged
sev_label additional.fields Merged
sign_label additional.fields Merged
Action extensions.auth.type Mapped: 111AUTHTYPE_UNSPECIFIED
Info metadata.description Directly mapped
dtUtc metadata.event_timestamp Parsed as MMM dd yyyy HH:mm:ss.SSS
rt metadata.event_timestamp Parsed as MMM dd yyyy HH:mm:ss
rtUtc metadata.event_timestamp Parsed as MMM dd yyyy HH:mm:ss.SSS
Action metadata.event_type Mapped: 111USER_LOGIN
has_principal metadata.event_type Mapped: trueFILE_UNCATEGORIZED, trueSTATUS_UPDATE
has_user metadata.event_type Mapped: trueUSER_UNCATEGORIZED
DbId metadata.product_log_id Directly mapped
pprUser principal.administrative_domain Directly mapped
HostName principal.asset.hostname Directly mapped
dhost principal.asset.hostname Directly mapped
RequesterIp principal.asset.ip Merged
StringIP principal.asset.ip Merged
src principal.asset.ip Merged
pFileHash principal.file.sha256 Directly mapped
HostName principal.hostname Directly mapped
dhost principal.hostname Directly mapped
RequesterIp principal.ip Merged
StringIP principal.ip Merged
src principal.ip Merged
osVer principal.platform_version Directly mapped
ppParams principal.process.file.full_path Directly mapped
gpFileHash principal.process.parent_process.file.sha256 Directly mapped
prUser principal.user.userid Directly mapped
sec_result security_result Merged
sev security_result.severity Mapped: MediumMEDIUM, LowLOW, HighHIGH, CriticalCRITICAL
domain target.administrative_domain Directly mapped
dst target.asset.ip Merged
Path target.file.full_path Directly mapped
filePath target.file.full_path Directly mapped
fileHash target.file.sha256 Directly mapped
scanGroupName target.group.group_display_name Directly mapped
dst target.ip Merged
UserName target.user.userid Directly mapped
duser target.user.userid Directly mapped
user target.user.userid Directly mapped
N/A extensions.auth.type Constant: AUTHTYPE_UNSPECIFIED
N/A metadata.event_type Constant: USER_LOGIN
N/A metadata.product_name Constant: Cynet 360 AutoXDR
N/A metadata.vendor_name Constant: Cynet 360 AutoXDR
N/A security_result.severity Constant: MEDIUM

Need more help? Get answers from Community members and Google SecOps professionals.