Cisco Secure Web Appliance(旧称 Web Security Appliance)のログを収集する

パーサーのバージョン: 7.0

以下でサポートされています。

このドキュメントでは、Bindplane を使用して Cisco Secure Web Appliance(旧称 Web Security Appliance)のログを Google Security Operations に取り込む方法について説明します。

Cisco Secure Web Appliance は、ウェブベースの脅威から組織を保護するオンプレミスのウェブ プロキシおよびセキュリティ ゲートウェイです。すべての HTTP、HTTPS、FTP トラフィックに対して、URL フィルタリング、マルウェア スキャン、データ損失防止、アプリケーションの可視性と制御を提供します。このアプライアンスは、利用規定を適用し、暗号化されたトラフィックを検査して、高度な脅威を検出してブロックします。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス
  • Windows Server 2016 以降、または systemd を使用する Linux ホスト
  • Bindplane エージェントと Cisco Secure Web Appliance 間のネットワーク接続
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します。
  • Cisco Secure Web Appliance ウェブ インターフェースへの特権アクセス

Bindplane エージェントの Google SecOps 認証情報を取得する

Bindplane エージェントを Google SecOps に対して認証するには、次のいずれかの方法を選択します。

  • 新規デプロイ: Chronicle API を使用します(オプション 1)。
  • 以前のデプロイ: 2027 年 7 月 20 日に Ingestion API が廃止されるまで、取り込み認証ファイル(オプション 2)を引き続き使用します。
  1. Google Cloud コンソールにログインし、Google SecOps インスタンスにリンクされている Google Cloud プロジェクトを選択します。
  2. [IAM と管理] > [サービス アカウント] に移動します。
  3. [サービス アカウントを作成] をクリックします。
  4. 次の構成情報を指定します。
    • サービス アカウント名: アカウントの名前を入力します(例: bindplane-ingest)。
    • サービス アカウントの説明: 説明を入力します(例: Bindplane agent log ingestion)。
  5. [作成して続行] をクリックします。
  6. [このサービス アカウントにプロジェクトへのアクセスを許可する] セクションで、[ロールを選択] をクリックし、[Chronicle 編集者] を選択します。
  7. [続行] をクリックして [完了] をクリックします。
  8. 作成したサービス アカウントをクリックし、[キー] タブに移動します。
  9. [鍵を追加] > [新しい鍵を作成] の順にクリックします。
  10. [JSON] を選択し、[作成] をクリックします。鍵ファイルがパソコンにダウンロードされます。
  11. 鍵ファイルを ingestion-auth.json として Bindplane コレクタ ディレクトリ(Linux の場合は /opt/observiq-otel-collector/ingestion-auth.json、Windows の場合は C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)に保存するか、config.yaml の creds_file_path を更新して、保存先のパスと一致させます。
  12. [IAM と管理] > [設定] に移動し、プロジェクト番号をコピーします。これはエクスポータの構成に必要です。

オプション 2: 取り込み認証ファイルをダウンロードする(レガシー)

  1. Google SecOps コンソールにログインします。
  2. [設定] > [データ管理] > [収集エージェント] に移動します。SIEM のみのプラットフォームを使用している場合は、[設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイルをダウンロードします。
  4. Bindplane エージェントがインストールされるシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [Settings] > [Administration] > [Profile] に移動します。SIEM のみのプラットフォームを使用している場合は、[設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows へのインストール

  1. 管理者としてコマンド プロンプトまたは PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sc query observiq-otel-collector
    

サービスが RUNNING と表示されます。

Linux へのインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sudo systemctl status observiq-otel-collector
    

サービスが active (running) と表示されます。

その他のインストール リソース

その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。

syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

構成ファイルを探す

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

構成ファイルを編集します。

  • config.yaml の内容全体を次の構成に置き換えます。

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/cisco_wsa:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: CISCO_WSA
        raw_log_field: body
    
    service:
      pipelines:
        logs/cisco_wsa_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/cisco_wsa
    

構成パラメータ

各プレースホルダを次のように置き換えます。

  • レシーバーの構成:

    • listen_address: リッスンする IP アドレスとポート。
      • 0.0.0.0: すべてのインターフェースでリッスンします(推奨)。
      • ポート 514 は標準の syslog ポートです(Linux では root が必要です。root 以外の場合は 1514 を使用します)。
  • エクスポータの構成:

    • creds_file_path: サービス アカウントの JSON キーファイルのフルパス(オプション 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps コンソールからコピーしたお客様 ID
    • location: <LOCATION> は、Google SecOps インスタンスのリージョン(us、europe、asia-southeast1 など)に置き換えます。エクスポーターは、chronicle.googleapis.com の前にこの値を付加します。完全なリストについては、リージョン エンドポイントをご覧ください。
    • project: <PROJECT_NUMBER> を、[IAM と管理] > [設定] のプロジェクト番号に置き換えます。
    • endpoint: chronicle.googleapis.com に設定したままにします。

以前の Ingestion API エクスポータ

  • オプション 2 の取り込み認証ファイルを使用する場合は、exporters ブロックを次のように置き換えます。creds_file_path を取り込み認証ファイルのパスに設定します。インスタンスが米国以外にある場合は、malachiteingestion-pa.googleapis.com をリージョン エンドポイント(例: europe-malachiteingestion-pa.googleapis.com)に置き換えます。

    exporters:
      chronicle/cisco_wsa:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: CISCO_WSA
        raw_log_field: body
    

構成ファイルを保存する

  • 編集が完了したら、ファイルを保存します。
    • Linux: Ctrl+O、Enter、Ctrl+X の順に押します。
    • Windows の場合: [ファイル] > [保存] をクリックします。

Bindplane エージェントを再起動して変更を適用する

Linux で Bindplane エージェントを再起動するには:

  1. 次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
  2. サービスが実行されていることを確認します。

    sudo systemctl status observiq-otel-collector
    
  3. ログでエラーを確認します。

    sudo journalctl -u observiq-otel-collector -f
    

Windows で Bindplane エージェントを再起動するには:

  1. 次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を実行します。
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • サービス コンソール:
      1. Win+R を押し、「services.msc」と入力して Enter キーを押します。
      2. observIQ OpenTelemetry Collector を見つけます。
      3. 右クリックして [再起動] を選択します。
  2. サービスが実行されていることを確認します。

    sc query observiq-otel-collector
    
  3. ログでエラーを確認します。

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

Cisco Secure Web Appliance で syslog 転送を構成する

  1. Cisco Secure Web Appliance のウェブ インターフェースにログインします。
  2. [System Administration] > [Log Subscriptions] に移動します。
  3. [ログ サブスクリプションを追加] をクリックします。
  4. [ログタイプ] プルダウンからログタイプを選択します。ウェブプロキシ トラフィックの場合は、[アクセスログ] を選択します。
  5. [ログ名] フィールドに、ログ サブスクリプションのわかりやすい名前(例: chronicle-access)を入力します。
  6. アクセスログの形式を選択します。

    • Squid - 標準の Squid 互換形式
    • Apache - Apache 互換形式
    • W3C Extended - 構成可能なフィールドを含む W3C Extended ログファイル形式
  7. ログのロールオーバー前の最大ファイルサイズと、ロールオーバー間の時間間隔を指定します。

  8. [ログレベル] を選択します。使用可能なオプションは、[Critical]、[Warning]、[Information]、[Debug]、[Trace] です。

  9. [Retrieval Method] セクションで、[Syslog Push] を選択します。

  10. 次の構成情報を提供してください。

    • ホスト名: Bindplane エージェント ホストの IP アドレスまたはホスト名を入力します(例: 192.168.1.100)。
    • ポート: Bindplane エージェントで構成されたポート番号を入力します(例: 514)。
    • プロトコル: [TCP] を選択します。
    • 最大メッセージ サイズ: リモート syslog サーバーに送信するログメッセージの最大サイズをバイト単位で入力します。
    • Facility: 必要な syslog ファシリティ(Local0 など)を選択します。
  11. [送信] をクリックします。

  12. [Commit Changes] をクリックして構成を適用します。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
_field additional.fields 統合済み
case_name_label additional.fields 統合済み
cmf_label additional.fields 統合済み
dcf_label additional.fields 統合済み
err_label additional.fields 統合済み
interaction_mode_label additional.fields 統合済み
proxy_session_id_label additional.fields 統合済み
request_size_label additional.fields 統合済み
total_bytes_label additional.fields 統合済み
transaction_disposition_label additional.fields 統合済み
auth_mechanism extensions.auth.auth_details 直接マッピングされます。
wsa_hostname intermediary.asset.hostname 直接マッピングされます。
wsa_hostname intermediary.hostname 直接マッピングされます。
description metadata.description 直接マッピングされます。
time metadata.event_timestamp MMM dd HH:mm:ss として解析
when metadata.event_timestamp UNIX として解析
has_principal metadata.event_type マッピング済み: true → NETWORK_HTTP、true → NETWORK_CONNECTION、true → STATUS_UPDATE
has_user metadata.event_type マッピング済み: true → USER_UNCATEGORIZED
action metadata.product_event_type 直接マッピングされます。
app_proto network.application_protocol 直接マッピングされます。
method network.http.method 直接マッピングされます。
referer_url network.http.referral_url 直接マッピングされます。
returnCode network.http.response_code 直接マッピングされます。
user_agent network.http.user_agent 直接マッピングされます。
response_size network.received_bytes 直接マッピングされます。
bytes_sent network.sent_bytes 直接マッピングされます。
size network.sent_bytes 直接マッピングされます。
session_id network.session_id 直接マッピングされます。
srcip principal.asset.ip 統合済み
srcip principal.ip 統合済み
process_id principal.process.pid 直接マッピングされます。
_field principal.resource.attribute.labels 統合済み
key principal.resource.attribute.labels マッピング済み: server_response → _field
username principal.user.userid 直接マッピングされます。
_security_result security_result 統合済み
domain target.administrative_domain 直接マッピングされます。
tgthost target.asset.hostname 直接マッピングされます。
tgtip target.asset.ip 統合済み
mime_type target.file.mime_type 直接マッピングされます。
tgthost target.hostname 直接マッピングされます。
tgtip target.ip 統合済み
tar_city target.location.city 直接マッピングされます。
tar_region target.location.country_or_region 直接マッピングされます。
tar_state target.location.state 直接マッピングされます。
tgtport target.port 直接マッピングされます。
kerberos_enctype_label target.resource.attribute.labels 統合済み
kerberos_keytab_label target.resource.attribute.labels 統合済み
kerberos_kvno_label target.resource.attribute.labels 統合済み
server_cert_organization_label target.resource.attribute.labels 統合済み
target_kerberos_realm_label target.resource.attribute.labels 統合済み
url target.url 直接マッピングされます。
なし metadata.event_type 定数: NETWORK_HTTP
なし metadata.product_name 定数: WSA
なし metadata.vendor_name 定数: CISCO
information event.idm.read_only_udm.additional.fields 変更履歴からマッピング
appname event.idm.read_only_udm.additional.fields 変更履歴からマッピング
facility event.idm.read_only_udm.additional.fields 変更履歴からマッピング
logtime event.idm.read_only_udm.additional.fields 変更履歴からマッピング
policy event.idm.read_only_udm.additional.fields 変更履歴からマッピング
hostname event.idm.read_only_udm.principal.hostname 変更履歴からマッピング
hostname event.idm.read_only_udm.principal.asset.hostname 変更履歴からマッピング
ser_url event.idm.read_only_udm.security_result.description 変更履歴からマッピング
ser_msg event.idm.read_only_udm.security_result.rule_name 変更履歴からマッピング
ser_data event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
priority event.idm.read_only_udm.security_result.severity_details 変更履歴からマッピング
srcport event.idm.read_only_udm.principal.port 変更履歴からマッピング
category event.idm.read_only_udm.security_result.category_details 変更履歴からマッピング
sha_value event.idm.read_only_udm.target.file.sha256 変更履歴からマッピング
cmf event.idm.read_only_udm.additional.fields 変更履歴からマッピング
dcf event.idm.read_only_udm.additional.fields 変更履歴からマッピング
err event.idm.read_only_udm.additional.fields 変更履歴からマッピング
case_name event.idm.read_only_udm.additional.fields 変更履歴からマッピング
total_bytes event.idm.read_only_udm.additional.fields 変更履歴からマッピング
request_size event.idm.read_only_udm.additional.fields 変更履歴からマッピング
transaction_disposition event.idm.read_only_udm.additional.fields 変更履歴からマッピング
application event.idm.read_only_udm.additional.fields 変更履歴からマッピング
bytes_sent event.idm.read_only_udm.network.sent_bytes 変更履歴からマッピング
response_size event.idm.read_only_udm.network.received_bytes 変更履歴からマッピング
description event.idm.read_only_udm.metadata.description 変更履歴からマッピング
referer_url event.idm.read_only_udm.network.http.referral_url 変更履歴からマッピング
wsa_hostname event.idm.read_only_udm.intermediary.hostname、event.idm.read_only_udm.intermediary.asset.hostname 変更履歴からマッピング

変更ログ

このパーサーの変更ログを表示する

さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。