Collect Broadcom CA PAM logs
This document explains how to ingest Broadcom CA Privileged Access Manager logs to Google Security Operations using Bindplane. Broadcom CA Privileged Access Manager (PAM) is an enterprise privileged access management solution that controls, monitors, and audits privileged user access to critical systems. It provides credential vaulting, session recording, and access policy enforcement across hybrid environments.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance.
- A Windows 2016 or later or Linux host with systemd.
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements.
- Privileged access to the Broadcom Privileged Access Management web UI.
Get Google SecOps ingestion authentication file
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agent.
- Download the Ingestion Authentication File. Save the file securely on the system where Bindplane will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
- Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open the Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
Additional installation resources
For additional installation options, consult the installation guide.
Configure the Bindplane agent to ingest syslog and send to Google SecOps
Access the configuration file:
- Locate the
config.yamlfile. Typically, it is in the/observiq-otel-collector/directory on Linux or in the installation directory on Windows. - Open the file using a text editor (for example,
nano,vi, or Notepad).
- Locate the
Edit the
config.yamlfile as follows:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/broadcom_ca_pam: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: BROADCOM_CA_PAM raw_log_field: body ingestion_labels: service: pipelines: logs/broadcom_ca_pam: receivers: - tcplog exporters: - chronicle/broadcom_ca_pam
- Replace the port and IP address as required in your infrastructure.
- Replace
<customer_id>with the actual customer ID. - Update
/path/to/ingestion-authentication-file.jsonto the path where the authentication file was saved in the Get Google SecOps ingestion authentication file section.
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux:
Run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows:
Choose one of the following options:
- Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collector- Services console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
- Press
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Configure remote syslog on Broadcom CA PAM
- Sign in to the Privileged Access Management web UI.
- Go to Configuration > Logs > Syslog.
- Select the Syslog Enabled toggle.
- Select Space Delimited from the Message Format list.
- Click Add Server.
Provide the following configuration details in the new row:
- Server: Enter the Bindplane agent IP address (for example,
192.168.1.100). - Port: Enter
514(or your configured Bindplane agent port). If you leave the port blank, it defaults to514. - Protocol: Select TCP.
- Server: Enter the Bindplane agent IP address (for example,
Click Update to save the settings.
Verify that logs are being sent by checking the Bindplane agent logs.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
UserGroup_label |
additional.fields |
Merged |
access_protocol |
metadata.access_protocol |
Directly mapped |
Details |
metadata.description |
Directly mapped |
has_principal |
metadata.event_type |
Mapped: true → SCAN_UNCATEGORIZED, true → STATUS_UPDATE |
has_user |
metadata.event_type |
Mapped: true → USER_UNCATEGORIZED |
host |
principal.asset.hostname |
Directly mapped |
host |
principal.hostname |
Directly mapped |
NatIP |
principal.nat_ip |
Merged |
Port |
principal.port |
Directly mapped |
pid |
principal.process.pid |
Directly mapped |
DeviceName |
principal.resource.name |
Directly mapped |
User |
principal.user.userid |
Directly mapped |
sec_res |
security_result |
Merged |
detection_fields |
security_result.detection_fields |
Merged |
Service_App |
target.application |
Directly mapped |
Address |
target.asset.hostname |
Directly mapped |
Address |
target.hostname |
Directly mapped |
| N/A | metadata.event_type |
Constant: SCAN_UNCATEGORIZED |
| N/A | metadata.product_name |
Constant: Broadcom CA Pam |
| N/A | metadata.vendor_name |
Constant: Broadcom |
Need more help? Get answers from Community members and Google SecOps professionals.