Barracuda Email Security Gateway のログを収集する

パーサーのバージョン: 4.0

以下でサポートされています。

このドキュメントでは、Bindplane を使用して Barracuda Email Security Gateway ログを Google Security Operations に取り込む方法について説明します。

Barracuda Email Security Gateway は、スパム、ウイルス、なりすまし、フィッシング攻撃に対するインバウンド フィルタリングを提供するメール セキュリティ アプライアンスです。また、データ損失防止とメール暗号化のための送信フィルタリングも提供します。ゲートウェイは、すべてのメール トランザクション、ポリシー アクション、脅威検出を syslog 経由でログに記録します。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス。
  • Windows 2016 以降、または systemd を使用する Linux ホスト。
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します。
  • Barracuda Email Security Gateway 管理コンソールへの特権アクセス。

Bindplane エージェントの Google SecOps 認証情報を取得する

Bindplane エージェントを Google SecOps に対して認証するには、次のいずれかの方法を選択します。

  • 新規デプロイ: Chronicle API を使用します(オプション 1)。
  • 以前のデプロイ: 2027 年 7 月 20 日に Ingestion API が廃止されるまで、取り込み認証ファイル(オプション 2)を引き続き使用します。
  1. Google Cloud コンソールにログインし、Google SecOps インスタンスにリンクされている Google Cloud プロジェクトを選択します。
  2. [IAM と管理] > [サービス アカウント] に移動します。
  3. [サービス アカウントを作成] をクリックします。
  4. 次の構成情報を指定します。
    • サービス アカウント名: アカウントの名前を入力します(例: bindplane-ingest)。
    • サービス アカウントの説明: 説明を入力します(例: Bindplane agent log ingestion)。
  5. [作成して続行] をクリックします。
  6. [このサービス アカウントにプロジェクトへのアクセスを許可する] セクションで、[ロールを選択] をクリックし、[Chronicle 編集者] を選択します。
  7. [続行] をクリックして [完了] をクリックします。
  8. 作成したサービス アカウントをクリックし、[キー] タブに移動します。
  9. [鍵を追加] > [新しい鍵を作成] の順にクリックします。
  10. [JSON] を選択し、[作成] をクリックします。鍵ファイルがパソコンにダウンロードされます。
  11. 鍵ファイルを ingestion-auth.json として Bindplane コレクタ ディレクトリ(Linux の場合は /opt/observiq-otel-collector/ingestion-auth.json、Windows の場合は C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)に保存するか、config.yaml の creds_file_path を更新して、保存先のパスと一致させます。
  12. [IAM と管理] > [設定] に移動し、プロジェクト番号をコピーします。これはエクスポータの構成に必要です。

オプション 2: 取り込み認証ファイルをダウンロードする(レガシー)

  1. Google SecOps コンソールにログインします。
  2. [設定] > [データ管理] > [収集エージェント] に移動します。SIEM のみのプラットフォームを使用している場合は、[設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイルをダウンロードします。
  4. Bindplane エージェントがインストールされるシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [Settings] > [Administration] > [Profile] に移動します。SIEM のみのプラットフォームを使用している場合は、[設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows へのインストール

  1. 管理者として コマンド プロンプトまたは PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux へのインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

その他のインストール リソース

その他のインストール オプションについては、こちらのインストール ガイドをご覧ください。

Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

  1. 構成ファイルにアクセスする:

    • config.yaml ファイルを見つけます。通常、Linux の場合は /observiq-otel-collector/ ディレクトリ、Windows の場合はインストール ディレクトリにあります。
    • テキスト エディタ(nano、vi、メモ帳など)を使用してファイルを開きます。
  2. config.yaml ファイルを次のように編集します。

    receivers:
      tcplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <your_customer_id>
        endpoint: chronicle.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'BARRACUDA_EMAIL'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - tcplog
          exporters:
            - chronicle/chronicle_w_labels
    
  • 自社のインフラストラクチャでの必要性に応じて、ポートと IP アドレスを置き換えます。
  • <LOCATION> は、Google SecOps インスタンスのリージョン(us、europe、asia-southeast1 など)に置き換えます。エクスポーターは、chronicle.googleapis.com の先頭にこの値を付加します。
  • <PROJECT_NUMBER> は、[IAM と管理] > [設定] のプロジェクト番号に置き換えます。
  • <your_customer_id> は、実際のお客様 ID に置き換えます。
  • /path/to/ingestion-authentication-file.json を、ステップ 1 でサービス アカウント キー ファイル(オプション 1)を保存したファイルパスに更新します。

以前の Ingestion API エクスポータ

  • オプション 2 の取り込み認証ファイルを使用する場合は、exporters ブロックを次のように置き換えます。creds_file_path を取り込み認証ファイルのパスに設定します。インスタンスが米国以外にある場合は、malachiteingestion-pa.googleapis.com をリージョン エンドポイント(例: europe-malachiteingestion-pa.googleapis.com)に置き換えます。

    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <your_customer_id>
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'BARRACUDA_EMAIL'
        raw_log_field: body
        ingestion_labels:
    

Bindplane エージェントを再起動して変更を適用する

Linux で Bindplane エージェントを再起動するには:

  1. 次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
  2. サービスが実行されていることを確認します。

    sudo systemctl status observiq-otel-collector
    
  3. ログでエラーを確認します。

    sudo journalctl -u observiq-otel-collector -f
    

Windows で Bindplane エージェントを再起動するには:

  1. 次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を実行します。
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • サービス コンソール:
      1. Win+R を押し、「services.msc」と入力して Enter キーを押します。
      2. observIQ OpenTelemetry Collector を見つけます。
      3. 右クリックして [再起動] を選択します。
  2. サービスが実行されていることを確認します。

    sc query observiq-otel-collector
    
  3. ログでエラーを確認します。

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

Barracuda Email Security Gateway で syslog 転送を構成する

  1. Barracuda Email Security Gateway のウェブ インターフェースにログインします。
  2. [詳細設定] > [詳細ネットワーク設定] に移動します。
  3. [Syslog] セクションで、次のフィールドを構成します。
    • Syslog サーバー: Bindplane エージェント ホストの IP アドレスまたはホスト名を入力します(例: 192.168.1.100)。
    • Syslog ポート: 514(または構成済みの Bindplane エージェント ポート)を入力します。
    • Syslog Protocol: [TCP] を選択します。
  4. [変更を保存] をクリックします。

syslog 配信を確認する

  1. syslog 転送を構成したら、ゲートウェイ経由でテストメールを送信します。
  2. ゲートウェイが syslog データを送信していることを確認するには、[ADVANCED] > [Troubleshooting] に移動し、[Syslog] セクションを表示して、リアルタイムのメール syslog 出力をモニタリングします。
  3. Bindplane エージェント ホストで、ログが受信されていることを確認します。

    sudo journalctl -u observiq-otel-collector -f
    

詳細については、Barracuda Email Security Gateway の syslog のドキュメントをご覧ください。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
dst_domain target.hostname dst_domain フィールドの値。
dst_domain target.asset.hostname dst_domain フィールドの値。
geoip target.location.country_or_region geoip フィールドの値。
hdr_from network.email.from hdr_from フィールドの値(メールアドレスの場合)。
hdr_to network.email.to hdr_to フィールドの値がメールアドレスの場合はその値。それ以外の場合は、hdr_to フィールドの JSON 配列から解析された値。
host principal.hostname host フィールドの値。
host principal.asset.hostname host フィールドの値。
message_id network.email.mail_id message_id フィールドの値。
product_log_id metadata.product_log_id product_log_id フィールドの値。
queue_id security_result.detection_fields queue_id フィールドの値。
recipient_email network.email.to recipient_email フィールドの値(空でも - でもない場合)。
recipients.action security_result.action 値が「allowed」の場合、ALLOW にマッピングされます。それ以外の場合は BLOCK にマッピングされます。
recipients.action security_result.action_details recipients.action フィールドの値。
recipients.delivery_detail security_result.detection_fields recipients.delivery_detail フィールドの値。
recipients.delivered security_result.detection_fields recipients.delivered フィールドの値。
recipients.email network.email.to recipients.email フィールドの値(メールアドレスの場合)。
recipients.reason security_result.detection_fields recipients.reason フィールドの値。
recipients.reason_extra security_result.detection_fields recipients.reason_extra フィールドの値。
recipients.taxonomy security_result.detection_fields recipients.taxonomy フィールドの値。
service security_result.summary service フィールドの値。
size network.received_bytes size フィールドの値が符号なし整数に変換されます。
src_ip principal.ip src_ip フィールドの値(空でも 0.0.0.0 でもない場合)。
src_ip principal.asset.ip src_ip フィールドの値(空でも 0.0.0.0 でもない場合)。
src_ip security_result.about.ip src_ip フィールドの値(空でも 0.0.0.0 でもない場合)。
subject network.email.subject subject フィールドの値。
target_ip target.ip target_ip フィールドの値。
target_ip target.asset.ip target_ip フィールドの値。
timestamp metadata.event_timestamp ログエントリから解析されたタイムスタンプ。
metadata.event_type EMAIL_TRANSACTION にハードコードされています。
metadata.log_type BARRACUDA_EMAIL にハードコードされています。
metadata.vendor_name 「Barracuda」にハードコードされています。
network.application_protocol process フィールドに「smtp」が含まれている場合は、SMTP に設定します。
network.direction process フィールドに「inbound」が含まれている場合は INBOUND に設定し、process フィールドに「outbound」が含まれている場合は OUTBOUND に設定します。
security_result.action action、action_code、service、delivered フィールドの組み合わせに基づいて設定されます。
security_result.category action、reason、その他のフィールドの組み合わせに基づいて設定されます。
auth_serv event.idm.read_only_udm.intermediary.hostname 変更履歴からマッピング
spf_sender_ip event.idm.read_only_udm.principal.ip と event.idm.read_only_udm.principal.asset.ip 変更履歴からマッピング
dkim_result event.idm.read_only_udm.additional.fields 変更履歴からマッピング
dmarc_result event.idm.read_only_udm.additional.fields 変更履歴からマッピング
dkim_domain event.idm.read_only_udm.additional.fields 変更履歴からマッピング
header_from event.idm.read_only_udm.additional.fields 変更履歴からマッピング
spf_result event.idm.read_only_udm.additional.fields 変更履歴からマッピング
smtp_mailfrom event.idm.read_only_udm.additional.fields 変更履歴からマッピング
gateway event.idm.read_only_udm.observer.hostname 変更履歴からマッピング
timestamp event.idm.read_only_udm.metadata.collected_timestamp 変更履歴からマッピング
attachment.name event.idm.read_only_udm.target.file.names 変更履歴からマッピング
attachment.md5 event.idm.read_only_udm.about 変更履歴からマッピング
intermediary event.idm.read_only_udm.intermediary 変更履歴からマッピング
account_id event.idm.read_only_udm.principal.user.userid 変更履歴からマッピング
domain_id event.idm.read_only_udm.target.user.userid 変更履歴からマッピング
tls event.idm.read_only_udm.additional.fields 変更履歴からマッピング
env_from event.idm.read_only_udm.additional.fields 変更履歴からマッピング
hdr_auth_results event.idm.read_only_udm.additional.fields 変更履歴からマッピング
recipient_count event.idm.read_only_udm.additional.fields 変更履歴からマッピング
ptr_record event.idm.read_only_udm.principal.hostname と event.idm.read_only_udm.principal.asset.hostname 変更履歴からマッピング
time event.idm.read_only_udm.metadata.event_timestamp 変更履歴からマッピング
log_header_end event.idm.read_only_udm.additional.fields 変更履歴からマッピング
payload.affected_mailboxes event.idm.read_only_udm.additional.fields 変更履歴からマッピング
payload.attachment event.idm.read_only_udm.additional.fields 変更履歴からマッピング
payload.body_text event.idm.read_only_udm.additional.fields 変更履歴からマッピング
accountId event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
accessTokenId event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
payload.type event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
payload.incident_id event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
payload.messages_received event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
payload.matched_email_count event.idm.read_only_udm.security_result.detection_fields 変更履歴からマッピング
product event.idm.read_only_udm.metadata.product_name 変更履歴からマッピング
payload.sender event.idm.read_only_udm.principal.user.email_addresses 変更履歴からマッピング
payload.recipient event.idm.read_only_udm.target.user.email_addresses 変更履歴からマッピング
payload.subject event.idm.read_only_udm.network.email.subject 変更履歴からマッピング
payload.date event.idm.read_only_udm.metadata.collected_timestamp 変更履歴からマッピング
payload.category event.idm.read_only_udm.security_result.category_details 変更履歴からマッピング
payload.created_by event.idm.read_only_udm.principal.user.email_addresses 変更履歴からマッピング
payload.sender_display_name event.idm.read_only_udm.principal.user.user_display_name 変更履歴からマッピング
payload.sender_email event.idm.read_only_udm.principal.user.email_addresses 変更履歴からマッピング
payload.login_country event.idm.read_only_udm.principal.location.country_or_region 変更履歴からマッピング
payload.login_ip event.idm.read_only_udm.principal.ip と event.idm.read_only_udm.principal.asset.ip 変更履歴からマッピング
payload.login_user_agent event.idm.read_only_udm.network.http.user_agent 変更履歴からマッピング
payload.user_display_name event.idm.read_only_udm.principal.user.user_display_name 変更履歴からマッピング
payload.user_email event.idm.read_only_udm.principal.user.email_addresses 変更履歴からマッピング
payload.body_links event.idm.read_only_udm.security_result.about.url 変更履歴からマッピング
payload.sender_name event.idm.read_only_udm.principal.user.user_display_name 変更履歴からマッピング
attachments additional.fields 変更履歴からマッピング
recipients.delivery_detail", "recipients.reason", "recipients.taxonomy", "recipients.reason_extra" and "recipient.delivered security_result.detection_fields 変更履歴からマッピング
sender_email network.email.from 変更履歴からマッピング
security_result.action QUARANTINE 変更履歴からマッピング

変更ログ

このパーサーの変更ログを表示する

さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。